source: projects/specs/trunk/f/freetype2/freetype2-vl.spec @ 10633

Revision 10633, 16.8 KB checked in by kudoh, 8 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%bcond_with subpixel_rendering
4%define ver_majar 2.6.5
5
6Summary: FreeType 2 library
7Summary(ja): FreeType 2 ライブラリ
8Name: freetype2
9Version: %{ver_majar}
10Release: 1%{?_dist_release}
11License: GPL/FTL dual license
12URL: http://www.freetype.org/
13Group: System Environment/Libraries
14
15Source: freetype-%{version}.tar.bz2
16Source1: freetype-doc-%{ver_majar}.tar.bz2
17Source2: ft2demos-%{ver_majar}.tar.bz2
18
19# enable subpixel rendering
20Patch21: freetype-2.3.0-enable-spr.patch
21# Enable otvalid and gxvalid modules
22Patch46:  freetype-2.2.1-enable-valid.patch
23# Fix multilib conflicts
24Patch88:  freetype-multilib.patch
25# Fix crash https://bugs.freedesktop.org/show_bug.cgi?id=6841
26Patch89:  freetype-2.2.1-memcpy-fix.patch
27#Patch90:  freetype-2.5.4-pkgconfig.patch
28
29Patch200: freetype-2.1.10-slight-embolden.patch
30Patch201: freetype-2.4.12-x86_64-invalid_outline.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33
34BuildRequires: zlib-devel
35BuildRequires: bzip2-devel
36BuildRequires: libX11-devel
37BuildRequires: libpng-devel
38
39%description
40The FreeType project is a team of volunteers who develop free,
41portable and high-quality software solutions for digital typography.
42They specifically target embedded systems and focus on bringing small,
43efficient and ubiquitous products.
44
45The FreeType 2 library is their new software font engine. It has been
46designed to provide the following important features:
47 * A universal and simple API to manage font files
48 * Support for several font formats through loadable modules
49 * High-quality anti-aliasing
50 * High portability & performance
51
52Supported font formats include:
53 * TrueType files (.ttf) and collections (.ttc)
54 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
55 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
56   routines to manage design instances easily
57 * Type 1 CID-keyed fonts
58 * OpenType/CFF (.otf) fonts
59 * CFF/Type 2 fonts
60 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
61   the Adobe SVG viewer plugin.
62 * Windows FNT/FON bitmap fonts
63
64This package contains the files needed to run programs that use the
65FreeType 2 library.
66
67
68%package demos
69Summary: A collection of FreeType demos
70Group: System Environment/Libraries
71Requires: %{name} = %{version}-%{release}
72Obsoletes: freetype-utils < 2.0
73Provides: freetype-utils = %{version}
74
75%description demos
76A collection of FreeType demos.
77
78
79%package -n compat32-%{name}
80Summary: FreeType 2 library
81Summary(ja): FreeType 2 ライブラリ
82Group: System Environment/Libraries
83Requires:       %{name} = %{version}-%{release}
84
85
86%description -n compat32-%{name}
87The FreeType project is a team of volunteers who develop free,
88portable and high-quality software solutions for digital typography.
89They specifically target embedded systems and focus on bringing small,
90efficient and ubiquitous products.
91
92The FreeType 2 library is their new software font engine. It has been
93designed to provide the following important features:
94 * A universal and simple API to manage font files
95 * Support for several font formats through loadable modules
96 * High-quality anti-aliasing
97 * High portability & performance
98
99Supported font formats include:
100 * TrueType files (.ttf) and collections (.ttc)
101 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
102 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
103   routines to manage design instances easily
104 * Type 1 CID-keyed fonts
105 * OpenType/CFF (.otf) fonts
106 * CFF/Type 2 fonts
107 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
108   the Adobe SVG viewer plugin.
109 * Windows FNT/FON bitmap fonts
110
111This package contains the files needed to run programs that use the
112FreeType 2 library.
113
114
115%package devel
116Summary:        Development files for FreeType 2 library
117Summary(ja):    FreeType 2 ライブラリの開発ファイル
118Group:          Development/Libraries
119Requires:       %{name} = %{version}-%{release}
120Requires:       zlib-devel
121Requires:       bzip2-devel
122Requires:       libpng-devel
123
124
125%description devel
126The FreeType project is a team of volunteers who develop free,
127portable and high-quality software solutions for digital typography.
128They specifically target embedded systems and focus on bringing small,
129efficient and ubiquitous products.
130
131The FreeType 2 library is their new software font engine. It has been
132designed to provide the following important features:
133 * A universal and simple API to manage font files
134 * Support for several font formats through loadable modules
135 * High-quality anti-aliasing
136 * High portability & performance
137
138Supported font formats include:
139 * TrueType files (.ttf) and collections (.ttc)
140 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
141 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
142   routines to manage design instances easily
143 * Type 1 CID-keyed fonts
144 * OpenType/CFF (.otf) fonts
145 * CFF/Type 2 fonts
146 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
147   the Adobe SVG viewer plugin.
148 * Windows FNT/FON bitmap fonts
149
150This package contains all supplementary files (static library, headers
151and documentation) you need to develop your own programs using the
152FreeType 2 library.
153
154
155%package -n compat32-%{name}-devel
156Summary:        FreeType 2 library
157Summary(ja):    FreeType 2 ライブラリ
158Group:          Development/Libraries
159Requires:       compat32-%{name} = %{version}-%{release}
160Requires:       %{name}-devel    = %{version}-%{release}
161Requires:       compat32-zlib-devel
162Requires:       compat32-bzip2-devel
163
164%description -n compat32-%{name}-devel
165The FreeType project is a team of volunteers who develop free,
166portable and high-quality software solutions for digital typography.
167They specifically target embedded systems and focus on bringing small,
168efficient and ubiquitous products.
169
170The FreeType 2 library is their new software font engine. It has been
171designed to provide the following important features:
172 * A universal and simple API to manage font files
173 * Support for several font formats through loadable modules
174 * High-quality anti-aliasing
175 * High portability & performance
176
177Supported font formats include:
178 * TrueType files (.ttf) and collections (.ttc)
179 * Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
180 * Type 1 Multiple Master fonts. The FreeType 2 API also provides
181   routines to manage design instances easily
182 * Type 1 CID-keyed fonts
183 * OpenType/CFF (.otf) fonts
184 * CFF/Type 2 fonts
185 * Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
186   the Adobe SVG viewer plugin.
187 * Windows FNT/FON bitmap fonts
188
189This package contains all supplementary files (static library, headers
190and documentation) you need to develop your own programs using the
191FreeType 2 library.
192
193%package static
194Summary:        Static ilbrary for FreeType 2
195Summary(ja):    FreeType 2 のスタティックライブラリ
196Group:          Development/Libraries
197Requires:       %{name}-devel = %{version}-%{release}
198
199%description static
200This package contains the static library for %{name}
201
202%prep
203%setup -q -n freetype-%{version} -b 1 -a 2
204
205%if %{with subpixel_rendering}
206%patch21 -p1 -b .enable-spr
207%endif
208
209%patch46 -p1 -b .enable-valid
210%patch88 -p1 -b .multilib
211%patch89 -p1 -b .memcpy
212#%patch90 -p1 -b .pkgconfig
213
214%patch200 -p1 -b .slight-embolden
215
216#%ifarch x86_64
217#%patch201 -p1 -b .invalid_outline
218#%endif
219
220%build
221%configure
222%__make %{?_smp_mflags}
223
224# Build demos
225pushd ft2demos-%{ver_majar}
226make TOP_DIR=".."
227popd
228
229
230%install
231[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
232
233%makeinstall gnulocaledir=$RPM_BUILD_ROOT%{_datadir}/locale
234
235for ftdemo in ftbench ftdump ftlint ftvalid ftdiff ftgamma ftgrid ftmulti ftstring ftview
236do
237  builds/unix/libtool --mode=install install -m 755 ft2demos-%{ver_majar}/bin/$ftdemo $RPM_BUILD_ROOT/%{_bindir}
238done
239
240## remove unuse files
241rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
242
243
244%clean
245[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
246
247
248%post -p /sbin/ldconfig
249
250%postun -p /sbin/ldconfig
251
252%post -n compat32-%{name} -p /sbin/ldconfig
253
254%postun -n compat32-%{name} -p /sbin/ldconfig
255
256%files
257%defattr(-, root, root)
258%{_libdir}/*.so*
259%doc docs
260
261%files devel
262%defattr(-, root, root)
263%{_bindir}/freetype-config
264%{_libdir}/*.so
265%{_libdir}/pkgconfig/*.pc
266%{_includedir}/%{name}
267%{_datadir}/aclocal/freetype2.m4
268%{_mandir}/man1/*
269
270%files static
271%defattr(-, root, root)
272%{_libdir}/*.a
273
274%files demos
275%defattr(-,root,root)
276%{_bindir}/ftbench
277%{_bindir}/ftdump
278%{_bindir}/ftlint
279%{_bindir}/ftvalid
280%{_bindir}/ftdiff
281%{_bindir}/ftgamma
282%{_bindir}/ftgrid
283%{_bindir}/ftmulti
284%{_bindir}/ftstring
285%{_bindir}/ftview
286
287%if %{build_compat32}
288%files -n compat32-%{name}
289%defattr(-, root, root)
290%{_libdir}/*.so*
291
292%files -n compat32-%{name}-devel
293%defattr(-, root, root)
294%{_libdir}/*.so
295%endif
296
297%changelog
298* Sun Jul 17 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1
299- new upstream release
300
301* Thu Mar 31 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1
302- new upstream release
303
304* Sat Dec 05 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.2-1
305- new upstream release
306- remade Patch88
307- deleted Pacth90
308- did not apply Patch201
309  - but included src.rpm
310
311* Fri Jan 16 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.5-1
312- new upstream release
313
314* Sun Dec 28 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.4-1
315- new upstream release
316- remade Patch90
317
318* Fri Jun 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.3-2
319- rebuilt with libpng-1.6.
320
321* Sun Apr 20 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.3-1
322- new upstream release
323- remade Patch90
324
325* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-5
326- add Requires: libpng-devel in %%{name}-devel
327
328* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-4
329- fix Patch90
330- fix %%files -n compat32-%%{name}-devel (remove pkgconfig files)
331
332* Tue Dec 24 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-3
333- re-fixed invalid infomation in freetype-config
334
335* Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-2
336- fixed invalid infomation in freetype-config (BTS:2711)
337
338* Sat Dec 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.2-1
339- new upstream release
340
341* Mon Aug 19 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5.0.1-1
342- new upstream release
343- added BuildRequires: libpng-devel
344
345* Sun Jul 14 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.12-2
346- fixed Patch88
347- added Pacth90 to fix BTS:2631
348
349* Sun May 19 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.12-1
350- new upstream release
351- refreshed Patch88, 201
352
353* Sat Dec 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.11-1
354- new upstream release
355
356* Sun Sep 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.10-1
357- new upstream release
358- updated Patch201
359
360* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.8-1
361- new upstream release
362- add BuildRequires: bzip2-devel
363- add Requires: bzip2-devel (-devel package)
364
365* Wed Sep 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-1
366- new upstream release
367
368* Fri Dec 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-1
369- new upstream release
370
371* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.4.2-2
372- build with rpm-4.8.1-1 for pkg-config file
373
374* Mon Aug 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
375- new upstream release
376
377* Tue Jul 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
378- new upstream release
379
380* Thu Jul 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
381- new upstream release
382
383* Sun May 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-2
384- enable bytecode interpreter, the patent is now expired.
385
386* Tue Feb 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.12-1
387- new upstream release
388
389* Tue Oct 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.11-1
390- new upstream release
391- update patch201
392
393* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-6
394- rebuild with gpg signing
395
396* Wed Jul 29 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.9-5
397- fixed "Invalid Outline" error on x86_64.
398
399* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.9-4
400- removed %%if !%%{build_compat32} case condition
401- removed CC='gcc -m32' before make setup
402
403* Sun Apr 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-3
404- enable Patch200 again
405
406* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-2
407- split static library to freetype2-static
408  - needed by tuxonice-userui
409- disable Patch200
410
411* Sat Mar 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-1
412- new upstream release
413
414* Wed Jan 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.8-1
415- new upstream release
416
417* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.7-2
418- removed *.la
419
420* Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-1
421- new upstream release
422
423* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-1
424- new upstream release
425
426* Sun May 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-3
427- add Provides: freetype-utils = %%{version} to freetype2-demos
428
429* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-2
430- remove %%{_bindir}/* from -devel
431
432* Fri Mar 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-1
433- new upstream release
434- add freetype2-demos
435  - Obsoletes: freetype-utils
436
437* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.4-0vl2
438- add Patch201 (CVE-2007-2754)
439
440* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.4-0vl1
441- new upstream release
442
443* Thu Aug 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.1.10-0vl8
444- add Requires: zlib-devel (devel package)
445- compat32
446  - add BuildRequires: compat32-zlib-devel
447  - add Requires: compat32-zlib-devel (devel package)
448
449* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl7
450- add Patch200 to adjust synthetic-embold font weight.
451  - default value is too heavy...
452
453* Sat Jun 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl6
454- add Patch100 for autofit-cjk
455
456* Fri Feb 24 2006 Shu KONNO <owa@bg.wakwak.com> 2.1.10-0vl5
457- added --libdir=%%{_libdir} to make setup
458- added CC='gcc -m32' before make setup if compat32
459
460* Sun Feb 12 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.1.10-0vl4
461- added compat32-* packages for x86_64 architecture support
462
463* Thu Oct 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl3
464- add upstream patches (from MDK)
465  - add Patch13 to fix memleak
466  - add Patch14 to put back internal API, used by XOrg
467  - add Patch15 to fix bad anti-aliasing
468
469* Sat Oct 01 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.10-0vl2
470- add upstream patches (from MDK)
471  - add Patch10 to add fixes from CVS
472  - add Patch11 to fix autofit render setup
473  - add Patch12 to fix kerning
474- add Patch20 (enable bytecode interpreter), but not applied by default
475
476* Tue Sep  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.10-0vl1
477- new upstream release
478- drop Patch1 (auto-hinter has been replaced with a new module)
479- drop Patch2 (included in freetype-2.1.8)
480- add pkgconfig file
481
482* Fri Apr 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl4
483- add xtt2-1.2a related patch which is merged in CVS.
484  (http://x-tt.sourceforge.jp/index_nippon.html)
485
486* Thu Apr 01 2004 Tomoya TAKA <taka@vinelinux.org> 2.1.7-0vl3
487- add a fix from Fedora freetype-2.1.7-3
488  * Wed Mar 10 2004 Mike A. Harris <mharris@redhat.com> 2.1.7-3
489  - Added -fno-strict-aliasing to CFLAGS and CXXFLAGS to try to fix SEGV and
490    SIGILL crashes in mkfontscale which have been traced into freetype and seem
491    to be caused by aliasing issues in freetype macros
492
493* Wed Dec 10 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.7-0vl2
494- update patch1
495
496* Sun Nov 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
497- new upstream release
498
499* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl2
500- rebuild for VineSeed
501
502* Sat Sep 27 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
503- source upgrade
504- add Patch1 from http://www.kde.gr.jp/~akito/
505- remove Source1
506- remove Patch0 (no need to 2.1.5)
507
508* Wed Aug 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
509- correct License tag from GPL to GPL/FTL dual license
510  - FTL: The FreeType Project License
511
512* Wed Apr  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.4-0vl1
513- source upgrade
514
515* Sat Dec  7 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
516- source and patch upgrade
517
518* Thu Dec  5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl3
519- rebuild with new toolchain
520
521* Wed Aug 21 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
522- add Patch0 to fix problem to Dyna-Font
523
524* Tue Jul 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl1
525- source upgrade
526- add %{_datadir}/aclocal/freetype2.m4 to -devel
527
528* Mon Jan 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.6-0vl2
529- modified %%build section
530
531* Wed Jan 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.6-0vl1
532- source update
533- add ftdocs
534
535* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.1-0vl5
536- small build fix
537
538* Wed May  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl4
539- Added Requires for -devel
540- Fixed config path
541
542* Mon Apr 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.1-0vl3
543- add %{_bindir} in devel package's %file section.
544
545* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl2
546- Added %defattr.
547
548* Sun Dec 17 2000 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.1-0vl1
549- Initial revision.
550
Note: See TracBrowser for help on using the repository browser.