source: projects/specs/trunk/f/freetds/freetds-vl.spec @ 9261

Revision 9261, 10.0 KB checked in by inagaki, 9 years ago (diff)

2015-01-15 Ryoichi INAGAKI <ryo1@…>

  • OpenColorIO, freetds, libodfgen, libvisio, libwps: NEW package


Line 
1%define git_commit      0a42888
2
3%ifarch alpha ia64 x86_64 ppc64 ppc64le sparc64 s390x aarch64
4%define bits    64
5%else
6%define bits    32
7%endif
8
9Name: freetds
10Summary: Implementation of the TDS (Tabular DataStream) protocol
11Version: 0.91.103
12Release: 16%{?_dist_release}
13
14Group: System Environment/Libraries
15License: LGPLv2+ and GPLv2+
16URL: http://www.freetds.org/
17
18#  download the latest git source for 0.91 branch from
19#   http://gitorious.org/freetds/freetds/archive-tarball/Branch-0_91
20#  then
21#   mv freetds-freetds-Branch-0_91.tar.gz freetds-%{version}-%{git_commit}.tar.gz
22#Source0: freetds-%{version}-%{git_commit}.tar.gz
23
24Source0: ftp://ftp.freetds.org/pub/freetds/stable/freetds-%{version}.tar.gz
25Source1: freetds-tds_sysdep_public.h
26Patch1: freetds-0.91-printf.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: unixODBC-devel, readline-devel, gnutls-devel, krb5-devel
30BuildRequires: libgcrypt-devel
31BuildRequires: libtool
32BuildRequires: doxygen, docbook-style-dsssl
33
34
35%description
36FreeTDS is a project to document and implement the TDS (Tabular
37DataStream) protocol. TDS is used by Sybase(TM) and Microsoft(TM) for
38client to database server communications. FreeTDS includes call
39level interfaces for DB-Lib, CT-Lib, and ODBC.
40
41
42%package devel
43Summary: Header files and development libraries for %{name}
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46
47%description devel
48This package contains the header files and development libraries
49for %{name}. If you like to develop programs using %{name}, you will need
50to install %{name}-devel.
51
52
53%package doc
54Summary: Development documentation for %{name}
55Group: Documentation
56BuildArch: noarch
57
58%description doc
59This package contains the development documentation for %{name}.
60If you like to develop programs using %{name}, you will need to install
61%{name}-doc.
62
63
64%prep
65#setup -q -n freetds-freetds
66%setup -q
67%patch1 -p1
68
69#  correct perl path
70sed -i '1 s,#!.*/perl,#!%{__perl},' samples/*.pl
71
72chmod -x samples/*.sh samples/*.pl
73
74find . -name .cvsignore -print | xargs rm -f
75find . -name .gitignore -print | xargs rm -f
76
77
78%build
79export LIBS=-lgcrypt
80
81[ -f configure ] || NOCONFIGURE=yes ./autogen.sh
82
83%configure \
84        --disable-dependency-tracking \
85        --disable-rpath \
86        %{!?_with_static: --disable-static} \
87        --with-tdsver="4.2" \
88        --with-unixodbc="%{_prefix}" \
89        --enable-msdblib \
90        --enable-sybase-compat \
91        --with-gnutls \
92        --enable-krb5
93
94make %{?_smp_mflags} DOCBOOK_DSL="`rpm -ql docbook-style-dsssl | fgrep html/docbook.dsl`"
95
96 
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install DOCDIR=doc/%{name} DESTDIR=$RPM_BUILD_ROOT
101
102rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
103rm -rf $RPM_BUILD_ROOT%{_docdir}/freetds
104
105mv -f $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public.h \
106        $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public_%{bits}.h
107install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public.h
108
109rm -f samples/Makefile* samples/*.in samples/README
110
111rm -f doc/doc/freetds-%{version}/reference/installdox
112
113mv -f samples/unixodbc.freetds.driver.template \
114        samples/unixodbc.freetds.driver.template-%{bits}
115
116
117%post -p /sbin/ldconfig
118
119%postun -p /sbin/ldconfig
120
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124 
125
126%files
127%defattr(-, root, root, -)
128%{_bindir}/*
129%{_libdir}/*.so.*
130%config(noreplace) %{_sysconfdir}/*.conf
131%doc AUTHORS BUGS COPYING* NEWS README TODO doc/*.html
132%doc doc/doc/freetds-%{version}/userguide doc/images
133%{_mandir}/*/*
134
135 
136%files devel
137%defattr (-, root, root, -)
138%doc samples
139%{?_with_static: %{_libdir}/*.a}
140%{_libdir}/*.so
141%{_includedir}/*
142
143
144%files doc
145%defattr (-, root, root, -)
146%doc doc/doc/freetds-%{version}/reference
147 
148
149%changelog
150* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.91.103-16
151- Initial build for Vine Linux
152- source as 0.91.103
153
154* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-15.git0a42888
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
156
157* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-14.git0a42888
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
159
160* Tue Apr 22 2014 Tomáš Mráz <tmraz@redhat.com> - 0.91-13.git0a42888
161- Rebuild for new libgcrypt
162
163* Fri Jan 10 2014 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-12.git0a42888
164- add ppc64le to the list of 64bit arches (#1051199)
165
166* Tue Dec  3 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-11.git0a42888
167- update to the latest git source for 0_91 branch
168- fix format-security issue (#1037071)
169
170* Thu Aug 22 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-10.git748aa26
171- update to the latest git source for 0_91 branch
172- fix #999696
173
174* Wed Aug  7 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-9.gitb760a89
175- update to the latest git source for 0_91 branch
176- fix #992295, #993762
177
178* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-8.gitf3ae29d
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
180
181* Thu Jun 13 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-7.gitf3ae29d
182- add aarch64 to the list of 64bit arches (#966129)
183
184* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-6.gitf3ae29d
185- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
186
187* Wed Nov  7 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-5.gitf3ae29d
188- update to the latest git source for 0_91 branch
189- fix #870483
190
191* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-4
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
193
194* Mon Feb 27 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-3
195- Enable Kerberos support (#797276)
196
197* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-2
198- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
199
200* Wed Oct 26 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-1
201- Upgrade to 0.91
202- Drop shared-libtds support
203
204* Wed Mar  9 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.3.20110306dev
205- update to the latest stable snapshot 0.82.1.dev.20110306
206- make build with shared-libtds conditional
207- disable shared-libtds patch by default (seems noone uses it for now)
208
209* Mon Feb 14 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.2.20100810dev
210- fix again shared-libtds patch to provide increased library version
211
212* Thu Feb 10 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.1.20100810dev
213- update to the latest stable snapshot 0.82.1.dev.20100810
214- fix shared-libtds patch to provide properly library names
215
216* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-7
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
218
219* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-6
220- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
221
222* Thu Mar 26 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-5
223- add upstream patch cspublic.BLK_VERSION_150.patch (#492393)
224
225* Tue Feb 24 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-4
226- fix autoconf data for libtool2 (patch by Tom Lane <tgl@redhat.com>)
227
228* Fri Jan 30 2009 Karsten Hopp <karsten@redhat.com> 0.82-3
229- add s390x to 64 bit archs
230
231* Sun Jan 11 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-3
232- Use gnutls for SSL (#479148)
233
234* Tue Jun 17 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-2
235- Continue to provide an internal libtds library as public
236  (patch from Hans de Goede, #451021). This shared library is needed
237  for some existing applications (libgda etc.), which still use it directly.
238
239* Mon Jun  9 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-1
240- Upgrade to 0.82
241
242* Tue Feb 26 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-11
243- fix "64 or 32 bit" test (#434975)
244
245* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.64-10
246- Autorebuild for GCC 4.3
247
248* Mon Jan 28 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-9
249- drop "Obsoletes:" from -doc subpackage to avoid extra complexity.
250
251* Fri Jan 25 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-8
252- resolve multiarch conflicts (#341181):
253  - split references to separate freetds-doc subpackage
254  - add arch-specific suffixes for arch-specific filenames in -devel
255  - add wrapper for tds_sysdep_public.h
256- add readline support (#430196)
257
258* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.64-7
259- Rebuild for selinux ppc32 issue.
260
261* Thu Aug 16 2007 Dmitry Butskoy <Dmitry@Butskoy.name>
262- Change License tag to "LGPLv2+ and GPLv2+"
263
264* Fri Jun 15 2007 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-6
265- bump release to provide update path over Livna
266
267* Wed Jun 13 2007 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-5
268- spec file cleanups
269- allowed for Fedora (no patent issues exist), clarification by
270  James K. Lowden <jklowden [AT] freetds.org>
271- approved for Fedora (review by Hans de Goede <j.w.r.degoede@hhs.nl>)
272
273* Wed Aug  2 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-4
274- approved for Livna (review by Hans de Goede <j.w.r.degoede@hhs.nl>)
275
276* Tue Aug  1 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-4
277- add patch to fix sed scripts in the doc/ Makefile
278- avoid using rpath in binaries
279- cleanup in samples/ dir
280
281* Thu Jul 27 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-3
282- rebuild userguide too.
283- move reference docs to -devel
284
285* Mon Jul 24 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-2
286- Properly clear extra executable bit in source
287- Regenerate docs using doxygen
288
289* Thu Jul 20 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-1
290- Upgrade to 0.64
291- Some spec file and distro cleanups
292
293* Tue Sep 20 2005 V.C.G.Yeah <VCGYeah@iname.com> - 0.63-1
294- Upgrade to 0.63
295- spec file cleanups
296- build static libs conditional
297
298* Thu Sep  2 2004 V.C.G.Yeah <VCGYeah@iname.com> - 0.62.4-1Y
299- Updated to release 0.62.4.
300- Leave includes in system default include dir (needed for php-mssql build)
301
302* Mon May 17 2004 Dag Wieers <dag@wieers.com> - 0.62.3-1
303- Updated to release 0.62.3.
304
305* Wed Feb 04 2004 Dag Wieers <dag@wieers.com> - 0.61.2-0
306- Added --enable-msdblib configure option. (Dean Mumby)
307- Updated to release 0.61.2.
308
309* Fri Jun 13 2003 Dag Wieers <dag@wieers.com> - 0.61-0
310- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.