source: projects/specs/trunk/f/freetds/freetds-vl.spec @ 9492

Revision 9492, 10.2 KB checked in by inagaki, 9 years ago (diff)

2015-04-05 Ryoichi INAGAKI <ryo1@…>

  • cadaver, freetds, iverlog: rebuilt
  • tgif: updated


Line 
1%define git_commit      0a42888
2
3%ifarch alpha ia64 x86_64 ppc64 ppc64le sparc64 s390x aarch64
4%define bits    64
5%else
6%define bits    32
7%endif
8
9Name: freetds
10Summary: Implementation of the TDS (Tabular DataStream) protocol
11Version: 0.91.103
12Release: 17%{?_dist_release}
13
14Group: System Environment/Libraries
15License: LGPLv2+ and GPLv2+
16URL: http://www.freetds.org/
17
18#  download the latest git source for 0.91 branch from
19#   http://gitorious.org/freetds/freetds/archive-tarball/Branch-0_91
20#  then
21#   mv freetds-freetds-Branch-0_91.tar.gz freetds-%{version}-%{git_commit}.tar.gz
22#Source0: freetds-%{version}-%{git_commit}.tar.gz
23
24Source0: ftp://ftp.freetds.org/pub/freetds/stable/freetds-%{version}.tar.gz
25Source1: freetds-tds_sysdep_public.h
26Patch1: freetds-0.91-printf.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: unixODBC-devel, readline-devel, gnutls-devel, krb5-devel
30BuildRequires: libgcrypt-devel
31BuildRequires: libtool
32BuildRequires: doxygen, docbook-style-dsssl
33
34
35%description
36FreeTDS is a project to document and implement the TDS (Tabular
37DataStream) protocol. TDS is used by Sybase(TM) and Microsoft(TM) for
38client to database server communications. FreeTDS includes call
39level interfaces for DB-Lib, CT-Lib, and ODBC.
40
41
42%package devel
43Summary: Header files and development libraries for %{name}
44Summary(ja): %{name} のヘッダファイル及び開発用ライブラリ
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47
48%description devel
49This package contains the header files and development libraries
50for %{name}. If you like to develop programs using %{name}, you will need
51to install %{name}-devel.
52
53%package doc
54Summary: Development documentation for %{name}
55Summary(ha): %{name} の開発用ドキュメント
56Group: Documentation
57BuildArch: noarch
58
59%description doc
60This package contains the development documentation for %{name}.
61If you like to develop programs using %{name}, you will need to install
62%{name}-doc.
63
64
65%prep
66%setup -q
67%patch1 -p1
68
69#  correct perl path
70sed -i '1 s,#!.*/perl,#!%{__perl},' samples/*.pl
71
72chmod -x samples/*.sh samples/*.pl
73
74find . -name .cvsignore -print | xargs rm -f
75find . -name .gitignore -print | xargs rm -f
76
77
78%build
79export LIBS=-lgcrypt
80
81[ -f configure ] || NOCONFIGURE=yes ./autogen.sh
82
83%configure \
84        --disable-dependency-tracking \
85        --disable-rpath \
86        %{!?_with_static: --disable-static} \
87        --with-tdsver="4.2" \
88        --with-unixodbc="%{_prefix}" \
89        --enable-msdblib \
90        --enable-sybase-compat \
91        --with-gnutls \
92        --enable-krb5
93
94make %{?_smp_mflags} DOCBOOK_DSL="`rpm -ql docbook-style-dsssl | fgrep html/docbook.dsl`"
95
96 
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install DOCDIR=doc/%{name} DESTDIR=$RPM_BUILD_ROOT
101
102rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
103rm -rf $RPM_BUILD_ROOT%{_docdir}/freetds
104
105mv -f $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public.h \
106        $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public_%{bits}.h
107install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/tds_sysdep_public.h
108
109rm -f samples/Makefile* samples/*.in samples/README
110
111rm -f doc/doc/freetds-%{version}/reference/installdox
112
113mv -f samples/unixodbc.freetds.driver.template \
114        samples/unixodbc.freetds.driver.template-%{bits}
115
116
117%post -p /sbin/ldconfig
118
119%postun -p /sbin/ldconfig
120
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124 
125
126%files
127%defattr(-, root, root, -)
128%{_bindir}/*
129%{_libdir}/*.so.*
130%config(noreplace) %{_sysconfdir}/*.conf
131%doc AUTHORS BUGS COPYING* NEWS README TODO doc/*.html
132%doc doc/doc/freetds-%{version}/userguide doc/images
133%{_mandir}/*/*
134
135 
136%files devel
137%defattr (-, root, root, -)
138%doc samples
139%{?_with_static: %{_libdir}/*.a}
140%{_libdir}/*.so
141%{_includedir}/*
142
143
144%files doc
145%defattr (-, root, root, -)
146%doc doc/doc/freetds-%{version}/reference
147 
148
149%changelog
150* Sun Apr  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.91.103-17
151- rebuilt with readline 6.3
152
153* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.91.103-16
154- Initial build for Vine Linux
155- source as 0.91.103
156
157* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-15.git0a42888
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
159
160* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-14.git0a42888
161- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
162
163* Tue Apr 22 2014 Tomáš Mráz <tmraz@redhat.com> - 0.91-13.git0a42888
164- Rebuild for new libgcrypt
165
166* Fri Jan 10 2014 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-12.git0a42888
167- add ppc64le to the list of 64bit arches (#1051199)
168
169* Tue Dec  3 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-11.git0a42888
170- update to the latest git source for 0_91 branch
171- fix format-security issue (#1037071)
172
173* Thu Aug 22 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-10.git748aa26
174- update to the latest git source for 0_91 branch
175- fix #999696
176
177* Wed Aug  7 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-9.gitb760a89
178- update to the latest git source for 0_91 branch
179- fix #992295, #993762
180
181* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-8.gitf3ae29d
182- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
183
184* Thu Jun 13 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-7.gitf3ae29d
185- add aarch64 to the list of 64bit arches (#966129)
186
187* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-6.gitf3ae29d
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
189
190* Wed Nov  7 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-5.gitf3ae29d
191- update to the latest git source for 0_91 branch
192- fix #870483
193
194* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-4
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
196
197* Mon Feb 27 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-3
198- Enable Kerberos support (#797276)
199
200* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-2
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
202
203* Wed Oct 26 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.91-1
204- Upgrade to 0.91
205- Drop shared-libtds support
206
207* Wed Mar  9 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.3.20110306dev
208- update to the latest stable snapshot 0.82.1.dev.20110306
209- make build with shared-libtds conditional
210- disable shared-libtds patch by default (seems noone uses it for now)
211
212* Mon Feb 14 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.2.20100810dev
213- fix again shared-libtds patch to provide increased library version
214
215* Thu Feb 10 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82.1-0.1.20100810dev
216- update to the latest stable snapshot 0.82.1.dev.20100810
217- fix shared-libtds patch to provide properly library names
218
219* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-7
220- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
221
222* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-6
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
224
225* Thu Mar 26 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-5
226- add upstream patch cspublic.BLK_VERSION_150.patch (#492393)
227
228* Tue Feb 24 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-4
229- fix autoconf data for libtool2 (patch by Tom Lane <tgl@redhat.com>)
230
231* Fri Jan 30 2009 Karsten Hopp <karsten@redhat.com> 0.82-3
232- add s390x to 64 bit archs
233
234* Sun Jan 11 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-3
235- Use gnutls for SSL (#479148)
236
237* Tue Jun 17 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-2
238- Continue to provide an internal libtds library as public
239  (patch from Hans de Goede, #451021). This shared library is needed
240  for some existing applications (libgda etc.), which still use it directly.
241
242* Mon Jun  9 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.82-1
243- Upgrade to 0.82
244
245* Tue Feb 26 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-11
246- fix "64 or 32 bit" test (#434975)
247
248* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.64-10
249- Autorebuild for GCC 4.3
250
251* Mon Jan 28 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-9
252- drop "Obsoletes:" from -doc subpackage to avoid extra complexity.
253
254* Fri Jan 25 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-8
255- resolve multiarch conflicts (#341181):
256  - split references to separate freetds-doc subpackage
257  - add arch-specific suffixes for arch-specific filenames in -devel
258  - add wrapper for tds_sysdep_public.h
259- add readline support (#430196)
260
261* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.64-7
262- Rebuild for selinux ppc32 issue.
263
264* Thu Aug 16 2007 Dmitry Butskoy <Dmitry@Butskoy.name>
265- Change License tag to "LGPLv2+ and GPLv2+"
266
267* Fri Jun 15 2007 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-6
268- bump release to provide update path over Livna
269
270* Wed Jun 13 2007 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-5
271- spec file cleanups
272- allowed for Fedora (no patent issues exist), clarification by
273  James K. Lowden <jklowden [AT] freetds.org>
274- approved for Fedora (review by Hans de Goede <j.w.r.degoede@hhs.nl>)
275
276* Wed Aug  2 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-4
277- approved for Livna (review by Hans de Goede <j.w.r.degoede@hhs.nl>)
278
279* Tue Aug  1 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-4
280- add patch to fix sed scripts in the doc/ Makefile
281- avoid using rpath in binaries
282- cleanup in samples/ dir
283
284* Thu Jul 27 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-3
285- rebuild userguide too.
286- move reference docs to -devel
287
288* Mon Jul 24 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-2
289- Properly clear extra executable bit in source
290- Regenerate docs using doxygen
291
292* Thu Jul 20 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.64-1
293- Upgrade to 0.64
294- Some spec file and distro cleanups
295
296* Tue Sep 20 2005 V.C.G.Yeah <VCGYeah@iname.com> - 0.63-1
297- Upgrade to 0.63
298- spec file cleanups
299- build static libs conditional
300
301* Thu Sep  2 2004 V.C.G.Yeah <VCGYeah@iname.com> - 0.62.4-1Y
302- Updated to release 0.62.4.
303- Leave includes in system default include dir (needed for php-mssql build)
304
305* Mon May 17 2004 Dag Wieers <dag@wieers.com> - 0.62.3-1
306- Updated to release 0.62.3.
307
308* Wed Feb 04 2004 Dag Wieers <dag@wieers.com> - 0.61.2-0
309- Added --enable-msdblib configure option. (Dean Mumby)
310- Updated to release 0.61.2.
311
312* Fri Jun 13 2003 Dag Wieers <dag@wieers.com> - 0.61-0
313- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.