source: projects/specs/trunk/f/freerdp/freerdp-vl.spec @ 12421

Revision 12421, 6.5 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

freerdp-2.1.2-1

redis-6.0.5-1

sqlite3-3.32.3-1

Line 
1#define rcnumber rc4
2
3Name:           freerdp
4Summary:        Remote Desktop Protocol client
5Summary(ja):    リモートデスクトッププロトコルクライアント
6Version:        2.1.2
7Release:        1%{?rcnumber:.%{rcnumber}}%{?_dist_release}
8Group:          Applications/Internet
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        GPLv2+
13URL:            http://www.freerdp.com/
14Source0:        https://pub.freerdp.com/releases/freerdp-%{version}.tar.gz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires:  cmake
18BuildRequires:  xmlto
19BuildRequires:  alsa-lib-devel
20BuildRequires:  cups-devel
21BuildRequires:  libX11-devel
22BuildRequires:  libXcursor-devel
23BuildRequires:  libXdamage-devel
24BuildRequires:  libXext-devel
25BuildRequires:  libXinerama-devel
26BuildRequires:  libxkbfile-devel
27BuildRequires:  libXv-devel
28BuildRequires:  libusb1-devel
29BuildRequires:  zlib-devel
30BuildRequires:  openssl-devel
31BuildRequires:  pulseaudio-libs-devel
32BuildRequires:  pcsc-lite-devel
33BuildRequires:  desktop-file-utils
34
35Provides:       xfreerdp = %{version}-%{release}
36Obsoletes:      freerdp-plugins < 2.0.0
37Requires:       %{name}-libs = %{version}-%{release}
38
39%description
40The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
41project.
42
43xfreerdp can connect to RDP servers such as Microsoft Windows
44machines, xrdp and VirtualBox.
45
46
47%package        libs
48Summary:        Core libraries implementing the RDP protocol
49Summary(ja):    RDPプロトコル実装のコアライブラリ
50Group:          System Environment/Libraries
51
52%description    libs
53libfreerdp implements the core of the RDP protocol.
54
55libfreerdpchanman can be used to load plugins that can handle channels
56in the RDP protocol.
57
58libfreerdpkbd implements functionality for handling keyboards in X.
59
60
61%package        devel
62Summary:        Development files for %{name}
63Summary(ja):    %{name}の開発ファイル
64Group:          Development/Libraries
65Requires:       %{name}-libs = %{version}-%{release}
66Requires:       pkgconfig
67
68%description    devel
69The %{name}-devel package contains libraries and header files for
70developing applications that use %{name}-libs.
71
72
73%prep
74%setup -q
75
76cat << EOF > xfreerdp.desktop
77[Desktop Entry]
78Type=Application
79Name=X FreeRDP
80NoDisplay=true
81Comment=Connect to RDP server and display remote desktop
82Icon=%{name}
83Exec=/usr/bin/xfreerdp
84Terminal=false
85Categories=Network;RemoteAccess;
86EOF
87
88%build
89%cmake \
90        -DCMAKE_BUILD_TYPE=Release \
91        -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
92        -DWITH_ALSA=ON \
93        -DWITH_CUPS=ON \
94        -DWITH_OPENSSL=ON \
95        -DWITH_PCSC=ON \
96        -DWITH_PULSE=ON \
97        -DWITH_X11=ON \
98        -DWITH_XCURSOR=ON \
99        -DWITH_XEXT=ON \
100        -DWITH_XINERAMA=ON \
101        -DWITH_XKBFILE=ON \
102        -DWITH_XV=ON \
103        -DWITH_ZLIB=ON \
104        -DWITH_CUNIT=OFF \
105        -DWITH_DIRECTFB=OFF \
106        -DWITH_FFMPEG=OFF \
107%ifarch x86_64
108    -DWITH_SSE2=ON \
109%else
110    -DWITH_SSE2=OFF \
111%endif
112        .
113
114
115make %{?_smp_mflags}
116
117pushd winpr/tools/makecert-cli
118make %{?_smp_mflags}
119popd
120
121%install
122rm -rf %{buildroot}
123
124%makeinstall DESTDIR=%{buildroot}
125%makeinstall DESTDIR=%{buildroot} COMPONENT=tools
126
127find %{buildroot} -name "*.a" -delete
128
129# No need for keymap files when using xkbfile
130rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
131
132desktop-file-install --dir=%{buildroot}%{_datadir}/applications xfreerdp.desktop
133install -p -D resources/FreeRDP_Icon_256px.png %{buildroot}%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
134
135
136%clean
137rm -rf %{buildroot}
138
139
140%post
141# This is no gtk application, but try to integrate nicely with GNOME if it is available
142gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
143
144
145%post libs -p /sbin/ldconfig
146
147
148%postun libs -p /sbin/ldconfig
149
150
151%files
152%defattr(-,root,root,-)
153%{_datadir}/applications/xfreerdp.desktop
154%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
155%{_bindir}/winpr-hash
156%{_bindir}/winpr-makecert
157%{_bindir}/xfreerdp
158%{_mandir}/man1/winpr-hash.1.*
159%{_mandir}/man1/winpr-makecert.1.*
160%{_mandir}/man1/xfreerdp.1.*
161
162%files libs
163%defattr(-,root,root,-)
164%license LICENSE
165%doc README ChangeLog
166%{_libdir}/lib*.so.*
167%{_mandir}/man7/wlog.*
168
169%files devel
170%defattr(-,root,root,-)
171%{_includedir}/*
172%{_libdir}/cmake/*
173%{_libdir}/lib*.so
174%{_libdir}/pkgconfig/*.pc
175
176
177%changelog
178* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.2-1
179- updated to 2.1.2.
180
181* Wed May 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
182- updated to 2.1.1.
183
184* Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
185- updated to 2.1.0.
186
187* Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.0-1.rc4
188- updated to 2.0.0-RC4.
189- dropped all patches.
190- dropped subpackage 'freerdp-plugins'.
191
192* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
193- add BuildRequires: alsa-lib-devel
194
195* Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
196- update to 1.0.2
197- fixed typo in Group
198- dropped Patch0 and Patch1
199- added Patch2 to build with current xmlto
200
201* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
202- update to 1.0.1
203- import patches from fedora package.
204- add BRs.
205
206* Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
207- initial build for Vine Linux
208
209* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
210- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
211
212* Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
213- rebuild on rawhide because of broken dependencies
214
215* Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
216- freerdp-0.8.2
217
218* Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
219- make -devel require pkgconfig
220- first official Fedora package
221
222* Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
223- freerdp-0.8.1
224
225* Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
226- hack the generated libtool to not set rpath on x86_64
227- configure with alsa explicitly
228
229* Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
230- freerdp-0.7.4
231- cleanup of packaging structure
232
233* Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
234- 0.7.3
235- fix some minor pylint warnings
236
237* Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
238- 0.7.2
239- Address many comments from cwickert:
240- - cleanup of old formatting, alignment with spectemplate-lib.spec and
241    cwickert spec from #616193
242- - add alsa as build requirement
243- - remove superfluous configure options and disable static libs
244- - add missing rpm groups
245
246* Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
247- First official release, first review request
Note: See TracBrowser for help on using the repository browser.