source: projects/specs/trunk/f/freerdp/freerdp-vl.spec @ 9670

Revision 9670, 6.5 KB checked in by Takemikaduchi, 9 years ago (diff)

system-config-printer: update
freerdp: add BR: alsa-lib-devel
libssh: add pkgconfig file
remmina: change BR: vte3-devel

Line 
1Name:           freerdp
2Summary:        Remote Desktop Protocol client
3Summary(ja):    リモートデスクトッププロトコルクライアント
4Version:        1.0.2
5Release:        2%{?_dist_release}
6
7Group:          Applications/Internet
8License:        GPLv2+
9URL:            http://www.freerdp.com/
10
11Source0:        https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
12# https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
13
14Patch0:         fastpath_send_input_pdu-sec_bytes.patch
15Patch1:         c10866db66c0d462ea7c2c38bb01740bcfb4fcb4.patch
16Patch2:         freerdp-1.0.2_xmlto.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires:  cmake
20BuildRequires:  xmlto
21BuildRequires:  openssl-devel
22BuildRequires:  libX11-devel
23BuildRequires:  libXext-devel
24BuildRequires:  libXinerama-devel
25BuildRequires:  libXcursor-devel
26BuildRequires:  libXdamage-devel
27BuildRequires:  libXv-devel
28BuildRequires:  libxkbfile-devel
29BuildRequires:  pulseaudio-libs-devel
30BuildRequires:  alsa-lib-devel
31BuildRequires:  cups-devel
32BuildRequires:  pcsc-lite-devel
33BuildRequires:  desktop-file-utils
34
35Provides:       xfreerdp = %{version}-%{release}
36Requires:       %{name}-libs = %{version}-%{release}, %{name}-plugins = %{version}-%{release}
37Requires:       %{name}-plugins = %{version}-%{release}
38
39%description
40The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
41project.
42
43xfreerdp can connect to RDP servers such as Microsoft Windows
44machines, xrdp and VirtualBox.
45
46
47%package        libs
48Summary:        Core libraries implementing the RDP protocol
49Summary(ja):    RDPプロトコル実装のコアライブラリ
50Group:          System Environment/Libraries
51
52%description    libs
53libfreerdp implements the core of the RDP protocol.
54
55libfreerdpchanman can be used to load plugins that can handle channels
56in the RDP protocol.
57
58libfreerdpkbd implements functionality for handling keyboards in X.
59
60
61%package        plugins
62Summary:        Plugins for handling the standard RDP channels
63Summary(ja):    標準RDPチャンネルを扱うためのプラグイン
64Group:          System Environment/Libraries
65Requires:       %{name}-libs = %{version}-%{release}
66
67%description    plugins
68A set of plugins to the channel manager implementing the standard virtual
69channels extending RDP core functionality.  For example, sounds, clipboard
70sync, disk/printer redirection, etc.
71
72
73%package        devel
74Summary:        Development files for %{name}
75Summary(ja):    %{name}の開発ファイル
76Group:          Development/Libraries
77Requires:       %{name}-libs = %{version}-%{release}
78Requires:       pkgconfig
79
80%description    devel
81The %{name}-devel package contains libraries and header files for
82developing applications that use %{name}-libs.
83
84
85%prep
86%setup -q -n FreeRDP-%{version}
87#patch0 -p1
88#patch1 -p1
89%patch2 -p1
90
91cat << EOF > xfreerdp.desktop
92[Desktop Entry]
93Type=Application
94Name=X FreeRDP
95NoDisplay=true
96Comment=Connect to RDP server and display remote desktop
97Icon=%{name}
98Exec=/usr/bin/xfreerdp
99Terminal=false
100Categories=Network;RemoteAccess;
101EOF
102
103%build
104%cmake \
105        -DCMAKE_BUILD_TYPE=Release \
106        -DWITH_CUPS=ON \
107        -DWITH_PCSC=ON \
108        -DWITH_PULSEAUDIO=ON \
109        -DWITH_X11=ON \
110        -DWITH_XCURSOR=ON \
111        -DWITH_XEXT=ON \
112        -DWITH_XINERAMA=ON \
113        -DWITH_XKBFILE=ON \
114        -DWITH_XV=ON \
115        -DWITH_ALSA=ON \
116        -DWITH_CUNIT=OFF \
117        -DWITH_DIRECTFB=OFF \
118        -DWITH_FFMPEG=OFF \
119        -DWITH_SSE2=OFF \
120        -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
121        .
122
123
124make %{?_smp_mflags}
125
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
131
132# No need for keymap files when using xkbfile
133rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
134
135desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications xfreerdp.desktop
136install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
137
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142
143%post
144# This is no gtk application, but try to integrate nicely with GNOME if it is available
145gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
146
147
148%post libs -p /sbin/ldconfig
149
150
151%postun libs -p /sbin/ldconfig
152
153
154%files
155%defattr(-,root,root,-)
156%{_bindir}/xfreerdp
157%{_mandir}/man1/xfreerdp.*
158%{_datadir}/applications/xfreerdp.desktop
159%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
160
161%files libs
162%defattr(-,root,root,-)
163%doc LICENSE README ChangeLog
164%{_libdir}/lib%{name}-*.so.*
165%dir %{_libdir}/%{name}/
166
167%files plugins
168%defattr(-,root,root,-)
169%{_libdir}/%{name}/*
170
171%files devel
172%defattr(-,root,root,-)
173%{_includedir}/%{name}/
174%{_libdir}/lib%{name}-*.so
175%{_libdir}/pkgconfig/%{name}.pc
176
177
178%changelog
179* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
180- add BuildRequires: alsa-lib-devel
181
182* Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
183- update to 1.0.2
184- fixed typo in Group
185- dropped Patch0 and Patch1
186- added Patch2 to build with current xmlto
187
188* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
189- update to 1.0.1
190- import patches from fedora package.
191- add BRs.
192
193* Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
194- initial build for Vine Linux
195
196* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
197- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
198
199* Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
200- rebuild on rawhide because of broken dependencies
201
202* Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
203- freerdp-0.8.2
204
205* Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
206- make -devel require pkgconfig
207- first official Fedora package
208
209* Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
210- freerdp-0.8.1
211
212* Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
213- hack the generated libtool to not set rpath on x86_64
214- configure with alsa explicitly
215
216* Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
217- freerdp-0.7.4
218- cleanup of packaging structure
219
220* Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
221- 0.7.3
222- fix some minor pylint warnings
223
224* Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
225- 0.7.2
226- Address many comments from cwickert:
227- - cleanup of old formatting, alignment with spectemplate-lib.spec and
228    cwickert spec from #616193
229- - add alsa as build requirement
230- - remove superfluous configure options and disable static libs
231- - add missing rpm groups
232
233* Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
234- First official release, first review request
Note: See TracBrowser for help on using the repository browser.