source: projects/specs/trunk/f/freerdp/freerdp-vl.spec @ 12413

Revision 12413, 6.4 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

cyrus-sasl-2.1.27-2

dnsmasq-2.81-1

freerdp-2.1.1-1

glib2-2.64.3-1

libmariadb-3.1.8-1

openssh-8.3p1-1

RevLine 
[12400]1#define rcnumber rc4
[11966]2
[3883]3Name:           freerdp
4Summary:        Remote Desktop Protocol client
5Summary(ja):    リモートデスクトッププロトコルクライアント
[12413]6Version:        2.1.1
[12400]7Release:        1%{?rcnumber:.%{rcnumber}}%{?_dist_release}
[8966]8Group:          Applications/Internet
[11966]9Vendor:         Project Vine
10Distribution:   Vine Linux
11
[12400]12License:        GPLv2+
13URL:            http://www.freerdp.com/
14Source0:        https://pub.freerdp.com/releases/freerdp-%{version}.tar.gz
[6955]15
[3883]16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
[6955]17BuildRequires:  cmake
18BuildRequires:  xmlto
[11966]19BuildRequires:  alsa-lib-devel
20BuildRequires:  cups-devel
[3883]21BuildRequires:  libX11-devel
[11966]22BuildRequires:  libXcursor-devel
23BuildRequires:  libXdamage-devel
[6955]24BuildRequires:  libXext-devel
25BuildRequires:  libXinerama-devel
[11966]26BuildRequires:  libxkbfile-devel
[6955]27BuildRequires:  libXv-devel
[12400]28BuildRequires:  libusb1-devel
[11966]29BuildRequires:  zlib-devel
30BuildRequires:  openssl-devel
[6955]31BuildRequires:  pulseaudio-libs-devel
32BuildRequires:  pcsc-lite-devel
33BuildRequires:  desktop-file-utils
[3883]34
35Provides:       xfreerdp = %{version}-%{release}
[11966]36Obsoletes:      freerdp-plugins < 2.0.0
37Requires:       %{name}-libs = %{version}-%{release}
[3883]38
39%description
40The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
41project.
42
43xfreerdp can connect to RDP servers such as Microsoft Windows
44machines, xrdp and VirtualBox.
45
46
47%package        libs
48Summary:        Core libraries implementing the RDP protocol
49Summary(ja):    RDPプロトコル実装のコアライブラリ
50Group:          System Environment/Libraries
[8966]51
[3883]52%description    libs
53libfreerdp implements the core of the RDP protocol.
54
55libfreerdpchanman can be used to load plugins that can handle channels
56in the RDP protocol.
57
58libfreerdpkbd implements functionality for handling keyboards in X.
59
60
61%package        devel
62Summary:        Development files for %{name}
63Summary(ja):    %{name}の開発ファイル
64Group:          Development/Libraries
65Requires:       %{name}-libs = %{version}-%{release}
66Requires:       pkgconfig
67
68%description    devel
69The %{name}-devel package contains libraries and header files for
70developing applications that use %{name}-libs.
71
72
73%prep
[12400]74%setup -q
[3883]75
[6955]76cat << EOF > xfreerdp.desktop
77[Desktop Entry]
78Type=Application
79Name=X FreeRDP
80NoDisplay=true
81Comment=Connect to RDP server and display remote desktop
82Icon=%{name}
83Exec=/usr/bin/xfreerdp
84Terminal=false
85Categories=Network;RemoteAccess;
86EOF
[3883]87
88%build
[6955]89%cmake \
[8966]90        -DCMAKE_BUILD_TYPE=Release \
[11966]91        -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
92        -DWITH_ALSA=ON \
[6955]93        -DWITH_CUPS=ON \
[11966]94        -DWITH_OPENSSL=ON \
[6955]95        -DWITH_PCSC=ON \
[11966]96        -DWITH_PULSE=ON \
[6955]97        -DWITH_X11=ON \
98        -DWITH_XCURSOR=ON \
99        -DWITH_XEXT=ON \
100        -DWITH_XINERAMA=ON \
101        -DWITH_XKBFILE=ON \
102        -DWITH_XV=ON \
[11966]103        -DWITH_ZLIB=ON \
[6955]104        -DWITH_CUNIT=OFF \
105        -DWITH_DIRECTFB=OFF \
106        -DWITH_FFMPEG=OFF \
[11966]107%ifarch x86_64
108    -DWITH_SSE2=ON \
109%else
110    -DWITH_SSE2=OFF \
111%endif
[6955]112        .
113
[3883]114
[8966]115make %{?_smp_mflags}
[3883]116
[11966]117pushd winpr/tools/makecert-cli
118make %{?_smp_mflags}
119popd
[8966]120
[3883]121%install
[11966]122rm -rf %{buildroot}
[6955]123
[11966]124%makeinstall DESTDIR=%{buildroot}
125%makeinstall DESTDIR=%{buildroot} COMPONENT=tools
[3883]126
[11966]127find %{buildroot} -name "*.a" -delete
128
[6955]129# No need for keymap files when using xkbfile
130rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
[3883]131
[11966]132desktop-file-install --dir=%{buildroot}%{_datadir}/applications xfreerdp.desktop
133install -p -D resources/FreeRDP_Icon_256px.png %{buildroot}%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
[6955]134
135
[3883]136%clean
[11966]137rm -rf %{buildroot}
[3883]138
139
[6955]140%post
141# This is no gtk application, but try to integrate nicely with GNOME if it is available
142gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
143
144
[3883]145%post libs -p /sbin/ldconfig
146
147
148%postun libs -p /sbin/ldconfig
149
150
151%files
152%defattr(-,root,root,-)
[6955]153%{_datadir}/applications/xfreerdp.desktop
154%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
[11966]155%{_bindir}/winpr-hash
156%{_bindir}/winpr-makecert
157%{_bindir}/xfreerdp
158%{_mandir}/man1/winpr-hash.1.*
159%{_mandir}/man1/winpr-makecert.1.*
160%{_mandir}/man1/xfreerdp.1.*
[3883]161
162%files libs
163%defattr(-,root,root,-)
[12400]164%license LICENSE
165%doc README ChangeLog
[11966]166%{_libdir}/lib*.so.*
167%{_mandir}/man7/wlog.*
[3883]168
169%files devel
170%defattr(-,root,root,-)
[11966]171%{_includedir}/*
172%{_libdir}/cmake/*
173%{_libdir}/lib*.so
174%{_libdir}/pkgconfig/*.pc
[3883]175
176
177%changelog
[12413]178* Wed May 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
179- updated to 2.1.1.
180
[12400]181* Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
182- updated to 2.1.0.
183
[11966]184* Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.0-1.rc4
185- updated to 2.0.0-RC4.
186- dropped all patches.
187- dropped subpackage 'freerdp-plugins'.
188
[9670]189* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
190- add BuildRequires: alsa-lib-devel
191
[8966]192* Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
193- update to 1.0.2
194- fixed typo in Group
195- dropped Patch0 and Patch1
196- added Patch2 to build with current xmlto
197
198* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
[6955]199- update to 1.0.1
200- import patches from fedora package.
201- add BRs.
202
[3883]203* Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
204- initial build for Vine Linux
205
206* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
207- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
208
209* Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
210- rebuild on rawhide because of broken dependencies
211
212* Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
213- freerdp-0.8.2
214
215* Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
216- make -devel require pkgconfig
217- first official Fedora package
218
219* Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
220- freerdp-0.8.1
221
222* Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
223- hack the generated libtool to not set rpath on x86_64
224- configure with alsa explicitly
225
226* Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
227- freerdp-0.7.4
228- cleanup of packaging structure
229
230* Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
231- 0.7.3
232- fix some minor pylint warnings
233
234* Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
235- 0.7.2
236- Address many comments from cwickert:
237- - cleanup of old formatting, alignment with spectemplate-lib.spec and
238    cwickert spec from #616193
239- - add alsa as build requirement
240- - remove superfluous configure options and disable static libs
241- - add missing rpm groups
242
243* Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
244- First official release, first review request
Note: See TracBrowser for help on using the repository browser.