source: projects/specs/trunk/f/freerdp/freerdp-vl.spec @ 11966

Revision 11966, 6.4 KB checked in by tomop, 5 years ago (diff)

freerdp-2.0.0-0.rc4, remmina-1.2.32.1-1

RevLine 
[11966]1%define rcnumber rc4
2
[3883]3Name:           freerdp
4Summary:        Remote Desktop Protocol client
5Summary(ja):    リモートデスクトッププロトコルクライアント
[11966]6Version:        2.0.0
7Release:        0%{?rcnumber:.%{rcnumber}}%{?_dist_release}
[3883]8
[8966]9Group:          Applications/Internet
[3883]10License:        GPLv2+
11URL:            http://www.freerdp.com/
[6955]12
[11966]13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16Source0:        https://github.com/downloads/FreeRDP/FreeRDP/FreeRDP-%{version}%{?rcnumber:-%{rcnumber}}.tar.gz
[6955]17# https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
18
[3883]19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
[6955]20BuildRequires:  cmake
21BuildRequires:  xmlto
[11966]22BuildRequires:  alsa-lib-devel
23BuildRequires:  cups-devel
[3883]24BuildRequires:  libX11-devel
[11966]25BuildRequires:  libXcursor-devel
26BuildRequires:  libXdamage-devel
[6955]27BuildRequires:  libXext-devel
28BuildRequires:  libXinerama-devel
[11966]29BuildRequires:  libxkbfile-devel
[6955]30BuildRequires:  libXv-devel
[11966]31BuildRequires:  zlib-devel
32BuildRequires:  openssl-devel
[6955]33BuildRequires:  pulseaudio-libs-devel
34BuildRequires:  pcsc-lite-devel
35BuildRequires:  desktop-file-utils
[3883]36
37Provides:       xfreerdp = %{version}-%{release}
[11966]38Obsoletes:      freerdp-plugins < 2.0.0
39Requires:       %{name}-libs = %{version}-%{release}
[3883]40
41%description
42The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
43project.
44
45xfreerdp can connect to RDP servers such as Microsoft Windows
46machines, xrdp and VirtualBox.
47
48
49%package        libs
50Summary:        Core libraries implementing the RDP protocol
51Summary(ja):    RDPプロトコル実装のコアライブラリ
52Group:          System Environment/Libraries
[8966]53
[3883]54%description    libs
55libfreerdp implements the core of the RDP protocol.
56
57libfreerdpchanman can be used to load plugins that can handle channels
58in the RDP protocol.
59
60libfreerdpkbd implements functionality for handling keyboards in X.
61
62
63%package        devel
64Summary:        Development files for %{name}
65Summary(ja):    %{name}の開発ファイル
66Group:          Development/Libraries
67Requires:       %{name}-libs = %{version}-%{release}
68Requires:       pkgconfig
69
70%description    devel
71The %{name}-devel package contains libraries and header files for
72developing applications that use %{name}-libs.
73
74
75%prep
[11966]76%setup -q -n FreeRDP-%{version}%{?rcnumber:-%{rcnumber}}
[3883]77
[6955]78cat << EOF > xfreerdp.desktop
79[Desktop Entry]
80Type=Application
81Name=X FreeRDP
82NoDisplay=true
83Comment=Connect to RDP server and display remote desktop
84Icon=%{name}
85Exec=/usr/bin/xfreerdp
86Terminal=false
87Categories=Network;RemoteAccess;
88EOF
[3883]89
90%build
[6955]91%cmake \
[8966]92        -DCMAKE_BUILD_TYPE=Release \
[11966]93        -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
94        -DWITH_ALSA=ON \
[6955]95        -DWITH_CUPS=ON \
[11966]96        -DWITH_OPENSSL=ON \
[6955]97        -DWITH_PCSC=ON \
[11966]98        -DWITH_PULSE=ON \
[6955]99        -DWITH_X11=ON \
100        -DWITH_XCURSOR=ON \
101        -DWITH_XEXT=ON \
102        -DWITH_XINERAMA=ON \
103        -DWITH_XKBFILE=ON \
104        -DWITH_XV=ON \
[11966]105        -DWITH_ZLIB=ON \
[6955]106        -DWITH_CUNIT=OFF \
107        -DWITH_DIRECTFB=OFF \
108        -DWITH_FFMPEG=OFF \
[11966]109%ifarch x86_64
110    -DWITH_SSE2=ON \
111%else
112    -DWITH_SSE2=OFF \
113%endif
[6955]114        .
115
[3883]116
[8966]117make %{?_smp_mflags}
[3883]118
[11966]119pushd winpr/tools/makecert-cli
120make %{?_smp_mflags}
121popd
[8966]122
[3883]123%install
[11966]124rm -rf %{buildroot}
[6955]125
[11966]126%makeinstall DESTDIR=%{buildroot}
127%makeinstall DESTDIR=%{buildroot} COMPONENT=tools
[3883]128
[11966]129find %{buildroot} -name "*.a" -delete
130
[6955]131# No need for keymap files when using xkbfile
132rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
[3883]133
[11966]134desktop-file-install --dir=%{buildroot}%{_datadir}/applications xfreerdp.desktop
135install -p -D resources/FreeRDP_Icon_256px.png %{buildroot}%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
[6955]136
137
[3883]138%clean
[11966]139rm -rf %{buildroot}
[3883]140
141
[6955]142%post
143# This is no gtk application, but try to integrate nicely with GNOME if it is available
144gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
145
146
[3883]147%post libs -p /sbin/ldconfig
148
149
150%postun libs -p /sbin/ldconfig
151
152
153%files
154%defattr(-,root,root,-)
[6955]155%{_datadir}/applications/xfreerdp.desktop
156%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
[11966]157%{_bindir}/winpr-hash
158%{_bindir}/winpr-makecert
159%{_bindir}/xfreerdp
160%{_mandir}/man1/winpr-hash.1.*
161%{_mandir}/man1/winpr-makecert.1.*
162%{_mandir}/man1/xfreerdp.1.*
[3883]163
164%files libs
165%defattr(-,root,root,-)
[6955]166%doc LICENSE README ChangeLog
[11966]167%{_libdir}/lib*.so.*
168%{_mandir}/man7/wlog.*
[3883]169
170%files devel
171%defattr(-,root,root,-)
[11966]172%{_includedir}/*
173%{_libdir}/cmake/*
174%{_libdir}/lib*.so
175%{_libdir}/pkgconfig/*.pc
[3883]176
177
178%changelog
[11966]179* Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.0-1.rc4
180- updated to 2.0.0-RC4.
181- dropped all patches.
182- dropped subpackage 'freerdp-plugins'.
183
[9670]184* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
185- add BuildRequires: alsa-lib-devel
186
[8966]187* Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
188- update to 1.0.2
189- fixed typo in Group
190- dropped Patch0 and Patch1
191- added Patch2 to build with current xmlto
192
193* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
[6955]194- update to 1.0.1
195- import patches from fedora package.
196- add BRs.
197
[3883]198* Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
199- initial build for Vine Linux
200
201* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
203
204* Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
205- rebuild on rawhide because of broken dependencies
206
207* Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
208- freerdp-0.8.2
209
210* Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
211- make -devel require pkgconfig
212- first official Fedora package
213
214* Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
215- freerdp-0.8.1
216
217* Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
218- hack the generated libtool to not set rpath on x86_64
219- configure with alsa explicitly
220
221* Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
222- freerdp-0.7.4
223- cleanup of packaging structure
224
225* Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
226- 0.7.3
227- fix some minor pylint warnings
228
229* Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
230- 0.7.2
231- Address many comments from cwickert:
232- - cleanup of old formatting, alignment with spectemplate-lib.spec and
233    cwickert spec from #616193
234- - add alsa as build requirement
235- - remove superfluous configure options and disable static libs
236- - add missing rpm groups
237
238* Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
239- First official release, first review request
Note: See TracBrowser for help on using the repository browser.