source: projects/specs/trunk/f/freeglut/freeglut-vl.spec @ 521

Revision 521, 6.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:   A freely licensed alternative to the GLUT library
2Summary(ja): 自由なライセンスで提供される GLUT ライブラリ
3Name:      freeglut
4Version:   2.4.0
5Release:   6%{?_dist_release}
6URL:       http://freeglut.sourceforge.net
7Source0:   %{name}-%{version}.tar.gz
8License:   MIT
9Group:     System Environment/Libraries
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: /sbin/ldconfig
13BuildRequires: pkgconfig
14BuildRequires: libXext-devel, libXxf86vm-devel, mesa-libGLU-devel
15# The virtual Provides below is present so that this freeglut package is a
16# drop in binary replacement for "glut" which will satisfy rpm dependancies
17# properly.  The Obsoletes tag is required in order for any pre-existing
18# "glut" package to be removed and replaced with freeglut when upgrading to
19# freeglut.  Note: This package will NOT co-exist with the glut package.
20Provides: glut = 3.7
21Obsoletes: glut <= 3.7
22
23Requires(post,postun): /sbin/ldconfig
24
25%description
26freeglut is a completely open source alternative to the OpenGL Utility Toolkit
27(GLUT) library with an OSI approved free software license. GLUT was originally
28written by Mark Kilgard to support the sample programs in the second edition
29OpenGL 'RedBook'. Since then, GLUT has been used in a wide variety of practical
30applications because it is simple, universally available and highly portable.
31
32freeglut allows the user to create and manage windows containing OpenGL
33contexts on a wide range of platforms and also read the mouse, keyboard and
34joystick functions.
35
36%package devel
37Summary: freeglut developmental libraries and header files
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Requires: mesa-libGL-devel, mesa-libGLU-devel
41Provides: glut-devel = 3.7
42Obsoletes: glut-devel <= 3.7
43
44%description devel
45Developmental libraries and header files required for developing or compiling
46software which links to the freeglut library, which is an open source
47alternative to the popular GLUT library, with an OSI approved free software
48license.
49
50%prep
51%setup -q
52
53%build
54%configure --disable-warnings
55make CFLAGS="$RPM_OPT_FLAGS -Wall $(pkg-config --cflags glib)"
56
57%install
58rm -rf $RPM_BUILD_ROOT
59%makeinstall
60/sbin/ldconfig -n %{_libdir}
61chmod 644 doc/*.{html,png}
62rm $RPM_BUILD_ROOT/%{_libdir}/*.la
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post -p /sbin/ldconfig
68%postun -p /sbin/ldconfig
69
70%files
71%defattr(-,root,root,-)
72%doc AUTHORS ChangeLog COPYING INSTALL NEWS README TODO doc/*.png doc/*.html
73# don't include contents of doc/ directory as it is mostly obsolete
74%{_libdir}/libglut*.so.*
75
76%files devel
77%defattr(-,root,root,-)
78%{_includedir}/GL/*.h
79%{_libdir}/libglut*.a
80#%{_libdir}/libglut*.la
81%{_libdir}/libglut.so
82
83%changelog
84* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-6
85- rebuild with mesa-7.1
86
87* Thu May 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-5
88- new versioning policy
89
90* Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-4vl2
91- build with xorg-x11-7.3 and mesa-7.0.2
92
93* Sun Sep 03 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.0-4vl1
94- imported from Fedora Core 5
95
96* Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 2.4.0-4
97- BuildRequires: libGLU-devel
98
99* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.0-3.2
100- bump again for double-long bug on ppc(64)
101
102* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.0-3.1
103- rebuilt for new gcc4.1 snapshot and glibc changes
104
105* Tue Jan 31 2006 Mike A. Harris <mharris@redhat.com> 2.4.0-3
106- Added "Requires: libGL-devel libGLU-devel" to fix bug (#179464)
107- Change file based GL header build dep to BuildRequires: libGL-devel
108
109* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> 2.4.0-2.1
110- rebuilt
111
112* Fri Nov 18 2005 Bill Nottingham <notting@redhat.com> 2.4.0-2
113- Remove references to obsolete /usr/X11R6 paths
114
115* Fri Sep 23 2005 Mike A. Harris <mharris@redhat.com> 2.4.0-1
116- Updated to freeglut-2.4.0
117- Removed unneeded patches:
118  - freeglut-2.2.0-gcc4-fix-invalid-lvalue-in-assignment-cvsps-392-393.patch
119- Use "-p /sbin/ldconfig" in post/postun scripts instead of a separate script.
120
121* Sat Mar  5 2005 Mike A. Harris <mharris@redhat.com> 2.2.0-16
122- Added freeglut-2.2.0-gcc4-fix-invalid-lvalue-in-assignment-cvsps-392-393.patch
123  to fix "invalid lvalue in assignment" bugs reported by gcc 4
124- Added "-Wall" to CFLAGS in specfile.
125
126* Thu Mar  3 2005 Mike A. Harris <mharris@redhat.com> 2.2.0-15
127- Rebuild with gcc 4 for FC4 development
128
129* Sat Aug 14 2004 Mike A. Harris <mharris@redhat.com> 2.2.0-14
130- Add post and postun scripts that call ldconfig (#128413)
131
132* Fri Jun 18 2004 Mike A. Harris <mharris@redhat.com> 2.2.0-13
133- Rebuilt with gcc 3.4 for FC3 development
134
135* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 2.2.0-12
136- rebuilt
137
138* Thu Mar 18 2004 Mike A. Harris <mharris@redhat.com> 2.2.0-11
139- Updated "Obsoletes: glut" to be "Obsoletes: glut <= 3.7" and
140  "Obsoletes: glut-devel" to be "Obsoletes: glut-devel <= 3.7" as per
141  suggestion from Matthias Saou in comment #14 of bug (#107228)
142
143* Sun Mar  7 2004 Mike A. Harris <mharris@redhat.com>
144- Made "glut-devel" virtual provides be "glut-devel = 3.7"
145
146* Sun Mar  7 2004 Mike A. Harris <mharris@redhat.com> 2.2.0-10
147- Initial Red Hat packaging created by taking the ATrpms src.rpm package from
148  http://tinyurl.com/2goog as suggested in bugzilla bug (#107228)
149- Bumped the Release field to "10" so our package is newer when people
150  upgrade to it, as requested in bug (#107228)
151- Removed redundant version/release macros from top of specfile
152- Versioned buildroot directory
153- Add --enable-warnings arg to ./configure script
154- Add HTML documentation to main package
155- Made "glut" virtual provides be "glut = 3.7"
156- Do not include *.la files
157
158* Sat Feb 21 2004 Axel Thimm <Axel.Thimm@physik.fu-berlin.de> 2.2.0
159- Added glut compatibility provides.
160- Moved *.so to devel package.
161
162* Tue Jan 13 2004 Andy Piper <andy.piper@freeuk.com>
163- updated to freeglut-2.2.0
164- fixed library install
165
166* Fri Nov 14 2003 Andy Piper <andy.piper@freeuk.com>
167- updated for freeglut-2.0.1
168
169* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
170- rebuilt
171
172* Tue Jun  3 2003 Mike A. Harris <mharris@www.linux.org.uk> 1.3-0.20020125.3
173- Add BuildRequires on /sbin/ldconfig
174- Change ldconfig call to explicit /sbin/ldconfig
175
176* Sun Jun  1 2003 Mike A. Harris <mharris@www.linux.org.uk> 1.3-0.20020125.2
177- Oddly, when I build this on my workstation, it only builds static libs, but
178  when I build it in the buildsystem it builds shared and static libs.  Must
179  be a twilight zone thing going on.  Add shared libs to file lists.
180
181* Sat May 31 2003 Mike A. Harris <mharris@www.linux.org.uk> 1.3-0.20020125.1
182- Added -L/usr/X11R6/%{_lib} configure script invocation and CFLAGS so lib64
183  is treated properly on x86_64/ppc64/s390x architectures
184 
185* Fri May 30 2003 Mike A. Harris <mharris@www.linux.org.uk> 1.3-0.20020125.0
186- Initial build.
Note: See TracBrowser for help on using the repository browser.