source: projects/specs/trunk/f/foomatic/foomatic-vl.spec @ 9588

Revision 9588, 23.0 KB checked in by tomop, 9 years ago (diff)

foomatic-4.0.12-1

Line 
1%define dbver_rel 4.0
2%define dbver_snap 20150415
3%define enginever 4.0.12
4%define filtersver 4.0-20150415
5
6Summary: Foomatic printer database.
7Name:           foomatic
8Version:        %{enginever}
9Release:        1%{?_dist_release}
10License:        GPL
11Group: System Environment/Libraries
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: tomop, daisuke, machino
16
17Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
18Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
19Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
20
21# Use libdir.
22Patch1: foomatic-filters-libdir.patch
23Patch2: foomatic-db-engine-libdir.patch
24
25# Handle non-UTF-8 encodings in imported PPD files.
26Patch15: foomatic-bad-utf8.patch
27
28Url:            http://www.linuxprinting.org
29Requires:       perl >= 5.12.3
30Requires:       %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
31Requires:       hplip
32BuildRequires:  perl >= 5.12.3
33BuildRequires:  libxml2-devel
34BuildRequires:  ghostscript-devel
35BuildRequires:  autoconf, automake
36BuildRequires:  mpage
37BuildRequires:  dbus-devel
38BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
39Provides:       perl(Foomatic::GrovePath)
40# For 'rm' and '/sbin/service' in post
41Requires(pre):  coreutils initscripts
42Obsoletes: foomatic-db < 4.0.0
43Obsoletes: foomatic-ppd < 4.0.0
44Obsoletes: foomatic-ppd-gimp-print < 4.0.0
45Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
46Obsoletes: foomatic-ppd-omni < 4.0.0
47
48# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
49Conflicts: ghostscript < 7.05
50
51%description
52Foomatic is a comprehensive, spooler-independent database of printers,
53printer drivers, and driver descriptions. It contains utilities to
54generate driver description files and printer queues for CUPS, LPD,
55LPRng, and PDQ using the database. There is also the possibility to
56read the PJL options out of PJL-capable laser printers and take them
57into account at the driver description file generation.
58
59There are spooler-independent command line interfaces to manipulate
60queues (foomatic-configure) and to print files/manipulate jobs
61(foomatic printjob).
62
63The site http://www.linuxprinting.org/ is based on this database.
64
65%prep
66%setup -q  -c -a 1 -a 2
67
68#pushd foomatic-filters-%{filtersver}
69#%patch1 -p1 -b .libdir
70#popd
71
72pushd foomatic-db-engine-%{enginever}
73chmod a+x mkinstalldirs
74#%patch2 -p1 -b .libdir
75#%patch15 -p1
76popd
77
78pushd foomatic-db-%{dbver_snap}
79
80cd db/source
81
82# For gutenprint printers, use gutenprint-ijs-simplified.5.2.
83perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
84
85# Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
86# Also foo2lava, foo2kyo, foo2xqx (bug #438319).
87for x in zjs oak hp qpdl lava kyo xqx
88do
89  find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
90  rm -f driver/foo2${x}.xml opt/foo2${x}-*
91done
92# Same for m2300w/m2400w
93find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
94rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
95# Same for all these.
96for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
97do
98  find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
99  rm -vf driver/${x}.xml opt/${x}-*
100done
101
102popd
103
104%build
105export LIB_CUPS=%{_libdir}/cups
106export CUPS_BACKENDS=%{_libdir}/cups/backend
107export CUPS_FILTERS=%{_libdir}/cups/filter
108export CUPS_PPDS=%{_datadir}/cups/model
109
110pushd foomatic-filters-%{filtersver}
111./make_configure
112%configure
113make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
114        INSTALLDIRS=vendor
115popd
116
117pushd foomatic-db-engine-%{enginever}
118%configure --disable-xmltest
119make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
120        INSTALLDIRS=vendor defaults
121make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
122        INSTALLDIRS=vendor
123popd
124
125pushd foomatic-db-%{dbver_snap}
126%configure
127make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
128        INSTALLDIRS=vendor
129popd
130
131%install
132rm -rf %{buildroot}
133
134pushd foomatic-filters-%{filtersver}
135eval `perl '-V:installvendorlib' '-V:installvendorarch'`
136mkdir -p %{buildroot}/$installvendorlib
137
138
139echo %{buildroot}
140
141make    DESTDIR=%{buildroot} PREFIX=%{_prefix} \
142        INSTALLDIRS=vendor \
143        INSTALLVENDORLIB=$installvendorlib \
144        INSTALLVENDORARCH=$installvendorarch \
145        install-main install-cups
146popd
147
148pushd foomatic-db-engine-%{enginever}
149make    DESTDIR=%buildroot PREFIX=%{_prefix} \
150        INSTALLDIRS=vendor \
151        INSTALLVENDORLIB=$installvendorlib \
152        INSTALLVENDORARCH=$installvendorarch \
153        install
154popd
155
156pushd foomatic-db-%{dbver_snap}
157make    DESTDIR=%buildroot PREFIX=%{_prefix} \
158        INSTALLDIRS=vendor \
159        INSTALLVENDORLIB=$installvendorlib \
160        INSTALLVENDORARCH=$installvendorarch \
161        install
162popd
163
164# Remove ghostscript UPP drivers that are gone in 7.07
165rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
166
167# Remove drivers with no command line.
168pushd foomatic-db-engine-%{enginever}
169perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
170popd
171
172# Update any old-style printer IDs still left around.
173echo '#!/usr/bin/perl -pi' > convert-printerids.pl
174sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
175        %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
176        >> convert-printerids.pl
177chmod a+x convert-printerids.pl
178./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
179find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
180
181# Use relative, not absolute, symlink for CUPS filter.
182ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
183
184# Use relative, not absolute, symlink for CUPS driver.
185mkdir -p %{buildroot}%{_libdir}/cups/driver
186ln -sf ../../../bin/foomatic-ppdfile %{buildroot}%{_libdir}/cups/driver/foomatic
187
188mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
189mkdir -p %{buildroot}%{_var}/cache/foomatic
190
191echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
192
193# Remove things we don't ship.
194rm -rf  %{buildroot}%{_libdir}/perl5/site_perl \
195        %{buildroot}%{_libdir}/ppr \
196        %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
197find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
198
199
200%post
201/bin/rm -f /var/cache/foomatic/*
202
203# restart the print server if it is running now
204/sbin/service lpd condrestart >/dev/null 2>&1
205/sbin/service cups condrestart >/dev/null 2>&1
206
207exit 0
208
209%clean
210rm -fr %buildroot $RPM_BUILD_DIR/%{name}
211
212%files
213%defattr(-,root,root)
214%doc --parents */README */USAGE */ChangeLog
215%dir %{_sysconfdir}/foomatic
216%config(noreplace) %{_sysconfdir}/foomatic/filter.conf
217%config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
218%{_bindir}/*
219%{_sbindir}/*
220%{perl_vendorlib}/Foomatic
221%{_libdir}/cups/backend/*
222%{_libdir}/cups/driver/*
223%{_libdir}/cups/filter/*
224%{_datadir}/foomatic
225%{_datadir}/cups/model/foomatic-db-ppds
226%{_mandir}/*/*
227%{_var}/cache/foomatic
228
229%changelog
230* Tue Jun  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-1
231- new upstream release.
232
233* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0.11-2
234- rebuild with perl-5.16
235- add BR: dbus-devel
236
237* Sun Jun  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.11-1
238- new upstream release.
239
240* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
241- new upstream release.
242
243* Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
244- added hplip and coreutils to "Requires:".
245- removed hpijs and fileutils from "Requires:".
246
247* Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
248- new upstream release.
249- dropped Source3 (no longer provided by upstream).
250- updated Patch2.
251
252* Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
253- rebuild with perl 5.12.3
254
255* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
256- add Requires: hpijs
257
258* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
259- new upstream release
260
261* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
262- new upstream release.
263- applied some patches from Fedora development.
264- remove subpackages.
265
266* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
267- applied new versioning policy
268- used rpm macros: %%perl_sitelib %%perl_sitearch
269- added foomatic-db-engine-3.1-20050411-combo-xml.patch
270- added foomatic-db-engine-3.1-20050411-perl-data.patch
271- fixed permission of %%{_datadir}/foomatic/db
272
273* Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
274- add BuildRequires: libxml2-devel, mpage, Omni
275- use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
276- run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
277- not create ppd-omni package if omni support is disabled
278
279* Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
280- updated foomatic-db to 20050411
281- updated foomatic-db-engine to 3.1-20050411
282- updated foomatic-db-hpijs to 1.5-20050411
283- updated foomatic-filters to 3.1-20050411
284
285* Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
286- updated foomatic-db to 20050112
287- updated foomatic-db-engine to 3.1-20050112
288- updated foomatic-db-hpijs to 1.5-20050112
289
290* Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
291- updated foomatic-db to 20041220
292- updated foomatic-db-hpijs to 1.5-20041220
293
294* Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
295- updated foomatic-db to 20040919
296- updated foomatic-db-engine to 3.0.2
297- updated foomatic-db-hpijs to 1.5-20040919
298- updated foomatic-filters to 3.0.2
299
300* Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
301- update foomatic-db to 20040526
302- update foomatic-db-hpijs to 1.5-20040526
303
304* Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
305- sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
306  ppd-gimp-print-ijs
307- add Requires: to ppd-* subpackages.
308
309* Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
310- new upstream version
311        -- Omni-printers-0.9.1
312        -- gimp-print-foomatic-db-4.2.6
313- foomatic.spec -> foomatic-vl.spec
314
315* Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
316- new upstream version
317        -- foomatic-filters-3.0.1
318        -- foomatic-db-engine-3.0.1
319        -- foomatic-db-20040219
320        -- foomatic-db-hpijs-1.5-20040219
321
322* Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
323- new upstream version
324        -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
325        -- defined filterver
326- dropped patch101
327
328* Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
329- new upstream cvs version(foomatic-3.0.1rc2)
330        -- foomatic-db-20040125
331        -- foomatic-db-engine-3.0.1rc2
332        -- foomatic-db-hpijs-1.5-20040125
333        -- foomatic-filters-3.0.1rc2
334- added patch101
335        -- tests diris null in foomatic-filters-3.0.1rc2
336
337* Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
338- new upstream cvs version
339        -- foomatic-db-20040123
340        -- foomatic-db-engine-3.0-20040123
341        -- foomatic-db-hpijs-1.5-20040123
342        -- foomatic-filters-3.0-20040123
343- dropped old patches
344
345* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
346- built on perl-5.8.2
347
348* Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
349- separated foomatic-db package included xml files
350
351* Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
352- added description of ppd sub package
353
354* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
355- separated foomatic-ppd package included PPD files
356
357* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
358- new upstream version
359        -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
360        -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
361- dropped patches
362        -- foomatic-filters-path.patch(patch0)
363        -- foomatic-2.0.2-fontpath.patch(patch3)
364- updated patches
365        -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
366        -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
367        -- foomatic-filters-3.0-20031109-vine.patch (patch100)
368
369* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
370- built on perl-5.8.1
371- fixed install section in spec file
372
373* Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
374- fix some bugs of foomatic-filters.
375A
376
377* Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
378- new upstream version
379        -- rewrote spec file
380        -- added some patches from rawhide(foomatic-3.0.0-5)
381- enable cups support
382
383* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
384- imported some patches from foomatic-2.0.2-18
385        -- added foomatic-2.0.2-psc2210.patch
386        -- added foomatic-2.0.2-duplex184.patch
387
388* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
389- imported foomatic-2.0.2-15
390 
391* Tue Feb  4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
392- Update data-generators to CVS.
393
394* Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
395- Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
396
397* Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
398- Pacify printers that don't understand duplex (bug #82385).
399
400* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
401- rebuilt
402
403* Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
404- Add autodetect info for HP DeskJet 656C.  It doesn't really do
405  IEEE 1284 IDs, but since it's a USB device we can figure out it's
406  manufacturer and model anyway.
407
408* Thu Jan  9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
409- Set GS_FONTPATH in gs wrapper (bug #81410).
410
411* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
412- use internal dep generator.
413
414* Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
415- Add several device IDs.
416
417* Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
418- Update Omni printers to 0.7.2.
419- No longer need Omni badxml patch.
420
421* Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
422- don't use rpms internal dep generator
423
424* Fri Dec  6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
425- Omni XML wasn't well-formed.
426
427* Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
428- Update gimp-print data.
429- Add 'generic postscript' model.
430
431* Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
432- Update Omni printers to 0.7.1.
433
434* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
435- Fix file manifest for perl modules.
436- Add autodetect information for HP DeskJet 990C.
437
438* Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
439- 2.0.2.
440- No longer need 67973, 970c patches.
441- Remove cups-drivers-* packages (no longer needed).
442- Remove files not shipped.  Ship filter.conf.
443- Conditionally restart cups.
444- Use libdir.
445- Don't put things in site_perl; use vendor_perl instead (bug #73528).
446
447* Fri Aug  9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
448- Fix autodetect information for HPDJ970C.
449
450* Thu Aug  8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
451- For gimp-print, use the Ghostscript stp driver in preference to the
452  IJS interface.
453
454* Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
455- Quieten scriptlets.
456
457* Fri Jul  5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
458- Fix autodetect information for HPLJ2100/2100M.
459
460* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
461- automated rebuild
462
463* Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
464- Omni 0.7.0 printers.
465
466* Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
467- Update to CVS.
468- Remove some more explicit perl dependencies that are picked up
469  automatically.
470
471* Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
472- Remove explicit perl-Storable dependency; it should be perl(Storable),
473  and that is picked up automatically.
474
475* Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
476- Fix release number.
477- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
478  (bug #63622).
479
480* Sun May 26 2002 Tim Powers <timp@redhat.com>
481- automated rebuild
482
483* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
484- Remove ghostscript UPP drivers that are gone in 7.05.
485
486* Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
487- Update to CVS.
488- Updated requirements.
489- Updated path and libdir patches.
490- Drop hpijs 1.0.2 patch.
491- foomatic-datafile has moved to %%{_bindir}.
492- Update gimp-print data to 4.2.1.
493- Update Omni printer data to 0.6.1.
494
495* Thu Apr  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
496- Fix the hpijs option data too (bug #62587).
497
498* Wed Apr  3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
499- Back off to 1.0.2 for hpijs driver data (bug #62587).
500
501* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
502- Update to CVS.
503
504* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
505- Update to CVS.
506- Patches no longer needed: conffile, sys, cachedir, fd0.
507- Adapted path patch.
508
509* Tue Mar  5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
510- Fix bug #58319.
511- Drop dbg patch.
512
513* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
514- Fix file lists.
515
516* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
517- Fix %post scriplet bug (bug #59942).
518
519* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
520- Rebuild in new environment.
521
522* Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
523- Merge cups-drivers.  No epoch needed.
524- Require perl-URI.
525
526* Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
527- Cache fix.
528
529* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
530- Don't ship backup files.
531
532* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
533- Rebuild to pick up new perl installsitelib.
534
535* Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
536- Fix a thinko in DB.pl.
537
538* Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
539- Update to CVS.
540- No longer need the cachedir patch.
541- Fix config file path.
542- Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
543
544* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
545- Update to CVS.
546- Patches no longer needed: prepend, fd3.
547- Use RPM_OPT_FLAGS.
548- Allow non-root users to use foomatic-datafile (bug #58956).
549
550* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
551- added Provides: perl(Foomatic::GrovePath)
552
553* Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
554- Update to CVS.
555- Updated Omni printers to those in Omni 0.5.1.
556- Updated patches: prepend, fd3.
557- Patches no longer needed: utf8, lpdomatic.
558- Added gimp-print (formerly stp) foomatic db info, and removed the old
559  stp.xml file.
560- Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
561
562* Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
563- REALLY fix PCL fixup code (bug #55909, others).
564- PreReq fileutils, initscripts (bug #56984).
565- Fix prepends in lpdomatic (bug #57371).
566- Run foomatic-cleanupdrivers during install, to remove driver entries
567  with no command line.
568- Put lpdomatic in /usr/sbin again.
569- Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
570
571* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
572- re-imported from upstream to fix some perl fixup code on pcl printers.
573
574* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
575- fix the rest of the quoting issues with foomatic-combo-xml with the patch
576- foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
577
578* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
579- respin to pull in latest foomatic database, fixes:
580-       properly use the cache in relation to foomatic-combo-xml's output
581-       fix _some_ of the quoting issues with calling foomatic-combo-xml
582
583* Wed Dec  5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
584- respin to pull in latest foomatic database, fixes:
585-       droping half of a large job
586-       -Mutf8 added to the upstream filters
587-       miscelaneous printer db updates
588
589* Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
590- added Requires: fileutils for the 'rm' in post
591
592* Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
593- /var/chache => /var/cache, doh!
594
595* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
596- fix %%post scriptlet
597
598* Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
599- changed the patch to use the -Mutf8 command line option,
600- and to restart the printserver, after rebuilding the settings.
601
602* Fri Nov  9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
603- grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
604- pragma. Without it, they break on _some_ of their options.
605
606* Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
607- patched lpdomatic to prepend PostScript options in the _right_ place.
608
609* Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
610- zap the foomatic cache on install
611
612* Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
613- rolled to pull in latest information.
614- added Omni printers to the printer list.
615
616* Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
617- rolled to pull in an ia64 fix to foomatic-combo-xml.c
618
619* Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
620- rolled to pull in foomatic fixes to foomatic-combo-xml.c
621
622* Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
623- upgraded to latest foomatic, we now have fast overview generation!
624- this means that there is no prebuilt overview file.
625
626* Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
627- WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
628- It is now fast enough that there is no real benifit to precompiling.
629- NOTE: this forces the package to stop being noarched.
630
631* Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
632- fresh pull, maybe it fixes the build errors.
633
634* Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
635- did a fresh database pull, which contains the old japanese printers as well.
636- removed japanese hack.
637
638* Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
639- Add Japanese printer entry.
640
641* Mon Aug  6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
642- move the cache back to /var, sigh.
643
644* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
645- made foomatic pre-compute its db
646
647* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
648- imported from mandrake.
649
650* Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
651- Added job listing/removal/manipulation and queue control to
652  foomatic-printjob
653- Support for printing multiple copies with PDQ
654
655* Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
656- Included the cupsomatic filter script
657- When a queue is set up, default options can be set now
658- Help messages of foomatic-configure and foomatic-printjob cleaned up.
659
660* Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
661- Many bugfixes in "foomatic-printjob".
662- "foomatic-configure" adds the Foomatic config file directory automatically
663  to the search paths of PDQ.
664- Printing a help page under PDQ was broken.
665
666* Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
667- BuildRequires:        perl-devel
668
669* Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
670- initial release.
671- Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
672- Patch applied which flushes the memory cache regularly, otherwise
673  foomatic-configure would hang when the Foomatic data of GIMP-Print is
674  installed.
Note: See TracBrowser for help on using the repository browser.