source: projects/specs/trunk/f/foomatic/foomatic-vl.spec @ 8700

Revision 8700, 22.7 KB checked in by daisuke, 10 years ago (diff)

foomatic: rebuild with new perl, add BR: dbus-devel

Line 
1%define dbver_rel 4.0
2%define dbver_snap 20140607
3%define enginever 4.0.11
4%define filtersver 4.0.17
5
6Summary: Foomatic printer database.
7Name:           foomatic
8Version:        %{enginever}
9Release:        2%{?_dist_release}
10License:        GPL
11Group: System Environment/Libraries
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: tomop, daisuke, machino
16
17Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
18Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
19Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
20
21# Use libdir.
22Patch1: foomatic-filters-libdir.patch
23Patch2: foomatic-db-engine-libdir.patch
24
25# Handle non-UTF-8 encodings in imported PPD files.
26Patch15: foomatic-bad-utf8.patch
27
28Url:            http://www.linuxprinting.org
29Requires:       perl >= 5.12.3
30Requires:       %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
31Requires:       hplip
32BuildRequires:  perl >= 5.12.3
33BuildRequires:  libxml2-devel
34BuildRequires:  ghostscript-devel
35BuildRequires:  autoconf, automake
36BuildRequires:  mpage
37BuildRequires:  dbus-devel
38BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
39Provides:       perl(Foomatic::GrovePath)
40# For 'rm' and '/sbin/service' in post
41Requires(pre):  coreutils initscripts
42Obsoletes: foomatic-db < 4.0.0
43Obsoletes: foomatic-ppd < 4.0.0
44Obsoletes: foomatic-ppd-gimp-print < 4.0.0
45Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
46Obsoletes: foomatic-ppd-omni < 4.0.0
47
48# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
49Conflicts: ghostscript < 7.05
50
51%description
52Foomatic is a comprehensive, spooler-independent database of printers,
53printer drivers, and driver descriptions. It contains utilities to
54generate driver description files and printer queues for CUPS, LPD,
55LPRng, and PDQ using the database. There is also the possibility to
56read the PJL options out of PJL-capable laser printers and take them
57into account at the driver description file generation.
58
59There are spooler-independent command line interfaces to manipulate
60queues (foomatic-configure) and to print files/manipulate jobs
61(foomatic printjob).
62
63The site http://www.linuxprinting.org/ is based on this database.
64
65%prep
66%setup -q  -c -a 1 -a 2
67
68#pushd foomatic-filters-%{filtersver}
69#%patch1 -p1 -b .libdir
70#popd
71
72pushd foomatic-db-engine-%{enginever}
73chmod a+x mkinstalldirs
74#%patch2 -p1 -b .libdir
75#%patch15 -p1
76popd
77
78pushd foomatic-db-%{dbver_snap}
79
80cd db/source
81
82# For gutenprint printers, use gutenprint-ijs-simplified.5.2.
83perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
84
85# Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
86# Also foo2lava, foo2kyo, foo2xqx (bug #438319).
87for x in zjs oak hp qpdl lava kyo xqx
88do
89  find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
90  rm -f driver/foo2${x}.xml opt/foo2${x}-*
91done
92# Same for m2300w/m2400w
93find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
94rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
95# Same for all these.
96for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
97do
98  find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
99  rm -vf driver/${x}.xml opt/${x}-*
100done
101
102popd
103
104%build
105export LIB_CUPS=%{_libdir}/cups
106export CUPS_BACKENDS=%{_libdir}/cups/backend
107export CUPS_FILTERS=%{_libdir}/cups/filter
108export CUPS_PPDS=%{_datadir}/cups/model
109
110pushd foomatic-filters-%{filtersver}
111%configure
112make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
113        INSTALLDIRS=vendor
114popd
115
116pushd foomatic-db-engine-%{enginever}
117%configure --disable-xmltest
118make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
119        INSTALLDIRS=vendor defaults
120make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
121        INSTALLDIRS=vendor
122popd
123
124pushd foomatic-db-%{dbver_snap}
125%configure
126make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
127        INSTALLDIRS=vendor
128popd
129
130%install
131rm -rf %{buildroot}
132
133pushd foomatic-filters-%{filtersver}
134eval `perl '-V:installvendorlib' '-V:installvendorarch'`
135mkdir -p %{buildroot}/$installvendorlib
136
137
138echo %{buildroot}
139
140make    DESTDIR=%{buildroot} PREFIX=%{_prefix} \
141        INSTALLDIRS=vendor \
142        INSTALLVENDORLIB=$installvendorlib \
143        INSTALLVENDORARCH=$installvendorarch \
144        install-main install-cups
145popd
146
147pushd foomatic-db-engine-%{enginever}
148make    DESTDIR=%buildroot PREFIX=%{_prefix} \
149        INSTALLDIRS=vendor \
150        INSTALLVENDORLIB=$installvendorlib \
151        INSTALLVENDORARCH=$installvendorarch \
152        install
153popd
154
155pushd foomatic-db-%{dbver_snap}
156make    DESTDIR=%buildroot PREFIX=%{_prefix} \
157        INSTALLDIRS=vendor \
158        INSTALLVENDORLIB=$installvendorlib \
159        INSTALLVENDORARCH=$installvendorarch \
160        install
161popd
162
163# Remove ghostscript UPP drivers that are gone in 7.07
164rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
165
166# Remove drivers with no command line.
167pushd foomatic-db-engine-%{enginever}
168perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
169popd
170
171# Update any old-style printer IDs still left around.
172echo '#!/usr/bin/perl -pi' > convert-printerids.pl
173sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
174        %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
175        >> convert-printerids.pl
176chmod a+x convert-printerids.pl
177./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
178find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
179
180# Use relative, not absolute, symlink for CUPS filter.
181ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
182
183mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
184mkdir -p %{buildroot}%{_var}/cache/foomatic
185
186echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
187
188# Remove things we don't ship.
189rm -rf  %{buildroot}%{_libdir}/perl5/site_perl \
190        %{buildroot}%{_libdir}/ppr \
191        %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
192find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
193
194
195%post
196/bin/rm -f /var/cache/foomatic/*
197
198# restart the print server if it is running now
199/sbin/service lpd condrestart >/dev/null 2>&1
200/sbin/service cups condrestart >/dev/null 2>&1
201
202exit 0
203
204%clean
205rm -fr %buildroot $RPM_BUILD_DIR/%{name}
206
207%files
208%defattr(-,root,root)
209%doc --parents */README */USAGE */ChangeLog
210%dir %{_sysconfdir}/foomatic
211%config(noreplace) %{_sysconfdir}/foomatic/filter.conf
212%config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
213%{_bindir}/*
214%{_sbindir}/*
215%{perl_vendorlib}/Foomatic
216%{_libdir}/cups/backend/*
217%{_libdir}/cups/driver/*
218%{_libdir}/cups/filter/*
219%{_datadir}/foomatic
220%{_datadir}/cups/model/foomatic-db-ppds
221%{_mandir}/*/*
222%{_var}/cache/foomatic
223
224%changelog
225* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0.11-2
226- rebuild with perl-5.16
227- add BR: dbus-devel
228
229* Sun Jun  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.11-1
230- new upstream release.
231
232* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
233- new upstream release.
234
235* Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
236- added hplip and coreutils to "Requires:".
237- removed hpijs and fileutils from "Requires:".
238
239* Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
240- new upstream release.
241- dropped Source3 (no longer provided by upstream).
242- updated Patch2.
243
244* Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
245- rebuild with perl 5.12.3
246
247* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
248- add Requires: hpijs
249
250* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
251- new upstream release
252
253* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
254- new upstream release.
255- applied some patches from Fedora development.
256- remove subpackages.
257
258* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
259- applied new versioning policy
260- used rpm macros: %%perl_sitelib %%perl_sitearch
261- added foomatic-db-engine-3.1-20050411-combo-xml.patch
262- added foomatic-db-engine-3.1-20050411-perl-data.patch
263- fixed permission of %%{_datadir}/foomatic/db
264
265* Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
266- add BuildRequires: libxml2-devel, mpage, Omni
267- use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
268- run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
269- not create ppd-omni package if omni support is disabled
270
271* Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
272- updated foomatic-db to 20050411
273- updated foomatic-db-engine to 3.1-20050411
274- updated foomatic-db-hpijs to 1.5-20050411
275- updated foomatic-filters to 3.1-20050411
276
277* Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
278- updated foomatic-db to 20050112
279- updated foomatic-db-engine to 3.1-20050112
280- updated foomatic-db-hpijs to 1.5-20050112
281
282* Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
283- updated foomatic-db to 20041220
284- updated foomatic-db-hpijs to 1.5-20041220
285
286* Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
287- updated foomatic-db to 20040919
288- updated foomatic-db-engine to 3.0.2
289- updated foomatic-db-hpijs to 1.5-20040919
290- updated foomatic-filters to 3.0.2
291
292* Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
293- update foomatic-db to 20040526
294- update foomatic-db-hpijs to 1.5-20040526
295
296* Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
297- sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
298  ppd-gimp-print-ijs
299- add Requires: to ppd-* subpackages.
300
301* Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
302- new upstream version
303        -- Omni-printers-0.9.1
304        -- gimp-print-foomatic-db-4.2.6
305- foomatic.spec -> foomatic-vl.spec
306
307* Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
308- new upstream version
309        -- foomatic-filters-3.0.1
310        -- foomatic-db-engine-3.0.1
311        -- foomatic-db-20040219
312        -- foomatic-db-hpijs-1.5-20040219
313
314* Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
315- new upstream version
316        -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
317        -- defined filterver
318- dropped patch101
319
320* Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
321- new upstream cvs version(foomatic-3.0.1rc2)
322        -- foomatic-db-20040125
323        -- foomatic-db-engine-3.0.1rc2
324        -- foomatic-db-hpijs-1.5-20040125
325        -- foomatic-filters-3.0.1rc2
326- added patch101
327        -- tests diris null in foomatic-filters-3.0.1rc2
328
329* Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
330- new upstream cvs version
331        -- foomatic-db-20040123
332        -- foomatic-db-engine-3.0-20040123
333        -- foomatic-db-hpijs-1.5-20040123
334        -- foomatic-filters-3.0-20040123
335- dropped old patches
336
337* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
338- built on perl-5.8.2
339
340* Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
341- separated foomatic-db package included xml files
342
343* Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
344- added description of ppd sub package
345
346* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
347- separated foomatic-ppd package included PPD files
348
349* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
350- new upstream version
351        -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
352        -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
353- dropped patches
354        -- foomatic-filters-path.patch(patch0)
355        -- foomatic-2.0.2-fontpath.patch(patch3)
356- updated patches
357        -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
358        -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
359        -- foomatic-filters-3.0-20031109-vine.patch (patch100)
360
361* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
362- built on perl-5.8.1
363- fixed install section in spec file
364
365* Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
366- fix some bugs of foomatic-filters.
367A
368
369* Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
370- new upstream version
371        -- rewrote spec file
372        -- added some patches from rawhide(foomatic-3.0.0-5)
373- enable cups support
374
375* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
376- imported some patches from foomatic-2.0.2-18
377        -- added foomatic-2.0.2-psc2210.patch
378        -- added foomatic-2.0.2-duplex184.patch
379
380* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
381- imported foomatic-2.0.2-15
382 
383* Tue Feb  4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
384- Update data-generators to CVS.
385
386* Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
387- Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
388
389* Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
390- Pacify printers that don't understand duplex (bug #82385).
391
392* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
393- rebuilt
394
395* Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
396- Add autodetect info for HP DeskJet 656C.  It doesn't really do
397  IEEE 1284 IDs, but since it's a USB device we can figure out it's
398  manufacturer and model anyway.
399
400* Thu Jan  9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
401- Set GS_FONTPATH in gs wrapper (bug #81410).
402
403* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
404- use internal dep generator.
405
406* Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
407- Add several device IDs.
408
409* Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
410- Update Omni printers to 0.7.2.
411- No longer need Omni badxml patch.
412
413* Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
414- don't use rpms internal dep generator
415
416* Fri Dec  6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
417- Omni XML wasn't well-formed.
418
419* Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
420- Update gimp-print data.
421- Add 'generic postscript' model.
422
423* Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
424- Update Omni printers to 0.7.1.
425
426* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
427- Fix file manifest for perl modules.
428- Add autodetect information for HP DeskJet 990C.
429
430* Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
431- 2.0.2.
432- No longer need 67973, 970c patches.
433- Remove cups-drivers-* packages (no longer needed).
434- Remove files not shipped.  Ship filter.conf.
435- Conditionally restart cups.
436- Use libdir.
437- Don't put things in site_perl; use vendor_perl instead (bug #73528).
438
439* Fri Aug  9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
440- Fix autodetect information for HPDJ970C.
441
442* Thu Aug  8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
443- For gimp-print, use the Ghostscript stp driver in preference to the
444  IJS interface.
445
446* Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
447- Quieten scriptlets.
448
449* Fri Jul  5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
450- Fix autodetect information for HPLJ2100/2100M.
451
452* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
453- automated rebuild
454
455* Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
456- Omni 0.7.0 printers.
457
458* Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
459- Update to CVS.
460- Remove some more explicit perl dependencies that are picked up
461  automatically.
462
463* Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
464- Remove explicit perl-Storable dependency; it should be perl(Storable),
465  and that is picked up automatically.
466
467* Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
468- Fix release number.
469- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
470  (bug #63622).
471
472* Sun May 26 2002 Tim Powers <timp@redhat.com>
473- automated rebuild
474
475* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
476- Remove ghostscript UPP drivers that are gone in 7.05.
477
478* Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
479- Update to CVS.
480- Updated requirements.
481- Updated path and libdir patches.
482- Drop hpijs 1.0.2 patch.
483- foomatic-datafile has moved to %%{_bindir}.
484- Update gimp-print data to 4.2.1.
485- Update Omni printer data to 0.6.1.
486
487* Thu Apr  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
488- Fix the hpijs option data too (bug #62587).
489
490* Wed Apr  3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
491- Back off to 1.0.2 for hpijs driver data (bug #62587).
492
493* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
494- Update to CVS.
495
496* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
497- Update to CVS.
498- Patches no longer needed: conffile, sys, cachedir, fd0.
499- Adapted path patch.
500
501* Tue Mar  5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
502- Fix bug #58319.
503- Drop dbg patch.
504
505* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
506- Fix file lists.
507
508* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
509- Fix %post scriplet bug (bug #59942).
510
511* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
512- Rebuild in new environment.
513
514* Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
515- Merge cups-drivers.  No epoch needed.
516- Require perl-URI.
517
518* Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
519- Cache fix.
520
521* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
522- Don't ship backup files.
523
524* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
525- Rebuild to pick up new perl installsitelib.
526
527* Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
528- Fix a thinko in DB.pl.
529
530* Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
531- Update to CVS.
532- No longer need the cachedir patch.
533- Fix config file path.
534- Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
535
536* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
537- Update to CVS.
538- Patches no longer needed: prepend, fd3.
539- Use RPM_OPT_FLAGS.
540- Allow non-root users to use foomatic-datafile (bug #58956).
541
542* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
543- added Provides: perl(Foomatic::GrovePath)
544
545* Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
546- Update to CVS.
547- Updated Omni printers to those in Omni 0.5.1.
548- Updated patches: prepend, fd3.
549- Patches no longer needed: utf8, lpdomatic.
550- Added gimp-print (formerly stp) foomatic db info, and removed the old
551  stp.xml file.
552- Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
553
554* Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
555- REALLY fix PCL fixup code (bug #55909, others).
556- PreReq fileutils, initscripts (bug #56984).
557- Fix prepends in lpdomatic (bug #57371).
558- Run foomatic-cleanupdrivers during install, to remove driver entries
559  with no command line.
560- Put lpdomatic in /usr/sbin again.
561- Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
562
563* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
564- re-imported from upstream to fix some perl fixup code on pcl printers.
565
566* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
567- fix the rest of the quoting issues with foomatic-combo-xml with the patch
568- foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
569
570* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
571- respin to pull in latest foomatic database, fixes:
572-       properly use the cache in relation to foomatic-combo-xml's output
573-       fix _some_ of the quoting issues with calling foomatic-combo-xml
574
575* Wed Dec  5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
576- respin to pull in latest foomatic database, fixes:
577-       droping half of a large job
578-       -Mutf8 added to the upstream filters
579-       miscelaneous printer db updates
580
581* Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
582- added Requires: fileutils for the 'rm' in post
583
584* Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
585- /var/chache => /var/cache, doh!
586
587* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
588- fix %%post scriptlet
589
590* Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
591- changed the patch to use the -Mutf8 command line option,
592- and to restart the printserver, after rebuilding the settings.
593
594* Fri Nov  9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
595- grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
596- pragma. Without it, they break on _some_ of their options.
597
598* Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
599- patched lpdomatic to prepend PostScript options in the _right_ place.
600
601* Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
602- zap the foomatic cache on install
603
604* Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
605- rolled to pull in latest information.
606- added Omni printers to the printer list.
607
608* Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
609- rolled to pull in an ia64 fix to foomatic-combo-xml.c
610
611* Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
612- rolled to pull in foomatic fixes to foomatic-combo-xml.c
613
614* Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
615- upgraded to latest foomatic, we now have fast overview generation!
616- this means that there is no prebuilt overview file.
617
618* Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
619- WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
620- It is now fast enough that there is no real benifit to precompiling.
621- NOTE: this forces the package to stop being noarched.
622
623* Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
624- fresh pull, maybe it fixes the build errors.
625
626* Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
627- did a fresh database pull, which contains the old japanese printers as well.
628- removed japanese hack.
629
630* Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
631- Add Japanese printer entry.
632
633* Mon Aug  6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
634- move the cache back to /var, sigh.
635
636* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
637- made foomatic pre-compute its db
638
639* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
640- imported from mandrake.
641
642* Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
643- Added job listing/removal/manipulation and queue control to
644  foomatic-printjob
645- Support for printing multiple copies with PDQ
646
647* Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
648- Included the cupsomatic filter script
649- When a queue is set up, default options can be set now
650- Help messages of foomatic-configure and foomatic-printjob cleaned up.
651
652* Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
653- Many bugfixes in "foomatic-printjob".
654- "foomatic-configure" adds the Foomatic config file directory automatically
655  to the search paths of PDQ.
656- Printing a help page under PDQ was broken.
657
658* Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
659- BuildRequires:        perl-devel
660
661* Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
662- initial release.
663- Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
664- Patch applied which flushes the memory cache regularly, otherwise
665  foomatic-configure would hang when the Foomatic data of GIMP-Print is
666  installed.
Note: See TracBrowser for help on using the repository browser.