source: projects/specs/trunk/f/foomatic/foomatic-vl.spec @ 12120

Revision 12120, 19.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define enginever 4.0.13
2
3Summary: Foomatic printer database.
4Name:           foomatic
5Version:        %{enginever}
6Release:        1%{?_dist_release}
7License:        GPL
8Group: System Environment/Libraries
9
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: tomop, daisuke, machino
13
14Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
15
16Patch101:       foomatic-manpages.patch
17
18Url:            http://www.linuxprinting.org
19Requires:       cups-filters
20Requires:       dbus
21Requires:       foomatic-db
22Requires:       hplip
23Requires:       %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
24# For 'rm' and '/sbin/service' in post
25Requires: fileutils initscripts
26
27BuildRequires:  cups
28BuildRequires:  perl >= 2:5.26.2
29BuildRequires:  libxml2-devel
30BuildRequires:  autoconf, automake
31BuildRequires:  mpage
32BuildRequires:  dbus-devel
33BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
34Provides:       perl(Foomatic::GrovePath)
35# For 'rm' and '/sbin/service' in post
36Requires(pre):  coreutils initscripts
37Obsoletes: foomatic-db < 4.0
38Obsoletes: foomatic-ppd < 4.0
39Obsoletes: foomatic-ppd-gimp-print < 4.0
40Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0
41Obsoletes: foomatic-ppd-omni < 4.0
42
43# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
44Conflicts: ghostscript < 7.05
45
46%description
47Foomatic is a comprehensive, spooler-independent database of printers,
48printer drivers, and driver descriptions. It contains utilities to
49generate driver description files and printer queues for CUPS, LPD,
50LPRng, and PDQ using the database. There is also the possibility to
51read the PJL options out of PJL-capable laser printers and take them
52into account at the driver description file generation.
53
54There are spooler-independent command line interfaces to manipulate
55queues (foomatic-configure) and to print files/manipulate jobs
56(foomatic printjob).
57
58The site http://www.linuxprinting.org/ is based on this database.
59
60%prep
61%setup -q -n foomatic-db-engine-%{version}
62
63# Ship more manpages.
64%patch101 -p1 -b .manpages
65
66chmod a+x mkinstalldirs
67
68%build
69export LIB_CUPS=%{_libdir}/cups
70export CUPS_BACKENDS=%{_libdir}/cups/backend
71export CUPS_FILTERS=%{_libdir}/cups/filter
72export CUPS_PPDS=%{_datadir}/cups/model
73
74aclocal
75autoconf
76%configure --disable-xmltest
77make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
78
79%install
80make    DESTDIR=%buildroot PREFIX=%{_prefix} \
81        INSTALLSITELIB=%{perl_vendorlib} \
82        INSTALLSITEARCH=%{perl_vendorarch} \
83        install
84
85# Use relative, not absolute, symlink for CUPS driver.
86ln -sf ../../../bin/foomatic-ppdfile %{buildroot}%{_libdir}/cups/driver/foomatic
87
88mkdir -p %{buildroot}%{_var}/cache/foomatic
89
90echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
91
92# Remove things we don't ship.
93rm -rf  \
94        %{buildroot}%{_libdir}/ppr \
95        %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample \
96        %{buildroot}%{_datadir}/foomatic/templates
97#%{buildroot}%%{_libdir}/perl5/site_perl
98find %{buildroot} -name .packlist | xargs rm -f
99
100%post
101/bin/rm -f /var/cache/foomatic/*
102exit 0
103
104%clean
105rm -fr %buildroot $RPM_BUILD_DIR/%{name}
106
107%files
108%defattr(-,root,root)
109%doc ChangeLog COPYING README TODO
110%dir %{_sysconfdir}/foomatic
111%config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
112%{_bindir}/*
113%{_sbindir}/*
114%{perl_vendorlib}/Foomatic
115%{_libdir}/cups/driver/*
116%{_datadir}/foomatic
117%{_mandir}/*/*
118%{_var}/cache/foomatic
119
120%changelog
121* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-1
122- new upstream release.
123- rebuilt with perl-5.26.
124
125* Sun Oct  4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-2
126- removed foomatic-filters (moved to cups-filters).
127- moved foomatic-db as a standalone package.
128
129* Tue Jun  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-1
130- new upstream release.
131
132* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0.11-2
133- rebuild with perl-5.16
134- add BR: dbus-devel
135
136* Sun Jun  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.11-1
137- new upstream release.
138
139* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
140- new upstream release.
141
142* Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
143- added hplip and coreutils to "Requires:".
144- removed hpijs and fileutils from "Requires:".
145
146* Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
147- new upstream release.
148- dropped Source3 (no longer provided by upstream).
149- updated Patch2.
150
151* Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
152- rebuild with perl 5.12.3
153
154* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
155- add Requires: hpijs
156
157* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
158- new upstream release
159
160* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
161- new upstream release.
162- applied some patches from Fedora development.
163- remove subpackages.
164
165* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
166- applied new versioning policy
167- used rpm macros: %%perl_sitelib %%perl_sitearch
168- added foomatic-db-engine-3.1-20050411-combo-xml.patch
169- added foomatic-db-engine-3.1-20050411-perl-data.patch
170- fixed permission of %%{_datadir}/foomatic/db
171
172* Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
173- add BuildRequires: libxml2-devel, mpage, Omni
174- use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
175- run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
176- not create ppd-omni package if omni support is disabled
177
178* Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
179- updated foomatic-db to 20050411
180- updated foomatic-db-engine to 3.1-20050411
181- updated foomatic-db-hpijs to 1.5-20050411
182- updated foomatic-filters to 3.1-20050411
183
184* Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
185- updated foomatic-db to 20050112
186- updated foomatic-db-engine to 3.1-20050112
187- updated foomatic-db-hpijs to 1.5-20050112
188
189* Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
190- updated foomatic-db to 20041220
191- updated foomatic-db-hpijs to 1.5-20041220
192
193* Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
194- updated foomatic-db to 20040919
195- updated foomatic-db-engine to 3.0.2
196- updated foomatic-db-hpijs to 1.5-20040919
197- updated foomatic-filters to 3.0.2
198
199* Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
200- update foomatic-db to 20040526
201- update foomatic-db-hpijs to 1.5-20040526
202
203* Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
204- sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
205  ppd-gimp-print-ijs
206- add Requires: to ppd-* subpackages.
207
208* Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
209- new upstream version
210        -- Omni-printers-0.9.1
211        -- gimp-print-foomatic-db-4.2.6
212- foomatic.spec -> foomatic-vl.spec
213
214* Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
215- new upstream version
216        -- foomatic-filters-3.0.1
217        -- foomatic-db-engine-3.0.1
218        -- foomatic-db-20040219
219        -- foomatic-db-hpijs-1.5-20040219
220
221* Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
222- new upstream version
223        -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
224        -- defined filterver
225- dropped patch101
226
227* Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
228- new upstream cvs version(foomatic-3.0.1rc2)
229        -- foomatic-db-20040125
230        -- foomatic-db-engine-3.0.1rc2
231        -- foomatic-db-hpijs-1.5-20040125
232        -- foomatic-filters-3.0.1rc2
233- added patch101
234        -- tests diris null in foomatic-filters-3.0.1rc2
235
236* Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
237- new upstream cvs version
238        -- foomatic-db-20040123
239        -- foomatic-db-engine-3.0-20040123
240        -- foomatic-db-hpijs-1.5-20040123
241        -- foomatic-filters-3.0-20040123
242- dropped old patches
243
244* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
245- built on perl-5.8.2
246
247* Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
248- separated foomatic-db package included xml files
249
250* Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
251- added description of ppd sub package
252
253* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
254- separated foomatic-ppd package included PPD files
255
256* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
257- new upstream version
258        -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
259        -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
260- dropped patches
261        -- foomatic-filters-path.patch(patch0)
262        -- foomatic-2.0.2-fontpath.patch(patch3)
263- updated patches
264        -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
265        -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
266        -- foomatic-filters-3.0-20031109-vine.patch (patch100)
267
268* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
269- built on perl-5.8.1
270- fixed install section in spec file
271
272* Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
273- fix some bugs of foomatic-filters.
274A
275
276* Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
277- new upstream version
278        -- rewrote spec file
279        -- added some patches from rawhide(foomatic-3.0.0-5)
280- enable cups support
281
282* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
283- imported some patches from foomatic-2.0.2-18
284        -- added foomatic-2.0.2-psc2210.patch
285        -- added foomatic-2.0.2-duplex184.patch
286
287* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
288- imported foomatic-2.0.2-15
289 
290* Tue Feb  4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
291- Update data-generators to CVS.
292
293* Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
294- Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
295
296* Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
297- Pacify printers that don't understand duplex (bug #82385).
298
299* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
300- rebuilt
301
302* Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
303- Add autodetect info for HP DeskJet 656C.  It doesn't really do
304  IEEE 1284 IDs, but since it's a USB device we can figure out it's
305  manufacturer and model anyway.
306
307* Thu Jan  9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
308- Set GS_FONTPATH in gs wrapper (bug #81410).
309
310* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
311- use internal dep generator.
312
313* Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
314- Add several device IDs.
315
316* Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
317- Update Omni printers to 0.7.2.
318- No longer need Omni badxml patch.
319
320* Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
321- don't use rpms internal dep generator
322
323* Fri Dec  6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
324- Omni XML wasn't well-formed.
325
326* Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
327- Update gimp-print data.
328- Add 'generic postscript' model.
329
330* Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
331- Update Omni printers to 0.7.1.
332
333* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
334- Fix file manifest for perl modules.
335- Add autodetect information for HP DeskJet 990C.
336
337* Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
338- 2.0.2.
339- No longer need 67973, 970c patches.
340- Remove cups-drivers-* packages (no longer needed).
341- Remove files not shipped.  Ship filter.conf.
342- Conditionally restart cups.
343- Use libdir.
344- Don't put things in site_perl; use vendor_perl instead (bug #73528).
345
346* Fri Aug  9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
347- Fix autodetect information for HPDJ970C.
348
349* Thu Aug  8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
350- For gimp-print, use the Ghostscript stp driver in preference to the
351  IJS interface.
352
353* Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
354- Quieten scriptlets.
355
356* Fri Jul  5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
357- Fix autodetect information for HPLJ2100/2100M.
358
359* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
360- automated rebuild
361
362* Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
363- Omni 0.7.0 printers.
364
365* Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
366- Update to CVS.
367- Remove some more explicit perl dependencies that are picked up
368  automatically.
369
370* Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
371- Remove explicit perl-Storable dependency; it should be perl(Storable),
372  and that is picked up automatically.
373
374* Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
375- Fix release number.
376- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
377  (bug #63622).
378
379* Sun May 26 2002 Tim Powers <timp@redhat.com>
380- automated rebuild
381
382* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
383- Remove ghostscript UPP drivers that are gone in 7.05.
384
385* Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
386- Update to CVS.
387- Updated requirements.
388- Updated path and libdir patches.
389- Drop hpijs 1.0.2 patch.
390- foomatic-datafile has moved to %%{_bindir}.
391- Update gimp-print data to 4.2.1.
392- Update Omni printer data to 0.6.1.
393
394* Thu Apr  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
395- Fix the hpijs option data too (bug #62587).
396
397* Wed Apr  3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
398- Back off to 1.0.2 for hpijs driver data (bug #62587).
399
400* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
401- Update to CVS.
402
403* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
404- Update to CVS.
405- Patches no longer needed: conffile, sys, cachedir, fd0.
406- Adapted path patch.
407
408* Tue Mar  5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
409- Fix bug #58319.
410- Drop dbg patch.
411
412* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
413- Fix file lists.
414
415* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
416- Fix %post scriplet bug (bug #59942).
417
418* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
419- Rebuild in new environment.
420
421* Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
422- Merge cups-drivers.  No epoch needed.
423- Require perl-URI.
424
425* Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
426- Cache fix.
427
428* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
429- Don't ship backup files.
430
431* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
432- Rebuild to pick up new perl installsitelib.
433
434* Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
435- Fix a thinko in DB.pl.
436
437* Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
438- Update to CVS.
439- No longer need the cachedir patch.
440- Fix config file path.
441- Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
442
443* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
444- Update to CVS.
445- Patches no longer needed: prepend, fd3.
446- Use RPM_OPT_FLAGS.
447- Allow non-root users to use foomatic-datafile (bug #58956).
448
449* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
450- added Provides: perl(Foomatic::GrovePath)
451
452* Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
453- Update to CVS.
454- Updated Omni printers to those in Omni 0.5.1.
455- Updated patches: prepend, fd3.
456- Patches no longer needed: utf8, lpdomatic.
457- Added gimp-print (formerly stp) foomatic db info, and removed the old
458  stp.xml file.
459- Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
460
461* Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
462- REALLY fix PCL fixup code (bug #55909, others).
463- PreReq fileutils, initscripts (bug #56984).
464- Fix prepends in lpdomatic (bug #57371).
465- Run foomatic-cleanupdrivers during install, to remove driver entries
466  with no command line.
467- Put lpdomatic in /usr/sbin again.
468- Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
469
470* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
471- re-imported from upstream to fix some perl fixup code on pcl printers.
472
473* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
474- fix the rest of the quoting issues with foomatic-combo-xml with the patch
475- foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
476
477* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
478- respin to pull in latest foomatic database, fixes:
479-       properly use the cache in relation to foomatic-combo-xml's output
480-       fix _some_ of the quoting issues with calling foomatic-combo-xml
481
482* Wed Dec  5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
483- respin to pull in latest foomatic database, fixes:
484-       droping half of a large job
485-       -Mutf8 added to the upstream filters
486-       miscelaneous printer db updates
487
488* Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
489- added Requires: fileutils for the 'rm' in post
490
491* Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
492- /var/chache => /var/cache, doh!
493
494* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
495- fix %%post scriptlet
496
497* Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
498- changed the patch to use the -Mutf8 command line option,
499- and to restart the printserver, after rebuilding the settings.
500
501* Fri Nov  9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
502- grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
503- pragma. Without it, they break on _some_ of their options.
504
505* Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
506- patched lpdomatic to prepend PostScript options in the _right_ place.
507
508* Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
509- zap the foomatic cache on install
510
511* Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
512- rolled to pull in latest information.
513- added Omni printers to the printer list.
514
515* Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
516- rolled to pull in an ia64 fix to foomatic-combo-xml.c
517
518* Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
519- rolled to pull in foomatic fixes to foomatic-combo-xml.c
520
521* Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
522- upgraded to latest foomatic, we now have fast overview generation!
523- this means that there is no prebuilt overview file.
524
525* Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
526- WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
527- It is now fast enough that there is no real benifit to precompiling.
528- NOTE: this forces the package to stop being noarched.
529
530* Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
531- fresh pull, maybe it fixes the build errors.
532
533* Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
534- did a fresh database pull, which contains the old japanese printers as well.
535- removed japanese hack.
536
537* Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
538- Add Japanese printer entry.
539
540* Mon Aug  6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
541- move the cache back to /var, sigh.
542
543* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
544- made foomatic pre-compute its db
545
546* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
547- imported from mandrake.
548
549* Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
550- Added job listing/removal/manipulation and queue control to
551  foomatic-printjob
552- Support for printing multiple copies with PDQ
553
554* Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
555- Included the cupsomatic filter script
556- When a queue is set up, default options can be set now
557- Help messages of foomatic-configure and foomatic-printjob cleaned up.
558
559* Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
560- Many bugfixes in "foomatic-printjob".
561- "foomatic-configure" adds the Foomatic config file directory automatically
562  to the search paths of PDQ.
563- Printing a help page under PDQ was broken.
564
565* Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
566- BuildRequires:        perl-devel
567
568* Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
569- initial release.
570- Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
571- Patch applied which flushes the memory cache regularly, otherwise
572  foomatic-configure would hang when the Foomatic data of GIMP-Print is
573  installed.
Note: See TracBrowser for help on using the repository browser.