source: projects/specs/trunk/f/foomatic/foomatic-vl.spec @ 9752

Revision 9752, 19.7 KB checked in by tomop, 8 years ago (diff)

cups-2.1.0-1, etc.

Line 
1%define enginever 4.0.12
2
3Summary: Foomatic printer database.
4Name:           foomatic
5Version:        %{enginever}
6Release:        2%{?_dist_release}
7License:        GPL
8Group: System Environment/Libraries
9
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: tomop, daisuke, machino
13
14Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
15
16Patch101:       foomatic-manpages.patch
17
18Url:            http://www.linuxprinting.org
19Requires:       cups-filters
20Requires:       dbus
21Requires:       foomatic-db
22Requires:       hplip
23Requires:       %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
24# For 'rm' and '/sbin/service' in post
25Requires: fileutils initscripts
26
27BuildRequires:  cups
28BuildRequires:  perl >= 5.12.3
29BuildRequires:  libxml2-devel
30BuildRequires:  autoconf, automake
31BuildRequires:  mpage
32BuildRequires:  dbus-devel
33BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
34Provides:       perl(Foomatic::GrovePath)
35# For 'rm' and '/sbin/service' in post
36Requires(pre):  coreutils initscripts
37Obsoletes: foomatic-db < 4.0
38Obsoletes: foomatic-ppd < 4.0
39Obsoletes: foomatic-ppd-gimp-print < 4.0
40Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0
41Obsoletes: foomatic-ppd-omni < 4.0
42
43# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
44Conflicts: ghostscript < 7.05
45
46%description
47Foomatic is a comprehensive, spooler-independent database of printers,
48printer drivers, and driver descriptions. It contains utilities to
49generate driver description files and printer queues for CUPS, LPD,
50LPRng, and PDQ using the database. There is also the possibility to
51read the PJL options out of PJL-capable laser printers and take them
52into account at the driver description file generation.
53
54There are spooler-independent command line interfaces to manipulate
55queues (foomatic-configure) and to print files/manipulate jobs
56(foomatic printjob).
57
58The site http://www.linuxprinting.org/ is based on this database.
59
60%prep
61%setup -q -n foomatic-db-engine-%{version}
62
63# Ship more manpages.
64%patch101 -p1 -b .manpages
65
66chmod a+x mkinstalldirs
67
68%build
69export LIB_CUPS=%{_libdir}/cups
70export CUPS_BACKENDS=%{_libdir}/cups/backend
71export CUPS_FILTERS=%{_libdir}/cups/filter
72export CUPS_PPDS=%{_datadir}/cups/model
73
74aclocal
75autoconf
76%configure --disable-xmltest
77make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
78
79%install
80make    DESTDIR=%buildroot PREFIX=%{_prefix} \
81        INSTALLSITELIB=%{perl_vendorlib} \
82        INSTALLSITEARCH=%{perl_vendorarch} \
83        install
84
85# Use relative, not absolute, symlink for CUPS driver.
86ln -sf ../../../bin/foomatic-ppdfile %{buildroot}%{_libdir}/cups/driver/foomatic
87
88mkdir -p %{buildroot}%{_var}/cache/foomatic
89
90echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
91
92# Remove things we don't ship.
93rm -rf  \
94        %{buildroot}%{_libdir}/ppr \
95        %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample \
96        %{buildroot}%{_datadir}/foomatic/templates
97#%{buildroot}%%{_libdir}/perl5/site_perl
98find %{buildroot} -name .packlist | xargs rm -f
99
100%post
101/bin/rm -f /var/cache/foomatic/*
102exit 0
103
104%clean
105rm -fr %buildroot $RPM_BUILD_DIR/%{name}
106
107%files
108%defattr(-,root,root)
109%doc ChangeLog COPYING README TODO
110%dir %{_sysconfdir}/foomatic
111%config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
112%{_bindir}/*
113%{_sbindir}/*
114%{perl_vendorlib}/Foomatic
115%{_libdir}/cups/driver/*
116%{_datadir}/foomatic
117%{_mandir}/*/*
118%{_var}/cache/foomatic
119
120%changelog
121* Sun Oct  4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-2
122- removed foomatic-filters (moved to cups-filters).
123- moved foomatic-db as a standalone package.
124
125* Tue Jun  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-1
126- new upstream release.
127
128* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0.11-2
129- rebuild with perl-5.16
130- add BR: dbus-devel
131
132* Sun Jun  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.11-1
133- new upstream release.
134
135* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
136- new upstream release.
137
138* Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
139- added hplip and coreutils to "Requires:".
140- removed hpijs and fileutils from "Requires:".
141
142* Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
143- new upstream release.
144- dropped Source3 (no longer provided by upstream).
145- updated Patch2.
146
147* Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
148- rebuild with perl 5.12.3
149
150* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
151- add Requires: hpijs
152
153* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
154- new upstream release
155
156* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
157- new upstream release.
158- applied some patches from Fedora development.
159- remove subpackages.
160
161* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
162- applied new versioning policy
163- used rpm macros: %%perl_sitelib %%perl_sitearch
164- added foomatic-db-engine-3.1-20050411-combo-xml.patch
165- added foomatic-db-engine-3.1-20050411-perl-data.patch
166- fixed permission of %%{_datadir}/foomatic/db
167
168* Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
169- add BuildRequires: libxml2-devel, mpage, Omni
170- use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
171- run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
172- not create ppd-omni package if omni support is disabled
173
174* Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
175- updated foomatic-db to 20050411
176- updated foomatic-db-engine to 3.1-20050411
177- updated foomatic-db-hpijs to 1.5-20050411
178- updated foomatic-filters to 3.1-20050411
179
180* Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
181- updated foomatic-db to 20050112
182- updated foomatic-db-engine to 3.1-20050112
183- updated foomatic-db-hpijs to 1.5-20050112
184
185* Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
186- updated foomatic-db to 20041220
187- updated foomatic-db-hpijs to 1.5-20041220
188
189* Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
190- updated foomatic-db to 20040919
191- updated foomatic-db-engine to 3.0.2
192- updated foomatic-db-hpijs to 1.5-20040919
193- updated foomatic-filters to 3.0.2
194
195* Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
196- update foomatic-db to 20040526
197- update foomatic-db-hpijs to 1.5-20040526
198
199* Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
200- sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
201  ppd-gimp-print-ijs
202- add Requires: to ppd-* subpackages.
203
204* Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
205- new upstream version
206        -- Omni-printers-0.9.1
207        -- gimp-print-foomatic-db-4.2.6
208- foomatic.spec -> foomatic-vl.spec
209
210* Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
211- new upstream version
212        -- foomatic-filters-3.0.1
213        -- foomatic-db-engine-3.0.1
214        -- foomatic-db-20040219
215        -- foomatic-db-hpijs-1.5-20040219
216
217* Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
218- new upstream version
219        -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
220        -- defined filterver
221- dropped patch101
222
223* Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
224- new upstream cvs version(foomatic-3.0.1rc2)
225        -- foomatic-db-20040125
226        -- foomatic-db-engine-3.0.1rc2
227        -- foomatic-db-hpijs-1.5-20040125
228        -- foomatic-filters-3.0.1rc2
229- added patch101
230        -- tests diris null in foomatic-filters-3.0.1rc2
231
232* Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
233- new upstream cvs version
234        -- foomatic-db-20040123
235        -- foomatic-db-engine-3.0-20040123
236        -- foomatic-db-hpijs-1.5-20040123
237        -- foomatic-filters-3.0-20040123
238- dropped old patches
239
240* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
241- built on perl-5.8.2
242
243* Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
244- separated foomatic-db package included xml files
245
246* Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
247- added description of ppd sub package
248
249* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
250- separated foomatic-ppd package included PPD files
251
252* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
253- new upstream version
254        -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
255        -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
256- dropped patches
257        -- foomatic-filters-path.patch(patch0)
258        -- foomatic-2.0.2-fontpath.patch(patch3)
259- updated patches
260        -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
261        -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
262        -- foomatic-filters-3.0-20031109-vine.patch (patch100)
263
264* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
265- built on perl-5.8.1
266- fixed install section in spec file
267
268* Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
269- fix some bugs of foomatic-filters.
270A
271
272* Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
273- new upstream version
274        -- rewrote spec file
275        -- added some patches from rawhide(foomatic-3.0.0-5)
276- enable cups support
277
278* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
279- imported some patches from foomatic-2.0.2-18
280        -- added foomatic-2.0.2-psc2210.patch
281        -- added foomatic-2.0.2-duplex184.patch
282
283* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
284- imported foomatic-2.0.2-15
285 
286* Tue Feb  4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
287- Update data-generators to CVS.
288
289* Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
290- Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
291
292* Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
293- Pacify printers that don't understand duplex (bug #82385).
294
295* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
296- rebuilt
297
298* Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
299- Add autodetect info for HP DeskJet 656C.  It doesn't really do
300  IEEE 1284 IDs, but since it's a USB device we can figure out it's
301  manufacturer and model anyway.
302
303* Thu Jan  9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
304- Set GS_FONTPATH in gs wrapper (bug #81410).
305
306* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
307- use internal dep generator.
308
309* Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
310- Add several device IDs.
311
312* Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
313- Update Omni printers to 0.7.2.
314- No longer need Omni badxml patch.
315
316* Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
317- don't use rpms internal dep generator
318
319* Fri Dec  6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
320- Omni XML wasn't well-formed.
321
322* Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
323- Update gimp-print data.
324- Add 'generic postscript' model.
325
326* Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
327- Update Omni printers to 0.7.1.
328
329* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
330- Fix file manifest for perl modules.
331- Add autodetect information for HP DeskJet 990C.
332
333* Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
334- 2.0.2.
335- No longer need 67973, 970c patches.
336- Remove cups-drivers-* packages (no longer needed).
337- Remove files not shipped.  Ship filter.conf.
338- Conditionally restart cups.
339- Use libdir.
340- Don't put things in site_perl; use vendor_perl instead (bug #73528).
341
342* Fri Aug  9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
343- Fix autodetect information for HPDJ970C.
344
345* Thu Aug  8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
346- For gimp-print, use the Ghostscript stp driver in preference to the
347  IJS interface.
348
349* Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
350- Quieten scriptlets.
351
352* Fri Jul  5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
353- Fix autodetect information for HPLJ2100/2100M.
354
355* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
356- automated rebuild
357
358* Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
359- Omni 0.7.0 printers.
360
361* Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
362- Update to CVS.
363- Remove some more explicit perl dependencies that are picked up
364  automatically.
365
366* Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
367- Remove explicit perl-Storable dependency; it should be perl(Storable),
368  and that is picked up automatically.
369
370* Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
371- Fix release number.
372- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
373  (bug #63622).
374
375* Sun May 26 2002 Tim Powers <timp@redhat.com>
376- automated rebuild
377
378* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
379- Remove ghostscript UPP drivers that are gone in 7.05.
380
381* Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
382- Update to CVS.
383- Updated requirements.
384- Updated path and libdir patches.
385- Drop hpijs 1.0.2 patch.
386- foomatic-datafile has moved to %%{_bindir}.
387- Update gimp-print data to 4.2.1.
388- Update Omni printer data to 0.6.1.
389
390* Thu Apr  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
391- Fix the hpijs option data too (bug #62587).
392
393* Wed Apr  3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
394- Back off to 1.0.2 for hpijs driver data (bug #62587).
395
396* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
397- Update to CVS.
398
399* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
400- Update to CVS.
401- Patches no longer needed: conffile, sys, cachedir, fd0.
402- Adapted path patch.
403
404* Tue Mar  5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
405- Fix bug #58319.
406- Drop dbg patch.
407
408* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
409- Fix file lists.
410
411* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
412- Fix %post scriplet bug (bug #59942).
413
414* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
415- Rebuild in new environment.
416
417* Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
418- Merge cups-drivers.  No epoch needed.
419- Require perl-URI.
420
421* Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
422- Cache fix.
423
424* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
425- Don't ship backup files.
426
427* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
428- Rebuild to pick up new perl installsitelib.
429
430* Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
431- Fix a thinko in DB.pl.
432
433* Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
434- Update to CVS.
435- No longer need the cachedir patch.
436- Fix config file path.
437- Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
438
439* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
440- Update to CVS.
441- Patches no longer needed: prepend, fd3.
442- Use RPM_OPT_FLAGS.
443- Allow non-root users to use foomatic-datafile (bug #58956).
444
445* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
446- added Provides: perl(Foomatic::GrovePath)
447
448* Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
449- Update to CVS.
450- Updated Omni printers to those in Omni 0.5.1.
451- Updated patches: prepend, fd3.
452- Patches no longer needed: utf8, lpdomatic.
453- Added gimp-print (formerly stp) foomatic db info, and removed the old
454  stp.xml file.
455- Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
456
457* Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
458- REALLY fix PCL fixup code (bug #55909, others).
459- PreReq fileutils, initscripts (bug #56984).
460- Fix prepends in lpdomatic (bug #57371).
461- Run foomatic-cleanupdrivers during install, to remove driver entries
462  with no command line.
463- Put lpdomatic in /usr/sbin again.
464- Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
465
466* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
467- re-imported from upstream to fix some perl fixup code on pcl printers.
468
469* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
470- fix the rest of the quoting issues with foomatic-combo-xml with the patch
471- foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
472
473* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
474- respin to pull in latest foomatic database, fixes:
475-       properly use the cache in relation to foomatic-combo-xml's output
476-       fix _some_ of the quoting issues with calling foomatic-combo-xml
477
478* Wed Dec  5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
479- respin to pull in latest foomatic database, fixes:
480-       droping half of a large job
481-       -Mutf8 added to the upstream filters
482-       miscelaneous printer db updates
483
484* Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
485- added Requires: fileutils for the 'rm' in post
486
487* Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
488- /var/chache => /var/cache, doh!
489
490* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
491- fix %%post scriptlet
492
493* Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
494- changed the patch to use the -Mutf8 command line option,
495- and to restart the printserver, after rebuilding the settings.
496
497* Fri Nov  9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
498- grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
499- pragma. Without it, they break on _some_ of their options.
500
501* Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
502- patched lpdomatic to prepend PostScript options in the _right_ place.
503
504* Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
505- zap the foomatic cache on install
506
507* Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
508- rolled to pull in latest information.
509- added Omni printers to the printer list.
510
511* Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
512- rolled to pull in an ia64 fix to foomatic-combo-xml.c
513
514* Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
515- rolled to pull in foomatic fixes to foomatic-combo-xml.c
516
517* Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
518- upgraded to latest foomatic, we now have fast overview generation!
519- this means that there is no prebuilt overview file.
520
521* Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
522- WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
523- It is now fast enough that there is no real benifit to precompiling.
524- NOTE: this forces the package to stop being noarched.
525
526* Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
527- fresh pull, maybe it fixes the build errors.
528
529* Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
530- did a fresh database pull, which contains the old japanese printers as well.
531- removed japanese hack.
532
533* Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
534- Add Japanese printer entry.
535
536* Mon Aug  6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
537- move the cache back to /var, sigh.
538
539* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
540- made foomatic pre-compute its db
541
542* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
543- imported from mandrake.
544
545* Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
546- Added job listing/removal/manipulation and queue control to
547  foomatic-printjob
548- Support for printing multiple copies with PDQ
549
550* Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
551- Included the cupsomatic filter script
552- When a queue is set up, default options can be set now
553- Help messages of foomatic-configure and foomatic-printjob cleaned up.
554
555* Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
556- Many bugfixes in "foomatic-printjob".
557- "foomatic-configure" adds the Foomatic config file directory automatically
558  to the search paths of PDQ.
559- Printing a help page under PDQ was broken.
560
561* Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
562- BuildRequires:        perl-devel
563
564* Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
565- initial release.
566- Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
567- Patch applied which flushes the memory cache regularly, otherwise
568  foomatic-configure would hang when the Foomatic data of GIMP-Print is
569  installed.
Note: See TracBrowser for help on using the repository browser.