source: projects/specs/trunk/f/foomatic-db/foomatic-db-vl.spec @ 9753

Revision 9753, 12.4 KB checked in by tomop, 8 years ago (diff)

new: foomatic-db

Line 
1%global dbver_rel 4.0
2# When you change dbver_snap, rebuild also foomatic against this build to pick up new IEEE 1284 Device IDs.
3# The postscriptdriver tags get put onto foomatic, because that's there the actual CUPS driver lives.
4%global dbver_snap 20150819
5
6Summary: Database of printers and printer drivers
7Name: foomatic-db
8Version: %{dbver_rel}
9Release: 48.%{dbver_snap}%{?_dist_release}
10License: GPLv2+
11Group: System Environment/Libraries
12Requires: %{name}-filesystem = %{version}-%{release}
13Requires: %{name}-ppds = %{version}-%{release}
14
15Source0: http://www.openprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
16
17Patch1: foomatic-db-device-ids.patch
18Patch2: foomatic-db-invalid.patch
19
20Url: http://www.openprinting.org
21BuildArch: noarch
22
23# Make sure we get postscriptdriver tags.
24BuildRequires: python-cups
25
26# Build requires cups so that configure knows where to put PPDs.
27BuildRequires: cups
28
29%description
30This is the database of printers, printer drivers, and driver options
31for Foomatic.
32
33The site http://www.openprinting.org/ is based on this database.
34
35%package filesystem
36Summary: Directory layout for the foomatic package
37License: Public Domain
38Group: System Environment/Base
39
40%description filesystem
41
42Directory layout for the foomatic package.
43
44%package ppds
45Summary: PPDs from printer manufacturers
46License: GPLv2+ and MIT
47Group: System Environment/Libraries
48# We ship a symlink in a directory owned by cups
49BuildRequires: cups
50Requires: cups
51Requires: sed
52Requires: %{name}-filesystem = %{version}-%{release}
53
54%description ppds
55PPDs from printer manufacturers.
56
57%prep
58%setup -q -n foomatic-db-%{dbver_snap}
59
60find -type d | xargs chmod g-s
61
62pushd db/source
63
64# For gutenprint printers, use gutenprint-ijs-simplified.5.2.
65perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
66
67# Remove references to SpliX (Samsung/Xerox/Dell)
68find printer -name '*.xml' |xargs grep -l "<driver>splix"|xargs rm -vf
69rm -f driver/splix.xml
70
71# Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
72# foo2zjs-z1, foo2zjs-z2, foo2zjs-z3 (bug #967930)
73# foo2lava, foo2kyo, foo2xqx (bug #438319)
74# foo2slx and foo2hiperc (bug #518267)
75# foo2hbpl2 (bug #970393)
76for x in zjs zjs-z1 zjs-z2 zjs-z3 oak oak-z1 hp qpdl lava kyo xqx slx hiperc hbpl2
77do
78  find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
79  rm -f driver/foo2${x}.xml opt/foo2${x}-*
80done
81
82# Binaries for these were previously provided by printer-filters, but aren't anymore (bug #972740)
83for x in lm1100 pentaxpj pbm2l2030 pbm2l7k lex5700 lex7000 c2050 c2070 cjet
84do
85  find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
86  rm -vf driver/${x}.xml opt/${x}-*
87done
88
89# Same for all these.
90for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j m2300w m2400w
91do
92  find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
93  rm -vf driver/${x}.xml opt/${x}-*
94done
95
96# Remove Samsung-CLP-610/620 (bug #967930), they're in foo2qpdl
97find printer -name '*.xml' |grep -E 'Samsung-CLP-610|Samsung-CLP-620'|xargs rm -vf
98
99# This one is part of foo2zjs
100find printer -name '*.xml' |grep -E 'KONICA_MINOLTA-magicolor_2430_DL'|xargs rm -vf
101
102# Remove Brother P-touch (bug #560610, comment #10)
103rm -vf driver/ptouch.xml
104rm -vf printer/Brother-PT-*.xml
105rm -vf printer/Brother-QL-*.xml
106rm -vf opt/Brother-Ptouch-*.xml
107
108popd
109
110# foomatic-db patches
111# Don't use "-b" when patching PPD files as the backups will be packaged.
112
113# Device IDs for:
114# Brother MFC-8840D (#678065)
115# HP LaserJet M1522nf MFP (#745499)
116# Lexmark C453 (#770169)
117# HP DeskJet 720C (bug #797099)
118# Kyocera FS-1118MFP (bug #782377)
119# Brother HL-2040 (bug #999040)
120%patch1 -p1
121
122# These can't be generated at all (bug #866476)
123%patch2 -p1
124
125# Use sed instead of perl in the PPDs (bug #512739).
126find db/source/PPD -type f -name '*.ppd' | xargs perl -pi -e 's,perl -p,sed,'
127
128%build
129%configure
130make PREFIX=%{_prefix}
131
132
133%install
134make    DESTDIR=%buildroot PREFIX=%{_prefix} \
135        install
136
137# Remove ghostscript UPP drivers that are gone in 7.07
138rm -f %{buildroot}%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
139
140find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
141
142mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
143
144rm -f   %{buildroot}%{_datadir}/foomatic/db/source/PPD/Kyocera/*.htm \
145        %{buildroot}%{_datadir}/cups/model/3-distribution
146
147# Convert absolute symlink to relative.
148rm -f %{buildroot}%{_datadir}/cups/model/foomatic-db-ppds
149ln -sf ../../foomatic/db/source/PPD %{buildroot}%{_datadir}/cups/model/foomatic-db-ppds
150
151%files filesystem
152%dir %{_datadir}/foomatic
153%dir %{_datadir}/foomatic/db
154%dir %{_datadir}/foomatic/db/source
155
156%files
157%doc db/source/PPD/Kyocera/*.htm
158%doc README
159%{_datadir}/foomatic/db/oldprinterids
160%{_datadir}/foomatic/db/source/printer
161%{_datadir}/foomatic/db/source/driver
162%{_datadir}/foomatic/db/source/opt
163%{_datadir}/foomatic/xmlschema
164
165%files ppds
166%doc COPYING
167%{_datadir}/foomatic/db/source/PPD
168%{_datadir}/cups/model/foomatic-db-ppds
169
170%changelog
171* Sun Oct  4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-48.20150819
172- initial build for Vine Linux.
173
174* Tue Sep 15 2015 Jiri Popelka <jpopelka@redhat.com> - 4.0-47.20150819
175- Updated to foomatic-db-4.0-20150819
176
177* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-46.20150415
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
179
180* Thu May 21 2015 Jiri Popelka <jpopelka@redhat.com> - 4.0-45.20150415
181- Updated to foomatic-db-4.0-20150415
182
183* Mon Jul 07 2014 Jiri Popelka <jpopelka@redhat.com> - 4.0-44.20140707
184- Updated to foomatic-db-4.0-20140707
185
186* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-43.20131218
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
188
189* Wed Dec 18 2013 Jiri Popelka <jpopelka@redhat.com> - 4.0-42.20131218
190- Remove references to splix and KONICA_MINOLTA-magicolor_2430_DL (bug #970393)
191
192* Wed Dec 18 2013 Jiri Popelka <jpopelka@redhat.com> - 4.0-41.20131218
193- Remove references to invalid printers (bug #866476, bug #972740)
194- Remove references to foo2hbpl (bug #970393)
195- Updated to foomatic-db-4.0-20131218
196
197* Wed Sep 11 2013 Jiri Popelka <jpopelka@redhat.com> - 4.0-40.20130911
198- Updated to foomatic-db-4.0-20130911
199- Device ID for Brother HL-2040 (bug #999040)
200
201* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-39.20130604
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
203
204* Tue Jun 04 2013 Jiri Popelka <jpopelka@redhat.com> - 4.0-38.20130604
205- Remove some file conflicts (bug #967930)
206- Updated to foomatic-db-4.0-20130604
207
208* Tue May 07 2013 Jiri Popelka <jpopelka@redhat.com> - 4.0-37.20130507
209- Updated to foomatic-db-4.0-20130507
210- Removed old 'Obsoletes: oki4linux'
211
212* Tue Mar 12 2013 Jiri Popelka <jpopelka@redhat.com> - 4.0-36.20130312
213- Updated to foomatic-db-4.0-20130312
214
215* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-35.20121011
216- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
217
218* Thu Oct 11 2012 Jiri Popelka <jpopelka@redhat.com> 4.0-34.20120719
219- Updated to foomatic-db-4.0-20121011
220
221* Thu Jul 19 2012 Jiri Popelka <jpopelka@redhat.com> 4.0-33.20120719
222- Updated to foomatic-db-4.0-20120719
223
224* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-32.20120103
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
226
227* Fri Feb 24 2012 Tim Waugh <twaugh@redhat.com> 4.0-31.20120103
228- Device IDs for:
229  - HP DeskJet 720C (bug #797099)
230  - Kyocera FS-1118MFP (bug #782377)
231
232* Wed Jan 04 2012 Jiri Popelka <jpopelka@redhat.com> 4.0-30.20120103
233- Updated to foomatic-db-4.0-20120103
234- spec modernized
235- Device IDs for:
236  - Brother MFC-8840D (#678065)
237  - HP LaserJet M1522nf MFP (#745499)
238  - Lexmark C453 (#770169)
239
240* Tue Jun 14 2011 Tim Waugh <twaugh@redhat.com> 4.0-29.20110614
241- Updated to foomatic-db-4.0-20110614.
242
243* Mon Feb 21 2011 Tim Waugh <twaugh@redhat.com> 4.0-28.20110221
244- Updated to foomatic-db-4.0-20110221.
245- No longer need hpijs data.
246
247* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-27.20101123
248- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
249
250* Fri Jan 28 2011 Tim Waugh <twaugh@redhat.com> 4.0-26.20101123
251- Rebuilt to pick up postscriptdriver tags now that python-cups
252  provides the machinery for this.
253- Build requires cups so that configure knows where to put PPDs.
254
255* Wed Jan 19 2011 Jiri Popelka <jpopelka@redhat.com> 4.0-25.20101123
256- Removed Brother P-touch (bug #560610, comment #10)
257
258* Mon Dec 06 2010 Jiri Popelka <jpopelka@redhat.com> 4.0-24.20101123
259- The pycups requirement is now python-cups.
260
261* Mon Dec 06 2010 Jiri Popelka <jpopelka@redhat.com> 4.0-23.20101123
262- Device IDs for:
263  - HP Deskjet D4100 (bug #658091)
264  - HP Color LaserJet CM4730 MFP (bug #658838)
265  - HP LaserJet 4050/4100/4350/5100/8000/P3005 (bug #659041)
266  - HP Color LaserJet 2500/3700/4550/4650/4700/5550 (bug #659042)
267
268* Tue Nov 23 2010 Jiri Popelka <jpopelka@redhat.com> 4.0-22.20101123
269- Updated to foomatic-db-4.0-20101123 (bug #655238).
270- Device ID for Canon iR 3225 (bug #651500).
271
272* Wed Nov 03 2010 Jiri Popelka <jpopelka@redhat.com> 4.0-21.20100819
273- Remove wrong Device ID for Canon iR 3170C (bug #617493).
274
275* Fri Aug 20 2010 Jiri Popelka <jpopelka@redhat.com> 4.0-20.20100819
276- Removed printer/Samsung-CLP-300|315.xml (bug #625505).
277- Removed references to foo2oak-z1.
278
279* Thu Aug 19 2010 Jiri Popelka <jpopelka@redhat.com> 4.0-19.20100819
280- Updated to foomatic-db-4.0-20100819, foomatic-db-hpijs-20090901.tar.gz
281- Device ID for Canon iR 3170C (bug #617493).
282
283* Mon Jul 12 2010 Jiri Popelka <jpopelka@redhat.com> 4.0-18.20100204
284- Moved COPYING file to ppds sub-package.
285
286* Mon May 17 2010 Tim Waugh <twaugh@redhat.com> 4.0-17.20100204
287- Don't ship backup files.
288
289* Sun May 16 2010 Tim Waugh <twaugh@redhat.com> 4.0-16.20100204
290- Device IDs for another 1302 Ricoh PPDs.
291
292* Thu May  6 2010 Tim Waugh <twaugh@redhat.com> 4.0-15.20100204
293- Device IDs for:
294  - HP Color LaserJet 2605dn (bug #583909).
295  - HP DeskJet F300 (bug #585644).
296  - HP OfficeJet 6200 (bug #215063).
297  - HP PSC 1400 (bug #586381).
298  - Ricoh Aficio MP C3500 (bug #589527).
299  - Ricoh Aficio SP C420DN (bug #589533).
300
301* Fri Apr 16 2010 Tim Waugh <twaugh@redhat.com> 4.0-14.20100204
302- Device IDs for:
303  - Canon BJC-4100 (bug #583060)
304  - HP Color LaserJet 3800 (bug #581936).
305  - HP DeskJet D2300 (bug #580341).
306  - HP DeskJet F2100 (bug #579245).
307  - HP OfficeJet 7300 (bug #577897).
308  - Lexmark E120 (bug #577881).
309  - HP DeskJet 1280 (bug #577870).
310  - HP PhotoSmart 7400 (bug #577866).
311  - Brother HL-2140 (bug #577863).
312  - HP OfficeJet 6200 (bug #215063).
313  - HP PSC 2400 (bug #188419).
314
315* Fri Mar 26 2010 Tim Waugh <twaugh@redhat.com> 4.0-13.20100204
316- Device IDs for HP PhotoSmart 2570, HP DeskJet 959C and HP OfficeJet
317  Pro K550 (bug #577280, bug #577293, bug #577296).
318
319* Thu Mar 25 2010 Tim Waugh <twaugh@redhat.com> 4.0-12.20100402
320- Fixed missing units in driver margins (bug #576370).
321
322* Fri Mar 19 2010 Tim Waugh <twaugh@redhat.com> 4.0-11.20100402
323- Device ID for Kyocera Mita FS-1020D (bug #575063).
324
325* Thu Feb  4 2010 Tim Waugh <twaugh@redhat.com> 4.0-10.20100402
326- Rebuild for postscriptdriver tags.
327
328* Thu Feb  4 2010 Tim Waugh <twaugh@redhat.com> 4.0-9.20100402
329- Updated to foomatic-db-4.0-20100402.
330
331* Fri Dec  4 2009 Tim Waugh <twaugh@redhat.com> 4.0-8.20091126
332- Added foomatic-db-hpijs tarball back in.
333
334* Thu Nov 26 2009 Tim Waugh <twaugh@redhat.com> 4.0-7.20091126
335- Updated to foomatic-db-4.0-20091126 (bug #538994).
336
337* Thu Aug 20 2009 Tim Waugh <twaugh@redhat.com> 4.0-6.20090819
338- Removed references to foo2slx and foo2hiperc (bug #518267).
339
340* Wed Aug 19 2009 Tim Waugh <twaugh@redhat.com> 4.0-5.20090819
341- Updated to foomatic-db-4.0-20090819.
342- Removed deprecated foomatic-db-hpijs tarball.
343- Use buildroot macro throughout.
344
345* Tue Aug 18 2009 Tim Waugh <twaugh@redhat.com> 4.0-4.20090702
346- Use stcolor driver for Epson Stylus Color 200 (bug #513676).
347
348* Mon Aug 17 2009 Tim Waugh <twaugh@redhat.com> 4.0-3.20090702
349- License for ppds sub-package should include GPLv2+.
350- Ship COPYING file in main package.
351- Added filesystem sub-package for directory ownership.
352
353* Mon Aug  3 2009 Tim Waugh <twaugh@redhat.com> 4.0-2.20090702
354- Move foomatic-db-ppds symlink to ppds sub-package.
355- Use sed instead of perl in raster PPDs (bug #512739).
356- Removed code to convert old-style printer IDs (there are none).
357- Ship README file.
358
359* Mon Aug  3 2009 Tim Waugh <twaugh@redhat.com> 4.0-1.20090702
360- Split database out from main foomatic package.
Note: See TracBrowser for help on using the repository browser.