source: projects/specs/trunk/f/fontforge/fontforge-vl.spec @ 7108

Revision 7108, 7.0 KB checked in by daisuke, 11 years ago (diff)

fontforge: fix to build on Vine6

Line 
1%define origversion 20120731-b
2
3Summary: Outline and bitmap font editor
4Summary(ja): アウトライン・ビットマップフォントエディタ
5Name: fontforge
6Version: 20120731b
7Release: 1%{?_dist_release}
8License: BSD
9Group: Applications/Publishing
10URL: http://fontforge.sourceforge.net/
11Source: fontforge_full-%{origversion}.tar.bz2
12Source10: %{name}.desktop
13Source20: %{name}.png
14Patch1:  fontforge-20090224-pythondl.patch
15
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19BuildRequires: xorg-x11-proto-devel
20BuildRequires: libXt-devel
21BuildRequires: freetype2-devel
22BuildRequires: libuninameslist-devel
23BuildRequires: libjpeg-turbo-devel
24BuildRequires: libpng-devel
25BuildRequires: libtiff-devel
26BuildRequires: giflib-devel
27BuildRequires: libxml2-devel
28BuildRequires: desktop-file-utils
29BuildRequires: python-devel
30BuildRequires: pango-devel
31BuildRequires: cairo-devel
32BuildRequires: libspiro-devel
33
34Obsoletes: pfaedit
35Obsoletes: fontforge-devel <= 20050310
36
37Requires: xdg-utils
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: daisuke
42
43%description
44FontForge (former PfaEdit) is a font editor for outline and bitmap
45fonts. It supports a range of font formats, including PostScript
46(ASCII and binary Type 1, some Type 3 and Type 0), TrueType, OpenType
47(Type2) and CID-keyed fonts.
48
49%prep
50%setup -q -n %{name}-%{origversion}
51%patch1 -p1
52
53%{__cp} %{SOURCE10} %{name}.desktop
54
55%build
56%configure --with-freetype-bytecode=no -with-regular-link --enable-pyextension
57%{__make} %{?_smp_mflags}
58
59%install
60%{__rm} -rf %{buildroot}
61%{__make} install DESTDIR=$RPM_BUILD_ROOT
62
63%{__install} -d -m0755 %{buildroot}%{_datadir}/applications/
64desktop-file-install \
65        --vendor "" \
66        --dir %{buildroot}%{_datadir}/applications \
67        fontforge.desktop
68
69rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/fontforge
70
71install -Dpm 644 Packaging/icons/scalable/apps/fontforge.svg \
72  $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/fontforge.svg
73
74%{__install} -d -m0755 %{buildroot}%{_datadir}/pixmaps/
75%{__install} -m644 %{SOURCE20} %{buildroot}%{_datadir}/pixmaps/
76
77mkdir -p $RPM_BUILD_ROOT/%{_datadir}/mime/packages
78install -p Packaging/fontforge.xml $RPM_BUILD_ROOT/%{_datadir}/mime/packages/
79
80
81%find_lang FontForge
82
83%{__rm} -f %{buildroot}%{_libdir}/*.la
84
85%clean
86%{__rm} -rf %{buildroot}
87
88%post
89/sbin/ldconfig 2>/dev/null
90update-desktop-database %{_datadir}/applications &>/dev/null || :
91update-mime-database %{_datadir}/mime &> /dev/null || :
92/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
93
94
95%postun
96/sbin/ldconfig 2>/dev/null
97update-desktop-database %{_datadir}/applications &>/dev/null || :
98update-mime-database %{_datadir}/mime &> /dev/null || :
99if [ $1 -eq 0 ] ; then
100    /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
101    /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
102fi
103
104%posttrans
105/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
106
107
108%files -f FontForge.lang
109%defattr(-, root, root, 0755)
110%doc AUTHORS LICENSE README-unix
111%{_bindir}/*
112%{_libdir}/lib*.so.*
113%{_libdir}/lib*.so
114%{_libdir}/pkgconfig/fontforge.pc
115%dir %{_includedir}/fontforge
116%{_includedir}/fontforge/*
117%{_datadir}/applications/fontforge.desktop
118%{_datadir}/pixmaps/fontforge.png
119%{_datadir}/icons/hicolor/*/apps/fontforge.*
120%{_datadir}/fontforge
121%{_datadir}/mime/packages/fontforge.xml
122%{_mandir}/man1/*.1*
123%{python_sitearch}/fontforge-1.0-py2.?.egg-info
124%{python_sitearch}/fontforge.so
125%{python_sitearch}/psMat.so
126
127%changelog
128* Sat Nov 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 20120731b-1
129- update to 20120731-b
130- add BR: libspiro-devel
131
132* Fri Apr 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 20120101-2
133- enable pyextensions
134
135* Tue Feb 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 20120101-1
136- update to upstream git snapshot
137
138* Tue Feb 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 20110222-3
139- rebuild with python-2.7
140
141* Tue Jan 31 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 20110222-2
142- add patch2
143  - http://sourceforge.net/mailarchive/message.php?msg_id=27133628
144
145* Sun Jul 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20110222-1
146- new upstream version
147
148* Mon Sep 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 20100501-1
149- new upstream release
150
151* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 20090923-3
152- rebuilt with rpm-4.8.1 for pkg-config
153
154* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 20090923-2
155- rebuilt with python-2.6.4-3
156
157* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20090923-1
158- new upstream release
159- add BR: pango-devel, cairo-devel
160
161* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20090408-1
162- new upstream release
163
164* Mon Nov 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 20081115-1
165- new upstream release
166
167* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 20080429-2
168- rebuild with python2.5
169
170* Sun Jun 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 20080429-1
171- new upstream release
172- build with xorg-x11-7.3
173- add Requires: xdg-utils
174
175* Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 20070723-1
176- rebuild with xorg-x11-7.3
177
178* Mon Jul 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 20070723-0vl1
179- new upstream release
180
181* Sat May 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 20070501-0vl1
182- new upstream release
183
184* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 20060822-0vl1
185- new upstream release
186- add -q option to %%setup
187
188* Sun Jul 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20060703-0vl1
189- new upstream release
190
191* Mon Oct 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 20050502-0vl1
192- new upstream release
193- update Summaries and descriptions, URL...
194- add fontforge icons and desktop file
195- add Patch10 to prefer htmlview or firefox for default browser
196
197* Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org>
198- move to fontforge
199
200* Fri Jul 19 2002 Ryoichi Ichiyama <ir@bellbind.net>
201- Updated to 2002/07/15.
202
203* Fri Apr 19 2002 Ryoichi Ichiyama <ir@bellbind.net>
204- Updated to 2002/04/16.
205
206* Sun Mar 3 2002 Ryoichi Ichiyama <ir@bellbind.net>
207- Updated to 2002/03/02.
208
209* Mon Feb 18 2002 Ryoichi Ichiyama <ir@bellbind.net>
210- Updated to 2002/02/16.
211
212* Sat Feb 16 2002 Ryoichi Ichiyama <ir@bellbind.net>
213- Updated to 2002/02/14.
214
215* Thu Feb 14 2002 Ryoichi Ichiyama <ir@bellbind.net>
216- Updated to 2002/02/12.
217
218* Mon Feb 10 2002 Ryoichi Ichiyama <ir@bellbind.net>
219- Updated to 2002/02/09.
220
221* Sat Feb 9 2002 Ryoichi Ichiyama <ir@bellbind.net>
222- Change SPEC file to VineLinux Style
223- Updated to 2002/02/05.
224
225* Fri Nov  2 2001 George Williams <gww@silcom.com>
226- went from three source packages down to just one which includes the others
227
228* Thu May 10 2001 George Williams <gww@silcom.com>
229- My first attempt at rpm, updated to 10 May sources
230
231* Tue May 01 2001 Scott Pakin <pakin@uiuc.edu>
232- Removed (unused) dynamic library files
233
234* Sun Apr 29 2001 Scott Pakin <pakin@uiuc.edu>
235- Upgraded from 220401 to 280401.
236
237* Tue Apr 24 2001 Scott Pakin <pakin@uiuc.edu>
238- Upgraded from 190401 to 220401.
239
240* Fri Apr 20 2001 Scott Pakin <pakin@uiuc.edu>
241- Upgraded from 020401 to 190401.
242
243* Tue Apr 10 2001 Scott Pakin <pakin@uiuc.edu>
244- Upgraded from 210301 to 020401.
245
246* Thu Mar 22 2001 Scott Pakin <pakin@uiuc.edu>
247- Initial release
Note: See TracBrowser for help on using the repository browser.