source: projects/specs/trunk/f/fontforge/fontforge-vl.spec @ 6013

Revision 6013, 6.1 KB checked in by daisuke, 12 years ago (diff)

fontforge: enable pyextensions

Line 
1%define origversion 20120101
2
3Summary: Outline and bitmap font editor
4Summary(ja): アウトライン・ビットマップフォントエディタ
5Name: fontforge
6Version: %{origversion}
7Release: 2%{?_dist_release}
8License: BSD
9Group: Applications/Publishing
10URL: http://fontforge.sourceforge.net/
11Source: fontforge_full-%{origversion}.tar.bz2
12Source10: %{name}.desktop
13Source20: %{name}.png
14Patch1:  fontforge-20090224-pythondl.patch
15Patch10: fontforge-browser.patch
16
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: xorg-x11-proto-devel
20BuildRequires: libXt-devel
21BuildRequires: freetype2-devel
22BuildRequires: libuninameslist-devel
23BuildRequires: libjpeg-turbo-devel
24BuildRequires: libpng-devel
25BuildRequires: libtiff-devel
26BuildRequires: giflib-devel
27BuildRequires: libxml2-devel
28BuildRequires: desktop-file-utils
29BuildRequires: python-devel
30BuildRequires:  pango-devel
31BuildRequires:  cairo-devel
32Obsoletes: pfaedit
33Obsoletes: fontforge-devel <= 20050310
34
35Requires: xdg-utils
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: daisuke
40
41%description
42FontForge (former PfaEdit) is a font editor for outline and bitmap
43fonts. It supports a range of font formats, including PostScript
44(ASCII and binary Type 1, some Type 3 and Type 0), TrueType, OpenType
45(Type2) and CID-keyed fonts.
46
47%prep
48%setup -q -n %{name}-%{origversion}
49%patch1 -p1
50%patch10 -p1 -b .browser
51
52%{__cp} %{SOURCE10} %{name}.desktop
53
54%build
55%configure --with-freetype-bytecode=no -with-regular-link --enable-pyextension
56%{__make} %{?_smp_mflags}
57
58%install
59%{__rm} -rf %{buildroot}
60%{__make} install DESTDIR=$RPM_BUILD_ROOT
61
62%{__install} -d -m0755 %{buildroot}%{_datadir}/applications/
63desktop-file-install \
64        --vendor "" \
65        --dir %{buildroot}%{_datadir}/applications \
66        fontforge.desktop
67
68rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/fontforge
69
70%{__install} -d -m0755 %{buildroot}%{_datadir}/pixmaps/
71%{__install} -m644 %{SOURCE20} %{buildroot}%{_datadir}/pixmaps/
72
73%find_lang FontForge
74
75%{__rm} -f %{buildroot}%{_libdir}/*.la
76
77%clean
78%{__rm} -rf %{buildroot}
79
80%post
81/sbin/ldconfig 2>/dev/null
82update-desktop-database %{_datadir}/applications &>/dev/null || :
83
84%postun
85/sbin/ldconfig 2>/dev/null
86update-desktop-database %{_datadir}/applications &>/dev/null || :
87
88%files -f FontForge.lang
89%defattr(-, root, root, 0755)
90%doc AUTHORS LICENSE README-unix
91%{_bindir}/*
92%{_libdir}/lib*.so.*
93%{_libdir}/lib*.so
94%{_libdir}/pkgconfig/fontforge.pc
95%dir %{_includedir}/fontforge
96%{_includedir}/fontforge/*
97%{_datadir}/applications/fontforge.desktop
98%{_datadir}/pixmaps/fontforge.png
99%{_datadir}/fontforge
100%{_mandir}/man1/*.1*
101%{python_sitearch}/fontforge-1.0-py2.7.egg-info
102%{python_sitearch}/fontforge.so
103%{python_sitearch}/psMat.so
104
105%changelog
106* Fri Apr 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 20120101-2
107- enable pyextensions
108
109* Tue Feb 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 20120101-1
110- update to upstream git snapshot
111
112* Tue Feb 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 20110222-3
113- rebuild with python-2.7
114
115* Tue Jan 31 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 20110222-2
116- add patch2
117  - http://sourceforge.net/mailarchive/message.php?msg_id=27133628
118
119* Sun Jul 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20110222-1
120- new upstream version
121
122* Mon Sep 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 20100501-1
123- new upstream release
124
125* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 20090923-3
126- rebuilt with rpm-4.8.1 for pkg-config
127
128* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 20090923-2
129- rebuilt with python-2.6.4-3
130
131* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20090923-1
132- new upstream release
133- add BR: pango-devel, cairo-devel
134
135* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20090408-1
136- new upstream release
137
138* Mon Nov 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 20081115-1
139- new upstream release
140
141* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 20080429-2
142- rebuild with python2.5
143
144* Sun Jun 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 20080429-1
145- new upstream release
146- build with xorg-x11-7.3
147- add Requires: xdg-utils
148
149* Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 20070723-1
150- rebuild with xorg-x11-7.3
151
152* Mon Jul 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 20070723-0vl1
153- new upstream release
154
155* Sat May 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 20070501-0vl1
156- new upstream release
157
158* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 20060822-0vl1
159- new upstream release
160- add -q option to %%setup
161
162* Sun Jul 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20060703-0vl1
163- new upstream release
164
165* Mon Oct 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 20050502-0vl1
166- new upstream release
167- update Summaries and descriptions, URL...
168- add fontforge icons and desktop file
169- add Patch10 to prefer htmlview or firefox for default browser
170
171* Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org>
172- move to fontforge
173
174* Fri Jul 19 2002 Ryoichi Ichiyama <ir@bellbind.net>
175- Updated to 2002/07/15.
176
177* Fri Apr 19 2002 Ryoichi Ichiyama <ir@bellbind.net>
178- Updated to 2002/04/16.
179
180* Sun Mar 3 2002 Ryoichi Ichiyama <ir@bellbind.net>
181- Updated to 2002/03/02.
182
183* Mon Feb 18 2002 Ryoichi Ichiyama <ir@bellbind.net>
184- Updated to 2002/02/16.
185
186* Sat Feb 16 2002 Ryoichi Ichiyama <ir@bellbind.net>
187- Updated to 2002/02/14.
188
189* Thu Feb 14 2002 Ryoichi Ichiyama <ir@bellbind.net>
190- Updated to 2002/02/12.
191
192* Mon Feb 10 2002 Ryoichi Ichiyama <ir@bellbind.net>
193- Updated to 2002/02/09.
194
195* Sat Feb 9 2002 Ryoichi Ichiyama <ir@bellbind.net>
196- Change SPEC file to VineLinux Style
197- Updated to 2002/02/05.
198
199* Fri Nov  2 2001 George Williams <gww@silcom.com>
200- went from three source packages down to just one which includes the others
201
202* Thu May 10 2001 George Williams <gww@silcom.com>
203- My first attempt at rpm, updated to 10 May sources
204
205* Tue May 01 2001 Scott Pakin <pakin@uiuc.edu>
206- Removed (unused) dynamic library files
207
208* Sun Apr 29 2001 Scott Pakin <pakin@uiuc.edu>
209- Upgraded from 220401 to 280401.
210
211* Tue Apr 24 2001 Scott Pakin <pakin@uiuc.edu>
212- Upgraded from 190401 to 220401.
213
214* Fri Apr 20 2001 Scott Pakin <pakin@uiuc.edu>
215- Upgraded from 020401 to 190401.
216
217* Tue Apr 10 2001 Scott Pakin <pakin@uiuc.edu>
218- Upgraded from 210301 to 020401.
219
220* Thu Mar 22 2001 Scott Pakin <pakin@uiuc.edu>
221- Initial release
Note: See TracBrowser for help on using the repository browser.