source: projects/specs/trunk/f/fontconfig/fontconfig-vl.spec @ 8353

Revision 8353, 24.0 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define freetype_version 2.4.11
3
4Summary: Font configuration and customization library
5Summary(ja): フォント設定/カスタマイズライブラリ
6Name: fontconfig
7Version: 2.11.1
8Release: 1%{?_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://fontconfig.org/
12
13Source: http://fontconfig.org/release/fontconfig-%{version}.tar.bz2
14Source10: 70-prefer-ja-font.conf
15Source11: 59-morisawa-font-alias.conf
16
17# from fedora
18# https://bugzilla.redhat.com/show_bug.cgi?id=140335
19Patch0:         fontconfig-2.8.0-sleep-less.patch
20
21# vine
22Patch4: fontconfig-2.3.2-subst-ja-font.patch
23Patch10: fontconfig-2.6.0-vine.patch
24
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: gawk
28BuildRequires: expat-devel
29BuildRequires: freetype2-devel >= %{freetype_version}
30BuildRequires: perl
31
32Requires(pre): freetype2 >= %{freetype_version}, coreutils
33Conflicts: XOrg-libs <= 6.9.0
34Obsoletes: XOrg-libs <= 6.9.0
35Conflicts: XOrg-font-utils <= 6.9.0
36Obsoletes: XOrg-font-utils <= 6.9.0
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42Fontconfig is designed to locate fonts within the
43system and select them according to requirements specified by
44applications.
45
46%description -l ja
47Fontconfig は、システム内のフォントを把握し、アプリケーション
48が指定した要求に応じてそれらを選択するためのライブラリです。
49
50%package devel
51Summary: Development files for %{name}
52Summary(ja): Fontconfig の開発ファイル
53Group: Development/Libraries
54Requires: fontconfig = %{version}-%{release}
55Requires: freetype2-devel >= %{freetype_version}
56Requires: expat-devel
57Requires: pkgconfig
58Conflicts: XOrg-devel <= 6.9.0
59Obsoletes: XOrg-devel <= 6.9.0
60
61%description devel
62The fontconfig-devel package includes the header files,
63and developer docs for the fontconfig package.
64
65%description -l ja devel
66fontconfig-devel パッケージには fontconfig を使ったソフトウエア
67を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
68ントが含まれています。
69
70# compat32
71%package -n compat32-%{name}
72Summary: Font configuration and customization library
73Summary(ja): フォント設定/カスタマイズライブラリ
74Group: System Environment/Libraries
75
76%description -n compat32-%{name}
77Fontconfig is designed to locate fonts within the
78system and select them according to requirements specified by
79applications.
80
81%description -l ja -n compat32-%{name}
82Fontconfig は、システム内のフォントを把握し、アプリケーション
83が指定した要求に応じてそれらを選択するためのライブラリです。
84
85%package -n compat32-%{name}-devel
86Summary: Font configuration and customization library
87Group: Development/Libraries
88Requires: compat32-%{name} = %{version}-%{release}
89Requires: %{name}-devel = %{version}-%{release}
90Requires: compat32-freetype2-devel >= %{freetype_version}
91Requires: compat32-expat-devel
92
93%description -n compat32-%{name}-devel
94The fontconfig-devel package includes the header files,
95and developer docs for the fontconfig package.
96
97%description -l ja -n compat32-%{name}-devel
98fontconfig-devel パッケージには fontconfig を使ったソフトウエア
99を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
100ントが含まれています。
101
102%prep
103%setup -q
104
105%patch0 -p1 -b .sleep-less
106
107%patch4 -p1 -b .subst-ja-font
108%patch10 -p1 -b .vine
109
110%build
111
112# We don't want to rebuild the docs, but we want to install the included ones.
113export HASDOCBOOK=no
114
115%configure \
116  --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
117
118%__make %{?_smp_mflags}
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123%__make install DESTDIR=$RPM_BUILD_ROOT
124
125ln -s %{_datadir}/fontconfig/conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
126install -m664 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_datadir}/fontconfig/conf.avail/
127for i in 70-prefer-ja-font.conf 59-morisawa-font-alias.conf
128do
129  ln -sf %{_datadir}/fontconfig/conf.avail/$i $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
130done
131
132# move installed doc files back to build directory to package themm
133# in the right place
134mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
135rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
136
137# All font packages depend on this package, so we create
138# and own /usr/share/fonts
139mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
140
141# Remove unpackaged files
142find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
143find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post
149/sbin/ldconfig
150umask 0022
151# Remove stale caches
152rm -f %{_localstatedir}/cache/fontconfig/????????????????????????????????-*.cache-2
153HOME=/root /usr/bin/fc-cache -f -s >& /dev/null
154
155
156%postun -p /sbin/ldconfig
157
158%post -n compat32-%{name} -p /sbin/ldconfig
159
160%postun -n compat32-%{name} -p /sbin/ldconfig
161
162%files
163%defattr(-, root, root)
164%doc README AUTHORS COPYING
165%doc fontconfig-user.txt fontconfig-user.html
166%doc %{_sysconfdir}/fonts/conf.d/README
167%{_libdir}/libfontconfig.so.*
168%{_bindir}/fc-cache
169%{_bindir}/fc-list
170%{_bindir}/fc-match
171%{_bindir}/fc-cat
172%{_bindir}/fc-query
173%{_bindir}/fc-scan
174%{_bindir}/fc-pattern
175%{_bindir}/fc-validate
176%dir %{_datadir}/fonts
177%{_datadir}/%{name}
178%{_datadir}/xml/%{name}/fonts.dtd
179%config %{_sysconfdir}/fonts/fonts.conf
180%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
181%dir %{_localstatedir}/cache/fontconfig
182
183%{_mandir}/man1/*
184%{_mandir}/man5/*
185
186%files devel
187%defattr(-, root, root)
188%doc fontconfig-devel.txt fontconfig-devel
189%{_libdir}/libfontconfig.so
190%{_libdir}/pkgconfig/*
191%{_includedir}/fontconfig
192%{_mandir}/man3/*
193
194# compat32
195%if %{build_compat32}
196%files -n compat32-%{name}
197%defattr(-, root, root)
198%{_libdir}/libfontconfig.so.*
199
200%files -n compat32-%{name}-devel
201%defattr(-, root, root)
202%{_libdir}/libfontconfig.so
203%endif
204
205%changelog
206* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.11.1-1
207- new upstream release
208
209* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.11.0-1
210- new upstream release
211- remove Patch1,2
212
213* Tue May 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.92-2
214- install/enable 70-prefer-ja-font.conf and 59-morisawa-font-alias.conf (again)
215- enable 25-unhint-nonlatin.conf (again)
216- add patch0-2 from fedora package
217  - patch0: less sleep in fc-cache
218  - patch1: fix font matching issue
219  - patch2: fix web font issue in firefox
220
221* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.92-1
222- new upstream release
223- remove Patch1 (fontconfig-2.2.1-AppleRoman-DynaFont.patch)
224
225* Fri Dec 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
226- rebuild with freetype2-2.4.8
227- add Requires: expat-devel (-devel package)
228
229* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.0-2
230- build with rpm-4.8.1-1 for pkg-config file
231
232* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
233- new upstream release
234- remove static libs
235
236* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-3
237- update %%post
238
239* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-2
240- add translated summary and description
241
242* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-1
243- new upstream release
244
245* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-2
246- add fc-query and fc-scan to %%files
247
248* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
249- new upstream release
250- update 59-morisawa-font-alias.conf
251
252* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.0-3
253- added compat32 package for x86_64 arch support
254
255* Tue Jan 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-2
256- update 59-morisawa-font-alias.conf
257  - add FutoMin, FutoGo, Jun alias
258
259* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-1
260- new upstream release
261- rename 10-prefer-ja-font.conf to 70-prefer-ja-font.conf
262
263* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-3
264- add 10-prefer-ja-font.conf to prefer Japanese fonts.
265- add 59-morisawa-font-alias.conf
266  - bind Ryumin to serif and GothicBBB to sans-serif
267
268* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
269- add legacy font path for compatibility
270
271* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
272- add Conflits/Obsoletes: XOrg-font-utils <= 6.9.0
273
274* Mon Dec 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
275- initial build for Vine Linux
276  - splitted from XOrg package.
277
278* Tue Nov 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.5.0-1
279- Update to 2.5.0.
280
281* Tue Nov 06 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.92-1
282- Update to 2.4.92.
283- Mark /etc/fonts/conf.d/* as config(noreplace).
284- Remove most of our conf file, all upstreamed except for
285  75-blacklist-fedora.conf that I'm happily dropping.  Who has
286  Hershey fonts these days...
287- ln upstream'ed 25-unhint-nonlatin.conf from conf.avail in conf.d
288- Add 25-no-bitmap-fedora.conf which is the tiny remaining bit
289  of conf that didn't end up upstream.  Can get rid of it in the
290  future, but not just yet.
291
292* Thu Oct 25 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.91-1
293- Update to 2.4.91.
294- Add /usr/local/share/fonts to default config. (#147004)
295- Don't rebuild docs, to fix multilib conflicts. (#313011)
296- Remove docbook and elinks BuildRequires and stuff as we don't
297  rebuild docs.
298
299* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 2.4.2-5
300- Rebuild for PPC toolchain bug
301- Add BuildRequires: gawk
302
303* Sun Jun 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-4
304- /etc/fonts/conf.d is now owned by filesystem
305
306* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-3
307- Add Liberation fonts to 30-aliases-fedora.conf
308
309* Fri Jan 12 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.2-2
310- Change /usr/share/X11/fonts/OTF to /usr/share/X11/fonts/TTF
311- Resolves: #220809
312
313* Tue Dec  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.2-1
314- Update to 2.4.2
315
316* Wed Oct  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.1-4
317- Fix a multilib upgrade problem (#208151)
318
319* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-3
320- rebuilt for unwind info generation, broken in gcc-4.1.1-21
321
322* Fri Sep 22 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-2
323- Update 30-aliases-fedora.conf to correctly alias MS and StarOffice
324  fonts. (#207460)
325
326* Fri Sep 15 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-1
327- Update to 2.4.1, a public API was dropped from 2.4.0
328- Remove upstreamed patch
329
330* Mon Sep 11 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.0-1
331- Update to 2.4.0
332- Rename/order our configuration stuff to match the new scheme.
333  Breaks expected :-(
334
335* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-3
336- Add missing file.  Previous update didn't go through
337
338* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-2
339- Add fontconfig-2.3.97-ppc64.patch, for ppc64 arch signature
340
341* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-1
342- update to 2.3.97
343- Drop upstreamed patches
344- Regenerate defaultconfig patch
345- Don't touch stamp as it was not ever needed
346
347* Thu Aug 17 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-11
348- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
349
350* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
351- use "%5x" instead of " %4x" to support 64k instead of
352  clamping.  Idea from Behdad.
353
354* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
355- tweak last patch to give a more reasonable page size
356  value if 64k page size is in effect.
357
358* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-8
359- maybe fix buffer overflow (bug 202152).
360
361* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-7
362- Update configs to provide better openoffice/staroffice
363  compatibility (bug 200723)
364
365* Thu Jul 27 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-6
366- Do umask 0022 in post
367- Update configs to reflect addition of new Indic fonts (#200381, #200397)
368
369* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-5
370- Plug a small memory leak
371
372* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1.1
373- rebuild
374
375* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1
376- rebuild
377
378* Fri Jun  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-4
379- Fix the handling of TTF font collections
380
381* Thu May 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-3
382- Apply a patch by David Turner to speed up cache generation
383
384* Wed Apr 26 2006 Bill Nottingham <notting@redhat.com> - 2.3.95-2
385- fix fonts.conf typo
386
387* Wed Apr 26 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-1
388- Update to 2.3.95
389
390* Fri Feb 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.94-1
391- Update to 2.3.94
392
393* Sat Feb 11 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060211-1
394- Newer cvs snapshot
395
396* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060208-1.1
397- bump again for double-long bug on ppc(64)
398
399* Wed Feb  8 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060208-1
400- Newer cvs snapshot
401
402* Tue Feb  7 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060207-1
403- Newer cvs snapshot
404- Drop upstreamed patches, pick up some new ones
405
406* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060131-3.1
407- rebuilt for new gcc4.1 snapshot and glibc changes
408
409* Thu Feb  2 2006 Ray Strode <rstrode@redhat.com> - 2.3.93.cvs20060131-3
410- Move user cache to a subdirectory (bug 160275)
411
412* Thu Feb  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-2
413- Accumulated patches
414
415* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-1
416- Newer cvs snapshot
417
418* Tue Jan 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060124-1
419- Newer cvs snapshot
420
421* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 2.3.93-4
422- apply patch from Tim Mayberry to correct aliasing and disable
423  hinting for the two Chinese font names AR PL ShanHeiSun Uni
424  and AR PL Zenkai Uni
425
426* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> - 2.3.93-3
427- prereq coreutils for mkdir/touch in %%post
428
429* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-2
430- Fix to create /var/cache/fontconfig/stamp in the post install stage.
431
432* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-1
433- New upstream version.
434
435* Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
436- Disable hinting for Lohit Gujarati
437
438* Fri Dec  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
439- Add two new Chinese font names to the default fonts.conf file:
440        AR PL ShanHeiSun Uni
441        AR PL Zenkai Uni
442
443* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
444- rebuilt
445
446* Mon Nov 28 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051129-1
447- Update to a newer cvs snapshot
448
449* Sat Nov 19 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051119-1
450- Update to a newer cvs snapshot
451
452* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 2.3.93-3
453- modular X moved fonts from /usr/X11R6/lib/X11/fonts to
454  /usr/share/X11/fonts, adjust %%configure accordingly and
455  conflict with older font packages
456
457* Wed Nov  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92-2
458- Remove inadvertent rejection of Luxi Mono from 40-blacklist-fonts.conf.
459  Fixes #172437
460
461* Fri Nov  4 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92-1
462- Update to 2.3.92
463
464* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051031-1
465- Update to a newer cvs snapshot
466- Add a patch which should help to understand broken cache problems
467
468* Fri Oct 21 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-2
469- Add new Chinese fonts
470- Fix the 40-blacklist-fonts.conf file to use the documented
471  fonts.conf syntax, and exclude the Hershey fonts by family
472  name.
473
474* Fri Oct 14 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-1
475- Update to the mmap branch of fontconfig
476
477* Fri Jul 22 2005 Kristian H淡gsberg <krh@redhat.com> - 2.3.2-1
478- Update to fontconfig-2.3.2.  Drop
479
480        fontconfig-2.1-slighthint.patch,
481        fontconfig-2.2.3-timestamp.patch,
482        fontconfig-2.2.3-names.patch,
483        fontconfig-2.2.3-ta-pa-orth.patch, and
484        fontconfig-2.2.3-timestamp.patch,
485
486  as they are now merged upstream.
487
488- Fold fontconfig-2.2.3-add-sazanami.patch into
489  fontconfig-2.3.2-defaultconfig.patch and split rules to disable CJK
490  hinting out into /etc/fonts/conf.d/50-no-hint-fonts.conf.
491
492- Drop fontconfig-0.0.1.020826.1330-blacklist.patch and use the new
493  rejectfont directive to reject those fonts in 40-blacklist-fonts.conf.
494
495- Add fontconfig-2.3.2-only-parse-conf-files.patch to avoid parsing
496  .rpmsave files.
497
498- Renable s390 documentation now that #97079 has been fixed and add
499  BuildRequires: for docbook-utils and docbook-utils-pdf.
500
501- Drop code to iconv and custom install man pages, upstream does the
502  right thing now.
503
504- Add workaround from hell to make elinks cooperate so we can build
505  txt documentation.
506
507* Tue Apr 19 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-13
508- Add another font family name Sazanami Gothic/Mincho (#148748)
509
510* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-12
511- Rebuild
512
513* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-11
514- Rebuild
515
516* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-10
517- Rebuild
518
519* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-9
520- Disable docs for s390 for now
521
522* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-8
523- Rebuild
524
525* Wed Dec  1 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-6
526- Sleep a second before the exit of fc-cache to fix problems with fast
527  serial installs of fonts (#140335)
528- Turn off hinting for Lohit Hindi/Bengali/Punjabi (#139816)
529
530* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-5
531- Add Lohit fonts for Indic languages (#134492)
532- Add Punjabi converage, fix Tamil coverage
533
534* Wed Sep 22 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-4
535- Update fonts-hebrew names to include CLM suffix
536
537* Thu Sep  2 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-3
538- Backport code from head branch of fontconfig CVS to parse names
539  for postscript fonts (fixes #127500, J. J. Ramsey)
540- Own /usr/share/fonts (#110956, David K. Levine)
541- Add KacstQura to serif/sans-serif/monospace aliases (#101182)
542
543* Mon Aug 16 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-2
544- Don't run fc-cache if the binary isn't there (#128072, tracked
545  down by Jay Turner)
546
547* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
548- Upgrade to 2.2.3
549- Convert man pages to UTF-8 (#108730, Peter van Egdom)
550- Renable docs on s390
551
552* Mon Jul 26 2004 Owen Taylor <otaylor@redhat.com> - 2.2.1-12
553- Rebuild for RHEL
554- Back freetype required version down to 2.1.4
555
556* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
557- rebuilt
558
559* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
560- Require recent freetype (#109592, Peter Oliver)
561- Remove fonts.conf timestamp to fix multiarch conflict (#118182)
562- Disable hinting for Mukti Narrow (#120915, Sayamindu Dasgupta)
563
564* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
565- Rebuild
566
567* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.0
568- Add Albany/Cumberland/Thorndale as fallbacks for Microsoft core fonts and
569  as non-preferred alternatives for Sans/Serif/Monospace
570- Fix FreeType includes for recent FreeType
571
572* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
573- rebuilt
574
575* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
576- rebuilt
577
578* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
579- Should have been passing --with-add-fonts, not --with-add-dirs to
580  configure ... caused wrong version of Luxi to be used. (#100862)
581
582* Fri Sep 19 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-5.0
583- Tweak fonts.conf to get right hinting for CJK fonts (#97337)
584
585* Tue Jun 17 2003 Bill Nottingham <notting@redhat.com> 2.2.1-3
586- handle null config->cache correctly
587
588* Thu Jun 12 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
589- Update default config to include Hebrew fonts (#90501, Dov Grobgeld)
590
591* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
592- As a workaround disable doc builds on s390
593
594* Mon Jun  9 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-1
595- Version 2.2.1
596
597* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
598- rebuilt
599
600* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
601- debuginfo rebuild
602
603* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com> 2.1-8
604- Fix segfault in fc-cache from .dircache patch
605
606* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com>
607- Back out patch that wrote fonts.conf entries that crash RH-8.0
608  gnome-terminal, go with patch from fontconfig CVS instead.
609  (#84863)
610
611* Tue Feb 11 2003 Owen Taylor <otaylor@redhat.com>
612- Move fontconfig man page to main package, since it contains non-devel
613  information (#76189)
614- Look in the OTF subdirectory of /usr/X11R6/lib/fonts as well
615  so we find Syriac fonts (#82627)
616
617* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 2.1-5
618- modified fontconfig-0.0.1.020626.1517-fontdir.patch to hard code
619  /usr/X11R6/lib/X11/fonts instead of using $(X_FONT_DIR).  This is
620  because on lib64 machines, fonts are not in /usr/X11R6/lib64/....
621
622* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
623- rebuilt
624
625* Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com>
626- Try a different tack when fixing cache problem
627
628* Tue Jan 14 2003 Owen Taylor <otaylor@redhat.com>
629- Try to fix bug where empty cache entries would be found in
630  ~/.fonts.cache-1 during scanning (#81335)
631
632* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 2.1-1
633- Updated to version 2.1
634- Updated slighthint patch to fontconfig-2.1-slighthint.patch
635- Updated freetype version required to 2.1.2-7
636
637* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
638- Version 2.0
639- Correct capitalization/spacing for ZYSong18030 name (#73272)
640
641* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
642- Blacklist fonts from ghostscript-fonts that don't render correctly
643
644* Mon Aug 26 2002 Owen Taylor <otaylor@redhat.com>
645- Upgrade to fcpackage rc3
646- Fix bug in comparisons for xx_XX language tags
647- Compensate for a minor config file change in rc3
648
649* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
650- Add an explicit PreReq for freetype
651- Move fonts we don't ship to the end of the fonts.conf aliases so
652  installing them doesn't change the look.
653
654* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
655- Memory leak fix when parsing config files
656- Set rh_prefer_bitmaps for .ja fonts to key off of in Xft
657- Fix some groff warnings for fontconfig.man (#72138)
658
659* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
660- Try once more to get the right default Sans-serif font :-(
661- Switch the Sans/Monospace aliases for Korean to Gulim, not Dotum
662
663* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
664- Fix %%post
665
666* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
667- Fix lost Luxi Sans default
668
669* Mon Aug 12 2002 Owen Taylor <otaylor@redhat.com>
670- Upgrade to rc2
671- Turn off hinting for all CJK fonts
672- Fix typo in %%post
673- Remove the custom language tag stuff in favor of Keith's standard
674  solution.
675
676* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
677- Prefer Luxi Sans to Nimbus Sans again
678
679* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
680- Add FC_HINT_STYLE to FcBaseObjectTypes
681- Switch Chinese fonts to always using Sung-ti / Ming-ti, and never Kai-ti
682- Add ZYSong18030 to aliases (#68428)
683
684* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
685- Fix a typo in the langtag patch (caught by Erik van der Poel)
686
687* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
688- Add FC_HINT_STYLE tag
689
690* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
691- New upstream version, with fix for problems with
692  ghostscript-fonts (Fonts don't work for Qt+CJK,
693  etc.)
694
695* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
696- New upstream version, fixing locale problem
697
698* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
699- Add a hack where we set the "language" fontconfig property based on the locale, then
700  we conditionalize base on that in the fonts.conf file.
701
702* Sun Jun 23 2002 Owen Taylor <otaylor@redhat.com>
703- New upstream version
704
705* Tue Jun 18 2002 Owen Taylor <otaylor@redhat.com>
706- Fix crash from FcObjectSetAdd
707
708* Tue Jun 11 2002 Owen Taylor <otaylor@redhat.com>
709- make fonts.conf %%config, not %%config(noreplace)
710- Another try at the CJK aliases
711- Add some CJK fonts to the config
712- Prefer Luxi Mono to Nimbus Mono
713
714* Mon Jun 10 2002 Owen Taylor <otaylor@redhat.com>
715- New upstream version
716- Fix matching for bitmap fonts
717
718* Mon Jun  3 2002 Owen Taylor <otaylor@redhat.com>
719- New version, new upstream mega-tarball
720
721* Tue May 28 2002 Owen Taylor <otaylor@redhat.com>
722- Fix problem with FcConfigSort
723
724* Fri May 24 2002 Owen Taylor <otaylor@redhat.com>
725- Initial specfile
726
Note: See TracBrowser for help on using the repository browser.