source: projects/specs/trunk/f/fontconfig/fontconfig-vl.spec @ 8084

Revision 8084, 23.9 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define freetype_version 2.4.11
3
4Summary: Font configuration and customization library
5Summary(ja): フォント設定/カスタマイズライブラリ
6Name: fontconfig
7Version: 2.11.0
8Release: 1%{?_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://fontconfig.org/
12
13Source: http://fontconfig.org/release/fontconfig-%{version}.tar.bz2
14Source10: 70-prefer-ja-font.conf
15Source11: 59-morisawa-font-alias.conf
16
17# from fedora
18# https://bugzilla.redhat.com/show_bug.cgi?id=140335
19Patch0:         fontconfig-2.8.0-sleep-less.patch
20
21# vine
22Patch4: fontconfig-2.3.2-subst-ja-font.patch
23Patch10: fontconfig-2.6.0-vine.patch
24
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: gawk
28BuildRequires: expat-devel
29BuildRequires: freetype2-devel >= %{freetype_version}
30BuildRequires: perl
31
32Requires(pre): freetype2 >= %{freetype_version}, coreutils
33Conflicts: XOrg-libs <= 6.9.0
34Obsoletes: XOrg-libs <= 6.9.0
35Conflicts: XOrg-font-utils <= 6.9.0
36Obsoletes: XOrg-font-utils <= 6.9.0
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42Fontconfig is designed to locate fonts within the
43system and select them according to requirements specified by
44applications.
45
46%description -l ja
47Fontconfig は、システム内のフォントを把握し、アプリケーション
48が指定した要求に応じてそれらを選択するためのライブラリです。
49
50%package devel
51Summary: Development files for %{name}
52Summary(ja): Fontconfig の開発ファイル
53Group: Development/Libraries
54Requires: fontconfig = %{version}-%{release}
55Requires: freetype2-devel >= %{freetype_version}
56Requires: expat-devel
57Requires: pkgconfig
58Conflicts: XOrg-devel <= 6.9.0
59Obsoletes: XOrg-devel <= 6.9.0
60
61%description devel
62The fontconfig-devel package includes the header files,
63and developer docs for the fontconfig package.
64
65%description -l ja devel
66fontconfig-devel パッケージには fontconfig を使ったソフトウエア
67を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
68ントが含まれています。
69
70# compat32
71%package -n compat32-%{name}
72Summary: Font configuration and customization library
73Summary(ja): フォント設定/カスタマイズライブラリ
74Group: System Environment/Libraries
75
76%description -n compat32-%{name}
77Fontconfig is designed to locate fonts within the
78system and select them according to requirements specified by
79applications.
80
81%description -l ja -n compat32-%{name}
82Fontconfig は、システム内のフォントを把握し、アプリケーション
83が指定した要求に応じてそれらを選択するためのライブラリです。
84
85%package -n compat32-%{name}-devel
86Summary: Font configuration and customization library
87Group: Development/Libraries
88Requires: compat32-%{name} = %{version}-%{release}
89Requires: %{name}-devel = %{version}-%{release}
90Requires: compat32-freetype2-devel >= %{freetype_version}
91Requires: compat32-expat-devel
92
93%description -n compat32-%{name}-devel
94The fontconfig-devel package includes the header files,
95and developer docs for the fontconfig package.
96
97%description -l ja -n compat32-%{name}-devel
98fontconfig-devel パッケージには fontconfig を使ったソフトウエア
99を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
100ントが含まれています。
101
102%prep
103%setup -q
104
105%patch0 -p1 -b .sleep-less
106
107%patch4 -p1 -b .subst-ja-font
108%patch10 -p1 -b .vine
109
110%build
111
112# We don't want to rebuild the docs, but we want to install the included ones.
113export HASDOCBOOK=no
114
115%configure \
116  --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
117
118%__make %{?_smp_mflags}
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123%__make install DESTDIR=$RPM_BUILD_ROOT
124
125ln -s %{_datadir}/fontconfig/conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
126install -m664 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_datadir}/fontconfig/conf.avail/
127for i in 70-prefer-ja-font.conf 59-morisawa-font-alias.conf
128do
129  ln -sf %{_datadir}/fontconfig/conf.avail/$i $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
130done
131
132# move installed doc files back to build directory to package themm
133# in the right place
134mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
135rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
136
137# All font packages depend on this package, so we create
138# and own /usr/share/fonts
139mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
140
141# Remove unpackaged files
142rm $RPM_BUILD_ROOT%{_libdir}/*.la
143rm $RPM_BUILD_ROOT%{_libdir}/*.a
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post
149/sbin/ldconfig
150umask 0022
151# Remove stale caches
152rm -f %{_localstatedir}/cache/fontconfig/????????????????????????????????-*.cache-2
153HOME=/root /usr/bin/fc-cache -f -s >& /dev/null
154
155
156%postun -p /sbin/ldconfig
157
158%post -n compat32-%{name} -p /sbin/ldconfig
159
160%postun -n compat32-%{name} -p /sbin/ldconfig
161
162%files
163%defattr(-, root, root)
164%doc README AUTHORS COPYING
165%doc fontconfig-user.txt fontconfig-user.html
166%doc %{_sysconfdir}/fonts/conf.d/README
167%{_libdir}/libfontconfig.so.*
168%{_bindir}/fc-cache
169%{_bindir}/fc-list
170%{_bindir}/fc-match
171%{_bindir}/fc-cat
172%{_bindir}/fc-query
173%{_bindir}/fc-scan
174%{_bindir}/fc-pattern
175%{_bindir}/fc-validate
176%dir %{_datadir}/fonts
177%{_datadir}/%{name}
178%{_datadir}/xml/%{name}/fonts.dtd
179%config %{_sysconfdir}/fonts/fonts.conf
180%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
181%dir %{_localstatedir}/cache/fontconfig
182
183%{_mandir}/man1/*
184%{_mandir}/man5/*
185
186%files devel
187%defattr(-, root, root)
188%doc fontconfig-devel.txt fontconfig-devel
189%{_libdir}/libfontconfig.so
190%{_libdir}/pkgconfig/*
191%{_includedir}/fontconfig
192%{_mandir}/man3/*
193
194# compat32
195%if %{build_compat32}
196%files -n compat32-%{name}
197%defattr(-, root, root)
198%{_libdir}/libfontconfig.so.*
199
200%files -n compat32-%{name}-devel
201%defattr(-, root, root)
202%{_libdir}/libfontconfig.so
203%{_libdir}/pkgconfig/*
204%endif
205
206%changelog
207* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.11.0-1
208- new upstream release
209- remove Patch1,2
210
211* Tue May 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.92-2
212- install/enable 70-prefer-ja-font.conf and 59-morisawa-font-alias.conf (again)
213- enable 25-unhint-nonlatin.conf (again)
214- add patch0-2 from fedora package
215  - patch0: less sleep in fc-cache
216  - patch1: fix font matching issue
217  - patch2: fix web font issue in firefox
218
219* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.92-1
220- new upstream release
221- remove Patch1 (fontconfig-2.2.1-AppleRoman-DynaFont.patch)
222
223* Fri Dec 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
224- rebuild with freetype2-2.4.8
225- add Requires: expat-devel (-devel package)
226
227* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.0-2
228- build with rpm-4.8.1-1 for pkg-config file
229
230* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
231- new upstream release
232- remove static libs
233
234* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-3
235- update %%post
236
237* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-2
238- add translated summary and description
239
240* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-1
241- new upstream release
242
243* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-2
244- add fc-query and fc-scan to %%files
245
246* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
247- new upstream release
248- update 59-morisawa-font-alias.conf
249
250* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.0-3
251- added compat32 package for x86_64 arch support
252
253* Tue Jan 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-2
254- update 59-morisawa-font-alias.conf
255  - add FutoMin, FutoGo, Jun alias
256
257* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-1
258- new upstream release
259- rename 10-prefer-ja-font.conf to 70-prefer-ja-font.conf
260
261* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-3
262- add 10-prefer-ja-font.conf to prefer Japanese fonts.
263- add 59-morisawa-font-alias.conf
264  - bind Ryumin to serif and GothicBBB to sans-serif
265
266* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
267- add legacy font path for compatibility
268
269* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
270- add Conflits/Obsoletes: XOrg-font-utils <= 6.9.0
271
272* Mon Dec 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
273- initial build for Vine Linux
274  - splitted from XOrg package.
275
276* Tue Nov 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.5.0-1
277- Update to 2.5.0.
278
279* Tue Nov 06 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.92-1
280- Update to 2.4.92.
281- Mark /etc/fonts/conf.d/* as config(noreplace).
282- Remove most of our conf file, all upstreamed except for
283  75-blacklist-fedora.conf that I'm happily dropping.  Who has
284  Hershey fonts these days...
285- ln upstream'ed 25-unhint-nonlatin.conf from conf.avail in conf.d
286- Add 25-no-bitmap-fedora.conf which is the tiny remaining bit
287  of conf that didn't end up upstream.  Can get rid of it in the
288  future, but not just yet.
289
290* Thu Oct 25 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.91-1
291- Update to 2.4.91.
292- Add /usr/local/share/fonts to default config. (#147004)
293- Don't rebuild docs, to fix multilib conflicts. (#313011)
294- Remove docbook and elinks BuildRequires and stuff as we don't
295  rebuild docs.
296
297* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 2.4.2-5
298- Rebuild for PPC toolchain bug
299- Add BuildRequires: gawk
300
301* Sun Jun 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-4
302- /etc/fonts/conf.d is now owned by filesystem
303
304* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-3
305- Add Liberation fonts to 30-aliases-fedora.conf
306
307* Fri Jan 12 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.2-2
308- Change /usr/share/X11/fonts/OTF to /usr/share/X11/fonts/TTF
309- Resolves: #220809
310
311* Tue Dec  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.2-1
312- Update to 2.4.2
313
314* Wed Oct  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.1-4
315- Fix a multilib upgrade problem (#208151)
316
317* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-3
318- rebuilt for unwind info generation, broken in gcc-4.1.1-21
319
320* Fri Sep 22 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-2
321- Update 30-aliases-fedora.conf to correctly alias MS and StarOffice
322  fonts. (#207460)
323
324* Fri Sep 15 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-1
325- Update to 2.4.1, a public API was dropped from 2.4.0
326- Remove upstreamed patch
327
328* Mon Sep 11 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.0-1
329- Update to 2.4.0
330- Rename/order our configuration stuff to match the new scheme.
331  Breaks expected :-(
332
333* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-3
334- Add missing file.  Previous update didn't go through
335
336* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-2
337- Add fontconfig-2.3.97-ppc64.patch, for ppc64 arch signature
338
339* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-1
340- update to 2.3.97
341- Drop upstreamed patches
342- Regenerate defaultconfig patch
343- Don't touch stamp as it was not ever needed
344
345* Thu Aug 17 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-11
346- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
347
348* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
349- use "%5x" instead of " %4x" to support 64k instead of
350  clamping.  Idea from Behdad.
351
352* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
353- tweak last patch to give a more reasonable page size
354  value if 64k page size is in effect.
355
356* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-8
357- maybe fix buffer overflow (bug 202152).
358
359* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-7
360- Update configs to provide better openoffice/staroffice
361  compatibility (bug 200723)
362
363* Thu Jul 27 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-6
364- Do umask 0022 in post
365- Update configs to reflect addition of new Indic fonts (#200381, #200397)
366
367* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-5
368- Plug a small memory leak
369
370* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1.1
371- rebuild
372
373* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1
374- rebuild
375
376* Fri Jun  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-4
377- Fix the handling of TTF font collections
378
379* Thu May 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-3
380- Apply a patch by David Turner to speed up cache generation
381
382* Wed Apr 26 2006 Bill Nottingham <notting@redhat.com> - 2.3.95-2
383- fix fonts.conf typo
384
385* Wed Apr 26 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-1
386- Update to 2.3.95
387
388* Fri Feb 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.94-1
389- Update to 2.3.94
390
391* Sat Feb 11 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060211-1
392- Newer cvs snapshot
393
394* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060208-1.1
395- bump again for double-long bug on ppc(64)
396
397* Wed Feb  8 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060208-1
398- Newer cvs snapshot
399
400* Tue Feb  7 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060207-1
401- Newer cvs snapshot
402- Drop upstreamed patches, pick up some new ones
403
404* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060131-3.1
405- rebuilt for new gcc4.1 snapshot and glibc changes
406
407* Thu Feb  2 2006 Ray Strode <rstrode@redhat.com> - 2.3.93.cvs20060131-3
408- Move user cache to a subdirectory (bug 160275)
409
410* Thu Feb  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-2
411- Accumulated patches
412
413* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-1
414- Newer cvs snapshot
415
416* Tue Jan 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060124-1
417- Newer cvs snapshot
418
419* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 2.3.93-4
420- apply patch from Tim Mayberry to correct aliasing and disable
421  hinting for the two Chinese font names AR PL ShanHeiSun Uni
422  and AR PL Zenkai Uni
423
424* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> - 2.3.93-3
425- prereq coreutils for mkdir/touch in %%post
426
427* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-2
428- Fix to create /var/cache/fontconfig/stamp in the post install stage.
429
430* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-1
431- New upstream version.
432
433* Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
434- Disable hinting for Lohit Gujarati
435
436* Fri Dec  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
437- Add two new Chinese font names to the default fonts.conf file:
438        AR PL ShanHeiSun Uni
439        AR PL Zenkai Uni
440
441* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
442- rebuilt
443
444* Mon Nov 28 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051129-1
445- Update to a newer cvs snapshot
446
447* Sat Nov 19 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051119-1
448- Update to a newer cvs snapshot
449
450* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 2.3.93-3
451- modular X moved fonts from /usr/X11R6/lib/X11/fonts to
452  /usr/share/X11/fonts, adjust %%configure accordingly and
453  conflict with older font packages
454
455* Wed Nov  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92-2
456- Remove inadvertent rejection of Luxi Mono from 40-blacklist-fonts.conf.
457  Fixes #172437
458
459* Fri Nov  4 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92-1
460- Update to 2.3.92
461
462* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051031-1
463- Update to a newer cvs snapshot
464- Add a patch which should help to understand broken cache problems
465
466* Fri Oct 21 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-2
467- Add new Chinese fonts
468- Fix the 40-blacklist-fonts.conf file to use the documented
469  fonts.conf syntax, and exclude the Hershey fonts by family
470  name.
471
472* Fri Oct 14 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-1
473- Update to the mmap branch of fontconfig
474
475* Fri Jul 22 2005 Kristian H淡gsberg <krh@redhat.com> - 2.3.2-1
476- Update to fontconfig-2.3.2.  Drop
477
478        fontconfig-2.1-slighthint.patch,
479        fontconfig-2.2.3-timestamp.patch,
480        fontconfig-2.2.3-names.patch,
481        fontconfig-2.2.3-ta-pa-orth.patch, and
482        fontconfig-2.2.3-timestamp.patch,
483
484  as they are now merged upstream.
485
486- Fold fontconfig-2.2.3-add-sazanami.patch into
487  fontconfig-2.3.2-defaultconfig.patch and split rules to disable CJK
488  hinting out into /etc/fonts/conf.d/50-no-hint-fonts.conf.
489
490- Drop fontconfig-0.0.1.020826.1330-blacklist.patch and use the new
491  rejectfont directive to reject those fonts in 40-blacklist-fonts.conf.
492
493- Add fontconfig-2.3.2-only-parse-conf-files.patch to avoid parsing
494  .rpmsave files.
495
496- Renable s390 documentation now that #97079 has been fixed and add
497  BuildRequires: for docbook-utils and docbook-utils-pdf.
498
499- Drop code to iconv and custom install man pages, upstream does the
500  right thing now.
501
502- Add workaround from hell to make elinks cooperate so we can build
503  txt documentation.
504
505* Tue Apr 19 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-13
506- Add another font family name Sazanami Gothic/Mincho (#148748)
507
508* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-12
509- Rebuild
510
511* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-11
512- Rebuild
513
514* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-10
515- Rebuild
516
517* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-9
518- Disable docs for s390 for now
519
520* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-8
521- Rebuild
522
523* Wed Dec  1 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-6
524- Sleep a second before the exit of fc-cache to fix problems with fast
525  serial installs of fonts (#140335)
526- Turn off hinting for Lohit Hindi/Bengali/Punjabi (#139816)
527
528* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-5
529- Add Lohit fonts for Indic languages (#134492)
530- Add Punjabi converage, fix Tamil coverage
531
532* Wed Sep 22 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-4
533- Update fonts-hebrew names to include CLM suffix
534
535* Thu Sep  2 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-3
536- Backport code from head branch of fontconfig CVS to parse names
537  for postscript fonts (fixes #127500, J. J. Ramsey)
538- Own /usr/share/fonts (#110956, David K. Levine)
539- Add KacstQura to serif/sans-serif/monospace aliases (#101182)
540
541* Mon Aug 16 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-2
542- Don't run fc-cache if the binary isn't there (#128072, tracked
543  down by Jay Turner)
544
545* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
546- Upgrade to 2.2.3
547- Convert man pages to UTF-8 (#108730, Peter van Egdom)
548- Renable docs on s390
549
550* Mon Jul 26 2004 Owen Taylor <otaylor@redhat.com> - 2.2.1-12
551- Rebuild for RHEL
552- Back freetype required version down to 2.1.4
553
554* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
555- rebuilt
556
557* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
558- Require recent freetype (#109592, Peter Oliver)
559- Remove fonts.conf timestamp to fix multiarch conflict (#118182)
560- Disable hinting for Mukti Narrow (#120915, Sayamindu Dasgupta)
561
562* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
563- Rebuild
564
565* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.0
566- Add Albany/Cumberland/Thorndale as fallbacks for Microsoft core fonts and
567  as non-preferred alternatives for Sans/Serif/Monospace
568- Fix FreeType includes for recent FreeType
569
570* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
571- rebuilt
572
573* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
574- rebuilt
575
576* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
577- Should have been passing --with-add-fonts, not --with-add-dirs to
578  configure ... caused wrong version of Luxi to be used. (#100862)
579
580* Fri Sep 19 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-5.0
581- Tweak fonts.conf to get right hinting for CJK fonts (#97337)
582
583* Tue Jun 17 2003 Bill Nottingham <notting@redhat.com> 2.2.1-3
584- handle null config->cache correctly
585
586* Thu Jun 12 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
587- Update default config to include Hebrew fonts (#90501, Dov Grobgeld)
588
589* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
590- As a workaround disable doc builds on s390
591
592* Mon Jun  9 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-1
593- Version 2.2.1
594
595* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
596- rebuilt
597
598* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
599- debuginfo rebuild
600
601* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com> 2.1-8
602- Fix segfault in fc-cache from .dircache patch
603
604* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com>
605- Back out patch that wrote fonts.conf entries that crash RH-8.0
606  gnome-terminal, go with patch from fontconfig CVS instead.
607  (#84863)
608
609* Tue Feb 11 2003 Owen Taylor <otaylor@redhat.com>
610- Move fontconfig man page to main package, since it contains non-devel
611  information (#76189)
612- Look in the OTF subdirectory of /usr/X11R6/lib/fonts as well
613  so we find Syriac fonts (#82627)
614
615* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 2.1-5
616- modified fontconfig-0.0.1.020626.1517-fontdir.patch to hard code
617  /usr/X11R6/lib/X11/fonts instead of using $(X_FONT_DIR).  This is
618  because on lib64 machines, fonts are not in /usr/X11R6/lib64/....
619
620* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
621- rebuilt
622
623* Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com>
624- Try a different tack when fixing cache problem
625
626* Tue Jan 14 2003 Owen Taylor <otaylor@redhat.com>
627- Try to fix bug where empty cache entries would be found in
628  ~/.fonts.cache-1 during scanning (#81335)
629
630* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 2.1-1
631- Updated to version 2.1
632- Updated slighthint patch to fontconfig-2.1-slighthint.patch
633- Updated freetype version required to 2.1.2-7
634
635* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
636- Version 2.0
637- Correct capitalization/spacing for ZYSong18030 name (#73272)
638
639* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
640- Blacklist fonts from ghostscript-fonts that don't render correctly
641
642* Mon Aug 26 2002 Owen Taylor <otaylor@redhat.com>
643- Upgrade to fcpackage rc3
644- Fix bug in comparisons for xx_XX language tags
645- Compensate for a minor config file change in rc3
646
647* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
648- Add an explicit PreReq for freetype
649- Move fonts we don't ship to the end of the fonts.conf aliases so
650  installing them doesn't change the look.
651
652* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
653- Memory leak fix when parsing config files
654- Set rh_prefer_bitmaps for .ja fonts to key off of in Xft
655- Fix some groff warnings for fontconfig.man (#72138)
656
657* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
658- Try once more to get the right default Sans-serif font :-(
659- Switch the Sans/Monospace aliases for Korean to Gulim, not Dotum
660
661* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
662- Fix %%post
663
664* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
665- Fix lost Luxi Sans default
666
667* Mon Aug 12 2002 Owen Taylor <otaylor@redhat.com>
668- Upgrade to rc2
669- Turn off hinting for all CJK fonts
670- Fix typo in %%post
671- Remove the custom language tag stuff in favor of Keith's standard
672  solution.
673
674* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
675- Prefer Luxi Sans to Nimbus Sans again
676
677* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
678- Add FC_HINT_STYLE to FcBaseObjectTypes
679- Switch Chinese fonts to always using Sung-ti / Ming-ti, and never Kai-ti
680- Add ZYSong18030 to aliases (#68428)
681
682* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
683- Fix a typo in the langtag patch (caught by Erik van der Poel)
684
685* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
686- Add FC_HINT_STYLE tag
687
688* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
689- New upstream version, with fix for problems with
690  ghostscript-fonts (Fonts don't work for Qt+CJK,
691  etc.)
692
693* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
694- New upstream version, fixing locale problem
695
696* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
697- Add a hack where we set the "language" fontconfig property based on the locale, then
698  we conditionalize base on that in the fonts.conf file.
699
700* Sun Jun 23 2002 Owen Taylor <otaylor@redhat.com>
701- New upstream version
702
703* Tue Jun 18 2002 Owen Taylor <otaylor@redhat.com>
704- Fix crash from FcObjectSetAdd
705
706* Tue Jun 11 2002 Owen Taylor <otaylor@redhat.com>
707- make fonts.conf %%config, not %%config(noreplace)
708- Another try at the CJK aliases
709- Add some CJK fonts to the config
710- Prefer Luxi Mono to Nimbus Mono
711
712* Mon Jun 10 2002 Owen Taylor <otaylor@redhat.com>
713- New upstream version
714- Fix matching for bitmap fonts
715
716* Mon Jun  3 2002 Owen Taylor <otaylor@redhat.com>
717- New version, new upstream mega-tarball
718
719* Tue May 28 2002 Owen Taylor <otaylor@redhat.com>
720- Fix problem with FcConfigSort
721
722* Fri May 24 2002 Owen Taylor <otaylor@redhat.com>
723- Initial specfile
724
Note: See TracBrowser for help on using the repository browser.