source: projects/specs/trunk/f/fontconfig/fontconfig-vl.spec @ 11323

Revision 11323, 24.2 KB checked in by tomop, 6 years ago (diff)

fontconfig-2.12.6-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4%define freetype_version 2.8.1
5
6Summary: Font configuration and customization library
7Summary(ja): フォント設定/カスタマイズライブラリ
8Name: fontconfig
9Version: 2.12.6
10Release: 1%{?_dist_release}
11License: MIT
12Group: System Environment/Libraries
13URL: http://fontconfig.org/
14
15Source: http://fontconfig.org/release/fontconfig-%{version}.tar.bz2
16Source10: 70-prefer-ja-font.conf
17Source11: 59-morisawa-font-alias.conf
18
19# from fedora
20# https://bugzilla.redhat.com/show_bug.cgi?id=140335
21Patch0:         fontconfig-2.8.0-sleep-less.patch
22
23# vine
24Patch4: fontconfig-2.3.2-subst-ja-font.patch
25Patch10: fontconfig-2.6.0-vine.patch
26
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: gawk
30BuildRequires: expat-devel
31BuildRequires: freetype2-devel >= %{freetype_version}
32BuildRequires: perl
33#BuildRequires: itstool
34#BuildRequires: libuuid-devel
35BuildRequires: gperf
36
37Requires(pre): freetype2 >= %{freetype_version}, coreutils
38Conflicts: XOrg-libs <= 6.9.0
39Obsoletes: XOrg-libs <= 6.9.0
40Conflicts: XOrg-font-utils <= 6.9.0
41Obsoletes: XOrg-font-utils <= 6.9.0
42
43Vendor: Project Vine
44Distribution: Vine Linux
45
46%description
47Fontconfig is designed to locate fonts within the
48system and select them according to requirements specified by
49applications.
50
51%description -l ja
52Fontconfig は、システム内のフォントを把握し、アプリケーション
53が指定した要求に応じてそれらを選択するためのライブラリです。
54
55%package devel
56Summary: Development files for %{name}
57Summary(ja): Fontconfig の開発ファイル
58Group: Development/Libraries
59Requires: fontconfig = %{version}-%{release}
60Requires: freetype2-devel >= %{freetype_version}
61Requires: expat-devel
62Requires: pkgconfig
63Conflicts: XOrg-devel <= 6.9.0
64Obsoletes: XOrg-devel <= 6.9.0
65
66%description devel
67The fontconfig-devel package includes the header files,
68and developer docs for the fontconfig package.
69
70%description -l ja devel
71fontconfig-devel パッケージには fontconfig を使ったソフトウエア
72を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
73ントが含まれています。
74
75# compat32
76%package -n compat32-%{name}
77Summary: Font configuration and customization library
78Summary(ja): フォント設定/カスタマイズライブラリ
79Group: System Environment/Libraries
80
81%description -n compat32-%{name}
82Fontconfig is designed to locate fonts within the
83system and select them according to requirements specified by
84applications.
85
86%description -l ja -n compat32-%{name}
87Fontconfig は、システム内のフォントを把握し、アプリケーション
88が指定した要求に応じてそれらを選択するためのライブラリです。
89
90%package -n compat32-%{name}-devel
91Summary: Font configuration and customization library
92Group: Development/Libraries
93Requires: compat32-%{name} = %{version}-%{release}
94Requires: %{name}-devel = %{version}-%{release}
95Requires: compat32-freetype2-devel >= %{freetype_version}
96Requires: compat32-expat-devel
97
98%description -n compat32-%{name}-devel
99The fontconfig-devel package includes the header files,
100and developer docs for the fontconfig package.
101
102%description -l ja -n compat32-%{name}-devel
103fontconfig-devel パッケージには fontconfig を使ったソフトウエア
104を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
105ントが含まれています。
106
107%prep
108%setup -q
109
110%patch0 -p1 -b .sleep-less
111
112%patch4 -p1 -b .subst-ja-font
113%patch10 -p1 -b .vine
114
115%build
116
117# We don't want to rebuild the docs, but we want to install the included ones.
118export HASDOCBOOK=no
119
120%configure \
121  --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
122
123%__make %{?_smp_mflags}
124
125%install
126rm -rf $RPM_BUILD_ROOT
127
128%__make install DESTDIR=$RPM_BUILD_ROOT
129
130ln -s %{_datadir}/fontconfig/conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
131install -m664 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_datadir}/fontconfig/conf.avail/
132for i in 70-prefer-ja-font.conf 59-morisawa-font-alias.conf
133do
134  ln -sf %{_datadir}/fontconfig/conf.avail/$i $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
135done
136
137# move installed doc files back to build directory to package themm
138# in the right place
139mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
140rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
141
142# All font packages depend on this package, so we create
143# and own /usr/share/fonts
144mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
145
146# Remove unpackaged files
147find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
148find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%post
154/sbin/ldconfig
155umask 0022
156# Remove stale caches
157rm -f %{_localstatedir}/cache/fontconfig/????????????????????????????????-*.cache-2
158HOME=/root /usr/bin/fc-cache -f -s >& /dev/null
159
160
161%postun -p /sbin/ldconfig
162
163%post -n compat32-%{name} -p /sbin/ldconfig
164
165%postun -n compat32-%{name} -p /sbin/ldconfig
166
167%files
168%defattr(-, root, root)
169%doc README AUTHORS COPYING
170%doc fontconfig-user.txt fontconfig-user.html
171%doc %{_sysconfdir}/fonts/conf.d/README
172%{_libdir}/libfontconfig.so.*
173%{_bindir}/fc-cache
174#%{_bindir}/fc-conflist
175%{_bindir}/fc-list
176%{_bindir}/fc-match
177%{_bindir}/fc-cat
178%{_bindir}/fc-query
179%{_bindir}/fc-scan
180%{_bindir}/fc-pattern
181%{_bindir}/fc-validate
182%dir %{_datadir}/fonts
183%{_datadir}/%{name}
184%{_datadir}/xml/%{name}/fonts.dtd
185%config %{_sysconfdir}/fonts/fonts.conf
186%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
187%dir %{_localstatedir}/cache/fontconfig
188
189%{_mandir}/man1/*
190%{_mandir}/man5/*
191
192%files devel
193%defattr(-, root, root)
194%doc fontconfig-devel.txt fontconfig-devel
195%{_libdir}/libfontconfig.so
196%{_libdir}/pkgconfig/*
197%{_includedir}/fontconfig
198%{_mandir}/man3/*
199
200# compat32
201%if %{build_compat32}
202%files -n compat32-%{name}
203%defattr(-, root, root)
204%{_libdir}/libfontconfig.so.*
205
206%files -n compat32-%{name}-devel
207%defattr(-, root, root)
208%{_libdir}/libfontconfig.so
209%endif
210
211%changelog
212* Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.12.6-1
213- new upstream release.
214- added BR:gperf.
215
216* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.11.1-1
217- new upstream release
218
219* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.11.0-1
220- new upstream release
221- remove Patch1,2
222
223* Tue May 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.92-2
224- install/enable 70-prefer-ja-font.conf and 59-morisawa-font-alias.conf (again)
225- enable 25-unhint-nonlatin.conf (again)
226- add patch0-2 from fedora package
227  - patch0: less sleep in fc-cache
228  - patch1: fix font matching issue
229  - patch2: fix web font issue in firefox
230
231* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.92-1
232- new upstream release
233- remove Patch1 (fontconfig-2.2.1-AppleRoman-DynaFont.patch)
234
235* Fri Dec 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
236- rebuild with freetype2-2.4.8
237- add Requires: expat-devel (-devel package)
238
239* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.0-2
240- build with rpm-4.8.1-1 for pkg-config file
241
242* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
243- new upstream release
244- remove static libs
245
246* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-3
247- update %%post
248
249* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-2
250- add translated summary and description
251
252* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-1
253- new upstream release
254
255* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-2
256- add fc-query and fc-scan to %%files
257
258* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
259- new upstream release
260- update 59-morisawa-font-alias.conf
261
262* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.0-3
263- added compat32 package for x86_64 arch support
264
265* Tue Jan 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-2
266- update 59-morisawa-font-alias.conf
267  - add FutoMin, FutoGo, Jun alias
268
269* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-1
270- new upstream release
271- rename 10-prefer-ja-font.conf to 70-prefer-ja-font.conf
272
273* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-3
274- add 10-prefer-ja-font.conf to prefer Japanese fonts.
275- add 59-morisawa-font-alias.conf
276  - bind Ryumin to serif and GothicBBB to sans-serif
277
278* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
279- add legacy font path for compatibility
280
281* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
282- add Conflits/Obsoletes: XOrg-font-utils <= 6.9.0
283
284* Mon Dec 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
285- initial build for Vine Linux
286  - splitted from XOrg package.
287
288* Tue Nov 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.5.0-1
289- Update to 2.5.0.
290
291* Tue Nov 06 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.92-1
292- Update to 2.4.92.
293- Mark /etc/fonts/conf.d/* as config(noreplace).
294- Remove most of our conf file, all upstreamed except for
295  75-blacklist-fedora.conf that I'm happily dropping.  Who has
296  Hershey fonts these days...
297- ln upstream'ed 25-unhint-nonlatin.conf from conf.avail in conf.d
298- Add 25-no-bitmap-fedora.conf which is the tiny remaining bit
299  of conf that didn't end up upstream.  Can get rid of it in the
300  future, but not just yet.
301
302* Thu Oct 25 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.91-1
303- Update to 2.4.91.
304- Add /usr/local/share/fonts to default config. (#147004)
305- Don't rebuild docs, to fix multilib conflicts. (#313011)
306- Remove docbook and elinks BuildRequires and stuff as we don't
307  rebuild docs.
308
309* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 2.4.2-5
310- Rebuild for PPC toolchain bug
311- Add BuildRequires: gawk
312
313* Sun Jun 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-4
314- /etc/fonts/conf.d is now owned by filesystem
315
316* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-3
317- Add Liberation fonts to 30-aliases-fedora.conf
318
319* Fri Jan 12 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.2-2
320- Change /usr/share/X11/fonts/OTF to /usr/share/X11/fonts/TTF
321- Resolves: #220809
322
323* Tue Dec  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.2-1
324- Update to 2.4.2
325
326* Wed Oct  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.1-4
327- Fix a multilib upgrade problem (#208151)
328
329* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-3
330- rebuilt for unwind info generation, broken in gcc-4.1.1-21
331
332* Fri Sep 22 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-2
333- Update 30-aliases-fedora.conf to correctly alias MS and StarOffice
334  fonts. (#207460)
335
336* Fri Sep 15 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-1
337- Update to 2.4.1, a public API was dropped from 2.4.0
338- Remove upstreamed patch
339
340* Mon Sep 11 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.0-1
341- Update to 2.4.0
342- Rename/order our configuration stuff to match the new scheme.
343  Breaks expected :-(
344
345* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-3
346- Add missing file.  Previous update didn't go through
347
348* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-2
349- Add fontconfig-2.3.97-ppc64.patch, for ppc64 arch signature
350
351* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-1
352- update to 2.3.97
353- Drop upstreamed patches
354- Regenerate defaultconfig patch
355- Don't touch stamp as it was not ever needed
356
357* Thu Aug 17 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-11
358- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
359
360* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
361- use "%5x" instead of " %4x" to support 64k instead of
362  clamping.  Idea from Behdad.
363
364* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
365- tweak last patch to give a more reasonable page size
366  value if 64k page size is in effect.
367
368* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-8
369- maybe fix buffer overflow (bug 202152).
370
371* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-7
372- Update configs to provide better openoffice/staroffice
373  compatibility (bug 200723)
374
375* Thu Jul 27 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-6
376- Do umask 0022 in post
377- Update configs to reflect addition of new Indic fonts (#200381, #200397)
378
379* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-5
380- Plug a small memory leak
381
382* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1.1
383- rebuild
384
385* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1
386- rebuild
387
388* Fri Jun  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-4
389- Fix the handling of TTF font collections
390
391* Thu May 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-3
392- Apply a patch by David Turner to speed up cache generation
393
394* Wed Apr 26 2006 Bill Nottingham <notting@redhat.com> - 2.3.95-2
395- fix fonts.conf typo
396
397* Wed Apr 26 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-1
398- Update to 2.3.95
399
400* Fri Feb 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.94-1
401- Update to 2.3.94
402
403* Sat Feb 11 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060211-1
404- Newer cvs snapshot
405
406* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060208-1.1
407- bump again for double-long bug on ppc(64)
408
409* Wed Feb  8 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060208-1
410- Newer cvs snapshot
411
412* Tue Feb  7 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060207-1
413- Newer cvs snapshot
414- Drop upstreamed patches, pick up some new ones
415
416* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060131-3.1
417- rebuilt for new gcc4.1 snapshot and glibc changes
418
419* Thu Feb  2 2006 Ray Strode <rstrode@redhat.com> - 2.3.93.cvs20060131-3
420- Move user cache to a subdirectory (bug 160275)
421
422* Thu Feb  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-2
423- Accumulated patches
424
425* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-1
426- Newer cvs snapshot
427
428* Tue Jan 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060124-1
429- Newer cvs snapshot
430
431* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 2.3.93-4
432- apply patch from Tim Mayberry to correct aliasing and disable
433  hinting for the two Chinese font names AR PL ShanHeiSun Uni
434  and AR PL Zenkai Uni
435
436* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> - 2.3.93-3
437- prereq coreutils for mkdir/touch in %%post
438
439* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-2
440- Fix to create /var/cache/fontconfig/stamp in the post install stage.
441
442* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-1
443- New upstream version.
444
445* Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
446- Disable hinting for Lohit Gujarati
447
448* Fri Dec  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
449- Add two new Chinese font names to the default fonts.conf file:
450        AR PL ShanHeiSun Uni
451        AR PL Zenkai Uni
452
453* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
454- rebuilt
455
456* Mon Nov 28 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051129-1
457- Update to a newer cvs snapshot
458
459* Sat Nov 19 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051119-1
460- Update to a newer cvs snapshot
461
462* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 2.3.93-3
463- modular X moved fonts from /usr/X11R6/lib/X11/fonts to
464  /usr/share/X11/fonts, adjust %%configure accordingly and
465  conflict with older font packages
466
467* Wed Nov  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92-2
468- Remove inadvertent rejection of Luxi Mono from 40-blacklist-fonts.conf.
469  Fixes #172437
470
471* Fri Nov  4 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92-1
472- Update to 2.3.92
473
474* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051031-1
475- Update to a newer cvs snapshot
476- Add a patch which should help to understand broken cache problems
477
478* Fri Oct 21 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-2
479- Add new Chinese fonts
480- Fix the 40-blacklist-fonts.conf file to use the documented
481  fonts.conf syntax, and exclude the Hershey fonts by family
482  name.
483
484* Fri Oct 14 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-1
485- Update to the mmap branch of fontconfig
486
487* Fri Jul 22 2005 Kristian H淡gsberg <krh@redhat.com> - 2.3.2-1
488- Update to fontconfig-2.3.2.  Drop
489
490        fontconfig-2.1-slighthint.patch,
491        fontconfig-2.2.3-timestamp.patch,
492        fontconfig-2.2.3-names.patch,
493        fontconfig-2.2.3-ta-pa-orth.patch, and
494        fontconfig-2.2.3-timestamp.patch,
495
496  as they are now merged upstream.
497
498- Fold fontconfig-2.2.3-add-sazanami.patch into
499  fontconfig-2.3.2-defaultconfig.patch and split rules to disable CJK
500  hinting out into /etc/fonts/conf.d/50-no-hint-fonts.conf.
501
502- Drop fontconfig-0.0.1.020826.1330-blacklist.patch and use the new
503  rejectfont directive to reject those fonts in 40-blacklist-fonts.conf.
504
505- Add fontconfig-2.3.2-only-parse-conf-files.patch to avoid parsing
506  .rpmsave files.
507
508- Renable s390 documentation now that #97079 has been fixed and add
509  BuildRequires: for docbook-utils and docbook-utils-pdf.
510
511- Drop code to iconv and custom install man pages, upstream does the
512  right thing now.
513
514- Add workaround from hell to make elinks cooperate so we can build
515  txt documentation.
516
517* Tue Apr 19 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-13
518- Add another font family name Sazanami Gothic/Mincho (#148748)
519
520* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-12
521- Rebuild
522
523* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-11
524- Rebuild
525
526* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-10
527- Rebuild
528
529* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-9
530- Disable docs for s390 for now
531
532* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-8
533- Rebuild
534
535* Wed Dec  1 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-6
536- Sleep a second before the exit of fc-cache to fix problems with fast
537  serial installs of fonts (#140335)
538- Turn off hinting for Lohit Hindi/Bengali/Punjabi (#139816)
539
540* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-5
541- Add Lohit fonts for Indic languages (#134492)
542- Add Punjabi converage, fix Tamil coverage
543
544* Wed Sep 22 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-4
545- Update fonts-hebrew names to include CLM suffix
546
547* Thu Sep  2 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-3
548- Backport code from head branch of fontconfig CVS to parse names
549  for postscript fonts (fixes #127500, J. J. Ramsey)
550- Own /usr/share/fonts (#110956, David K. Levine)
551- Add KacstQura to serif/sans-serif/monospace aliases (#101182)
552
553* Mon Aug 16 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-2
554- Don't run fc-cache if the binary isn't there (#128072, tracked
555  down by Jay Turner)
556
557* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
558- Upgrade to 2.2.3
559- Convert man pages to UTF-8 (#108730, Peter van Egdom)
560- Renable docs on s390
561
562* Mon Jul 26 2004 Owen Taylor <otaylor@redhat.com> - 2.2.1-12
563- Rebuild for RHEL
564- Back freetype required version down to 2.1.4
565
566* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
567- rebuilt
568
569* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
570- Require recent freetype (#109592, Peter Oliver)
571- Remove fonts.conf timestamp to fix multiarch conflict (#118182)
572- Disable hinting for Mukti Narrow (#120915, Sayamindu Dasgupta)
573
574* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
575- Rebuild
576
577* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.0
578- Add Albany/Cumberland/Thorndale as fallbacks for Microsoft core fonts and
579  as non-preferred alternatives for Sans/Serif/Monospace
580- Fix FreeType includes for recent FreeType
581
582* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
583- rebuilt
584
585* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
586- rebuilt
587
588* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
589- Should have been passing --with-add-fonts, not --with-add-dirs to
590  configure ... caused wrong version of Luxi to be used. (#100862)
591
592* Fri Sep 19 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-5.0
593- Tweak fonts.conf to get right hinting for CJK fonts (#97337)
594
595* Tue Jun 17 2003 Bill Nottingham <notting@redhat.com> 2.2.1-3
596- handle null config->cache correctly
597
598* Thu Jun 12 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
599- Update default config to include Hebrew fonts (#90501, Dov Grobgeld)
600
601* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
602- As a workaround disable doc builds on s390
603
604* Mon Jun  9 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-1
605- Version 2.2.1
606
607* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
608- rebuilt
609
610* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
611- debuginfo rebuild
612
613* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com> 2.1-8
614- Fix segfault in fc-cache from .dircache patch
615
616* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com>
617- Back out patch that wrote fonts.conf entries that crash RH-8.0
618  gnome-terminal, go with patch from fontconfig CVS instead.
619  (#84863)
620
621* Tue Feb 11 2003 Owen Taylor <otaylor@redhat.com>
622- Move fontconfig man page to main package, since it contains non-devel
623  information (#76189)
624- Look in the OTF subdirectory of /usr/X11R6/lib/fonts as well
625  so we find Syriac fonts (#82627)
626
627* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 2.1-5
628- modified fontconfig-0.0.1.020626.1517-fontdir.patch to hard code
629  /usr/X11R6/lib/X11/fonts instead of using $(X_FONT_DIR).  This is
630  because on lib64 machines, fonts are not in /usr/X11R6/lib64/....
631
632* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
633- rebuilt
634
635* Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com>
636- Try a different tack when fixing cache problem
637
638* Tue Jan 14 2003 Owen Taylor <otaylor@redhat.com>
639- Try to fix bug where empty cache entries would be found in
640  ~/.fonts.cache-1 during scanning (#81335)
641
642* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 2.1-1
643- Updated to version 2.1
644- Updated slighthint patch to fontconfig-2.1-slighthint.patch
645- Updated freetype version required to 2.1.2-7
646
647* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
648- Version 2.0
649- Correct capitalization/spacing for ZYSong18030 name (#73272)
650
651* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
652- Blacklist fonts from ghostscript-fonts that don't render correctly
653
654* Mon Aug 26 2002 Owen Taylor <otaylor@redhat.com>
655- Upgrade to fcpackage rc3
656- Fix bug in comparisons for xx_XX language tags
657- Compensate for a minor config file change in rc3
658
659* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
660- Add an explicit PreReq for freetype
661- Move fonts we don't ship to the end of the fonts.conf aliases so
662  installing them doesn't change the look.
663
664* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
665- Memory leak fix when parsing config files
666- Set rh_prefer_bitmaps for .ja fonts to key off of in Xft
667- Fix some groff warnings for fontconfig.man (#72138)
668
669* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
670- Try once more to get the right default Sans-serif font :-(
671- Switch the Sans/Monospace aliases for Korean to Gulim, not Dotum
672
673* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
674- Fix %%post
675
676* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
677- Fix lost Luxi Sans default
678
679* Mon Aug 12 2002 Owen Taylor <otaylor@redhat.com>
680- Upgrade to rc2
681- Turn off hinting for all CJK fonts
682- Fix typo in %%post
683- Remove the custom language tag stuff in favor of Keith's standard
684  solution.
685
686* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
687- Prefer Luxi Sans to Nimbus Sans again
688
689* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
690- Add FC_HINT_STYLE to FcBaseObjectTypes
691- Switch Chinese fonts to always using Sung-ti / Ming-ti, and never Kai-ti
692- Add ZYSong18030 to aliases (#68428)
693
694* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
695- Fix a typo in the langtag patch (caught by Erik van der Poel)
696
697* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
698- Add FC_HINT_STYLE tag
699
700* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
701- New upstream version, with fix for problems with
702  ghostscript-fonts (Fonts don't work for Qt+CJK,
703  etc.)
704
705* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
706- New upstream version, fixing locale problem
707
708* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
709- Add a hack where we set the "language" fontconfig property based on the locale, then
710  we conditionalize base on that in the fonts.conf file.
711
712* Sun Jun 23 2002 Owen Taylor <otaylor@redhat.com>
713- New upstream version
714
715* Tue Jun 18 2002 Owen Taylor <otaylor@redhat.com>
716- Fix crash from FcObjectSetAdd
717
718* Tue Jun 11 2002 Owen Taylor <otaylor@redhat.com>
719- make fonts.conf %%config, not %%config(noreplace)
720- Another try at the CJK aliases
721- Add some CJK fonts to the config
722- Prefer Luxi Mono to Nimbus Mono
723
724* Mon Jun 10 2002 Owen Taylor <otaylor@redhat.com>
725- New upstream version
726- Fix matching for bitmap fonts
727
728* Mon Jun  3 2002 Owen Taylor <otaylor@redhat.com>
729- New version, new upstream mega-tarball
730
731* Tue May 28 2002 Owen Taylor <otaylor@redhat.com>
732- Fix problem with FcConfigSort
733
734* Fri May 24 2002 Owen Taylor <otaylor@redhat.com>
735- Initial specfile
736
Note: See TracBrowser for help on using the repository browser.