source: projects/specs/trunk/f/fmt/fmt-vl.spec @ 12510

Revision 12510, 7.0 KB checked in by tomop, 3 years ago (diff)

updated 11 packages

Field3D-1.7.3-2

ImageMagick?-6.9.11.48-1

OpenEXR-2.5.3-1

OpenImageIO-2.2.9.0-1

babl-0.1.82-1

fmt-7.1.3-2

gegl04-0.4.26-2

gimp-2.10.22-1

hdf5-1.12.0-1

opencv-4.5.0-1

robin-map-0.6.3-4

Line 
1%undefine __cmake_in_source_build
2%bcond_with doc
3
4Name:           fmt
5Summary:        Small, safe and fast formatting library for C++
6Version:        7.1.3
7Release:        2%{?_dist_release}
8Group:          system
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12
13License:        BSD
14URL:            https://github.com/fmtlib/%{name}
15Source0:        %{url}/archive/%{version}.tar.gz
16# See https://github.com/fmtlib/fmt/issues/443 and https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/LVKYLDLJVWAVJE4MQVKDO6PYZRD5MCP6/
17Patch1:         doc-build-removed-all-pip-internet-stuff.patch
18Patch3:         doc-build-do-not-create-virtual-environment.patch
19Patch4:         doc-_templates-layout-stripped-Google-Analytics.patch
20Patch5:         doc-_templates-layout-stripped-download-links.patch
21Patch6:         doc-index-removed-GitHub-iframe.patch
22Patch7:         doc-build-use-sphinx-build-3.patch
23
24BuildRequires:  gcc
25BuildRequires:  gcc-c++
26BuildRequires:  ninja
27BuildRequires:  cmake
28%if %{with doc}
29BuildRequires:  doxygen
30BuildRequires:  nodejs
31BuildRequires:  python3-sphinx
32BuildRequires:  python3-breathe
33%else
34Provides:       %{name}-doc = %{?epoch:%{epoch}:}%{version}-%{release}
35Obsoletes:      %{name}-doc < %{?epoch:%{epoch}:}%{version}-%{release}
36%endif
37
38# This package replaces the old name of cppformat
39Provides:       cppformat = %{?epoch:%{epoch}:}%{version}-%{release}
40Obsoletes:      cppformat < %{?epoch:%{epoch}:}%{version}-%{release}
41
42%description
43C++ Format is an open-source formatting library for C++. It can be used as a
44safe alternative to printf or as a fast alternative to IOStreams.
45
46
47%package        devel
48Summary:        Development files for %{name}
49Group:          programming
50Requires:       %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
51
52# This package replaces the old name of cppformat
53Provides:       cppformat-devel = %{?epoch:%{epoch}:}%{version}-%{release}
54Obsoletes:      cppformat-devel < %{?epoch:%{epoch}:}%{version}-%{release}
55
56%description    devel
57This package contains the header file for using %{name}.
58
59
60%if %{with doc}
61%package        doc
62Summary:        Documentation files for %{name}
63Group:          documentation
64License:        Python
65BuildArch:      noarch
66
67# This package replaces the old name of cppformat
68Provides:       cppformat-doc = %{?epoch:%{epoch}:}%{version}-%{release}
69Obsoletes:      cppformat-doc < %{?epoch:%{epoch}:}%{version}-%{release}
70
71%description    doc
72This package contains documentation for developer documentation for %{name}.
73%endif
74
75
76%debug_package
77
78
79%prep
80%autosetup -p1
81
82%if %{with doc}
83# Remove --clean-css since that plugin isn't available
84sed -i "s/'--clean-css',//" doc/build.py
85%endif
86
87
88%build
89%cmake                                        \
90    -G Ninja                                  \
91    -DCMAKE_BUILD_TYPE=RelWithDebInfo         \
92    -DCMAKE_POSITION_INDEPENDENT_CODE=ON      \
93    -DFMT_CMAKE_DIR=%{_datadir}/cmake/%{name} \
94    -DFMT_LIB_DIR=%{_libdir}
95
96%__cmake --build . \
97%if %{with doc}
98    --target doc \
99%endif
100    --target all
101
102%if %{with doc}
103# Remove temporary build products
104rm -rf %{_vpath_builddir}/doc/html/{.buildinfo,.doctrees,objects.inv}
105%endif
106
107
108%install
109DESTDIR="%{buildroot}" %__cmake --install .
110 
111
112#%check
113#%ctest
114
115
116%files
117%license LICENSE.rst
118%doc ChangeLog.rst README.rst
119%{_libdir}/lib%{name}.so.7*
120
121%files devel
122%{_includedir}/%{name}
123%{_libdir}/lib%{name}.so
124%{_datadir}/cmake/%{name}
125%{_libdir}/pkgconfig/%{name}.pc
126
127%if %{with doc}
128%files doc
129%doc %{_datadir}/doc/%{name}
130%license doc/python-license.txt
131%endif
132
133
134%changelog
135* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.1.3-2
136- initial build for Vine Linux.
137
138* Sun Nov 29 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.1.3-1
139- Updated to version 7.1.3.
140
141* Tue Nov 10 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.1.2-1
142- Updated to version 7.1.2.
143
144* Sat Aug 08 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.3-1
145- Updated to version 7.0.3.
146
147* Wed Jul 29 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.2-1
148- Updated to version 7.0.2.
149
150* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.1-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
152
153* Wed Jul 08 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.1-1
154- Updated to version 7.0.1.
155
156* Sat May 09 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 6.2.1-1
157- Updated to version 6.2.1.
158
159* Thu Apr 30 2020 Kefu Chai <tchaikov@gmail.com> - 6.2.0-2
160- Incorporate patch from upstream to address https://github.com/fmtlib/fmt/issues/1631
161
162* Mon Apr 06 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 6.2.0-1
163- Updated to version 6.2.0.
164
165* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.2-2
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
167
168* Wed Dec 18 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 6.1.2-1
169- Updated to version 6.1.2.
170- Recreated all documentation patches.
171- SPEC file cleanup.
172
173* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.0-2
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
175
176* Mon Jun 10 2019 Jan Staněk <jstanek@redhat.com> - 5.3.0-1
177- Update to 5.3.0
178- Recreate documentation build patches
179- Package new pkg-config files
180
181* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-2
182- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
183
184* Thu Oct 11 2018 Kefu Chai <tchaikov@gmail.com> - 5.2.1-1
185- Update to 5.2.1
186- Build using python3 packages on fedora
187- Remove links in document accessing network
188- Package ChangeLog.rst and README.rst
189- Drop fmt-static package
190
191* Fri Aug 31 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.0.2-7
192- Fix python2 issue for doc
193
194* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-6
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
196
197* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-5
198- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
199
200* Wed Aug 09 2017 Dave Johansen <davejohansen@gmail.com> - 3.0.2-4
201- Patch for Test 8 segfault
202
203* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-3
204- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
205
206* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
207- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
208
209* Sat Jun 24 2017 Dave Johansen <davejohansen@gmail.com> - 3.0.2-1
210- Upstream release
211
212* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1-3
213- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
214
215* Tue Dec 27 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.1-2
216- Build documentation
217
218* Fri Nov 25 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.1-1
219- Upstream release
220
221* Tue Nov 15 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.0-2
222- Fix expected unqualified-id before numeric constant error
223
224* Wed Aug 24 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.0-1
225- Initial RPM release
Note: See TracBrowser for help on using the repository browser.