source: projects/specs/trunk/f/fluxbox/fluxbox-vl.spec @ 521

Revision 521, 14.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define FBversion 1.1.1
2%define patchversion 1.1.0.1
3
4%define fbumenu_version 0.5.2
5%define vinefiles_version 9.8
6
7Summary:        Fluxbox is a windowmanager that is based on Blackbox.
8summary(ja):    Fluxbox は Blackbox から派生したウインドウマネージャです。
9Name:           fluxbox
10Version:        %{FBversion}
11Release:        1%{?_dist_release}
12Group:          User Interface/Desktops
13License:        MIT
14URL:            http://fluxbox.org/
15Vendor:         Project Vine
16Distribution:   Vine Linux
17Source0:        http://downloads.sourceforge.net/fluxbox/%{name}-%{version}.tar.bz2
18# styles & scripts
19Source1:        vinefiles-%{vinefiles_version}.tar.bz2
20Source2:        styles2.tar.bz2
21
22Patch0:         fluxbox-%{version}.init-in.patch
23##Patch1:               fluxbox-%{patchversion}.src-clock-tool.patch
24##Patch2:               fluxbox-%{patchversion}.src-Makefile-in.patch
25Patch3:         fluxbox-%{patchversion}.nls-ja.patch
26Patch4:         fluxbox-%{version}.startfb.patch
27Patch5:         fluxbox-%{patchversion}.menugen-menu-default.patch
28Patch6:         fluxbox-%{patchversion}.menugen-add-app.patch
29Patch8:         fluxbox-%{patchversion}.menugen-utf-8.patch
30Patch9:         fluxbox-%{patchversion}.menugen-vine-ext.patch
31
32Patch10:        fbsetbg_setter_priority.patch
33Patch20:        fluxbox-%{patchversion}.Xclients.patch
34##Patch30:      fluxbox-%{patchversion}.nls-hh.patch
35Patch40:        fluxbox-%{patchversion}.nls-ja-make.patch
36Patch41:        fluxbox-%{patchversion}.update_cfg.patch
37
38#Patch100:       fluxbox-%{patchversion}.20080913.patch
39
40BuildRoot:      %{_tmppath}/%{name}-buildroot
41BuildRequires:  libX11-devel libXext-devel
42BuildRequires:  bzip2 imlib2-devel zlib-devel freetype2-devel
43Requires:       imlib2 imlib2-loader ImageMagick nkf xsri xinitrc
44
45%description
46
47Fluxbox is yet another windowmanager for X.
48It's based on the Blackbox 0.61.1 code.
49Fluxbox looks like blackbox and handles styles, colors, window
50placement and similar thing exactly like blackbox
51    (100% theme/style compability).
52So what's the difference between fluxbox and blackbox then?
53The answer is: LOTS!
54Here is a list of features that fluxbox already has, or is in the works...
55
56%description -l ja
57
58fluxbox は X Window System 用の、一味違ったウィンドウマネージャです。
59それは blackbox-0.61.1 のプログラムコードをベースに開発されています。
60fluxbox は blackbox によく似ていて、スタイル、カラーリング、ウィンドウ
61の配置などを blackbox 同様に処理します。(スタイル(テーマ)は 100% 互換)
62では、fluxbox と blackbox の違いは?  ...  その答えは「いっぱい」!
63
64fluxbox に何が出来るか、今後何を計画しているのか?
65詳しくは http://fluxbox.sourceforge.net/ をご覧下さい。
66
67%prep
68%__rm -rf %{buildroot}
69##%%setup -T -n %{name}-%{version} -c
70%setup -q -a 1
71
72##%__tar jxf  %{SOURCE0}
73##mv -f %{name}-%{FBversion}/* ./
74##rm -rf %{name}-%{FBversion}
75
76%patch0 -p1
77##%patch1 -p1
78##%patch2 -p1
79%patch3 -p1
80%patch4 -p1
81%patch5 -p1
82%patch6 -p1
83%patch8 -p1
84%patch9 -p1
85%patch10 -p1
86##%patch30 -p1
87%patch40 -p1
88%patch41 -p1
89
90##%patch100 -p1
91
92%__tar jxf  %{SOURCE1}
93%__tar jxf  %{SOURCE2}
94
95%build
96
97CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
98CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
99FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
100./configure --enable-nls \
101        --prefix=%{_prefix} \
102        --exec-prefix=%{_exec_prefix} \
103        --bindir=%{_bindir} \
104        --sbindir=%{_sbindir} \
105        --sysconfdir=%{_sysconfdir} \
106        --datadir=%{_datadir} \
107        --includedir=%{_includedir} \
108        --libdir=%{_libdir} \
109        --libexecdir=%{_libexecdir} \
110        --localstatedir=%{_localstatedir} \
111        --sharedstatedir=%{_sharedstatedir} \
112        --mandir=%{_mandir} \
113        --infodir=%{_infodir}
114
115%__make
116
117%install
118%__rm -rf  %{buildroot}
119# fluxbox installation
120make "DESTDIR=%{buildroot}" install
121
122%__rm data/styles/Makefile*
123%__cp -a data/styles                %{buildroot}%{_datadir}/%{name}/
124%__cp -a data/styles2               %{buildroot}%{_datadir}/%{name}/
125%__cp -a data/backgrounds           %{buildroot}%{_datadir}/%{name}/
126%__cp -a data/images                %{buildroot}%{_datadir}/%{name}/
127%__cp -a data/UserMenu              %{buildroot}%{_datadir}/%{name}/
128%__cp data/fb_welcome.sh            %{buildroot}%{_datadir}/%{name}/
129%__cp data/*.html                   %{buildroot}%{_datadir}/%{name}/
130%__cp data/fluxbox.desktop.seed     %{buildroot}%{_datadir}/%{name}/fluxbox.desktop
131%__cp data/*.sample                 %{buildroot}%{_datadir}/%{name}/
132%__cp data/fb_welcome               %{buildroot}%{_datadir}/%{name}/
133%__cp data/cng_fbtips               %{buildroot}%{_datadir}/%{name}/
134%__cp data/change-rootcmd           %{buildroot}%{_datadir}/%{name}/
135%__cp data/change-init_rootcmd      %{buildroot}%{_datadir}/%{name}/
136%__cp %{PATCH20}                    %{buildroot}%{_datadir}/%{name}/
137%__cp data/mk-rootcmds              %{buildroot}%{_bindir}/
138%__cp data/fbumenu_gen-%{fbumenu_version} %{buildroot}%{_bindir}/fbumenu_gen
139%__cp ChangeLog                     %{buildroot}%{_datadir}/%{name}/
140
141# gdm session
142%__mkdir_p %{buildroot}%{_sysconfdir}/X11/dm/Sessions/
143%__cp %{buildroot}%{_datadir}/fluxbox/fluxbox.desktop %{buildroot}%{_sysconfdir}/X11/dm/Sessions/
144
145if [ -z "$DEBUG" ]; then
146        strip   %{buildroot}%{_bindir}/fluxbox \
147                %{buildroot}%{_bindir}/fbsetroot \
148                %{buildroot}%{_bindir}/fbrun
149fi
150
151bzip2 %{buildroot}%{_mandir}/man1/*.1
152
153%post
154
155local_lang=`echo $LANG | grep ja_JP`
156if ! [ -z "$local_lang" ]; then
157    l_lang=`echo $LANG | grep ja_JP | cut -d '.' -f 2`
158    case $l_lang in
159        UTF-8)
160            nkfopt="-w"
161            ;;
162        eucJP)
163            nkfopt="-e"
164            ;;
165    esac
166fi
167
168if [ -n "`grep -n "startWM FluxBox fluxbox" /etc/X11/xinit/Xclients | grep "^43:"`" ]; then
169    %__patch -p0 < %{_datadir}/%{name}/fluxbox-%{patchversion}.Xclients.patch
170elif [ -z "`grep "startWM" /etc/X11/xinit/Xclients | grep "startfluxbox$"`" ]; then
171    cat << EOF | nkf $nkfopt
172
173最新でない、改変された /etc/X11/xinit/Xclients が使われているようです。
174起動コマンドを "fluxbox" ではなく "startfluxbox" に設定して下さい。
175
176EOF
177fi
178
179# New menu-system
180%__rm %{_datadir}/fluxbox/menu*
181%{_bindir}/fluxbox-generate_menu \
182        -p %{_prefix} \
183        -o %{_datadir}/fluxbox/menu 2> /dev/null
184
185cat << EOF | nkf $nkfopt
186
187* fluxbox-%{version} : インストール|アップグレードされました。*
188
189※幾つかの更新が有ります。詳細は、
190    file:///usr/share/fluxbox/flux_news.html
191を御覧下さい。
192
193EOF
194
195%clean
196
197%__rm -rf %{buildroot}
198
199%files
200%defattr(-,root,root,755)
201%doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
202%dir %{_datadir}/%{name}
203%{_bindir}/*
204%{_mandir}/*
205%{_datadir}/%{name}/*
206%{_sysconfdir}/X11/dm/Sessions/fluxbox.desktop
207
208%changelog
209* Fri Sep 19 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-1
210- new upstream release.
211- removed upstream patchs.
212- rewrote Vine documents.
213
214* Sat Sep 14 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-3
215- Applied upstream patchs.
216
217* Fri Sep 12 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-2
218- updated mk-rootcmds
219- updated vine documents. (keys.html, flux_news.html)
220
221* Thu Sep 11 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-1
222- new upstream release
223- removed fluxbox-%{FBversion}.nls-hh.patch
224- rewrote documents. (keys.html, flux_news.html)
225- added new default keys file
226
227* Sun Aug 24 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-6
228- fixed locale problem
229-     rewrote scripts for eucJP and UTF-8
230- revived fluxbox-%{FBversion}.Xclients.patch. (for startx)
231
232* Sun Jun 22 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-5
233- add new style. (tux)
234
235* Mon Jun 16 2008  KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-3
236- corrected line gap of nls-header
237-   (fluxbox-1.0.0.nls-hh.patch)
238
239* Tue May 27 2008  KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-2
240- adjust startup sequence
241-   (rewrite desktop entry file for dm sessions)
242-   (remove fluxbox-%{FBversion}.Xclients.patch)
243
244* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1
245- applied new versioning policy
246- rebuilt with xorg-x11 7.3
247- spec in UTF-8
248
249* Tue Dec  4 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl3, 4
250- retouch patchs for ja_JP.UTF-8 locale
251-     : for root menu & help message
252- rewrite vine documents
253
254* Mon Oct 15 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl1, 2
255- new upstream 'stable' release
256- add new documents(styles tips, keys tips).
257- add new styles
258- update patch files, vine documents, vine scripts
259
260* Wed Apr 11 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc3.1, 2
261- new upstream release
262- add rewrited system styles
263- update patch files
264- update vine documents
265
266* Sun Dec 24 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.3, 4
267- add BuildRequires: zlib-devel freetype2-devel
268- add Requires: xsri
269- Change wpsetter's priority (fbsetbg_setter_priority.patch)
270
271* Thu Jul 20 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.1, 2
272- new upstream release
273- update patch files
274- update vine documents
275
276* Thu Jul  6 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc0.1, 2
277- new upstream release
278- update patch files
279- added 'additional applications' extension to fluxbox-generate_menu
280
281* Tue Apr  8 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15.1-0vl1, 2
282- new upstream release
283- add 'init file rewrite' script for back-compatible
284- rewrite documents
285
286* Wed Mar 29 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15-0vl1, 2
287- new upstream release
288- update *tips*
289- update patch files
290- add & update script files
291- update & retouch style files (VineStyle*, BlueStar*)
292- retouch menu structure (Vine tools)
293- add script for back compatible to background-style
294
295* Sun Mar 19 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1.1, 2.2
296- update *_tips.html
297    (retouch link errors)
298- retouch ja_JP/Translation.m
299- update menugen patch
300- update style file (VineStyle, BlueStar)
301- add index.html, scripts for 'wellcome'
302
303* Tue Oct 25 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1, 2
304- new upstream release
305- update vine patch
306        (retouch init file for new spec.)
307- update vinefiles
308    (update fbumenu_gen(usermenu generator))
309        (update 2 style files for new spec.)
310        (update fluxtips.txt)
311- update fluxbox_menu_tips.html
312
313* Sun Jun  5 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl3, 4
314- update vine patch
315        (add some menu items to fluxbox-generate_menu)
316            (retouch menu structure)
317                (rewrite 'about menu')
318- update vinefiles
319    (add usermenu generator to x-utilus)
320- update fluxbox_menu_tips.html
321
322* Fri May 27 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl1
323- new upstream release
324- update vine patch
325        (add some menu items to fluxbox-generate_menu)
326                (extend 'about toolbar')
327- update nls-ja patch
328- update fluxtips.txt
329    (rewrite, add '0.9.13 news')
330
331* Sun Feb  6 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.12-0vl1
332- new upstream release
333- update vine patch
334        (add some menu items to fluxbox-generate_menu)
335            (include blackbox styles)
336                (extend 'my_mail')
337                (extend 'about menu')
338- add nls-ja patch
339
340* Sun Dec 12 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.11-0vl1
341- new upstream release
342- update vine patch
343    (generate japanese menu)
344        (add some menu items to fluxbox-generate_menu)
345        (retouch menu structure)
346        (fix menu backup problem)
347
348* Wed Nov 24 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.10-0vl1
349- new upstream release
350- update vine patch ( merged vine patches )
351- add font_locale patch ( Patch100 )
352- fix typo: s/buidroot/buildroot/g
353
354* Sun Jun 20 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.9-0vl2
355- rewrite 2 styles (VineStyleII, BlueStarII)
356- rewrite fluxtips.txt(for 0.9.x)
357- modifying menu-generator
358    (fix problems of 'can't generates some menus')
359    (add some menu items)
360    (Japanese help messages)
361- modifying 'init' file(default style, menu-alpha)
362- append sample of 'keys' file
363
364* Sun May  2 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.9-0vl1
365- new upstream release
366
367* Sun Mar 14 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl2
368- using rpm macros
369- fix nonexistent directory for styles in postscript
370- add BuildRequires: bzip2
371- drop Prefix tag
372
373* Sat Mar  6 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl1
374- new upstream release
375- update vine patch (Patch101)
376
377* Mon Aug 11 2003 IWAI, Masaharu <iwai@alib.jp> 0.1.14-1_0vl2
378- build for VineSeed
379- fix Group tag for VineLinux:
380    Graphical desktop/Other -> User Interface/Desktops
381- add /usr/share/%%{name} directory in %%files section
382
383* Sat May 31 2003 KATO Masashi <mkato@par.odn.ne.jp> 0.1.14-1_0vl1
384- fluxbox for Vine Linux. Japanese menu enabled at default.
385- modified menu-generator patch (x-terminals)
386- modified init.in patch (date,workspace name,default style)
387- added 2 styles (VineStyle, BlueStar)
388
389* Mon Dec  9 2002 Han Boetes <han@mijncomputer.nl> 0.1.14-1
390- And we have a new release
391
392* Sun Dec  1 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-4
393- added only missing patch from bugfixpatch
394
395* Mon Nov 25 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-3
396- aa-startup- and openoffice-patch from Rathnor
397
398* Thu Nov 21 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-2
399- Fix locales patch
400
401* Tue Nov 19 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-1
402- Bump
403
404* Fri Sep 13 2002 Han Boetes <han@linux-mandrake.com> 0.1.12-1
405- Bump
406
407* Tue Sep 10 2002 Han Boetes <han@linux-mandrake.com> 0.1.11-3
408- Applied bugfix2 patch
409
410* Tue Sep 10 2002 Han Boetes <han@linux-mandrake.com> 0.1.11-2
411- Applied bugfix1 patch
412
413* Tue Sep  3 2002 Han Boetes <han@mijncomputer.nl> 0.1.11-1
414- Bump
415
416* Mon Jul 15 2002 Han Boetes <han@mijncomputer.nl> 0.1.10-1
417- Bump ;kudo's to Kurt Bechstein for recovering the rpm.
418
419* Mon Jun  3 2002 Han Boetes <han@mijncomputer.nl> 0.1.9-2
420- Applied bugfix-patch 2
421
422* Sat May 25 2002 Han Boetes <han@mijncomputer.nl> 0.1.9-1
423- Version Bump
424- New menu-system
425
426* Thu May  9 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-4
427- Esthetic and Profilactic cleanups
428
429* Fri May  3 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-3
430- Applied bugfix-patch 1+2+3
431
432* Sat Apr 27 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-2
433- Applied bugfix-patch 1
434
435* Fri Apr 19 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-1
436- Bump to version 0.1.8
437
438* Sat Mar  9 2002 Han Boetes <han@mijncomputer.nl> 0.1.7-3
439- Applied patch 1
440
441* Wed Mar  6 2002 Han Boetes <han@mijncomputer.nl> 0.1.7-2
442- Added DEBUG flavor
443
444* Fri Mar  1 2002 Han Boetes <han@mijncomputer.nl> 0.1.7-1
445- BUMP!
446
447* Thu Feb 07 2002 Christian Pelealu <chris@nerv-9.net> 0.1.6-3RH
448- Changed a lot of the build spec for RedHat 7.2
449
450* Tue Jan 29 2002 Han Boetes <han@mijncomputer.nl> 0.1.6-3
451- Applied patch 2
452
453* Sun Jan 13 2002 Han Boetes <han@mijncomputer.nl> 0.1.6-2
454- Applied patch.
455
456* Fri Jan 11 2002 Han Boetes <han@mijncomputer.nl> 0.1.6-1
457- Bump version.
458
459* Fri Dec 28 2001 Han Boetes <han@mijncomputer.nl> 0.1.5-1
460- Initial build
461
Note: See TracBrowser for help on using the repository browser.