source: projects/specs/trunk/f/fltk/fltk-vl.spec @ 966

Revision 966, 8.9 KB checked in by owa, 14 years ago (diff)

add new pkg fltk2

Line 
1%define _default_patch_fuzz 2
2
3#define snap    r6027
4#define _disable_static --disable-static
5
6Summary:        C++ user interface toolkit
7Summary(ja): C++用の軽量GUIライブラリキット
8Name:           fltk
9Version:        1.1.10
10Release:        2%{?_dist_release}
11
12# see COPYING (or http://www.fltk.org/COPYING.php ) for exceptions details
13License:        LGPLv2+ with exceptions
14Group:          System Environment/Libraries
15URL:            http://www.fltk.org/
16%if "%{?snap:1}" == "1"
17Source0:        http://ftp.easysw.com/pub/fltk/snapshots/fltk-1.1.x-%{snap}.tar.bz2
18%else
19Source0:        http://ftp.easysw.com/pub/fltk/%{version}/%{name}-%{version}-source.tar.bz2
20%endif
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22
23## FIXME/TODO: upstream these asap -- Rex
24# omit extraneous bits from fltk-config --cflags|--libs (http://bugzilla.redhat.com/199656)
25Patch1:         fltk-1.1.x-r5750-199656.patch
26Patch2:         fltk-1.1.7-test.patch
27# libfltk_gl.so had undefined symbols
28Patch3:         fltk-1.1.x-r5750-undefined.patch
29# nuke --rpath (#238284)
30Patch4:         fltk-1.1.x-r5750-rpath.patch
31Patch5:         fltk-1.1.8-fluid_desktop.patch
32
33BuildRequires:  libICE-devel libSM-devel
34BuildRequires:  libXext-devel libXinerama-devel libXft-devel libXt-devel libX11-devel
35BuildRequires:  xorg-x11-proto-devel xorg-x11-utils
36BuildRequires:  libjpeg-devel
37BuildRequires:  zlib-devel
38BuildRequires:  libpng-devel
39BuildRequires:  libGL-devel libGLU-devel
40BuildRequires:  pkgconfig
41BuildRequires:  desktop-file-utils
42BuildRequires:  man
43
44%description
45FLTK (pronounced "fulltick") is a cross-platform C++ GUI toolkit.
46It provides modern GUI functionality without the bloat, and supports
473D graphics via OpenGL and its built-in GLUT emulation.
48
49
50%package devel
51Summary:        Development files for %{name}
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       libstdc++34-devel
55Requires:       libGL-devel libGLU-devel
56Requires:       libXft-devel libXext-devel
57Requires:       libX11-devel libSM-devel libICE-devel
58%description devel
59%{summary}.
60
61%package fluid
62Summary:        Fast Light User Interface Designer
63Group:          Development/Tools
64Requires:       %{name}-devel = %{version}-%{release}
65%description fluid
66%{summary}, an interactive GUI designer for %{name}.
67
68
69%prep
70%if "%{?snap:1}" == "1"
71%setup -q -n fltk-1.1.x-%{snap}
72%else
73%setup -q
74%endif
75
76%patch1 -p1 -b .199656
77%patch2 -p1 -b .test
78%patch3 -p1 -b .undefined
79%patch4 -p1 -b .rpath
80%patch5 -p1 -b .fluid_desktop
81
82
83%build
84
85# using --with-optim, so unset CFLAGS/CXXFLAGS
86export CFLAGS=" "
87export CXXFLAGS=" "
88
89%configure \
90  %{?_disable_static} \
91  --with-optim="%{optflags}" \
92  --enable-largefile \
93  --enable-shared \
94  --enable-threads \
95  --enable-xdbe \
96  --enable-xinerama \
97  --enable-xft
98
99make %{?_smp_mflags}
100
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105# Makefile hack for 64bitness
106%if "%{_lib}" != "lib"
107mkdir -p $RPM_BUILD_ROOT%{_libdir}
108pushd $RPM_BUILD_ROOT%{_libdir}/..
109ln -s %{_lib} lib
110popd
111%endif
112
113make install install-desktop DESTDIR=$RPM_BUILD_ROOT
114
115# omit examples/games:
116make -C test uninstall-linux DESTDIR=$RPM_BUILD_ROOT
117rm -f  $RPM_BUILD_ROOT%{_mandir}/man?/{blocks,checkers,sudoku}*
118
119# Makefile hack for 64bitness
120%if "%{_lib}" != "lib"
121rm -f  $RPM_BUILD_ROOT%{_libdir}/../lib
122%endif
123
124desktop-file-install --vendor="%{name}" \
125  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
126    $RPM_BUILD_ROOT%{_datadir}/applications/fluid.desktop
127
128# docs
129rm -rf __docs
130mv $RPM_BUILD_ROOT%{_docdir}/fltk __docs
131
132## unpackaged files
133# errant docs
134rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
135# static libs
136%if "%{?_disable_static:1}" == "1"
137rm -f  $RPM_BUILD_ROOT%{_libdir}/lib*.a
138%endif
139
140
141%check
142make test ||:
143
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148
149%post -p /sbin/ldconfig
150
151%postun -p /sbin/ldconfig
152
153%post fluid
154touch --no-create %{_datadir}/icons/hicolor ||:
155gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
156update-desktop-database >& /dev/null ||:
157
158%postun fluid
159touch --no-create %{_datadir}/icons/hicolor ||:
160gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
161update-desktop-database >& /dev/null ||:
162
163
164%files
165%defattr(-,root,root,-)
166%doc ANNOUNCEMENT CHANGES COPYING CREDITS README
167%{_libdir}/libfltk.so.*
168%{_libdir}/libfltk_forms.so.*
169%{_libdir}/libfltk_gl.so.*
170%{_libdir}/libfltk_images.so.*
171
172%files devel
173%defattr(-,root,root,-)
174%doc __docs/*
175%{_bindir}/fltk-config
176%{_includedir}/FL/
177%{_includedir}/Fl
178%{_libdir}/libfltk.so
179%{_libdir}/libfltk_forms.so
180%{_libdir}/libfltk_gl.so
181%{_libdir}/libfltk_images.so
182%if "%{?_disable_static:1}" != "1"
183%{_libdir}/libfltk.a
184%{_libdir}/libfltk_forms.a
185%{_libdir}/libfltk_gl.a
186%{_libdir}/libfltk_images.a
187%endif
188%{_mandir}/man1/fltk-config.1*
189%{_mandir}/man3/fltk.3*
190
191%files fluid
192%defattr(-,root,root,-)
193%{_bindir}/fluid
194%{_mandir}/man1/fluid.1*
195%{_datadir}/applications/fluid.desktop
196%{_datadir}/icons/hicolor/*/*/*
197# FIXME
198%{_datadir}/mimelnk/*/*.desktop
199
200
201%changelog
202* Sat May 08 2010 Shu KONNO <owa@bg.wakwak.com> - 1.1.10-2
203- fixed duplecate desktop files
204
205* Fri May 07 2010 Shu KONNO <owa@bg.wakwak.com> - 1.1.10-1
206- updated fltk to 1.1.10
207- added japanese summary
208
209* Thu Feb 19 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.9-1
210- initial build for Vine Linux
211
212* Wed Oct 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.1.9-1
213- fltk-1.1.9
214
215* Sat Mar 29 2008 Rex Dieter <rdieter@fedoraproject.org> 1.1.8-1
216- fltk-1.1.8 (final)
217
218* Tue Feb 29 2008 Rex Dieter <rdieter@fedoraproject.org> 1.1.8-0.8.r6027
219- fltk-1.1.x-r6027
220
221* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 1.1.8-0.7.r5989
222- respin (gcc43)
223
224* Wed Dec 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.6.r5989
225- --enable-largefile
226- fltk-1.1.x-r5989 snapshot (1.1.8 pre-release)
227
228* Mon Aug 20 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.5.r5750
229- License: LGPLv2+ with exceptions
230
231* Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.4.r5750
232- License: LGPLv2+ (with exceptions)
233
234* Sun Apr 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.3.r5750
235- *really* fix --rpath issue, using non-empty patch this time (#238284)
236
237* Sun Apr 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.2.r5750
238- nuke --rpath (#238284)
239
240* Thu Apr 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.1.r5750
241- fltk-1.1.x-r5750 snapshot (1.1.8 pre-release)
242- --enable-xinerama
243- patch for undefined symbols in libfltk_gl
244
245* Wed Apr  4 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 1.1.7-9.r5555
246- Always apply fltk-config patch (#199656)
247- Update fltk-1.1.7-config.patch
248
249* Wed Dec 13 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-8.r5555
250- more 64bit hackage to workaround broken Makefile logic (#219348)
251
252* Wed Dec 13 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-7.r5555
253- fltk-1.1.x-r5555 snapshot, for 64bit issues (#219348)
254- restore static libs (they're tightly coupled with fltk-config)
255- cleanup %%description's
256
257* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-6
258- move tests to %%check section
259
260* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-5
261- use included icon/.desktop files
262- fix up fltk-config (#199656)
263
264* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-3
265- follow icon spec
266- omit static libs
267
268* Wed Sep 06 2006 Michael J. Knox <michael[AT]knox.net.nz> - 1.1.7-2
269- rebuild for FC6
270
271* Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.7-1
272- Upstream update
273
274* Thu Nov 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.6-4
275- Fixed BR and -devel Requires for modular X
276
277* Sun Nov 13 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.6-3
278- Update BuildRequires as well
279
280* Sun Nov 13 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.6-2
281- Update Requires for -devel
282
283* Thu Oct 27 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.6-1
284- Upstream update
285
286* Thu Aug 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.4-10
287- Fixed BR/Requires for x86_64
288
289* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
290- rebuilt
291
292* Thu Nov 20 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.8
293- Hopefully fixed Xft flags for rh80
294
295* Thu Nov 20 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.7
296- Fixed typo
297
298* Thu Nov 20 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.6
299- Added xft.pc build dependency
300- Added BuildReq:man
301
302* Sun Nov  9 2003 Ville Skyttä <ville.skytta@iki.fi> 0:1.1.4-0.fdr.4
303- Spec file cleanup
304- Enabled xft and threads
305
306* Tue Oct 28 2003 Dams <anvil[AT]livna.org> - 0:1.1.4-0.fdr.3
307- Added missing symlink in includedir
308
309* Wed Oct  1 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.2
310- Removed comment after scriptlets
311
312* Wed Oct  1 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.1
313- Updated to final 1.1.4
314
315* Wed Sep 24 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.0.4.rc1
316- Fixed documentation path in configure
317
318* Fri Aug 29 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.0.3.rc1
319- Fixed typo in desktop entry
320- Added missing BuildRequires ImageMagick and desktop-file-utils
321
322* Fri Aug 29 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.0.2.rc1
323- Moved fluid to its own package
324- Added missing Requires for devel package
325
326* Sat Aug 16 2003 Dams <anvil[AT]livna.org>
327- Initial build.
Note: See TracBrowser for help on using the repository browser.