source: projects/specs/trunk/f/flim/flim-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define emacsen_pkgdir /usr/lib/emacsen-common/packages
4
5
6%define       origver       1.14.9
7%define       origname      flim
8
9Summary:      Library to provide basic features about message for Emacsen
10Summary(ja):  Emacsen 用の message に関する表現形式や符号化のためのライブラリです。
11Name:         %{origname}
12Version:      %{origver}
13Release:      2%{?_dist_release}
14
15Source0:      http://www.kanji.zinbun.kyoto-u.ac.jp/~tomo/comp/emacsen/lisp/flim/flim-1.14/flim-%{origver}.tar.gz
16Source1:      %{origname}-install.sh
17Source2:      %{origname}-remove.sh
18Source3:      %{origname}-init.el
19Patch0:       FLIM-CFG.emacs.patch
20
21License:      1993-1999 Free Software Foundation, Inc., Dan Rich, Morioka Tomohiko, Kobayashi Shuhei
22Group:        Applications/Editors/Emacs
23BuildRoot:    %{_tmppath}/%{name}-%{version}-root
24BuildArch:    noarch
25
26PreReq:       emacsen
27%prereq_ge    emacsen-common
28%prereq_ge    apel
29Obsoletes:    flim-el
30Conflicts:    semi <= 1.14.5-0vl2
31
32Vendor:       Project Vine
33Distribution: Vine Linux
34Packager:     shaolin
35
36
37%description
38FLIM is a library to provide basic features about message
39representation or encoding.
40
41Note: in order to rebuild this SRPM package, you need
42emacsen, emacsen-common and apel installed.
43
44
45%description -l ja
46FLIM は Internet message に関する様々な表現形式や符号化に関する
47基礎的な機能を提供するための汎用部品です.
48
49注意:この SRPM パッケージを rebuild するには、emacsen と emacsen-common
50及び apel がインストールされている必要があります.
51
52
53%prep
54
55rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
56
57
58%setup  -n %{origname}-%{origver}
59
60%patch0 -p1
61
62
63%install
64[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
65[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
66
67mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
68mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
69mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
70
71#
72# remove unnecessary file
73#
74## upstream is dropped in FLIM-ELS: see ChangeLog file 2002-11-15
75%{__rm} -f mailcap.el
76
77#
78# install el files
79#
80
81cp Makefile FLIM-* *.el %{SOURCE3} \
82   ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
83
84#
85# install  script( bytecompile el and install elc , remove )   
86#
87
88%_installemacsenscript %{origname} %{SOURCE1}
89
90%_removeemacsenscript  %{origname} %{SOURCE2}
91
92#
93# install info file
94#
95
96mkdir -p ${RPM_BUILD_ROOT}/usr/info
97
98
99%post
100#
101# bytecompile and install
102#
103
104if [ "$1" = 2 ]; then
105
106%_emacsenPackageRemove %{origname}
107
108fi
109
110
111
112%_addemacsenlist %{origname}
113
114%_emacsenPackageInstall %{origname}
115
116
117%preun
118
119if [ "$1" = 0 ]; then
120
121%_emacsenPackageRemove %{origname}
122
123%_removeemacsenlist %{origname}
124
125fi
126
127
128%triggerpostun -- flim-el
129
130%_emacsenPackageInstall %{origname}
131
132
133%clean
134[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
135
136rm -rf ${RPM_BUILD_DIR}/apel-%{apelver}
137
138
139%files
140%defattr(-,root,root)
141%doc ChangeLog NEWS README* VERSION
142/usr/share/emacs/site-lisp/%{origname}/
143%{emacsen_pkgdir}/install/%{origname}
144%{emacsen_pkgdir}/remove/%{origname}
145
146 
147%changelog
148* Thu Mar  4 2010 IWAI, Masaharu <iwai@alib.jp> 1.14.9-2
149- remove mailcap.el: <BTS:VineLinux:935>
150- update Packager's syntax
151- update description-{en,ja}
152
153* Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.14.9-1vl5
154- applied new versioning policy, spec in utf-8
155- added %%emacsen_pkgdir macro
156
157* Fri Dec  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.9-0vl1
158- updated to 1.14.9
159
160* Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.8-0vl1
161- updated in sync with 1.14.8 release
162
163* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.7-0vl2
164- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
165- s/Copyright/License/
166
167* Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.7-0vl1
168- updated in sync with 1.14.7 release
169
170* Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.6-0vl1
171- updated in sync with 1.14.6 release
172
173* Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.5-0vl2
174- increased release number for the new apel release
175
176* Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.5-0vl1
177- updated in sync with 1.14.5 release
178
179* Mon Jun 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.4-0vl1
180- updated in sync with 1.14.4 release
181
182* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl9
183- Obsoletes: flim-el now, instead of Conflicts:
184- added %%triggerpostun -- flim-el
185
186* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl8
187- package name changed flim-el -> flim again
188- added Source3 for forthcoming site-start mechanism
189
190* Sun Dec 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl7
191- modified Source1 to remove mel-b-ccl.el* if the flavor is xemacs-21.1.x
192  (see http://lists.airs.net/wl/archive/200101/msg00077.html)
193
194* Fri Nov  9 2001 Kazuhisa TAKEI <takei@vinelinux.org>
195- change Patch0( fixed load-path)
196
197* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org>
198- requires: emacsen-common -> prereq
199
200* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
201- emacsenize
202
203* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
204- 1.14.3-0vl2
205- back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
206
207* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
208- 1.14.3-0vl1
209- updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
210
211* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
212- 1.13.7-8
213- added %define _noVersionedDependencies 1
214
215* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
216- 1.13.7-7
217- modified %files section to handle compressed man page(s)
218
219* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
220- 1.13.7-6
221- apel updated to 10.2
222
223* Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
224- 1.13.7-5
225- added patch (see emacs-mime-ja: 00303) to format texinfo correctly
226
227* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
228- 1.13.7-4
229- updated in sync with apel-10.0 / clime-1.13.6 release
230
231* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji
232- 1.13.7-3
233- change Group to Applications/Editors/EmacsLisp
234
235* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
236- 1.13.7-2
237- added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
238- now emh-1.10.1 and rmail-mime-1.13.0 are also included
239- documentation files are properly stored under /usr/doc directory
240
241* Wed Nov  3 1999 MATSUBAYASHI 'Shaolin' Kohji
242- 1.13.7-1
243- updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
244- added Japanese / English info files to be installed
Note: See TracBrowser for help on using the repository browser.