source: projects/specs/trunk/f/flim/flim-vl.spec @ 9511

Revision 9511, 7.0 KB checked in by inagaki, 9 years ago (diff)

2015-04-15 Ryoichi INAGAKI <ryo1@…>

  • flim, semi: rebuilt
  • rail, xsp: updated


Line 
1%define _noVersionedDependencies        1
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4
5%define       origver       1.14.9
6%define       origname      flim
7
8Summary:      Library to provide basic features about message for Emacsen
9Summary(ja):  Emacsen 用の message に関する表現形式や符号化のためのライブラリです。
10Name:         %{origname}
11Version:      %{origver}
12Release:      5%{?_dist_release}
13
14License:      1993-1999 Free Software Foundation, Inc., Dan Rich, Morioka Tomohiko, Kobayashi Shuhei
15Group:        Applications/Editors/Emacs
16URL:          http://git.chise.org/elisp/flim/
17
18Source0:      http://git.chise.org/elisp/dist/flim/flim-1.14/%{name}-%{version}.tar.gz
19
20Source1:      %{origname}-install.sh
21Source2:      %{origname}-remove.sh
22Source3:      %{origname}-init.el
23Patch0:       FLIM-CFG.emacs.patch
24
25BuildRoot:    %{_tmppath}/%{name}-%{version}-root
26BuildArch:    noarch
27
28Requires(post,preun): emacsen emacsen-common
29Requires(post): apel
30Requires:     apel
31Obsoletes:    flim-el
32Conflicts:    semi <= 1.14.5-0vl2
33
34Vendor:       Project Vine
35Distribution: Vine Linux
36Packager:     shaolin
37
38
39%description
40FLIM is a library to provide basic features about message
41representation or encoding.
42
43Note: in order to rebuild this SRPM package, you need
44emacsen, emacsen-common and apel installed.
45
46
47%description -l ja
48FLIM は Internet message に関する様々な表現形式や符号化に関する
49基礎的な機能を提供するための汎用部品です.
50
51注意:この SRPM パッケージを rebuild するには、emacsen と emacsen-common
52及び apel がインストールされている必要があります.
53
54
55%prep
56
57rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
58
59%setup  -q -n %{origname}-%{origver}
60
61%patch0 -p1
62
63iconv -f iso8859-1 -t utf8 -o ChangeLog.new ChangeLog
64iconv -f iso2022jp -t utf8 -o README.ja.new README.ja
65mv ChangeLog.new ChangeLog
66mv README.ja.new README.ja
67
68
69%install
70[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
71[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
72
73mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
74mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
75mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
76
77#
78# remove unnecessary file
79#
80## upstream is dropped in FLIM-ELS: see ChangeLog file 2002-11-15
81%{__rm} -f mailcap.el
82
83#
84# install el files
85#
86
87cp Makefile FLIM-* *.el %{SOURCE3} \
88   ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
89
90#
91# install  script( bytecompile el and install elc , remove )   
92#
93
94%_installemacsenscript %{origname} %{SOURCE1}
95
96%_removeemacsenscript  %{origname} %{SOURCE2}
97
98#
99# install info file
100#
101
102mkdir -p ${RPM_BUILD_ROOT}/usr/info
103
104
105%post
106#
107# bytecompile and install
108#
109
110if [ "$1" = 2 ]; then
111
112%_emacsenPackageRemove %{origname}
113
114fi
115
116
117
118%_addemacsenlist %{origname}
119
120%_emacsenPackageInstall %{origname}
121
122
123%preun
124
125if [ "$1" = 0 ]; then
126
127%_emacsenPackageRemove %{origname}
128
129%_removeemacsenlist %{origname}
130
131fi
132
133
134%triggerpostun -- flim-el
135
136%_emacsenPackageInstall %{origname}
137
138
139%clean
140[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
141
142rm -rf ${RPM_BUILD_DIR}/apel-%{apelver}
143
144
145%files
146%defattr(-,root,root)
147%doc ChangeLog NEWS README* VERSION
148/usr/share/emacs/site-lisp/%{origname}/
149%{emacsen_pkgdir}/install/%{origname}
150%{emacsen_pkgdir}/remove/%{origname}
151
152 
153%changelog
154* Wed Apr 15 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.14.9-5
155- rebuilt on current VineSeed
156- added URL tag
157- updated Source0
158
159* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 1.14.9-4
160- add Requires: apel
161- add Requires(preun): emacsen emacsen-common: fix 1.14.9-3
162
163* Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.14.9-3
164- drop defining prereq_ge macro
165 - using Requires(post) tag
166
167* Thu Mar  4 2010 IWAI, Masaharu <iwai@alib.jp> 1.14.9-2
168- remove mailcap.el: <BTS:VineLinux:935>
169- update Packager's syntax
170- update description-{en,ja}
171
172* Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.14.9-1vl5
173- applied new versioning policy, spec in utf-8
174- added %%emacsen_pkgdir macro
175
176* Fri Dec  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.9-0vl1
177- updated to 1.14.9
178
179* Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.8-0vl1
180- updated in sync with 1.14.8 release
181
182* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.7-0vl2
183- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
184- s/Copyright/License/
185
186* Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.7-0vl1
187- updated in sync with 1.14.7 release
188
189* Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.6-0vl1
190- updated in sync with 1.14.6 release
191
192* Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.5-0vl2
193- increased release number for the new apel release
194
195* Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.5-0vl1
196- updated in sync with 1.14.5 release
197
198* Mon Jun 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.4-0vl1
199- updated in sync with 1.14.4 release
200
201* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl9
202- Obsoletes: flim-el now, instead of Conflicts:
203- added %%triggerpostun -- flim-el
204
205* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl8
206- package name changed flim-el -> flim again
207- added Source3 for forthcoming site-start mechanism
208
209* Sun Dec 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl7
210- modified Source1 to remove mel-b-ccl.el* if the flavor is xemacs-21.1.x
211  (see http://lists.airs.net/wl/archive/200101/msg00077.html)
212
213* Fri Nov  9 2001 Kazuhisa TAKEI <takei@vinelinux.org>
214- change Patch0( fixed load-path)
215
216* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org>
217- requires: emacsen-common -> prereq
218
219* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
220- emacsenize
221
222* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
223- 1.14.3-0vl2
224- back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
225
226* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
227- 1.14.3-0vl1
228- updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
229
230* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
231- 1.13.7-8
232- added %define _noVersionedDependencies 1
233
234* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
235- 1.13.7-7
236- modified %files section to handle compressed man page(s)
237
238* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
239- 1.13.7-6
240- apel updated to 10.2
241
242* Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
243- 1.13.7-5
244- added patch (see emacs-mime-ja: 00303) to format texinfo correctly
245
246* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
247- 1.13.7-4
248- updated in sync with apel-10.0 / clime-1.13.6 release
249
250* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji
251- 1.13.7-3
252- change Group to Applications/Editors/EmacsLisp
253
254* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
255- 1.13.7-2
256- added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
257- now emh-1.10.1 and rmail-mime-1.13.0 are also included
258- documentation files are properly stored under /usr/doc directory
259
260* Wed Nov  3 1999 MATSUBAYASHI 'Shaolin' Kohji
261- 1.13.7-1
262- updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
263- added Japanese / English info files to be installed
Note: See TracBrowser for help on using the repository browser.