source: projects/specs/trunk/f/flac111/flac111-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define xmmsinputdir %{_libdir}/xmms/Input
2%define srcname flac
3
4Summary:        FLAC - Free Lossless Audio Codec
5Summary(ja):    FLAC - フリーの可逆音声圧縮コーデック
6Name:           flac111
7Version:        1.1.1
8Release:        1%{?_dist_release}
9License:        GPL/LGPL
10Group:          Applications/Multimedia
11Source:         http://prdownloads.sourceforge.net/flac/%{srcname}-%{version}.tar.gz
12URL:            http://flac.sourceforge.net/
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14Requires:       libogg
15BuildRequires:  libogg-devel
16%ifarch %ix86
17BuildRequires:  nasm
18%endif
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22
23%description
24FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
25similar to MP3, but lossless.
26
27The FLAC project consists of:
28
29  * the stream format
30  * libFLAC  - reference encoders and decoders in library form
31  * flac     - a command-line program to encode and decode FLAC files
32  * metaflac - a command-line metadata editor for FLAC files
33  * input plugins for various music players
34
35This package contains the FLAC libraries to use applications compiled with
36FLAC-1.1.1.
37
38%description -l ja
39FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
40MP3 に似ていますが、音質が劣化しません。
41
42FLAC プロジェクトは以下により構成されています。
43
44  * ストリーム形式
45  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
46  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
47               プログラム。
48  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
49  * 各種音楽再生プログラム用入力プラグイン
50
51このパッケージには、FLAC-1.1.1 でコンパイルされたアプリケーションを使うため
52に必要なライブラリが含まれています。
53
54
55%prep
56%setup -q -n %{srcname}-%{version}
57
58%build
59%configure
60%__make %{?_smp_mflags}
61
62%install
63%__rm -rf %{buildroot}
64%makeinstall \
65        xmmsinputplugindir=%{buildroot}%{xmmsinputdir}
66
67%clean
68%__rm -rf %{buildroot}
69
70%post -p %{_syssbindir}/ldconfig
71
72%postun -p %{_syssbindir}/ldconfig
73
74%files
75%defattr(-,root,root)
76%doc AUTHORS COPYING* README
77%{_libdir}/*.so.*
78
79
80%changelog
81* Sun Sep 07 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl5
82- applied new versioning policy, spec in utf-8
83
84* Sun Feb 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
85- change package-name from flac to flac111
86- drop patches
87
88* Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
89- fix typo
90
91* Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
92- move html docs to devel package
93
94* Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
95- add input plugin for beepmp based on for xmms (patch1)
96  - BuildRequires: beepmp-devel >= 0.9.7
97- define build_*_plugin macros to build input plugin sub-packages
98- update description
99
100* Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
101- drop BuildRequires: zlib-devel (was required to build with id3lib)
102
103* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
104- upstream release
105- drop (Build)Requires: id3lib(-devel)
106
107* Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
108- 1.1.1-beta1
109- add BuildRequires: gtk+-devel, zlib-devel
110
111* Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
112- xmms-flac
113  - enable to convert charset from/to EUC-JP-MS (Patch0)
114  - Requires: glibc >= 2.3.3
115
116* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
117- fix docs
118
119* Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
120- first build for Vine Linux
121
122* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
123- Rebuilt for Red Hat Linux 9.
124- Exclude .la files.
125- Updated description.
126
127* Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
128- Fix nasm dep to be only for ix86.
129
130* Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
131- Update to 1.1.0.
132
133* Sun Jan  5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
134- Rebuilt against the latest id3lib for the xmms plugin.
135
136* Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
137- Fixed location of include files, doh!
138
139* Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
140- Rebuilt for Red Hat Linux 8.0.
141
142* Thu Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
143- Update to 1.0.4.
144- Removed obsolete build patch, the xmms plugin builds cleanly at last!
145
146* Thu Jul  4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
147- Update to 1.0.3.
148
149* Tue Apr 23 2002 Daniel Resare <noa@resare.com>
150- Fixed plugin build when flac is not already installed
151
152* Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
153- Replaced the hard-coded xmms input path with an expansion.
154- Fixed spec (License tag and redundant Group for devel package).
155- Fixed defattr for the xmms plugin.
156
157* Sat Apr  6 2002 Daniel Resare <noa@resare.com>
158- Update to 1.0.2.
159- Splitted out xmms plugin to a separate subpackage.
160
161* Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
162- Update to 1.0.1.
163
164* Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
165- Rebuilt for Red Hat 7.2 and added xmms dependency.
166
167* Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
168- Initial RPM release.
169- You cannot rebuild this SRPM easily if you want the xmms plugin.
170
Note: See TracBrowser for help on using the repository browser.