source: projects/specs/trunk/f/flac/flac-vl.spec @ 521

Revision 521, 8.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# set 1 if you want to build input plugin for xmms
2%define build_xmms_plugin 0
3
4%define xmmsinputdir %{_libdir}/xmms/Input
5
6#%%define extraver beta
7
8Summary:        FLAC - Free Lossless Audio Codec
9Summary(ja):    FLAC - フリーの可逆音声圧縮コーデック
10Name:           flac
11Version:        1.2.1
12Release:        1%{?_dist_release}
13License:        GPL/LGPL
14Group:          Applications/Multimedia
15Source:         http://prdownloads.sourceforge.net/flac/%{name}-%{version}%{?extraver:-%extraver}.tar.gz
16Patch0:         flac-xmms-euc-jp-ms.patch
17URL:            http://flac.sourceforge.net/
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19Requires:       libogg
20BuildRequires:  libogg-devel
21%ifarch %ix86
22BuildRequires:  nasm
23%endif
24
25Vendor:         Project Vine
26Distribution:   Vine Linux
27
28%description
29FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
30similar to MP3, but lossless.
31
32The FLAC project consists of:
33
34  * the stream format
35  * libFLAC  - reference encoders and decoders in library form
36  * flac     - a command-line program to encode and decode FLAC files
37  * metaflac - a command-line metadata editor for FLAC files
38#  * input plugins for various music players (the xmms plugin is in a xmms-
39#    flac package)
40
41%description -l ja
42FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
43MP3 に似ていますが、音質が劣化しません。
44
45FLAC プロジェクトは以下により構成されています。
46
47  * ストリーム形式
48  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
49  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
50               プログラム。
51  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
52#  * 各種音楽再生プログラム用入力プラグイン (XMMS プラグインは xmms-flac パッ
53#    ケージに含まれます)
54
55%package devel
56Summary:        Development libraries and header files from FLAC
57Summary(ja):    FLAC アプリケーション開発用ライブラリ及びヘッダファイル
58Group:          Development/Libraries
59Requires:       %{name} = %{version}
60Requires:       pkgconfig
61
62%description devel
63This package contains all the files needed to develop applications that
64will use the Free Lossless Audio Codec (FLAC).
65
66%description -l ja devel
67このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
68開発するために必要なライブラリ及びヘッダファイルが含まれています。
69
70%if %{build_xmms_plugin}
71%package -n xmms-flac
72Summary:        X MultiMedia System plugin to play FLAC files
73Summary(ja):    FLAC ファイルを再生するための XMMS プラグイン
74Group:          Applications/Multimedia
75Requires:       xmms, %{name} = %{version}
76BuildRequires:  xmms-devel >= 0.9.5.1, gtk+-devel
77
78%description -n xmms-flac
79An input plugin that enables playback of FLAC files in xmms.
80
81%description -l ja -n xmms-flac
82XMMS で FLAC ファイル (*.flac) を再生するための入力プラグインです。
83%endif
84
85
86%prep
87%define srcver %{version}%{?extraver:-%extraver}
88
89%setup -q -n %{name}-%{srcver}
90
91%if %{build_xmms_plugin}
92%patch0 -p1 -b .euc-jp-ms
93%endif
94
95%build
96%ifarch ppc
97%configure --disable-static --disable-asm-optimizations
98%else
99%configure --disable-static
100%endif
101%__make %{?_smp_mflags}
102
103%install
104%__rm -rf %{buildroot}
105%makeinstall \
106        xmmsinputplugindir=%{buildroot}%{xmmsinputdir}
107
108# remove unneeded files
109%{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
110
111%clean
112%__rm -rf %{buildroot}
113
114%post -p %{_syssbindir}/ldconfig
115
116%postun -p %{_syssbindir}/ldconfig
117
118%files
119%defattr(-,root,root)
120%doc AUTHORS COPYING.* README
121%{_bindir}/*
122%{_libdir}/*.so.*
123%{_mandir}/*/*
124
125%files devel
126%defattr(-,root,root)
127%doc doc/html COPYING.*
128%{_includedir}/*
129%{_libdir}/*.so
130%{_libdir}/pkgconfig/*.pc
131%{_datadir}/aclocal/*.m4
132
133%if %{build_xmms_plugin}
134%files -n xmms-flac
135%defattr(-,root,root)
136%{xmmsinputdir}/*.so
137%endif
138
139
140%changelog
141* Sun Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
142- applied new versioning policy
143- spec in UTF-8
144
145* Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
146- new upstream release
147- drop bmp-plugin.patch (patch1)
148- disable xmms plugin
149
150* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
151- new upsteram release
152- dropped Patch2 (merged into upstream)
153- do not build beepmp plugin
154
155* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
156- rebuilt with new toolchain
157
158* Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
159- add '--disable-static' option to %%configure
160- remove *.la
161
162* Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
163- rebuild
164
165* Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
166- --disable-asm-optimizations on ppc
167
168* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
169- rebuild
170
171* Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
172- initialize flac_cfg.stream with NULL to avoid crashing (patch2)
173
174* Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
175- upstream release
176- update bmp-plugin.patch
177
178* Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
179- upstream release
180- update bmp-plugin.patch
181
182* Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
183- fix typo
184
185* Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
186- move html docs to devel package
187
188* Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
189- add input plugin for beepmp based on for xmms (patch1)
190  - BuildRequires: beepmp-devel >= 0.9.7
191- define build_*_plugin macros to build input plugin sub-packages
192- update description
193
194* Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
195- drop BuildRequires: zlib-devel (was required to build with id3lib)
196
197* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
198- upstream release
199- drop (Build)Requires: id3lib(-devel)
200
201* Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
202- 1.1.1-beta1
203- add BuildRequires: gtk+-devel, zlib-devel
204
205* Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
206- xmms-flac
207  - enable to convert charset from/to EUC-JP-MS (Patch0)
208  - Requires: glibc >= 2.3.3
209
210* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
211- fix docs
212
213* Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
214- first build for Vine Linux
215
216* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
217- Rebuilt for Red Hat Linux 9.
218- Exclude .la files.
219- Updated description.
220
221* Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
222- Fix nasm dep to be only for ix86.
223
224* Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
225- Update to 1.1.0.
226
227* Sun Jan  5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
228- Rebuilt against the latest id3lib for the xmms plugin.
229
230* Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
231- Fixed location of include files, doh!
232
233* Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
234- Rebuilt for Red Hat Linux 8.0.
235
236* Thu Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
237- Update to 1.0.4.
238- Removed obsolete build patch, the xmms plugin builds cleanly at last!
239
240* Thu Jul  4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
241- Update to 1.0.3.
242
243* Tue Apr 23 2002 Daniel Resare <noa@resare.com>
244- Fixed plugin build when flac is not already installed
245
246* Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
247- Replaced the hard-coded xmms input path with an expansion.
248- Fixed spec (License tag and redundant Group for devel package).
249- Fixed defattr for the xmms plugin.
250
251* Sat Apr  6 2002 Daniel Resare <noa@resare.com>
252- Update to 1.0.2.
253- Splitted out xmms plugin to a separate subpackage.
254
255* Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
256- Update to 1.0.1.
257
258* Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
259- Rebuilt for Red Hat 7.2 and added xmms dependency.
260
261* Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
262- Initial RPM release.
263- You cannot rebuild this SRPM easily if you want the xmms plugin.
264
Note: See TracBrowser for help on using the repository browser.