source: projects/specs/trunk/f/flac/flac-vl.spec @ 12372

Revision 12372, 10.2 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

acpica-tools-20190509-1

ethtool-5.4-1

flac-1.3.3-1

iproute-5.6.0-1

libcap-ng-0.7.10-1

libestr-0.1.11-2

libfastjson-0.99.8-4

libproxy-0.4.15-2

libpwquality-1.4.2-1

libunistring-0.9.10-2

mdadm-4.1-1

python-six-1.14.0-1

rsyslog-8.2002.0-1

speexdsp-1.2-0.16.rc3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           flac
4Summary:        FLAC - Free Lossless Audio Codec
5Summary(ja):    FLAC - フリーの可逆音声圧縮コーデック
6Version:        1.3.3
7Release:        1%{?_dist_release}
8Group:          Applications/Multimedia
9Vendor:         Project Vine
10Distribution:   Vine Linux
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13License:        BSD and GPLv2+
14URL:            https://xiph.org/flac/
15Source:         https://github.com/xiph/flac/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
16
17BuildRequires:  libogg-devel
18BuildRequires:  automake autoconf libtool gettext-devel
19%ifarch %ix86
20# 2.0 supports symbol visibility
21BuildRequires:  nasm >= 2.0
22%endif
23
24%description
25FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
26similar to MP3, but lossless.
27
28The FLAC project consists of:
29
30  * the stream format
31  * libFLAC  - reference encoders and decoders in library form
32  * flac     - a command-line program to encode and decode FLAC files
33  * metaflac - a command-line metadata editor for FLAC files
34
35%description -l ja
36FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
37MP3 に似ていますが、音質が劣化しません。
38
39FLAC プロジェクトは以下により構成されています。
40
41  * ストリーム形式
42  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
43  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
44               プログラム。
45  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
46
47%package devel
48Summary:        Development libraries and header files from FLAC
49Summary(ja):    FLAC アプリケーション開発用ライブラリ及びヘッダファイル
50Group:          Development/Libraries
51Requires:       %{name} = %{version}
52Requires:       pkgconfig
53
54%description devel
55This package contains all the files needed to develop applications that
56will use the Free Lossless Audio Codec (FLAC).
57
58%description -l ja devel
59このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
60開発するために必要なライブラリ及びヘッダファイルが含まれています。
61
62# compat32
63%package -n compat32-%{name}
64Summary: FLAC - Free Lossless Audio Codec
65Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
66Group: System Environment/Libraries
67
68%description -n compat32-%{name}
69FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
70similar to MP3, but lossless.
71
72The FLAC project consists of:
73
74  * the stream format
75  * libFLAC  - reference encoders and decoders in library form
76  * flac     - a command-line program to encode and decode FLAC files
77  * metaflac - a command-line metadata editor for FLAC files
78
79%description -n compat32-%{name} -l ja
80FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
81MP3 に似ていますが、音質が劣化しません。
82
83FLAC プロジェクトは以下により構成されています。
84
85  * ストリーム形式
86  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
87  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
88               プログラム。
89  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
90
91%package -n compat32-%{name}-devel
92Summary:        Development libraries and header files from FLAC
93Summary(ja):    FLAC アプリケーション開発用ライブラリ及びヘッダファイル
94Group:          Development/Libraries
95Requires:       %{name}-devel = %{version}-%{release}
96Requires:       compat32-%{name} = %{version}-%{release}
97Requires:       compat32-pkgconfig
98
99%description -n compat32-%{name}-devel
100This package contains all the files needed to develop applications that
101will use the Free Lossless Audio Codec (FLAC).
102
103%description -n compat32-%{name}-devel -l ja
104このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
105開発するために必要なライブラリ及びヘッダファイルが含まれています。
106
107%prep
108%define srcver %{version}%{?extraver:-%extraver}
109
110%setup -q -n %{name}-%{srcver}
111
112
113%build
114./autogen.sh -V
115
116%configure \
117    --disable-static \
118    --disable-xmms-plugin \
119%ifarch ppc
120    --disable-asm-optimizations \
121%endif
122    --disable-thorough-tests
123
124make %{?_smp_mflags}
125
126
127%install
128%__rm -rf %{buildroot}
129make install DESTDIR=%{buildroot}
130
131rm -rf ./htmldoc
132mv -f %{buildroot}%{_docdir}/flac ./htmldoc
133
134# remove unneeded files
135%{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
136
137
138%check
139make check
140
141%clean
142%__rm -rf %{buildroot}
143
144%post -p %{_syssbindir}/ldconfig
145%postun -p %{_syssbindir}/ldconfig
146
147%post -n compat32-%{name} -p /sbin/ldconfig
148%postun -n compat32-%{name} -p /sbin/ldconfig
149
150
151%files
152%defattr(-,root,root)
153%license COPYING.*
154%doc AUTHORS README
155%{_bindir}/*
156%{_libdir}/*.so.*
157%{_mandir}/*/*
158
159%files devel
160%defattr(-,root,root)
161%license COPYING.*
162%doc doc/html
163%{_includedir}/*
164%{_libdir}/*.so
165%{_libdir}/pkgconfig/*.pc
166%{_datadir}/aclocal/*.m4
167
168# compat32
169%if %{build_compat32}
170%files -n compat32-%{name}
171%defattr(-,root,root)
172%license COPYING.*
173%doc AUTHORS README
174%{_libdir}/*.so.*
175
176%files -n compat32-%{name}-devel
177%defattr(-,root,root,-)
178%{_libdir}/*.so
179%endif
180
181
182%changelog
183* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
184- new upstream release.
185
186* Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
187- new upstream release.
188
189* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-3
190- rebuilt with new toolchain.
191
192* Sat May 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.1-2
193- added compat32 subpackages
194
195* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
196- new upstream release
197- remove old patches
198
199* Sat Jul 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
200- new upstream release
201- remove Patch1-6
202- add Patch1,2 from Fedora
203
204* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-2
205- rebuilt with rpm-4.8.1 for pkg-config
206- added Patch1-6 from Fedora
207
208* Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
209- applied new versioning policy
210- spec in UTF-8
211
212* Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
213- new upstream release
214- drop bmp-plugin.patch (patch1)
215- disable xmms plugin
216
217* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
218- new upsteram release
219- dropped Patch2 (merged into upstream)
220- do not build beepmp plugin
221
222* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
223- rebuilt with new toolchain
224
225* Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
226- add '--disable-static' option to %%configure
227- remove *.la
228
229* Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
230- rebuild
231
232* Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
233- --disable-asm-optimizations on ppc
234
235* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
236- rebuild
237
238* Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
239- initialize flac_cfg.stream with NULL to avoid crashing (patch2)
240
241* Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
242- upstream release
243- update bmp-plugin.patch
244
245* Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
246- upstream release
247- update bmp-plugin.patch
248
249* Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
250- fix typo
251
252* Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
253- move html docs to devel package
254
255* Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
256- add input plugin for beepmp based on for xmms (patch1)
257  - BuildRequires: beepmp-devel >= 0.9.7
258- define build_*_plugin macros to build input plugin sub-packages
259- update description
260
261* Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
262- drop BuildRequires: zlib-devel (was required to build with id3lib)
263
264* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
265- upstream release
266- drop (Build)Requires: id3lib(-devel)
267
268* Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
269- 1.1.1-beta1
270- add BuildRequires: gtk+-devel, zlib-devel
271
272* Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
273- xmms-flac
274  - enable to convert charset from/to EUC-JP-MS (Patch0)
275  - Requires: glibc >= 2.3.3
276
277* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
278- fix docs
279
280* Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
281- first build for Vine Linux
282
283* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
284- Rebuilt for Red Hat Linux 9.
285- Exclude .la files.
286- Updated description.
287
288* Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
289- Fix nasm dep to be only for ix86.
290
291* Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
292- Update to 1.1.0.
293
294* Sun Jan  5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
295- Rebuilt against the latest id3lib for the xmms plugin.
296
297* Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
298- Fixed location of include files, doh!
299
300* Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
301- Rebuilt for Red Hat Linux 8.0.
302
303* Wed Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
304- Update to 1.0.4.
305- Removed obsolete build patch, the xmms plugin builds cleanly at last!
306
307* Thu Jul  4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
308- Update to 1.0.3.
309
310* Tue Apr 23 2002 Daniel Resare <noa@resare.com>
311- Fixed plugin build when flac is not already installed
312
313* Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
314- Replaced the hard-coded xmms input path with an expansion.
315- Fixed spec (License tag and redundant Group for devel package).
316- Fixed defattr for the xmms plugin.
317
318* Sat Apr  6 2002 Daniel Resare <noa@resare.com>
319- Update to 1.0.2.
320- Splitted out xmms plugin to a separate subpackage.
321
322* Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
323- Update to 1.0.1.
324
325* Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
326- Rebuilt for Red Hat 7.2 and added xmms dependency.
327
328* Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
329- Initial RPM release.
330- You cannot rebuild this SRPM easily if you want the xmms plugin.
331
Note: See TracBrowser for help on using the repository browser.