source: projects/specs/trunk/f/flac/flac-vl.spec @ 11506

Revision 11506, 10.0 KB checked in by tomop, 6 years ago (diff)

flac-1.3.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           flac
4Summary:        FLAC - Free Lossless Audio Codec
5Summary(ja):    FLAC - フリーの可逆音声圧縮コーデック
6Version:        1.3.2
7Release:        1%{?_dist_release}
8
9Group:          Applications/Multimedia
10License:        BSD and GPLv2+
11URL:            http://flac.sourceforge.net/
12
13Source:         http://prdownloads.sourceforge.net/flac/%{name}-%{version}%{?extraver:-%extraver}.tar.xz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: libogg-devel
17BuildRequires: automake autoconf libtool gettext-devel
18%ifarch %ix86
19# 2.0 supports symbol visibility
20BuildRequires:  nasm >= 2.0
21%endif
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25
26%description
27FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
28similar to MP3, but lossless.
29
30The FLAC project consists of:
31
32  * the stream format
33  * libFLAC  - reference encoders and decoders in library form
34  * flac     - a command-line program to encode and decode FLAC files
35  * metaflac - a command-line metadata editor for FLAC files
36
37%description -l ja
38FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
39MP3 に似ていますが、音質が劣化しません。
40
41FLAC プロジェクトは以下により構成されています。
42
43  * ストリーム形式
44  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
45  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
46               プログラム。
47  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
48
49%package devel
50Summary:        Development libraries and header files from FLAC
51Summary(ja):    FLAC アプリケーション開発用ライブラリ及びヘッダファイル
52Group:          Development/Libraries
53Requires:       %{name} = %{version}
54Requires:       pkgconfig
55
56%description devel
57This package contains all the files needed to develop applications that
58will use the Free Lossless Audio Codec (FLAC).
59
60%description -l ja devel
61このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
62開発するために必要なライブラリ及びヘッダファイルが含まれています。
63
64# compat32
65%package -n compat32-%{name}
66Summary: FLAC - Free Lossless Audio Codec
67Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
68Group: System Environment/Libraries
69
70%description -n compat32-%{name}
71FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
72similar to MP3, but lossless.
73
74The FLAC project consists of:
75
76  * the stream format
77  * libFLAC  - reference encoders and decoders in library form
78  * flac     - a command-line program to encode and decode FLAC files
79  * metaflac - a command-line metadata editor for FLAC files
80
81%description -n compat32-%{name} -l ja
82FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
83MP3 に似ていますが、音質が劣化しません。
84
85FLAC プロジェクトは以下により構成されています。
86
87  * ストリーム形式
88  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
89  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
90               プログラム。
91  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
92
93%package -n compat32-%{name}-devel
94Summary:        Development libraries and header files from FLAC
95Summary(ja):    FLAC アプリケーション開発用ライブラリ及びヘッダファイル
96Group:          Development/Libraries
97Requires:       %{name}-devel = %{version}-%{release}
98Requires:       compat32-%{name} = %{version}-%{release}
99Requires:       compat32-pkgconfig
100
101%description -n compat32-%{name}-devel
102This package contains all the files needed to develop applications that
103will use the Free Lossless Audio Codec (FLAC).
104
105%description -n compat32-%{name}-devel -l ja
106このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
107開発するために必要なライブラリ及びヘッダファイルが含まれています。
108
109%prep
110%define srcver %{version}%{?extraver:-%extraver}
111
112%setup -q -n %{name}-%{srcver}
113
114%build
115./autogen.sh -V
116
117%configure \
118    --disable-static \
119    --disable-xmms-plugin \
120%ifarch ppc
121    --disable-asm-optimizations \
122%endif
123    --disable-thorough-tests
124
125make %{?_smp_mflags}
126
127%install
128%__rm -rf %{buildroot}
129make install DESTDIR=%{buildroot}
130
131# remove unneeded files
132%{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
133%{_bindir}/find doc/ -name "Makefile*" -exec %__rm -f "{}" \;
134
135%check
136make -C test check &> /dev/null
137
138%clean
139%__rm -rf %{buildroot}
140
141%post -p %{_syssbindir}/ldconfig
142%postun -p %{_syssbindir}/ldconfig
143
144%post -n compat32-%{name} -p /sbin/ldconfig
145%postun -n compat32-%{name} -p /sbin/ldconfig
146
147
148%files
149%defattr(-,root,root)
150%doc AUTHORS COPYING.* README
151%{_bindir}/*
152%{_libdir}/*.so.*
153%{_mandir}/*/*
154
155%files devel
156%defattr(-,root,root)
157%doc doc/html COPYING.*
158%{_includedir}/*
159%{_libdir}/*.so
160%{_libdir}/pkgconfig/*.pc
161%{_datadir}/aclocal/*.m4
162
163# compat32
164%if %{build_compat32}
165%files -n compat32-%{name}
166%defattr(-,root,root)
167%doc AUTHORS COPYING.* README
168%{_libdir}/*.so.*
169
170%files -n compat32-%{name}-devel
171%defattr(-,root,root,-)
172%{_libdir}/*.so
173%{_libdir}/pkgconfig/*.pc
174%endif
175
176
177%changelog
178* Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
179- new upstream release.
180
181* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-3
182- rebuilt with new toolchain.
183
184* Sat May 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.1-2
185- added compat32 subpackages
186
187* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
188- new upstream release
189- remove old patches
190
191* Sat Jul 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
192- new upstream release
193- remove Patch1-6
194- add Patch1,2 from Fedora
195
196* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-2
197- rebuilt with rpm-4.8.1 for pkg-config
198- added Patch1-6 from Fedora
199
200* Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
201- applied new versioning policy
202- spec in UTF-8
203
204* Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
205- new upstream release
206- drop bmp-plugin.patch (patch1)
207- disable xmms plugin
208
209* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
210- new upsteram release
211- dropped Patch2 (merged into upstream)
212- do not build beepmp plugin
213
214* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
215- rebuilt with new toolchain
216
217* Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
218- add '--disable-static' option to %%configure
219- remove *.la
220
221* Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
222- rebuild
223
224* Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
225- --disable-asm-optimizations on ppc
226
227* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
228- rebuild
229
230* Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
231- initialize flac_cfg.stream with NULL to avoid crashing (patch2)
232
233* Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
234- upstream release
235- update bmp-plugin.patch
236
237* Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
238- upstream release
239- update bmp-plugin.patch
240
241* Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
242- fix typo
243
244* Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
245- move html docs to devel package
246
247* Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
248- add input plugin for beepmp based on for xmms (patch1)
249  - BuildRequires: beepmp-devel >= 0.9.7
250- define build_*_plugin macros to build input plugin sub-packages
251- update description
252
253* Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
254- drop BuildRequires: zlib-devel (was required to build with id3lib)
255
256* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
257- upstream release
258- drop (Build)Requires: id3lib(-devel)
259
260* Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
261- 1.1.1-beta1
262- add BuildRequires: gtk+-devel, zlib-devel
263
264* Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
265- xmms-flac
266  - enable to convert charset from/to EUC-JP-MS (Patch0)
267  - Requires: glibc >= 2.3.3
268
269* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
270- fix docs
271
272* Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
273- first build for Vine Linux
274
275* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
276- Rebuilt for Red Hat Linux 9.
277- Exclude .la files.
278- Updated description.
279
280* Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
281- Fix nasm dep to be only for ix86.
282
283* Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
284- Update to 1.1.0.
285
286* Sun Jan  5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
287- Rebuilt against the latest id3lib for the xmms plugin.
288
289* Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
290- Fixed location of include files, doh!
291
292* Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
293- Rebuilt for Red Hat Linux 8.0.
294
295* Wed Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
296- Update to 1.0.4.
297- Removed obsolete build patch, the xmms plugin builds cleanly at last!
298
299* Thu Jul  4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
300- Update to 1.0.3.
301
302* Tue Apr 23 2002 Daniel Resare <noa@resare.com>
303- Fixed plugin build when flac is not already installed
304
305* Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
306- Replaced the hard-coded xmms input path with an expansion.
307- Fixed spec (License tag and redundant Group for devel package).
308- Fixed defattr for the xmms plugin.
309
310* Sat Apr  6 2002 Daniel Resare <noa@resare.com>
311- Update to 1.0.2.
312- Splitted out xmms plugin to a separate subpackage.
313
314* Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
315- Update to 1.0.1.
316
317* Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
318- Rebuilt for Red Hat 7.2 and added xmms dependency.
319
320* Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
321- Initial RPM release.
322- You cannot rebuild this SRPM easily if you want the xmms plugin.
323
Note: See TracBrowser for help on using the repository browser.