source: projects/specs/trunk/f/flac/flac-vl.spec @ 9568

Revision 9568, 9.9 KB checked in by inagaki, 9 years ago (diff)

2015-05-16 Ryoichi INAGAKI <ryo1@…>

  • flac: added compat32 subpackage
  • libvorbis: updated


Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           flac
4Summary:        FLAC - Free Lossless Audio Codec
5Summary(ja):    FLAC - フリーの可逆音声圧縮コーデック
6Version:        1.3.1
7Release:        2%{?_dist_release}
8
9Group:          Applications/Multimedia
10License:        BSD and GPLv2+
11URL:            http://flac.sourceforge.net/
12
13Source:         http://prdownloads.sourceforge.net/flac/%{name}-%{version}%{?extraver:-%extraver}.tar.xz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: libogg-devel
17BuildRequires: automake autoconf libtool gettext-devel
18%ifarch %ix86
19# 2.0 supports symbol visibility
20BuildRequires:  nasm >= 2.0
21%endif
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25
26%description
27FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
28similar to MP3, but lossless.
29
30The FLAC project consists of:
31
32  * the stream format
33  * libFLAC  - reference encoders and decoders in library form
34  * flac     - a command-line program to encode and decode FLAC files
35  * metaflac - a command-line metadata editor for FLAC files
36
37%description -l ja
38FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
39MP3 に似ていますが、音質が劣化しません。
40
41FLAC プロジェクトは以下により構成されています。
42
43  * ストリーム形式
44  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
45  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
46               プログラム。
47  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
48
49%package devel
50Summary:        Development libraries and header files from FLAC
51Summary(ja):    FLAC アプリケーション開発用ライブラリ及びヘッダファイル
52Group:          Development/Libraries
53Requires:       %{name} = %{version}
54Requires:       pkgconfig
55
56%description devel
57This package contains all the files needed to develop applications that
58will use the Free Lossless Audio Codec (FLAC).
59
60%description -l ja devel
61このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
62開発するために必要なライブラリ及びヘッダファイルが含まれています。
63
64# compat32
65%package -n compat32-%{name}
66Summary: FLAC - Free Lossless Audio Codec
67Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
68Group: System Environment/Libraries
69
70%description -n compat32-%{name}
71FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
72similar to MP3, but lossless.
73
74The FLAC project consists of:
75
76  * the stream format
77  * libFLAC  - reference encoders and decoders in library form
78  * flac     - a command-line program to encode and decode FLAC files
79  * metaflac - a command-line metadata editor for FLAC files
80
81%description -n compat32-%{name} -l ja
82FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
83MP3 に似ていますが、音質が劣化しません。
84
85FLAC プロジェクトは以下により構成されています。
86
87  * ストリーム形式
88  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
89  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
90               プログラム。
91  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
92
93%package -n compat32-%{name}-devel
94Summary:        Development libraries and header files from FLAC
95Summary(ja):    FLAC アプリケーション開発用ライブラリ及びヘッダファイル
96Group:          Development/Libraries
97Requires:       %{name}-devel = %{version}-%{release}
98Requires:       compat32-%{name} = %{version}-%{release}
99Requires:       compat32-pkgconfig
100
101%description -n compat32-%{name}-devel
102This package contains all the files needed to develop applications that
103will use the Free Lossless Audio Codec (FLAC).
104
105%description -n compat32-%{name}-devel -l ja
106このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
107開発するために必要なライブラリ及びヘッダファイルが含まれています。
108
109%prep
110%define srcver %{version}%{?extraver:-%extraver}
111
112%setup -q -n %{name}-%{srcver}
113
114%build
115./autogen.sh -V
116
117%configure \
118    --disable-static \
119    --disable-xmms-plugin \
120%ifarch ppc
121    --disable-asm-optimizations \
122%endif
123    --disable-thorough-tests
124
125make %{?_smp_mflags}
126
127%install
128%__rm -rf %{buildroot}
129make install DESTDIR=%{buildroot}
130
131# remove unneeded files
132%{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
133%{_bindir}/find doc/ -name "Makefile*" -exec %__rm -f "{}" \;
134
135%check
136make -C test check &> /dev/null
137
138%clean
139%__rm -rf %{buildroot}
140
141%post -p %{_syssbindir}/ldconfig
142%postun -p %{_syssbindir}/ldconfig
143
144%post -n compat32-%{name} -p /sbin/ldconfig
145%postun -n compat32-%{name} -p /sbin/ldconfig
146
147
148%files
149%defattr(-,root,root)
150%doc AUTHORS COPYING.* README
151%{_bindir}/*
152%{_libdir}/*.so.*
153%{_mandir}/*/*
154
155%files devel
156%defattr(-,root,root)
157%doc doc/html COPYING.*
158%{_includedir}/*
159%{_libdir}/*.so
160%{_libdir}/pkgconfig/*.pc
161%{_datadir}/aclocal/*.m4
162
163# compat32
164%if %{build_compat32}
165%files -n compat32-%{name}
166%defattr(-,root,root)
167%doc AUTHORS COPYING.* README
168%{_libdir}/*.so.*
169
170%files -n compat32-%{name}-devel
171%defattr(-,root,root,-)
172%{_libdir}/*.so
173%{_libdir}/pkgconfig/*.pc
174%endif
175
176
177%changelog
178* Sat May 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.1-2
179- added compat32 subpackages
180
181* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
182- new upstream release
183- remove old patches
184
185* Sat Jul 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
186- new upstream release
187- remove Patch1-6
188- add Patch1,2 from Fedora
189
190* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-2
191- rebuilt with rpm-4.8.1 for pkg-config
192- added Patch1-6 from Fedora
193
194* Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
195- applied new versioning policy
196- spec in UTF-8
197
198* Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
199- new upstream release
200- drop bmp-plugin.patch (patch1)
201- disable xmms plugin
202
203* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
204- new upsteram release
205- dropped Patch2 (merged into upstream)
206- do not build beepmp plugin
207
208* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
209- rebuilt with new toolchain
210
211* Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
212- add '--disable-static' option to %%configure
213- remove *.la
214
215* Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
216- rebuild
217
218* Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
219- --disable-asm-optimizations on ppc
220
221* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
222- rebuild
223
224* Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
225- initialize flac_cfg.stream with NULL to avoid crashing (patch2)
226
227* Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
228- upstream release
229- update bmp-plugin.patch
230
231* Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
232- upstream release
233- update bmp-plugin.patch
234
235* Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
236- fix typo
237
238* Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
239- move html docs to devel package
240
241* Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
242- add input plugin for beepmp based on for xmms (patch1)
243  - BuildRequires: beepmp-devel >= 0.9.7
244- define build_*_plugin macros to build input plugin sub-packages
245- update description
246
247* Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
248- drop BuildRequires: zlib-devel (was required to build with id3lib)
249
250* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
251- upstream release
252- drop (Build)Requires: id3lib(-devel)
253
254* Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
255- 1.1.1-beta1
256- add BuildRequires: gtk+-devel, zlib-devel
257
258* Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
259- xmms-flac
260  - enable to convert charset from/to EUC-JP-MS (Patch0)
261  - Requires: glibc >= 2.3.3
262
263* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
264- fix docs
265
266* Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
267- first build for Vine Linux
268
269* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
270- Rebuilt for Red Hat Linux 9.
271- Exclude .la files.
272- Updated description.
273
274* Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
275- Fix nasm dep to be only for ix86.
276
277* Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
278- Update to 1.1.0.
279
280* Sun Jan  5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
281- Rebuilt against the latest id3lib for the xmms plugin.
282
283* Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
284- Fixed location of include files, doh!
285
286* Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
287- Rebuilt for Red Hat Linux 8.0.
288
289* Wed Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
290- Update to 1.0.4.
291- Removed obsolete build patch, the xmms plugin builds cleanly at last!
292
293* Thu Jul  4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
294- Update to 1.0.3.
295
296* Tue Apr 23 2002 Daniel Resare <noa@resare.com>
297- Fixed plugin build when flac is not already installed
298
299* Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
300- Replaced the hard-coded xmms input path with an expansion.
301- Fixed spec (License tag and redundant Group for devel package).
302- Fixed defattr for the xmms plugin.
303
304* Sat Apr  6 2002 Daniel Resare <noa@resare.com>
305- Update to 1.0.2.
306- Splitted out xmms plugin to a separate subpackage.
307
308* Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
309- Update to 1.0.1.
310
311* Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
312- Rebuilt for Red Hat 7.2 and added xmms dependency.
313
314* Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
315- Initial RPM release.
316- You cannot rebuild this SRPM easily if you want the xmms plugin.
317
Note: See TracBrowser for help on using the repository browser.