source: projects/specs/trunk/f/firstboot/firstboot-vl.spec @ 521

Revision 521, 29.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Initial system configuration utility
2Summary(ja): 初期システム設定ユーティリティ
3
4Name: firstboot
5Version: 1.4.27.3
6Release: 1%{?_dist_release}
7URL: http://fedoraproject.org/wiki/FirstBoot
8License: GPLv2+
9ExclusiveOS: Linux
10Group: System Environment/Base
11Source0: %{name}-%{version}.tar.bz2
12Patch1: firstboot-vine.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildArch: noarch
16Prereq: chkconfig
17BuildRequires: gettext
18Requires: pygtk2
19Requires: metacity
20Requires: rhpl
21Requires: rhpxl
22Requires: system-config-display
23#Requires: system-config-language
24#Requires: system-config-soundcard
25Requires: system-config-securitylevel
26Requires: system-config-network
27Requires: system-config-users
28Requires: system-config-date
29Requires: system-config-keyboard
30Requires: authconfig-gtk
31Requires: libuser
32#Requires: system-logos
33Requires: firstboot-tui = %{version}
34ExcludeArch: s390 s390x ppc64
35
36%description
37The firstboot utility runs after installation.  It guides the
38user through a series of steps that allows for easier
39configuration of the machine.
40
41%package tui
42Summary: A text interface for firstboot
43Summary(ja): A text interface for firstboot
44Group: System Environment/Base
45Prereq: chkconfig, /etc/init.d
46BuildPreReq: gettext
47Requires: python
48Requires: usermode
49Requires: rhpl
50Requires: system-config-securitylevel-tui
51Requires: system-config-network-tui
52Requires: ntsysv
53Requires: authconfig
54
55%description tui
56firstboot-tui is a text interface for initial system configuration.
57
58%prep
59%setup -q
60%patch1 -p1
61
62sed -i -e 's|/usr/bin/python2|/usr/bin/python|g' \
63    src/firstboot src/xfirstboot.py src/firstboot.py
64
65%build
66make
67
68%install
69make INSTROOT=$RPM_BUILD_ROOT install
70
71mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
72echo "RUN_FIRSTBOOT=NO" > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/firstboot
73
74%find_lang %name
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post tui
80if ! [ -f /etc/sysconfig/firstboot ]
81then
82  chkconfig --add firstboot
83fi
84
85%preun
86if [ $1 = 0 ]; then
87  rm -rf /usr/share/firstboot/*.pyc
88  rm -rf /usr/share/firstboot/modules/*.pyc
89fi
90
91%preun tui
92if [ $1 = 0 ]; then
93  chkconfig --del firstboot
94fi
95
96%files -f %{name}.lang
97%defattr(-,root,root)
98%config %{_sysconfdir}/sysconfig/firstboot
99%dir %{_datadir}/firstboot/
100%dir %{_datadir}/firstboot/modules/
101%dir %{_datadir}/firstboot/pixmaps/
102%{_datadir}/firstboot/exceptionWindow.py*
103%{_datadir}/firstboot/firstbootWindow.py*
104%{_datadir}/firstboot/firstboot_module_window.py*
105%{_datadir}/firstboot/xfirstboot.py*
106%{_datadir}/firstboot/modules/*
107%{_datadir}/firstboot/pixmaps/*
108
109%files -f %{name}.lang tui
110%defattr(-,root,root)
111%config %{_sysconfdir}/rc.d/init.d/firstboot
112%dir %{_datadir}/firstboot/
113%{_sbindir}/firstboot
114%{_datadir}/firstboot/constants_text.py*
115%{_datadir}/firstboot/eula_strings.py*
116%{_datadir}/firstboot/firstboot.py*
117%{_datadir}/firstboot/firstbootBackend.py*
118%{_datadir}/firstboot/functions.py*
119%{_datadir}/firstboot/textWindow.py*
120
121
122%changelog
123* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.27.3-1
124- initial build for Vine Linux
125
126* Fri Nov  9 2007 Karanbir Singh <kbsingh@centos.org> 1.4.27.3-1.el5.centos
127- Roll in CentOS Branding
128
129* Thu Jun 28 2007 Chris Lumens <clumens@redhat.com> 1.4.27.3-1
130- Iterate over all possible CD drives on the additional CD module (#231612).
131- Enable fullscreen mode again; scale sidebar graphics (#211198).
132
133* Mon Jan 15 2007 Chris Lumens <clumens@redhat.com> 1.4.27.2-1
134- Pull in updated gu_IN translation (#222628).
135- Merge in additional CDs patch so it doesn't get dropped.
136
137* Mon Dec 18 2006 Chris Lumens <clumens@redhat.com> 1.4.27.1-1
138- Allow running on s390 and ppc64 under reconfig mode (#217921).
139
140* Wed Dec 13 2006 Chris Lumens <clumens@redhat.com> 1.4.27-1
141- More translation updates (#212958, #198872).
142
143* Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> 1.4.26-1
144- Update translations (#198872).
145
146* Thu Oct 26 2006 Chris Lumens <clumens@redhat.com> 1.4.25-1
147- Require matching versions of firstboot and firstboot-tui.
148- Fix language in non-rhgb graphical case (notting).
149
150* Wed Oct 25 2006 Chris Lumens <clumens@redhat.com> 1.4.24-1
151- Pick up new si_LK translation (#200532).
152- Support noSidebar value for modules (#210697).
153- Fix release number.
154- Do start up in English on CJKI installs in text mode (#211936).
155
156* Mon Oct 02 2006 Chris Lumens <clumens@redhat.com> - 1.4.23-1
157- runPriority can now be a float.
158- Pick up new translations (#208867).
159- Set window to 800x600 instead of fullscreening (#208331, #208620).
160
161* Wed Sep 20 2006 Chris Lumens <clumens@redhat.com> 1.4.22-1
162- Add help output to /etc/init.d/firstboot (#207043).
163- Fix a window manager warning (#206369).
164- Don't start up in English on CJKI installs (#206600).
165
166* Fri Sep 15 2006 Chris Lumens <clumens@redhat.com> 1.4.21-1
167- Use system-config-network-tui instead of netconfig in the text
168  interface.
169- Remove unused methods in the modules.
170
171* Tue Sep 12 2006 Chris Lumens <clumens@redhat.com> 1.4.20-1
172- Don't specify a default color depth.
173- Pull in new translations (#199090).
174
175* Tue Aug 08 2006 Chris Lumens <clumens@redhat.com> 1.4.19-1
176- Don't fill in the Create User UI with whatever user happens to have
177  UID 500 (#200695).
178
179* Wed Aug 02 2006 Chris Lumens <clumens@redhat.com> 1.4.18-1
180- Remove ddc probe support that rhpxl no longer provides.
181
182* Fri Jul 28 2006 Chris Lumens <clumens@redhat.com> 1.4.17-1
183- Pick up new or_IN translation (#200210).
184- Use new rhpxl X startup code.
185
186* Mon Jul 24 2006 Chris Lumens <clumens@redhat.com> 1.4.16-1
187- Fix system-config-soundcard API change.
188- Make sure firstboot starts after HAL (#199899).
189
190* Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 1.4.15-1
191- Really disable the display module.
192
193* Wed Jul 19 2006 Chris Lumens <clumens@redhat.com> 1.4.14-1
194- Disable the display module for now.
195
196* Fri Jul 10 2006 Chris Lumens <clumens@redhat.com> 1.4.13-1
197- Better fix for the no display hardware case (#192808).
198
199* Wed Jun 21 2006 Chris Lumens <clumens@redhat.com> 1.4.12-1
200- Update translation files (#195010).
201- Fix traceback on exiting (#196128).
202
203* Mon Jun 12 2006 Chris Lumens <clumens@redhat.com> 1.4.11-1
204- Don't traceback on the display module if there's no display hardware
205  (#142522).
206- Don't forget about reconfig mode if the timer expires (#170609).
207
208* Fri May 26 2006 Chris Lumens <clumens@redhat.com> 1.4.10-1
209- Fix reconfig mode.
210
211* Fri May 19 2006 Chris Lumens <clumens@redhat.com> 1.4.9-1
212- Make /etc/modprobe.conf reading more robust (#191819).
213- Don't try to call readHTML from anaconda's ICS.
214
215* Mon May 15 2006 Chris Lumens <clumens@redhat.com> 1.4.8-2
216- Require system-logos instead of an OS-specific package (#191407).
217
218* Tue Apr 04 2006 Chris Lumens <clumens@redhat.com> 1.4.8-1
219- Allow firstboot to run in kadischi (#186870).
220- Updated for rhpxl changes.
221
222* Mon Mar 20 2006 Martin Stransky <stransky@redhat.com> 1.4.7-1
223- replaced "Play test button" by "Play" button for s-c-s (#185931)
224- Fix soundcard string (#177425).
225- Fix label inconsistency on welcome screen (#183899).
226- Rework "System User" string (#177940).
227- Don't create a user if a homedir with that username already exists
228  (#143150).
229
230* Fri Mar 03 2006 Chris Lumens <clumens@redhat.com> 1.4.6-1
231- Revert UI changes that broke s-c-keyboard (#183718).
232
233* Wed Mar 01 2006 Chris Lumens <clumens@redhat.com> 1.4.5-1
234- Run if RUN_FIRSTBOOT != "NO" (#180520).
235- Don't let dialog windows hide behind the main window.
236- Remove timeout waiting for server to start.
237
238* Wed Feb 08 2006 Chris Lumens <clumens@redhat.com> 1.4.4-1
239- Get rid of chkconfig --off calls.
240- Smarter checking for if we need to reboot or not.
241
242* Mon Feb 06 2006 Chris Lumens <clumens@redhat.com> 1.4.3-1
243- Tweak firstboot-tui requires to not require X (#180046).
244- Wrap left side labels if they're too long.
245- Remove "Click to Finish" module (#178109).
246- Try to prevent running in runlevel 3 if we failed in runlevel 5
247  (#145169).
248
249* Fri Jan 27 2006 Chris Lumens <clumens@redhat.com> 1.4.2-1
250- Layout cleanups and simplification.
251- Use GTK styles to display the new artwork in non-debug mode.
252
253* Wed Jan 25 2006 Chris Lumens <clumens@redhat.com> 1.4.1-1
254- Fix debug mode.
255- Use the new bubbly artwork (#178106).
256
257* Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 1.4.0-1
258- Split into separate packages for X and no X (#178216).
259
260* Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.3.57-1
261- Use scdMainWindow instead of mainWindow to fix random python import
262  tracebacks.
263
264* Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.3.56-2
265- Remove dependancy on system-config-packages.
266
267* Thu Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.3.56-1
268- Increase timeout on waiting for X to start (#176782).
269- Update translations.
270
271* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
272- rebuilt
273
274* Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 1.3.55-1
275- Fix grammar problems (#143953).
276- Fix traceback on user screen (#175227).
277
278* Wed Nov 30 2005 Chris Lumens <clumens@redhat.com> 1.3.54-1
279- Use system-config-users for user/group/password validation (#174255).
280
281* Wed Nov 16 2005 Chris Lumens <clumens@redhat.com> 1.3.53-1
282- Disable Additional CDs module for now.
283
284* Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 1.3.52-1
285- Set a timeout on waiting for the window manager to start.
286- Correct ps output.
287- Move keyboard initialization to after the modules have been loaded
288  (#133074, #157870).
289
290* Mon Oct 17 2005 Chris Lumens <clumens@redhat.com> 1.3.51-1
291- Fix whrandom deprecation warnings.
292- Fix render_to_drawable deprecation warnings.
293- Change "Next" button on last page to "Finish".
294
295* Tue Oct 11 2005 Chris Lumens <clumens@redhat.com> 1.3.50-1
296- Decrease blank space on finished screen (#144496).
297- Fix import of rhpxl.videocard.
298
299* Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 1.3.49-1
300- Use rhpxl instead of rhpl for X stuff.
301
302* Fri Sep 23 2005 Chris Lumens <clumens@redhat.com> 1.3.48-1
303- Fix autoscreenshot test (#169102).
304- Allow unicode letters in full user names (#169043).
305
306* Thu Sep 15 2005 Jeremy Katz <katzj@redhat.com> - 1.3.47-2
307- exclude arch ppc64 to stop from being included in ppc64 compose where
308  we don't have X
309
310* Thu Sep 15 2005 Chris Lumens <clumens@redhat.com> 1.3.47-1
311- Moved firstboot_gui_window here from rhpl and renamed it to
312  firstboot_module_window.
313- Converted /usr/sbin/firstboot into a python script.
314- Converted the rest of firstboot into a module suitable for importing.
315
316* Tue Sep 13 2005 Chris Lumens <clumens@redhat.com> 1.3.46-1
317- Remove dependancy on up2date (#167663).
318- Use rhpl's X startup code instead of using something different.
319
320* Wed Aug 17 2005 Chris Lumens <clumens@redhat.com> 1.3.45-1
321- Don't fail if no ifcfg script exists for a NIC found in modprobe.conf
322  (#164874).
323- Restore focus after closing dialogs (#143388, #143711).
324
325* Tue Aug 02 2005 Chris Lumens <clumens@redhat.com> 1.3.44-1
326- Allow modules to specify that the system should be rebooted after
327  firstboot has run via the needsReboot module attribute.
328- Enable checking for capital letters in usernames again to be consistent
329  with system-config-users (#164852).
330- Use libuser for adding users again (#164160).
331- Rebuilt translations.
332
333* Thu Jul 07 2005 Chris Lumens <clumens@redhat.com> 1.3.43-1
334- Remove dependancy on xsri (#145807).
335- Fix typo in "additional" (#158435).
336- Tabs vs. spaces consistency (#156456).
337- Don't require system-config-display on ppc64.
338
339* Wed May 25 2005 Jeremy Katz <katzj@redhat.com> - 1.3.42-1
340- Stop using deprecated gtk.{TRUE,FALSE} (#153033)
341
342* Tue May 24 2005 Adrian Likins <alikins@redhat.com> - 1.3.41
343- fix #158095 - Subscription Alert (on first login) on non network installs
344
345* Thu May 19 2005 Adrian Likins <alikins@redhat.com> - 1.3.40
346- fix #154606 - First boot displays "please insert the red hat enterprise linux extras disk"
347
348* Fri Dec 14 2004 Adrian Likins <alikins@redhat.com> - 1.3.39-2
349- really fix #138727 (was looking for cdroms in the wrong place)
350
351* Fri Dec 14 2004 Adrian Likins <alikins@redhat.com> - 1.3.38-1
352- fix #138727 (patch from katzj)
353- latest translations
354
355* Fri Nov 12 2004 Adrian Likins <alikins@redhat.com> - 1.3.37-2
356- fix #139060
357
358* Wed Nov 10 2004 Adrian Likins <alikins@redhat.com> - 1.3.35-1
359- fix #137151
360- fix #138541
361
362* Wed Oct 27 2004 Adrian Likins <alikins@redhat.com> - 1.3.34-1
363- add code to detect if a module wants to be skipped
364  (basically, stuff to me not show RHN modules on fedora)
365
366* Mon Oct 18 2004 Adrian Likins <alikins@redhat.com> - 1.3.33-1
367- #129885 (do the right thing on ia64)
368- #129532 (typo in display file location)
369
370* Fri Oct 15 2004 Adrian Likins <alikins@redhat.com> - 1.3.30-1
371- merge some updates from rhel3 branch
372- try enabling tui stuff again
373
374* Tue Oct 5 2004 Adrian Likins <alikins@redhat.com> - 1.3.28-1
375- text changes for #129885
376- get rid of some deprecation warnings
377
378* Tue Sep 28 2004 Nils Philippsen <nphilipp@redhat.com> - 1.3.27-1
379- let timezone only be configured on --reconfig (#133748)
380- require system-config-date >= 1.7.9
381
382* Thu Sep 23 2004 Adrian Likins <alikins@redhat.com> - 1.3.26-1
383- applied patch from #132736
384
385* Tue Sep 14 2004 Adrian Likins <alikins@redhat.com> - 1.3.25-1
386- change finish screen to not show default "success"
387  message if were also showing errors
388- fix forward/back behaviour
389
390* Fri Sep 10 2004 Adrian Likins <alikins@redhat.com> - 1.3.23-1
391- fix for finish screen
392- ignore modules that throw exceptions on import
393  (#129532 and other variations of "firstboot doesnt start)
394* Fri Sep 3 2004 Adrian Likins <alikins@redhat.com> - 1.3.21-1
395- more fixes for #131308
396
397* Wed Sep 1 2004 Adrian Likins <alikins@redhat.com> - 1.3.20-1
398- better fix for #131308 (works now, but needs some
399  screen resizing)
400
401* Tue Aug 31 2004 Adrian Likins <alikins@redhat.com> - 1.3.19-1
402- #131308 (system-config-date changed, working to not
403  traceback, still needs more fixing)
404
405* Thu Jul 15 2004 Adrian Likins <alikins@redhat.com> - 1.3.17-1
406- allow screens to catch a signal when they are shown
407
408* Wed Jun 30 2004 Adrian Likins <alikins@redhat.com> - 1.3.16-1
409- apply patch to allow modules to go forward/back in
410  the module order
411
412* Mon Jun 21 2004 Brent Fox <bfox@redhat.com> - 1.3.15-1
413- apply patch from mikem in bug #121489
414
415* Wed May 12 2004 Elliot Lee <sopwith@redhat.com> 1.3.14-1
416- Fix initscript (#121489)
417
418* Mon May  3 2004 Brent Fox <bfox@redhat.com> 1.3.13-1
419- fix Norwegian translation bug (bug #122206)
420
421* Thu Apr 22 2004 Brent Fox <bfox@redhat.com> 1.3.12-1
422- look for xorg.conf, not XF86Config (bug #121489)
423
424* Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 1.3.11-1
425- fix bug #120669
426
427* Wed Apr  7 2004 Brent Fox <bfox@redhat.com> 1.3.10-2
428- allow for correct text mode button translations (bug #120087)
429
430* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 1.3.10-1
431- fix password to be encrypted properly
432
433* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 1.3.9-1
434- more workarounds for selinux (don't use libuser at all for create_user.py
435  for right now)
436
437* Wed Mar 17 2004 Brent Fox <bfox@redhat.com> 1.3.8-1
438- workaround selinux - patch from jeremy
439
440* Tue Mar  9 2004 Brent Fox <bfox@redhat.com> 1.3.7-2
441- fix typo (bug #117867)
442
443* Mon Mar  8 2004 Brent Fox <bfox@redhat.com> 1.3.7-1
444- drop the verbose print statements
445
446* Thu Mar  4 2004 Brent Fox <bfox@redhat.com> 1.3.6-1
447- only call chkconfig -add if /etc/sysconfig/firstboot does not exist
448
449* Mon Mar  1 2004 Brent Fox <bfox@redhat.com> 1.3.5-2
450- remove Requires on system-config-mouse
451
452* Tue Feb 17 2004 Brent Fox <bfox@redhat.com> 1.3.5-1
453- call self.win.present() to allow initial keyboard input
454
455* Mon Feb 16 2004 Brent Fox <bfox@redhat.com> 1.3.4-1
456- UTF-8ify fr.po
457- make sure the root window stays on the bottom (bug #105631)
458
459* Tue Jan 27 2004 Tim Powers <timp@ragnarok.devel.redhat.com> 1.3.3-3
460- fedora-logos -> redhat-logos since redhat-logos is a virtual
461  provides (used so that we can switch out redhat-logos with
462  fedora-logos easily). Will change to system-logos once the changes
463  have been made.
464
465* Fri Jan 23 2004 Bill Nottingham <notting@redhat.com> 1.3.3-2
466- some more s/redhat/system/ on requires
467
468* Mon Dec  1 2003 Brent Fox <bfox@redhat.com> 1.3.2-2
469- redhat-logos hasn't been renamed to system-logos yet
470
471* Mon Nov 24 2003 Brent Fox <bfox@redhat.com> 1.3.2-1
472- make changes for Python2.3
473
474* Sun Nov 23 2003 Brent Fox <bfox@redhat.com> 1.3.2-1
475- update Requires for system-config name change
476- make changes for Python2.3
477
478* Mon Oct 27 2003 Brent Fox <bfox@redhat.com> 1.3.1-1
479- fix initscript for text mode
480
481* Fri Oct 24 2003 Brent Fox <bfox@redhat.com> 1.3.1-1
482- bump version
483- use CVS head now for Fedora Core 2
484- made firstboot-cambridge branch for Fedora Core 1
485- first stab at text mode
486
487* Wed Oct 15 2003 Brent Fox <bfox@redhat.com> 1.2.4-1
488- pull lightrays.png from a different location
489
490* Wed Oct  8 2003 Brent Fox <bfox@redhat.com> 1.2.3-1
491- override rhgb's background
492
493* Wed Oct  8 2003 Brent Fox <bfox@redhat.com> 1.2.2-1
494- remove up2date module from Fedora
495
496* Mon Sep 22 2003 Brent Fox <bfox@redhat.com> 1.2.1-1
497- remove some items from the additional cd's screen for now
498- remove some references to Red Hat Linux from welcome.py and up2date.py
499
500* Fri Aug 29 2003 Brent Fox <bfox@redhat.com> 1.1.16-2
501- bump relnum and rebuild
502
503* Fri Aug 29 2003 Brent Fox <bfox@redhat.com> 1.1.16-1
504- call authconfig with --firstboot flag correctly (bug #103367)
505
506* Thu Aug 28 2003 Brent Fox <bfox@bfox.devel.redhat.com> 1.1.15-2
507- bump relnum and rebuild
508
509* Thu Aug 28 2003 Brent Fox <bfox@bfox.devel.redhat.com> 1.1.15-1
510- handle network timeouts better in the date.py screen
511
512* Thu Aug 28 2003 Brent Fox <bfox@bfox.devel.redhat.com> 1.1.14-1
513- handle cds without autorun files better in additional_cds.py
514
515* Thu Aug 21 2003 Brent Fox <bfox@redhat.com> 1.1.13-3
516- bump relnum and rebuild
517
518* Thu Aug 21 2003 Brent Fox <bfox@redhat.com> 1.1.13-2
519- bump relnum and rebuild
520
521* Thu Aug 21 2003 Brent Fox <bfox@redhat.com> 1.1.13-1
522- pass --firstboot flag to authconfig-gtk in create_user.py
523
524* Tue Aug 19 2003 Brent Fox <bfox@redhat.com> 1.1.12-2
525- bump relnum and rebuild
526
527* Tue Aug 19 2003 Brent Fox <bfox@redhat.com> 1.1.12-1
528- fix formatting bug in create_user.py
529
530* Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 1.1.11-2
531- bump relnum and rebuild
532
533* Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 1.1.11-1
534- run 'chkconfig --del firstboot' when it's done
535
536* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.1.10-1
537- allow underscores and dashes in usernames (bug #99115)
538
539* Wed Aug 13 2003 Brent Fox <bfox@redhat.com> 1.1.9-1
540- replace BuildRequires on python-tools with gettext
541
542* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.8-2
543- bump relnum and rebuild
544
545* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.8-1
546- apply patch from hfuchi@redhat.com for Japanese translation
547
548* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.7-2
549- bump relnum and rebuild
550
551* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.7-1
552- change runPriority in welcome module
553
554* Tue Jul 22 2003 Brent Fox <bfox@redhat.com> 1.1.6-2
555- bump relnum and rebuild
556
557* Tue Jul 22 2003 Brent Fox <bfox@redhat.com> 1.1.6-1
558- resolve conflict between "Next" and "Forward" (bug #100498)
559
560* Fri Jul 18 2003 Brent Fox <bfox@redhat.com> 1.1.5-2
561- bump relnum and rebuild
562
563* Fri Jul 18 2003 Brent Fox <bfox@redhat.com> 1.1.5-1
564- fix conficting nmemonics (bug #99279)
565
566* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.4-2
567- bump relnum and rebuild
568
569* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.4-1
570- remove unneeded code from the neworking module
571
572* Thu Jun 26 2003 Brent Fox <bfox@redhat.com> 1.1.3-1
573- first stab at getting locale changing working (#91984)
574
575* Thu Jun 19 2003 Brent Fox <bfox@redhat.com> 1.1.2-2
576- bump number and rebuild
577
578* Thu Jun 19 2003 Brent Fox <bfox@redhat.com> 1.1.2-1
579- implement networking screen for reconfig mode (bug #91984)
580
581* Mon Jun 16 2003 Brent Fox <bfox@redhat.com> 1.1.1-2
582- bump number and rebuild
583
584* Mon Jun 16 2003 Brent Fox <bfox@redhat.com> 1.1.1-1
585- create a timezone module (bug #91984)
586
587* Tue Jun 10 2003 Brent Fox <bfox@redhat.com> 1.0.12-1
588- change "Forward" button to "Next"
589
590* Fri May 30 2003 Brent Fox <bfox@redhat.com> 1.0.11-1
591- fix traceback in username verification
592
593* Thu May 29 2003 Brent Fox <bfox@redhat.com> 1.0.10-1
594- updated deprecated function call in functions.py
595- don't grab the whole screen in debug mode
596
597* Thu May 22 2003 Brent Fox <bfox@redhat.com> 1.0.9-1
598- remove explicit vt7 argument to X (bug #87636)
599
600* Thu May 22 2003 Brent Fox <bfox@redhat.com> 1.0.8-1
601- pass rhgb status into firstbootWindow.py
602- don't draw background if rhgb isn't running
603
604* Mon May 19 2003 Brent Fox <bfox@redhat.com> 1.0.7-1
605- check to see if rhgb is running
606- if rhgb is running, start up metacity and merge X resources
607
608* Fri May 16 2003 Brent Fox <bfox@redhat.com> 1.0.6-2
609- Added a mnemonic for network login button (bug #90636)
610- added more mnemonics create_user.py (bug #90865)
611
612* Mon Mar 24 2003 Brent Fox <bfox@redhat.com> 1.0.6-1
613- add a button to create_user.py to launch authconfig-gtk
614
615* Fri Mar  7 2003 Brent Fox <bfox@redhat.com> 1.0.5-13
616- bump rev for 3.0E
617
618* Fri Feb 28 2003 Brent Fox <bfox@redhat.com> 1.0.5-12
619- fix bug #85358
620
621* Tue Feb 25 2003 Jeremy Katz <katzj@redhat.com> 1.0.5-11
622- background image name changed (#85160)
623- don't traceback if background doesn't exist
624
625* Mon Feb 24 2003 Nalin Dahyabhai <nalin@redhat.com> 1.0.5-10
626- compare text to string.whitespace, not whitespace (#85038)
627
628* Mon Feb 24 2003 Brent Fox <bfox@redhat.com> 1.0.5-9
629- apply initscript patch from mikem@redhat.com.  Avoids calling telinit (bug #84848)
630
631* Fri Feb 21 2003 Brent Fox <bfox@redhat.com> 1.0.5-8
632- call RGB_DITHER_MAX (bug #84850)
633
634* Thu Feb 20 2003 Brent Fox <bfox@redhat.com> 1.0.5-7
635- fix traceback in create_users.py (bug #84722)
636
637* Tue Feb 18 2003 Brent Fox <bfox@redhat.com> 1.0.5-6
638- add mnemonics to up2date.py (bug #84487)
639
640* Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 1.0.5-5
641- only launch r-c-xfree86 if in runlevel 3 and XF86Config does not exist (bug #84135)
642
643* Tue Feb 11 2003 Brent Fox <bfox@redhat.com> 1.0.5-4
644- fix bug #84068
645
646* Wed Feb  5 2003 Brent Fox <bfox@redhat.com> 1.0.5-3
647- check for empty soundcard list, not list = None
648
649* Mon Feb  3 2003 Brent Fox <bfox@redhat.com> 1.0.5-2
650- notting fixed the initscript to pull in the locale
651
652* Fri Jan 31 2003 Brent Fox <bfox@redhat.com> 1.0.5-1
653- new strings in up2date module
654
655* Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 1.0.4-8
656- don't run firstboot in runlevel 3 at all (bug #78239)
657- fix return tuple if no soundcards are found in soundcard_gui.py
658- use backslash instead of forward slash in the init script
659
660* Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 1.0.4-6
661- give the X server 1 second to close before we exit firstboot (bug #81313)
662
663* Tue Jan 28 2003 Brent Fox <bfox@redhat.com> 1.0.4-5
664- don't use Yes/No dialogs in create_user.py (bug #82680)
665- only use root window mode in non-debug mode
666- make module titles consistent with each other
667
668* Fri Jan 24 2003 Brent Fox <bfox@redhat.com> 1.0.4-4
669- better validity checking for user name and password
670
671* Tue Jan 21 2003 Brent Fox <bfox@redhat.com> 1.0.4-3
672- remove print statement that was causing a traceback
673
674* Mon Jan 20 2003 Brent Fox <bfox@redhat.com> 1.0.4-2
675- use the gdm background as the background image
676
677* Fri Jan 17 2003 Brent Fox <bfox@redhat.com> 1.0.4-1
678- make hboxes transparent and use a new background
679
680* Mon Jan 13 2003 Brent Fox <bfox@redhat.com> 1.0.3-6
681- make it so that we can paint the root window
682
683* Thu Jan  9 2003 Brent Fox <bfox@redhat.com> 1.0.3-5
684- sleep .5 sec on exit (bug #81313)
685
686* Mon Dec 23 2002 Brent Fox <bfox@redhat.com> 1.0.3-4
687- enforce 6 char user passwords
688
689* Sun Dec 22 2002 Brent Fox <bfox@redhat.com> 1.0.3-3
690- require an NTP server if NTP selected in date.py
691
692* Tue Dec 17 2002 Brent Fox <bfox@redhat.com> 1.0.3-2
693- don't run x tool if /etc/sysconfig/firstboot exists
694
695* Mon Dec 02 2002 Brent Fox <bfox@redhat.com> 1.0.3-1
696- Create a message for machines that boot in runlevel 3
697
698* Tue Nov 26 2002 Brent Fox <bfox@redhat.com> 1.0.2-4
699- Mark initscript strings as internationalizable (bug 77826)
700
701* Fri Nov 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
702- exclude mainframe
703
704* Wed Nov 13 2002 Brent Fox <bfox@redhat.com> 1.0.2-3
705- fix soundcard and mouse problem
706
707* Tue Nov 12 2002 Brent Fox <bfox@redhat.com> 1.0.2-2
708- explicitly kill X server pid
709- Latest translations
710
711* Thu Sep 05 2002 Brent Fox <bfox@redhat.com> 1.0.1-10
712- moved some pixmaps to redhat-logos package
713- added a requires for redhat-logos package
714
715* Tue Sep 03 2002 Brent Fox <bfox@redhat.com> 1.0.1-9
716- call dithering magic to make new pixmaps appear correctly
717
718* Tue Sep 03 2002 Brent Fox <bfox@redhat.com> 1.0.1-8
719- get new pixmaps from garrett
720
721* Fri Aug 30 2002 Brent Fox <bfox@redhat.com> 1.0.1-7
722- Wrap umount in a try/except in additional_cds.py
723
724* Fri Aug 30 2002 Brent Fox <bfox@redhat.com> 1.0.1-6
725- run chkconfig on starting/stopping ntpd
726
727* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.0.1-5
728- Make the date screen update the time widgets when the screen is entered
729
730* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.0.1-4
731- Convert po files to UTF-8
732
733* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.0.1-3
734- created a flag so that failed connections to NTP servers don't advance the screens
735- Don't try to display the parent window pixmap gradient
736- Make the parent window background a little darker
737
738* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.1-2
739- Fix typo
740
741* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.1-1
742- Convert to noarch
743- Add a root window mode for firstbootWindow
744- Use a gtkInvisible dialog to block on up2date and the package screen
745
746* Wed Aug 28 2002 Karsten Hopp <karsten@redhat.de> 1.0.0-5
747- don't require config-mouse, config-keyboard, config-soundcard
748  on S390
749
750* Tue Aug 27 2002 Brent Fox <bfox@redhat.com> 1.0.0-4
751- fix hang on unreponsive ntp servers
752 
753* Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 1.0.0-3
754- Don't draw window decorations
755
756* Wed Aug 21 2002 Brent Fox <bfox@redhat.com> 1.0.0-2
757- pull translation domains from rhpl
758
759* Wed Aug 21 2002 Brent Fox <bfox@redhat.com> 1.0.0-1
760- Implement a lowres mode for 640x480 screens
761
762* Thu Aug 15 2002 Brent Fox <bfox@rehdat.com> 0.9.9-13
763- Don't show up2date screen if machine is already registered
764
765* Wed Aug 14 2002 Brent Fox <bfox@redhat.com> 0.9.9-12
766- fix reconfig mode
767- change pixmap on finished screen
768
769* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-11
770- pass None into startNtpService
771
772* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-10
773- If there's no XF86Config file, start redhat-config-xfree86 first
774
775* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-9
776- only start in runlevel 5
777
778* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-8
779- include cd.png
780
781* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-7
782- improved UI on additional cd screen
783
784* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-6
785- Require redhat-config-packages
786- Change string in finished module
787
788* Mon Aug 12 2002 Brent Fox <bfox@redhat.com> 0.9.9-5
789- Print out a message if user tries to run firstboot again
790- move firstboot to firstboot.py and create a shell script for firstboot
791- applied a patch from dburcaw@terraplex.com to check to see if we're run as root
792
793* Mon Aug 12 2002 Brent Fox <bfox@redhat.com> 0.9.9-4
794- Try to fix race condition
795- Have init script return 0 instead of 1
796- Make Forward button grab the focus
797
798* Wed Aug 07 2002 Brent Fox <bfox@redhat.com> 0.9.9-1
799- Rebuild for Jay, who is being a punk ;)
800 
801* Fri Aug 02 2002 Brent Fox <bfox@redhat.com> 0.9.8-1
802- Make changes for new pam timestamp policy
803
804* Thu Aug 01 2002 Brent Fox <bfox@redhat.com> 0.9.7-1
805- fix typo in finished module
806- create better text in the exception screen
807- save traceback info in /tmp/firstboot.txt
808
809* Tue Jul 30 2002 Brent Fox <bfox@redhat.com> 0.9.6-5
810- merge Xresources on startup.  Fixes bug #68724
811
812* Thu Jul 25 2002 Brent Fox <bfox@redhat.com> 0.9.6-4
813- change background color
814- give some padding to the icon box
815- put new splash and text on welcome and finished modules
816
817* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-3
818- fix Makefiles and spec files so that translations get installed
819
820* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-2
821- update spec file for public beta 2
822
823* Tue Jul 23 2002 Brent Fox <bfox@redhat.com> 0.9.6-1
824- removed register module
825- added a finished module
826- pulled in new icons
827
828* Fri Jul 19 2002 Brent Fox <bfox@redhat.com> 0.9.5-1
829- wire up register module
830- wire up up2date module
831- fix pointer pixmap bug
832- create an exceptionWindow to capture tracebacks
833
834* Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.9.4-2
835- bump rev num and rebuild
836
837* Sat Jul 13 2002 Brent Fox <bfox@redhat.com> 0.9.4-1
838- fixed preun script to not blow away runlevel symlinks on upgrades
839
840* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-2
841- Update changelogs and rebuild
842
843* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-1
844- Update changelogs and rebuild
845
846* Mon Jul 01 2002 Brent Fox <bfox@redhat.com> 0.9.2-1
847- Bump rev number
848
849* Fri Jun 28 2002 Brent Fox <bfox@redhat.com> 0.9.1-4
850- Require metacity
851
852* Fri Jun 28 2002 Brent Fox <bfox@redhta.com> 0.9.1-3
853- Backed out some changes from init script
854- Fixed icon path in date module
855
856* Thu Jun 27 2002 Brent Fox <bfox@redhat.com> 0.9.1-2
857- Popup warning for unimplemented features
858
859* Wed Jun 26 2002 Brent Fox <bfox@redhat.com> 0.9.1-1
860- Only run in runlevel 5
861
862* Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.9.0-5
863- Change initscript to not start firstboot on runlevel changes
864
865* Mon Jun 24 2002 Brent Fox <bfox@redhat.com> 0.9.0-4
866- Fix spec file
867
868* Fri Jun 21 2002 Brent Fox <bfox@redhat.com> 0.9.0-3
869- Added snapsrc to makefile
870- Rebuild for completeness
871
872* Wed Jun 12 2002 Brent Fox <bfox@redhat.com> 0.2.0-3
873- Fixed a string error in the welcome module
874
875* Fri May 31 2002 Brent Fox <bfox@redhat.com> 0.2.0-2
876- Some additions to hardware screen
877
878* Fri May 31 2002 Brent Fox <bfox@redhat.com> 0.2.0-1
879- Fix hardare screen's run priority
880
881* Thu May 30 2002 Brent Fox <bfox@redhat.com> 0.1.0-8
882- Created the beginnings of the hardware screen
883
884* Thu May 30 2002 Brent Fox <bfox@redhat.com> 0.1.0-7
885- Fixed Requires to not pull in pygnome
886
887* Tue May 28 2002 Brent Fox <bfox@redhat.com> 0.1.0-6
888- Rebuild for completeness
889- Fix bug in init script
890
891* Sun May 26 2002 Brent Fox <bfox@redhat.com> 0.1.0-4
892- Get startup scripts ready to go
893- Prepare package for placement into newest tree
894- Install init script into correct place
895
896* Tue Nov 28 2001 Brent Fox <bfox@redhat.com>
897- initial coding and packaging
898
Note: See TracBrowser for help on using the repository browser.