source: projects/specs/trunk/f/firstboot/firstboot-vl.spec @ 5701

Revision 5701, 30.0 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1Summary: Initial system configuration utility
2Summary(ja): 初期システム設定ユーティリティ
3
4Name: firstboot
5Version: 1.4.27.3
6Release: 3%{?_dist_release}
7URL: http://fedoraproject.org/wiki/FirstBoot
8License: GPLv2+
9ExclusiveOS: Linux
10Group: System Environment/Base
11Source0: %{name}-%{version}.tar.bz2
12Patch1: firstboot-vine.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildArch: noarch
16Requires(pre): chkconfig
17BuildRequires: gettext
18Requires: pygtk2
19Requires: metacity
20Requires: rhpl
21Requires: rhpxl
22Requires: system-config-display
23#Requires: system-config-language
24#Requires: system-config-soundcard
25Requires: system-config-securitylevel
26Requires: system-config-network
27Requires: system-config-users
28Requires: system-config-date
29Requires: system-config-keyboard
30Requires: authconfig-gtk
31Requires: libuser
32#Requires: system-logos
33Requires: firstboot-tui = %{version}
34ExcludeArch: s390 s390x ppc64
35
36%description
37The firstboot utility runs after installation.  It guides the
38user through a series of steps that allows for easier
39configuration of the machine.
40
41%package tui
42Summary: A text interface for firstboot
43Summary(ja): fistboot のテキストインタフェース
44Group: System Environment/Base
45Requires(post): chkconfig, /etc/init.d
46BuildRequires: gettext
47Requires: python
48Requires: usermode
49Requires: rhpl
50Requires: system-config-securitylevel-tui
51Requires: system-config-network-tui
52Requires: ntsysv
53Requires: authconfig
54
55%description tui
56firstboot-tui is a text interface for initial system configuration.
57
58%prep
59%setup -q
60%patch1 -p1
61
62sed -i -e 's|/usr/bin/python2|/usr/bin/python|g' \
63    src/firstboot src/xfirstboot.py src/firstboot.py
64
65%build
66make
67
68%install
69make INSTROOT=$RPM_BUILD_ROOT install
70
71mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
72echo "RUN_FIRSTBOOT=NO" > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/firstboot
73
74%find_lang %name
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post tui
80if ! [ -f /etc/sysconfig/firstboot ]
81then
82  chkconfig --add firstboot
83fi
84
85%preun
86if [ $1 = 0 ]; then
87  rm -rf /usr/share/firstboot/*.pyc
88  rm -rf /usr/share/firstboot/modules/*.pyc
89fi
90
91%preun tui
92if [ $1 = 0 ]; then
93  chkconfig --del firstboot
94fi
95
96%files -f %{name}.lang
97%defattr(-,root,root)
98%config %{_sysconfdir}/sysconfig/firstboot
99%dir %{_datadir}/firstboot/
100%dir %{_datadir}/firstboot/modules/
101%dir %{_datadir}/firstboot/pixmaps/
102%{_datadir}/firstboot/exceptionWindow.py*
103%{_datadir}/firstboot/firstbootWindow.py*
104%{_datadir}/firstboot/firstboot_module_window.py*
105%{_datadir}/firstboot/xfirstboot.py*
106%{_datadir}/firstboot/modules/*
107%{_datadir}/firstboot/pixmaps/*
108
109%files -f %{name}.lang tui
110%defattr(-,root,root)
111%config %{_sysconfdir}/rc.d/init.d/firstboot
112%dir %{_datadir}/firstboot/
113%{_sbindir}/firstboot
114%{_datadir}/firstboot/constants_text.py*
115%{_datadir}/firstboot/eula_strings.py*
116%{_datadir}/firstboot/firstboot.py*
117%{_datadir}/firstboot/firstbootBackend.py*
118%{_datadir}/firstboot/functions.py*
119%{_datadir}/firstboot/textWindow.py*
120
121
122%changelog
123* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.27.3-3
124- rebuild with python-2.7.2
125
126* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.27.3-2
127- rebuild for Vine 6
128
129* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.27.3-1
130- initial build for Vine Linux
131
132* Fri Nov  9 2007 Karanbir Singh <kbsingh@centos.org> 1.4.27.3-1.el5.centos
133- Roll in CentOS Branding
134
135* Thu Jun 28 2007 Chris Lumens <clumens@redhat.com> 1.4.27.3-1
136- Iterate over all possible CD drives on the additional CD module (#231612).
137- Enable fullscreen mode again; scale sidebar graphics (#211198).
138
139* Mon Jan 15 2007 Chris Lumens <clumens@redhat.com> 1.4.27.2-1
140- Pull in updated gu_IN translation (#222628).
141- Merge in additional CDs patch so it doesn't get dropped.
142
143* Mon Dec 18 2006 Chris Lumens <clumens@redhat.com> 1.4.27.1-1
144- Allow running on s390 and ppc64 under reconfig mode (#217921).
145
146* Wed Dec 13 2006 Chris Lumens <clumens@redhat.com> 1.4.27-1
147- More translation updates (#212958, #198872).
148
149* Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> 1.4.26-1
150- Update translations (#198872).
151
152* Thu Oct 26 2006 Chris Lumens <clumens@redhat.com> 1.4.25-1
153- Require matching versions of firstboot and firstboot-tui.
154- Fix language in non-rhgb graphical case (notting).
155
156* Wed Oct 25 2006 Chris Lumens <clumens@redhat.com> 1.4.24-1
157- Pick up new si_LK translation (#200532).
158- Support noSidebar value for modules (#210697).
159- Fix release number.
160- Do start up in English on CJKI installs in text mode (#211936).
161
162* Mon Oct 02 2006 Chris Lumens <clumens@redhat.com> - 1.4.23-1
163- runPriority can now be a float.
164- Pick up new translations (#208867).
165- Set window to 800x600 instead of fullscreening (#208331, #208620).
166
167* Wed Sep 20 2006 Chris Lumens <clumens@redhat.com> 1.4.22-1
168- Add help output to /etc/init.d/firstboot (#207043).
169- Fix a window manager warning (#206369).
170- Don't start up in English on CJKI installs (#206600).
171
172* Fri Sep 15 2006 Chris Lumens <clumens@redhat.com> 1.4.21-1
173- Use system-config-network-tui instead of netconfig in the text
174  interface.
175- Remove unused methods in the modules.
176
177* Tue Sep 12 2006 Chris Lumens <clumens@redhat.com> 1.4.20-1
178- Don't specify a default color depth.
179- Pull in new translations (#199090).
180
181* Tue Aug 08 2006 Chris Lumens <clumens@redhat.com> 1.4.19-1
182- Don't fill in the Create User UI with whatever user happens to have
183  UID 500 (#200695).
184
185* Wed Aug 02 2006 Chris Lumens <clumens@redhat.com> 1.4.18-1
186- Remove ddc probe support that rhpxl no longer provides.
187
188* Fri Jul 28 2006 Chris Lumens <clumens@redhat.com> 1.4.17-1
189- Pick up new or_IN translation (#200210).
190- Use new rhpxl X startup code.
191
192* Mon Jul 24 2006 Chris Lumens <clumens@redhat.com> 1.4.16-1
193- Fix system-config-soundcard API change.
194- Make sure firstboot starts after HAL (#199899).
195
196* Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 1.4.15-1
197- Really disable the display module.
198
199* Wed Jul 19 2006 Chris Lumens <clumens@redhat.com> 1.4.14-1
200- Disable the display module for now.
201
202* Fri Jul 10 2006 Chris Lumens <clumens@redhat.com> 1.4.13-1
203- Better fix for the no display hardware case (#192808).
204
205* Wed Jun 21 2006 Chris Lumens <clumens@redhat.com> 1.4.12-1
206- Update translation files (#195010).
207- Fix traceback on exiting (#196128).
208
209* Mon Jun 12 2006 Chris Lumens <clumens@redhat.com> 1.4.11-1
210- Don't traceback on the display module if there's no display hardware
211  (#142522).
212- Don't forget about reconfig mode if the timer expires (#170609).
213
214* Fri May 26 2006 Chris Lumens <clumens@redhat.com> 1.4.10-1
215- Fix reconfig mode.
216
217* Fri May 19 2006 Chris Lumens <clumens@redhat.com> 1.4.9-1
218- Make /etc/modprobe.conf reading more robust (#191819).
219- Don't try to call readHTML from anaconda's ICS.
220
221* Mon May 15 2006 Chris Lumens <clumens@redhat.com> 1.4.8-2
222- Require system-logos instead of an OS-specific package (#191407).
223
224* Tue Apr 04 2006 Chris Lumens <clumens@redhat.com> 1.4.8-1
225- Allow firstboot to run in kadischi (#186870).
226- Updated for rhpxl changes.
227
228* Mon Mar 20 2006 Martin Stransky <stransky@redhat.com> 1.4.7-1
229- replaced "Play test button" by "Play" button for s-c-s (#185931)
230- Fix soundcard string (#177425).
231- Fix label inconsistency on welcome screen (#183899).
232- Rework "System User" string (#177940).
233- Don't create a user if a homedir with that username already exists
234  (#143150).
235
236* Fri Mar 03 2006 Chris Lumens <clumens@redhat.com> 1.4.6-1
237- Revert UI changes that broke s-c-keyboard (#183718).
238
239* Wed Mar 01 2006 Chris Lumens <clumens@redhat.com> 1.4.5-1
240- Run if RUN_FIRSTBOOT != "NO" (#180520).
241- Don't let dialog windows hide behind the main window.
242- Remove timeout waiting for server to start.
243
244* Wed Feb 08 2006 Chris Lumens <clumens@redhat.com> 1.4.4-1
245- Get rid of chkconfig --off calls.
246- Smarter checking for if we need to reboot or not.
247
248* Mon Feb 06 2006 Chris Lumens <clumens@redhat.com> 1.4.3-1
249- Tweak firstboot-tui requires to not require X (#180046).
250- Wrap left side labels if they're too long.
251- Remove "Click to Finish" module (#178109).
252- Try to prevent running in runlevel 3 if we failed in runlevel 5
253  (#145169).
254
255* Fri Jan 27 2006 Chris Lumens <clumens@redhat.com> 1.4.2-1
256- Layout cleanups and simplification.
257- Use GTK styles to display the new artwork in non-debug mode.
258
259* Wed Jan 25 2006 Chris Lumens <clumens@redhat.com> 1.4.1-1
260- Fix debug mode.
261- Use the new bubbly artwork (#178106).
262
263* Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 1.4.0-1
264- Split into separate packages for X and no X (#178216).
265
266* Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.3.57-1
267- Use scdMainWindow instead of mainWindow to fix random python import
268  tracebacks.
269
270* Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.3.56-2
271- Remove dependancy on system-config-packages.
272
273* Thu Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.3.56-1
274- Increase timeout on waiting for X to start (#176782).
275- Update translations.
276
277* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
278- rebuilt
279
280* Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 1.3.55-1
281- Fix grammar problems (#143953).
282- Fix traceback on user screen (#175227).
283
284* Wed Nov 30 2005 Chris Lumens <clumens@redhat.com> 1.3.54-1
285- Use system-config-users for user/group/password validation (#174255).
286
287* Wed Nov 16 2005 Chris Lumens <clumens@redhat.com> 1.3.53-1
288- Disable Additional CDs module for now.
289
290* Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 1.3.52-1
291- Set a timeout on waiting for the window manager to start.
292- Correct ps output.
293- Move keyboard initialization to after the modules have been loaded
294  (#133074, #157870).
295
296* Mon Oct 17 2005 Chris Lumens <clumens@redhat.com> 1.3.51-1
297- Fix whrandom deprecation warnings.
298- Fix render_to_drawable deprecation warnings.
299- Change "Next" button on last page to "Finish".
300
301* Tue Oct 11 2005 Chris Lumens <clumens@redhat.com> 1.3.50-1
302- Decrease blank space on finished screen (#144496).
303- Fix import of rhpxl.videocard.
304
305* Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 1.3.49-1
306- Use rhpxl instead of rhpl for X stuff.
307
308* Fri Sep 23 2005 Chris Lumens <clumens@redhat.com> 1.3.48-1
309- Fix autoscreenshot test (#169102).
310- Allow unicode letters in full user names (#169043).
311
312* Thu Sep 15 2005 Jeremy Katz <katzj@redhat.com> - 1.3.47-2
313- exclude arch ppc64 to stop from being included in ppc64 compose where
314  we don't have X
315
316* Thu Sep 15 2005 Chris Lumens <clumens@redhat.com> 1.3.47-1
317- Moved firstboot_gui_window here from rhpl and renamed it to
318  firstboot_module_window.
319- Converted /usr/sbin/firstboot into a python script.
320- Converted the rest of firstboot into a module suitable for importing.
321
322* Tue Sep 13 2005 Chris Lumens <clumens@redhat.com> 1.3.46-1
323- Remove dependancy on up2date (#167663).
324- Use rhpl's X startup code instead of using something different.
325
326* Wed Aug 17 2005 Chris Lumens <clumens@redhat.com> 1.3.45-1
327- Don't fail if no ifcfg script exists for a NIC found in modprobe.conf
328  (#164874).
329- Restore focus after closing dialogs (#143388, #143711).
330
331* Tue Aug 02 2005 Chris Lumens <clumens@redhat.com> 1.3.44-1
332- Allow modules to specify that the system should be rebooted after
333  firstboot has run via the needsReboot module attribute.
334- Enable checking for capital letters in usernames again to be consistent
335  with system-config-users (#164852).
336- Use libuser for adding users again (#164160).
337- Rebuilt translations.
338
339* Thu Jul 07 2005 Chris Lumens <clumens@redhat.com> 1.3.43-1
340- Remove dependancy on xsri (#145807).
341- Fix typo in "additional" (#158435).
342- Tabs vs. spaces consistency (#156456).
343- Don't require system-config-display on ppc64.
344
345* Wed May 25 2005 Jeremy Katz <katzj@redhat.com> - 1.3.42-1
346- Stop using deprecated gtk.{TRUE,FALSE} (#153033)
347
348* Tue May 24 2005 Adrian Likins <alikins@redhat.com> - 1.3.41
349- fix #158095 - Subscription Alert (on first login) on non network installs
350
351* Thu May 19 2005 Adrian Likins <alikins@redhat.com> - 1.3.40
352- fix #154606 - First boot displays "please insert the red hat enterprise linux extras disk"
353
354* Fri Dec 14 2004 Adrian Likins <alikins@redhat.com> - 1.3.39-2
355- really fix #138727 (was looking for cdroms in the wrong place)
356
357* Fri Dec 14 2004 Adrian Likins <alikins@redhat.com> - 1.3.38-1
358- fix #138727 (patch from katzj)
359- latest translations
360
361* Fri Nov 12 2004 Adrian Likins <alikins@redhat.com> - 1.3.37-2
362- fix #139060
363
364* Wed Nov 10 2004 Adrian Likins <alikins@redhat.com> - 1.3.35-1
365- fix #137151
366- fix #138541
367
368* Wed Oct 27 2004 Adrian Likins <alikins@redhat.com> - 1.3.34-1
369- add code to detect if a module wants to be skipped
370  (basically, stuff to me not show RHN modules on fedora)
371
372* Mon Oct 18 2004 Adrian Likins <alikins@redhat.com> - 1.3.33-1
373- #129885 (do the right thing on ia64)
374- #129532 (typo in display file location)
375
376* Fri Oct 15 2004 Adrian Likins <alikins@redhat.com> - 1.3.30-1
377- merge some updates from rhel3 branch
378- try enabling tui stuff again
379
380* Tue Oct 5 2004 Adrian Likins <alikins@redhat.com> - 1.3.28-1
381- text changes for #129885
382- get rid of some deprecation warnings
383
384* Tue Sep 28 2004 Nils Philippsen <nphilipp@redhat.com> - 1.3.27-1
385- let timezone only be configured on --reconfig (#133748)
386- require system-config-date >= 1.7.9
387
388* Thu Sep 23 2004 Adrian Likins <alikins@redhat.com> - 1.3.26-1
389- applied patch from #132736
390
391* Tue Sep 14 2004 Adrian Likins <alikins@redhat.com> - 1.3.25-1
392- change finish screen to not show default "success"
393  message if were also showing errors
394- fix forward/back behaviour
395
396* Fri Sep 10 2004 Adrian Likins <alikins@redhat.com> - 1.3.23-1
397- fix for finish screen
398- ignore modules that throw exceptions on import
399  (#129532 and other variations of "firstboot doesnt start)
400* Fri Sep 3 2004 Adrian Likins <alikins@redhat.com> - 1.3.21-1
401- more fixes for #131308
402
403* Wed Sep 1 2004 Adrian Likins <alikins@redhat.com> - 1.3.20-1
404- better fix for #131308 (works now, but needs some
405  screen resizing)
406
407* Tue Aug 31 2004 Adrian Likins <alikins@redhat.com> - 1.3.19-1
408- #131308 (system-config-date changed, working to not
409  traceback, still needs more fixing)
410
411* Thu Jul 15 2004 Adrian Likins <alikins@redhat.com> - 1.3.17-1
412- allow screens to catch a signal when they are shown
413
414* Wed Jun 30 2004 Adrian Likins <alikins@redhat.com> - 1.3.16-1
415- apply patch to allow modules to go forward/back in
416  the module order
417
418* Mon Jun 21 2004 Brent Fox <bfox@redhat.com> - 1.3.15-1
419- apply patch from mikem in bug #121489
420
421* Wed May 12 2004 Elliot Lee <sopwith@redhat.com> 1.3.14-1
422- Fix initscript (#121489)
423
424* Mon May  3 2004 Brent Fox <bfox@redhat.com> 1.3.13-1
425- fix Norwegian translation bug (bug #122206)
426
427* Thu Apr 22 2004 Brent Fox <bfox@redhat.com> 1.3.12-1
428- look for xorg.conf, not XF86Config (bug #121489)
429
430* Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 1.3.11-1
431- fix bug #120669
432
433* Wed Apr  7 2004 Brent Fox <bfox@redhat.com> 1.3.10-2
434- allow for correct text mode button translations (bug #120087)
435
436* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 1.3.10-1
437- fix password to be encrypted properly
438
439* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 1.3.9-1
440- more workarounds for selinux (don't use libuser at all for create_user.py
441  for right now)
442
443* Wed Mar 17 2004 Brent Fox <bfox@redhat.com> 1.3.8-1
444- workaround selinux - patch from jeremy
445
446* Tue Mar  9 2004 Brent Fox <bfox@redhat.com> 1.3.7-2
447- fix typo (bug #117867)
448
449* Mon Mar  8 2004 Brent Fox <bfox@redhat.com> 1.3.7-1
450- drop the verbose print statements
451
452* Thu Mar  4 2004 Brent Fox <bfox@redhat.com> 1.3.6-1
453- only call chkconfig -add if /etc/sysconfig/firstboot does not exist
454
455* Mon Mar  1 2004 Brent Fox <bfox@redhat.com> 1.3.5-2
456- remove Requires on system-config-mouse
457
458* Tue Feb 17 2004 Brent Fox <bfox@redhat.com> 1.3.5-1
459- call self.win.present() to allow initial keyboard input
460
461* Mon Feb 16 2004 Brent Fox <bfox@redhat.com> 1.3.4-1
462- UTF-8ify fr.po
463- make sure the root window stays on the bottom (bug #105631)
464
465* Tue Jan 27 2004 Tim Powers <timp@ragnarok.devel.redhat.com> 1.3.3-3
466- fedora-logos -> redhat-logos since redhat-logos is a virtual
467  provides (used so that we can switch out redhat-logos with
468  fedora-logos easily). Will change to system-logos once the changes
469  have been made.
470
471* Fri Jan 23 2004 Bill Nottingham <notting@redhat.com> 1.3.3-2
472- some more s/redhat/system/ on requires
473
474* Mon Dec  1 2003 Brent Fox <bfox@redhat.com> 1.3.2-2
475- redhat-logos hasn't been renamed to system-logos yet
476
477* Mon Nov 24 2003 Brent Fox <bfox@redhat.com> 1.3.2-1
478- make changes for Python2.3
479
480* Sun Nov 23 2003 Brent Fox <bfox@redhat.com> 1.3.2-1
481- update Requires for system-config name change
482- make changes for Python2.3
483
484* Mon Oct 27 2003 Brent Fox <bfox@redhat.com> 1.3.1-1
485- fix initscript for text mode
486
487* Fri Oct 24 2003 Brent Fox <bfox@redhat.com> 1.3.1-1
488- bump version
489- use CVS head now for Fedora Core 2
490- made firstboot-cambridge branch for Fedora Core 1
491- first stab at text mode
492
493* Wed Oct 15 2003 Brent Fox <bfox@redhat.com> 1.2.4-1
494- pull lightrays.png from a different location
495
496* Wed Oct  8 2003 Brent Fox <bfox@redhat.com> 1.2.3-1
497- override rhgb's background
498
499* Wed Oct  8 2003 Brent Fox <bfox@redhat.com> 1.2.2-1
500- remove up2date module from Fedora
501
502* Mon Sep 22 2003 Brent Fox <bfox@redhat.com> 1.2.1-1
503- remove some items from the additional cd's screen for now
504- remove some references to Red Hat Linux from welcome.py and up2date.py
505
506* Fri Aug 29 2003 Brent Fox <bfox@redhat.com> 1.1.16-2
507- bump relnum and rebuild
508
509* Fri Aug 29 2003 Brent Fox <bfox@redhat.com> 1.1.16-1
510- call authconfig with --firstboot flag correctly (bug #103367)
511
512* Thu Aug 28 2003 Brent Fox <bfox@bfox.devel.redhat.com> 1.1.15-2
513- bump relnum and rebuild
514
515* Thu Aug 28 2003 Brent Fox <bfox@bfox.devel.redhat.com> 1.1.15-1
516- handle network timeouts better in the date.py screen
517
518* Thu Aug 28 2003 Brent Fox <bfox@bfox.devel.redhat.com> 1.1.14-1
519- handle cds without autorun files better in additional_cds.py
520
521* Thu Aug 21 2003 Brent Fox <bfox@redhat.com> 1.1.13-3
522- bump relnum and rebuild
523
524* Thu Aug 21 2003 Brent Fox <bfox@redhat.com> 1.1.13-2
525- bump relnum and rebuild
526
527* Thu Aug 21 2003 Brent Fox <bfox@redhat.com> 1.1.13-1
528- pass --firstboot flag to authconfig-gtk in create_user.py
529
530* Tue Aug 19 2003 Brent Fox <bfox@redhat.com> 1.1.12-2
531- bump relnum and rebuild
532
533* Tue Aug 19 2003 Brent Fox <bfox@redhat.com> 1.1.12-1
534- fix formatting bug in create_user.py
535
536* Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 1.1.11-2
537- bump relnum and rebuild
538
539* Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 1.1.11-1
540- run 'chkconfig --del firstboot' when it's done
541
542* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.1.10-1
543- allow underscores and dashes in usernames (bug #99115)
544
545* Wed Aug 13 2003 Brent Fox <bfox@redhat.com> 1.1.9-1
546- replace BuildRequires on python-tools with gettext
547
548* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.8-2
549- bump relnum and rebuild
550
551* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.8-1
552- apply patch from hfuchi@redhat.com for Japanese translation
553
554* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.7-2
555- bump relnum and rebuild
556
557* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.7-1
558- change runPriority in welcome module
559
560* Tue Jul 22 2003 Brent Fox <bfox@redhat.com> 1.1.6-2
561- bump relnum and rebuild
562
563* Tue Jul 22 2003 Brent Fox <bfox@redhat.com> 1.1.6-1
564- resolve conflict between "Next" and "Forward" (bug #100498)
565
566* Fri Jul 18 2003 Brent Fox <bfox@redhat.com> 1.1.5-2
567- bump relnum and rebuild
568
569* Fri Jul 18 2003 Brent Fox <bfox@redhat.com> 1.1.5-1
570- fix conficting nmemonics (bug #99279)
571
572* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.4-2
573- bump relnum and rebuild
574
575* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.4-1
576- remove unneeded code from the neworking module
577
578* Thu Jun 26 2003 Brent Fox <bfox@redhat.com> 1.1.3-1
579- first stab at getting locale changing working (#91984)
580
581* Thu Jun 19 2003 Brent Fox <bfox@redhat.com> 1.1.2-2
582- bump number and rebuild
583
584* Thu Jun 19 2003 Brent Fox <bfox@redhat.com> 1.1.2-1
585- implement networking screen for reconfig mode (bug #91984)
586
587* Mon Jun 16 2003 Brent Fox <bfox@redhat.com> 1.1.1-2
588- bump number and rebuild
589
590* Mon Jun 16 2003 Brent Fox <bfox@redhat.com> 1.1.1-1
591- create a timezone module (bug #91984)
592
593* Tue Jun 10 2003 Brent Fox <bfox@redhat.com> 1.0.12-1
594- change "Forward" button to "Next"
595
596* Fri May 30 2003 Brent Fox <bfox@redhat.com> 1.0.11-1
597- fix traceback in username verification
598
599* Thu May 29 2003 Brent Fox <bfox@redhat.com> 1.0.10-1
600- updated deprecated function call in functions.py
601- don't grab the whole screen in debug mode
602
603* Thu May 22 2003 Brent Fox <bfox@redhat.com> 1.0.9-1
604- remove explicit vt7 argument to X (bug #87636)
605
606* Thu May 22 2003 Brent Fox <bfox@redhat.com> 1.0.8-1
607- pass rhgb status into firstbootWindow.py
608- don't draw background if rhgb isn't running
609
610* Mon May 19 2003 Brent Fox <bfox@redhat.com> 1.0.7-1
611- check to see if rhgb is running
612- if rhgb is running, start up metacity and merge X resources
613
614* Fri May 16 2003 Brent Fox <bfox@redhat.com> 1.0.6-2
615- Added a mnemonic for network login button (bug #90636)
616- added more mnemonics create_user.py (bug #90865)
617
618* Mon Mar 24 2003 Brent Fox <bfox@redhat.com> 1.0.6-1
619- add a button to create_user.py to launch authconfig-gtk
620
621* Fri Mar  7 2003 Brent Fox <bfox@redhat.com> 1.0.5-13
622- bump rev for 3.0E
623
624* Fri Feb 28 2003 Brent Fox <bfox@redhat.com> 1.0.5-12
625- fix bug #85358
626
627* Tue Feb 25 2003 Jeremy Katz <katzj@redhat.com> 1.0.5-11
628- background image name changed (#85160)
629- don't traceback if background doesn't exist
630
631* Mon Feb 24 2003 Nalin Dahyabhai <nalin@redhat.com> 1.0.5-10
632- compare text to string.whitespace, not whitespace (#85038)
633
634* Mon Feb 24 2003 Brent Fox <bfox@redhat.com> 1.0.5-9
635- apply initscript patch from mikem@redhat.com.  Avoids calling telinit (bug #84848)
636
637* Fri Feb 21 2003 Brent Fox <bfox@redhat.com> 1.0.5-8
638- call RGB_DITHER_MAX (bug #84850)
639
640* Thu Feb 20 2003 Brent Fox <bfox@redhat.com> 1.0.5-7
641- fix traceback in create_users.py (bug #84722)
642
643* Tue Feb 18 2003 Brent Fox <bfox@redhat.com> 1.0.5-6
644- add mnemonics to up2date.py (bug #84487)
645
646* Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 1.0.5-5
647- only launch r-c-xfree86 if in runlevel 3 and XF86Config does not exist (bug #84135)
648
649* Tue Feb 11 2003 Brent Fox <bfox@redhat.com> 1.0.5-4
650- fix bug #84068
651
652* Wed Feb  5 2003 Brent Fox <bfox@redhat.com> 1.0.5-3
653- check for empty soundcard list, not list = None
654
655* Mon Feb  3 2003 Brent Fox <bfox@redhat.com> 1.0.5-2
656- notting fixed the initscript to pull in the locale
657
658* Fri Jan 31 2003 Brent Fox <bfox@redhat.com> 1.0.5-1
659- new strings in up2date module
660
661* Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 1.0.4-8
662- don't run firstboot in runlevel 3 at all (bug #78239)
663- fix return tuple if no soundcards are found in soundcard_gui.py
664- use backslash instead of forward slash in the init script
665
666* Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 1.0.4-6
667- give the X server 1 second to close before we exit firstboot (bug #81313)
668
669* Tue Jan 28 2003 Brent Fox <bfox@redhat.com> 1.0.4-5
670- don't use Yes/No dialogs in create_user.py (bug #82680)
671- only use root window mode in non-debug mode
672- make module titles consistent with each other
673
674* Fri Jan 24 2003 Brent Fox <bfox@redhat.com> 1.0.4-4
675- better validity checking for user name and password
676
677* Tue Jan 21 2003 Brent Fox <bfox@redhat.com> 1.0.4-3
678- remove print statement that was causing a traceback
679
680* Mon Jan 20 2003 Brent Fox <bfox@redhat.com> 1.0.4-2
681- use the gdm background as the background image
682
683* Fri Jan 17 2003 Brent Fox <bfox@redhat.com> 1.0.4-1
684- make hboxes transparent and use a new background
685
686* Mon Jan 13 2003 Brent Fox <bfox@redhat.com> 1.0.3-6
687- make it so that we can paint the root window
688
689* Thu Jan  9 2003 Brent Fox <bfox@redhat.com> 1.0.3-5
690- sleep .5 sec on exit (bug #81313)
691
692* Mon Dec 23 2002 Brent Fox <bfox@redhat.com> 1.0.3-4
693- enforce 6 char user passwords
694
695* Sun Dec 22 2002 Brent Fox <bfox@redhat.com> 1.0.3-3
696- require an NTP server if NTP selected in date.py
697
698* Tue Dec 17 2002 Brent Fox <bfox@redhat.com> 1.0.3-2
699- don't run x tool if /etc/sysconfig/firstboot exists
700
701* Mon Dec 02 2002 Brent Fox <bfox@redhat.com> 1.0.3-1
702- Create a message for machines that boot in runlevel 3
703
704* Tue Nov 26 2002 Brent Fox <bfox@redhat.com> 1.0.2-4
705- Mark initscript strings as internationalizable (bug 77826)
706
707* Fri Nov 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
708- exclude mainframe
709
710* Wed Nov 13 2002 Brent Fox <bfox@redhat.com> 1.0.2-3
711- fix soundcard and mouse problem
712
713* Tue Nov 12 2002 Brent Fox <bfox@redhat.com> 1.0.2-2
714- explicitly kill X server pid
715- Latest translations
716
717* Thu Sep 05 2002 Brent Fox <bfox@redhat.com> 1.0.1-10
718- moved some pixmaps to redhat-logos package
719- added a requires for redhat-logos package
720
721* Tue Sep 03 2002 Brent Fox <bfox@redhat.com> 1.0.1-9
722- call dithering magic to make new pixmaps appear correctly
723
724* Tue Sep 03 2002 Brent Fox <bfox@redhat.com> 1.0.1-8
725- get new pixmaps from garrett
726
727* Fri Aug 30 2002 Brent Fox <bfox@redhat.com> 1.0.1-7
728- Wrap umount in a try/except in additional_cds.py
729
730* Fri Aug 30 2002 Brent Fox <bfox@redhat.com> 1.0.1-6
731- run chkconfig on starting/stopping ntpd
732
733* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.0.1-5
734- Make the date screen update the time widgets when the screen is entered
735
736* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.0.1-4
737- Convert po files to UTF-8
738
739* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.0.1-3
740- created a flag so that failed connections to NTP servers don't advance the screens
741- Don't try to display the parent window pixmap gradient
742- Make the parent window background a little darker
743
744* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.1-2
745- Fix typo
746
747* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.1-1
748- Convert to noarch
749- Add a root window mode for firstbootWindow
750- Use a gtkInvisible dialog to block on up2date and the package screen
751
752* Wed Aug 28 2002 Karsten Hopp <karsten@redhat.de> 1.0.0-5
753- don't require config-mouse, config-keyboard, config-soundcard
754  on S390
755
756* Tue Aug 27 2002 Brent Fox <bfox@redhat.com> 1.0.0-4
757- fix hang on unreponsive ntp servers
758 
759* Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 1.0.0-3
760- Don't draw window decorations
761
762* Wed Aug 21 2002 Brent Fox <bfox@redhat.com> 1.0.0-2
763- pull translation domains from rhpl
764
765* Wed Aug 21 2002 Brent Fox <bfox@redhat.com> 1.0.0-1
766- Implement a lowres mode for 640x480 screens
767
768* Thu Aug 15 2002 Brent Fox <bfox@rehdat.com> 0.9.9-13
769- Don't show up2date screen if machine is already registered
770
771* Wed Aug 14 2002 Brent Fox <bfox@redhat.com> 0.9.9-12
772- fix reconfig mode
773- change pixmap on finished screen
774
775* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-11
776- pass None into startNtpService
777
778* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-10
779- If there's no XF86Config file, start redhat-config-xfree86 first
780
781* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-9
782- only start in runlevel 5
783
784* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-8
785- include cd.png
786
787* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-7
788- improved UI on additional cd screen
789
790* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-6
791- Require redhat-config-packages
792- Change string in finished module
793
794* Mon Aug 12 2002 Brent Fox <bfox@redhat.com> 0.9.9-5
795- Print out a message if user tries to run firstboot again
796- move firstboot to firstboot.py and create a shell script for firstboot
797- applied a patch from dburcaw@terraplex.com to check to see if we're run as root
798
799* Mon Aug 12 2002 Brent Fox <bfox@redhat.com> 0.9.9-4
800- Try to fix race condition
801- Have init script return 0 instead of 1
802- Make Forward button grab the focus
803
804* Wed Aug 07 2002 Brent Fox <bfox@redhat.com> 0.9.9-1
805- Rebuild for Jay, who is being a punk ;)
806 
807* Fri Aug 02 2002 Brent Fox <bfox@redhat.com> 0.9.8-1
808- Make changes for new pam timestamp policy
809
810* Thu Aug 01 2002 Brent Fox <bfox@redhat.com> 0.9.7-1
811- fix typo in finished module
812- create better text in the exception screen
813- save traceback info in /tmp/firstboot.txt
814
815* Tue Jul 30 2002 Brent Fox <bfox@redhat.com> 0.9.6-5
816- merge Xresources on startup.  Fixes bug #68724
817
818* Thu Jul 25 2002 Brent Fox <bfox@redhat.com> 0.9.6-4
819- change background color
820- give some padding to the icon box
821- put new splash and text on welcome and finished modules
822
823* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-3
824- fix Makefiles and spec files so that translations get installed
825
826* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-2
827- update spec file for public beta 2
828
829* Tue Jul 23 2002 Brent Fox <bfox@redhat.com> 0.9.6-1
830- removed register module
831- added a finished module
832- pulled in new icons
833
834* Fri Jul 19 2002 Brent Fox <bfox@redhat.com> 0.9.5-1
835- wire up register module
836- wire up up2date module
837- fix pointer pixmap bug
838- create an exceptionWindow to capture tracebacks
839
840* Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.9.4-2
841- bump rev num and rebuild
842
843* Sat Jul 13 2002 Brent Fox <bfox@redhat.com> 0.9.4-1
844- fixed preun script to not blow away runlevel symlinks on upgrades
845
846* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-2
847- Update changelogs and rebuild
848
849* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-1
850- Update changelogs and rebuild
851
852* Mon Jul 01 2002 Brent Fox <bfox@redhat.com> 0.9.2-1
853- Bump rev number
854
855* Fri Jun 28 2002 Brent Fox <bfox@redhat.com> 0.9.1-4
856- Require metacity
857
858* Fri Jun 28 2002 Brent Fox <bfox@redhta.com> 0.9.1-3
859- Backed out some changes from init script
860- Fixed icon path in date module
861
862* Thu Jun 27 2002 Brent Fox <bfox@redhat.com> 0.9.1-2
863- Popup warning for unimplemented features
864
865* Wed Jun 26 2002 Brent Fox <bfox@redhat.com> 0.9.1-1
866- Only run in runlevel 5
867
868* Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.9.0-5
869- Change initscript to not start firstboot on runlevel changes
870
871* Mon Jun 24 2002 Brent Fox <bfox@redhat.com> 0.9.0-4
872- Fix spec file
873
874* Fri Jun 21 2002 Brent Fox <bfox@redhat.com> 0.9.0-3
875- Added snapsrc to makefile
876- Rebuild for completeness
877
878* Wed Jun 12 2002 Brent Fox <bfox@redhat.com> 0.2.0-3
879- Fixed a string error in the welcome module
880
881* Fri May 31 2002 Brent Fox <bfox@redhat.com> 0.2.0-2
882- Some additions to hardware screen
883
884* Fri May 31 2002 Brent Fox <bfox@redhat.com> 0.2.0-1
885- Fix hardare screen's run priority
886
887* Thu May 30 2002 Brent Fox <bfox@redhat.com> 0.1.0-8
888- Created the beginnings of the hardware screen
889
890* Thu May 30 2002 Brent Fox <bfox@redhat.com> 0.1.0-7
891- Fixed Requires to not pull in pygnome
892
893* Tue May 28 2002 Brent Fox <bfox@redhat.com> 0.1.0-6
894- Rebuild for completeness
895- Fix bug in init script
896
897* Sun May 26 2002 Brent Fox <bfox@redhat.com> 0.1.0-4
898- Get startup scripts ready to go
899- Prepare package for placement into newest tree
900- Install init script into correct place
901
902* Tue Nov 28 2001 Brent Fox <bfox@redhat.com>
903- initial coding and packaging
904
Note: See TracBrowser for help on using the repository browser.