source: projects/specs/trunk/f/file/file-vl.spec @ 8236

Revision 8236, 10.7 KB checked in by iwaim, 10 years ago (diff)

file 5.14-1

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3%define __libtoolize :
4
5Summary: A utility for determining file types.
6Summary(ja): ファイルの種類を判別するユーティリティー
7Name: file
8Version: 5.14
9Release: 1%{?_dist_release}
10License: BSD
11Group: Applications/System
12Obsoletes: file-static
13
14Source0: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
15
16# Addtional magic file for Vine
17Source10: magic.printer-j
18
19# Upstream says it's up to distributions to add a way to support local-magic.
20Patch0: file-localmagic.patch
21# sent upstream - should be included in next upstream release
22Patch1: file-5.10-strength.patch
23Patch2: file-5.10-sticky-bit.patch
24Patch3: file-4.17-rpm-name.patch
25Patch4: file-5.04-volume_key.patch
26Patch5: file-5.04-man-return-code.patch
27Patch6: file-5.04-generic-msdos.patch
28Patch7: file-5.14-x86boot.patch
29Patch8: file-5.14-perl.patch
30Patch9: file-5.14-elfspace.patch
31Patch10: file-5.14-bad-fsmagic-space.patch
32Patch11: file-5.14-no-magic.patch
33Patch12: file-5.14-journald.patch
34Patch13: file-5.14-magic_load.patch
35
36#Vine
37Patch100: file-5.14-magicbuild-fix.patch
38
39Buildroot: %{_tmppath}/%{name}-%{version}-root
40#BuildRequires: automake
41#BuildRequires: autoconf
42BuildRequires: zlib-devel
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: daisuke
47
48%description
49The file command is used to identify a particular file according to the
50type of data contained by the file.  File can identify many different
51file types, including ELF binaries, system libraries, RPM packages, and
52different graphics formats.
53
54You should install the file package, since the file command is such a
55useful utility.
56
57%description -l ja
58file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
59どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
60ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
61を含む、多くの異なるファイルの種類を見分けることができます。
62
63
64%package devel
65Summary:  Libraries and header files for file development
66Summary(ja): libmagic の開発用ファイル
67Group:    Development/Libraries
68Requires: %{name} = %{version}-%{release}
69
70%description devel
71The file-devel package contains the header files and libmagic library
72necessary for developing programs using libmagic.
73
74%package -n python-magic
75Summary: Python bindings for the libmagic API
76Group:   Development/Libraries
77BuildRequires: python-devel
78Requires: %{name} = %{version}-%{release}
79
80%description -n python-magic
81This package contains the Python bindings to allow access to the
82libmagic API. The libmagic library is also used by the familiar
83file(1) command.
84
85
86%prep
87%setup -q
88# Don't use -b -- it will lead to poblems when compiling magic file!
89%patch0 -p1
90%patch1 -p1
91%patch2 -p1
92%patch3 -p1
93%patch4 -p1
94%patch5 -p1
95%patch6 -p1
96%patch7 -p1
97%patch8 -p1
98%patch9 -p1
99%patch10 -p1
100%patch11 -p1
101%patch12 -p1
102%patch13 -p1
103
104#Vine
105%patch100 -p1
106
107cat %{SOURCE10} >> ./magic/Localstuff
108
109iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
110touch -r doc/libmagic.man doc/libmagic.man_
111mv doc/libmagic.man_ doc/libmagic.man
112
113%build
114autoreconf
115CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
116%configure --enable-fsect-man5 --disable-rpath
117# remove hardcoded library paths from local libtool
118sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
119sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
120export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
121make
122
123cd python
124CFLAGS="%{optflags}" %{__python} setup.py build
125
126%install
127rm -rf $RPM_BUILD_ROOT
128mkdir -p $RPM_BUILD_ROOT%{_bindir}
129mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
130mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
131mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
132mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
133mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
134
135make install DESTDIR=$RPM_BUILD_ROOT
136
137cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
138ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
139##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
140ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
141
142cd python
143%{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT}
144%{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
145
146
147# LIBTOOL=/usr/bin/libtool
148#ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
149#ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
150
151#ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
152
153#{ cd ${RPM_BUILD_ROOT}
154#  strip .%{_bindir}/file
155#  cp %SOURCE1 .%{_datadir}/magic.mime
156#}
157
158# remove unuse files
159rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164%post -p /sbin/ldconfig
165
166%postun -p /sbin/ldconfig
167
168
169%files
170%defattr(-,root,root)
171%doc COPYING ChangeLog README
172%{_bindir}/*
173%{_libdir}/libmagic.so.*
174%{_datadir}/file/*
175%{_datadir}/magic*
176%{_datadir}/misc/*
177%{_mandir}/man[15]/*
178
179%files devel
180%defattr(-,root,root,-)
181%{_libdir}/*.so
182%{_includedir}/magic.h
183%{_mandir}/man3/*
184
185%files -n python-magic
186%defattr(-, root, root, -)
187%doc python/README COPYING python/example.py
188%{python_sitelib}/magic.py
189%{python_sitelib}/magic.pyc
190%{python_sitelib}/magic.pyo
191%{python_sitelib}/*egg-info
192
193
194%changelog
195* Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
196- new upstream reelase
197- add patch100 to fix build error
198- remove -static subpackage and add Obs: file-static
199- fix old changelog date...
200
201* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
202- new upstream reelase
203- drop all local patches
204- import fedora patches
205
206* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
207- rebuild with python-2.7.2
208
209* Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
210- rebuild package
211- fix Patch100
212
213* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
214- new upstream release
215- updated Vine patches (but Patch100 has not been ported yet...)
216- split to devel and static subpackcages
217
218* Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
219- rebuilt with rpm-4.8.1
220- add environment variable LIBTOOL for make command
221
222* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
223- spec in utf-8
224- removed *.la
225
226* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
227- applied new versioning policy
228
229* Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
230- new upstream release
231- import debian/fedora patches
232- drop obsolete vine magic.
233
234* Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
235- rebuild for VineSeed with new tool chain
236
237* Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
238- add patch110 for fix CVE-2007-2799
239- add zlib-devel to BuildPreReq tag
240
241* Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
242- add patch100 for fix CVE-2007-1536
243
244* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
245- changed Group to Applications/System
246
247* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
248- new upstream release
249- update vine patches
250
251* Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
252- update Patch10, use 'size_t' in src/jcode.[ch]
253
254* Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
255- update to 4.03
256- update Patch0, 1, 10 for 4.03
257- s/Copyright/License/
258
259* Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
260- update to 4.02
261- update Vine patches for 4.02
262
263* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
264- new upstream release
265  - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
266- remove unneeded patches.
267- update Vine patches for 3.41
268
269* Mon Apr  1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
270- added NPDL2 data [Vine:02348]
271
272* Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
273- update to 3.37
274
275* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
276- 3.35-0vl3
277- disable some entries in elf for problems on big-endian archs
278
279* Wed Jun  6 2001 Jun Nishii <jun@vinelinux.org>
280- file-3.35-0vl1
281- ver.up
282- added %doc
283
284* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
285- file-3.33-1vl4
286- more fix and clean up jtext patch (file-3.33-vinejtext.patch)
287
288* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
289- file-3.33-1vl3
290- fix again jtext patch (file-3.33-vinejtext.patch)
291- added file-3.33-vinenames.patch to avoid miss-judgement
292
293* Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
294- file-3.33-1vl2
295- update jtext patch (file-3.33-vinejtext.patch)
296
297* Mon Jan  8 2001 Jun Nishii <jun@vinelinux.org>
298- file-3.33-1vl1
299- modify description-ja and spec
300
301* Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
302- file-3.28-2vl2
303- fixed %files section to handle compressed man pages
304
305* Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
306- marged RH 3.28-2 and Vine 3.27-3vl3
307
308* Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
309- add ia64 patch from rth
310
311* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
312- handle compressed manpages
313- update to 3.28
314
315* Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
316- Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
317
318* Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
319- patch  dues not apply bug.
320
321* Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
322- not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
323- ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
324
325* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
326- identify ELF stripped files correctly (#4665).
327- use SPARC (not sparc) consistently throughout (#4665).
328- add entries for MS Office files (#4665).
329
330* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
331- diddle magic so that *.tfm files are identified correctly.
332
333* Tue Jul  6 1999 Jeff Johnson <jbj@redhat.com>
334- update to 3.27.
335
336* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
337- experimental support for realmedia files added
338
339* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
340- auto rebuild in the new build environment (release 5)
341
342* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
343- strip binary.
344
345* Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
346- add SPARC V9 magic.
347
348* Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
349- update to 3.26.
350
351* Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
352- update to 3.25.
353- detect gimp XCF versions.
354
355* Thu May 07 1998 Prospector System <bugs@redhat.com>
356- translations modified for de, fr, tr
357
358* Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
359- updated to 3.24
360- buildrooted
361
362* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
363- built against glibc
364
365* Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
366- Fixed problems caused by 64 bit time_t.
367
368* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
369- Improved recognition of Linux kernel images.
Note: See TracBrowser for help on using the repository browser.