source: projects/specs/trunk/f/file/file-vl.spec @ 521

Revision 521, 7.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define __libtoolize :
2Summary: A utility for determining file types.
3Summary(ja): ファイルの種類を判別するユーティリティー
4Name: file
5Version: 4.21
6Release: 2%{?_dist_release}
7License: Distributable
8Group: Applications/System
9URL:    http://www.darwinsys.com/file/
10
11Source: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
12Source1: magic.mime
13# Source for Vine
14Source6: printer-j.magic2
15
16Patch1: file-4.19-debian.patch
17Patch3: file-4.21-magic.patch
18Patch5: file-4.13-fsdump.patch
19Patch6: file-4.13-quick.patch
20Patch8: file-4.15-berkeley.patch
21Patch12: file-4.16-xen.patch
22Patch16: file-4.21-oracle.patch
23Patch17: file-4.17-clamav.patch
24Patch20: file-4.17-bash.patch
25Patch21: file-4.19-ELF.patch
26Patch22: file-4.19-ooffice.patch
27patch23: file-4.21-core_from.patch
28patch24: file-4.21-msoffice.patch
29
30# Vine patch
31Patch100: file-4.21-jtext.patch
32Patch110: file-4.21-vinemagic.patch
33Patch120: file-4.09-vinenames.patch
34
35Buildroot: %{_tmppath}/%{name}-%{version}-root
36BuildRequires: automake, autoconf, zlib-devel
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42The file command is used to identify a particular file according to the
43type of data contained by the file.  File can identify many different
44file types, including ELF binaries, system libraries, RPM packages, and
45different graphics formats.
46
47You should install the file package, since the file command is such a
48useful utility.
49
50%description -l ja
51ファイルコマンドは、ファイルに含まれるデータの種類によって各ファイルが
52どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
53ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
54を含む、多くの異なるファイルの種類を見分けることができます。
55
56file コマンドは大変役に立つユーティリティーなので、必ずインストールして
57ください。
58
59%prep
60%setup -q
61
62%patch1 -p1 -b .debian
63%patch3 -p1 -b .magic
64%patch5 -p1 -b .fsdump
65%patch6 -p1 -b .quick
66%patch8 -p1 -b .berkeley
67%patch12 -p1 -b .xen
68%patch16 -p1 -b .oracle
69%patch17 -p1 -b .clamav
70%patch20 -p1 -b .bash
71%patch21 -p1 -b .ELF
72%patch22 -p1 -b .ooffice
73%patch23 -p1 -b .core_from
74%patch24 -p1 -b .msoffice
75
76%patch100 -p1 -b .vinejtext
77%patch110 -p1 -b .vinemagic
78%patch120 -p1 -b .vinenames
79
80cp -p %{SOURCE6} ./magic/Magdir/printer-j
81
82%build
83autoreconf
84CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
85%configure --enable-fsect-man5
86make
87
88%install
89rm -rf ${RPM_BUILD_ROOT}
90mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
91mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
92mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man5
93mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/misc
94
95%makeinstall
96ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
97ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
98
99ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
100
101{ cd ${RPM_BUILD_ROOT}
102  strip .%{_bindir}/file
103  cp %SOURCE1 .%{_datadir}/magic.mime
104}
105## remove unuse files
106rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
107
108
109%clean
110rm -rf ${RPM_BUILD_ROOT}
111
112%files
113%defattr(-,root,root)
114%doc LEGAL.NOTICE README
115%{_bindir}/*
116%{_libdir}/libmagic.so.*
117%{_datadir}/file/*
118%{_datadir}/magic*
119%{_datadir}/misc/*
120%{_mandir}/man[15]/*
121
122%{_includedir}/magic.h
123%{_libdir}/libmagic.a
124%{_libdir}/libmagic.so
125%{_mandir}/man3/*
126
127
128%changelog
129* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
130- spec in utf-8
131- removed *.la
132
133* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
134- applied new versioning policy
135
136* Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
137- new upstream release
138- import debian/fedora patches
139- drop obsolete vine magic.
140
141* Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
142- rebuild for VineSeed with new tool chain
143
144* Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
145- add patch110 for fix CVE-2007-2799
146- add zlib-devel to BuildPreReq tag
147
148* Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
149- add patch100 for fix CVE-2007-1536
150
151* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
152- changed Group to Applications/System
153
154* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
155- new upstream release
156- update vine patches
157
158* Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
159- update Patch10, use 'size_t' in src/jcode.[ch]
160
161* Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
162- update to 4.03
163- update Patch0, 1, 10 for 4.03
164- s/Copyright/License/
165
166* Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
167- update to 4.02
168- update Vine patches for 4.02
169
170* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
171- new upstream release
172  - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
173- remove unneeded patches.
174- update Vine patches for 3.41
175
176* Mon Apr  1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
177- added NPDL2 data [Vine:02348]
178
179* Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
180- update to 3.37
181
182* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
183- 3.35-0vl3
184- disable some entries in elf for problems on big-endian archs
185
186* Wed Jun  6 2001 Jun Nishii <jun@vinelinux.org>
187- file-3.35-0vl1
188- ver.up
189- added %doc
190
191* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
192- file-3.33-1vl4
193- more fix and clean up jtext patch (file-3.33-vinejtext.patch)
194
195* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
196- file-3.33-1vl3
197- fix again jtext patch (file-3.33-vinejtext.patch)
198- added file-3.33-vinenames.patch to avoid miss-judgement
199
200* Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
201- file-3.33-1vl2
202- update jtext patch (file-3.33-vinejtext.patch)
203
204* Mon Jan  8 2001 Jun Nishii <jun@vinelinux.org>
205- file-3.33-1vl1
206- modify description-ja and spec
207
208* Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
209- file-3.28-2vl2
210- fixed %files section to handle compressed man pages
211
212* Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
213- marged RH 3.28-2 and Vine 3.27-3vl3
214
215* Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
216- add ia64 patch from rth
217
218* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
219- handle compressed manpages
220- update to 3.28
221
222* Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
223- Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
224
225* Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
226- patch  dues not apply bug.
227
228* Wed Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
229- not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
230- ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
231
232* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
233- identify ELF stripped files correctly (#4665).
234- use SPARC (not sparc) consistently throughout (#4665).
235- add entries for MS Office files (#4665).
236
237* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
238- diddle magic so that *.tfm files are identified correctly.
239
240* Tue Jul  6 1999 Jeff Johnson <jbj@redhat.com>
241- update to 3.27.
242
243* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
244- experimental support for realmedia files added
245
246* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
247- auto rebuild in the new build environment (release 5)
248
249* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
250- strip binary.
251
252* Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
253- add SPARC V9 magic.
254
255* Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
256- update to 3.26.
257
258* Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
259- update to 3.25.
260- detect gimp XCF versions.
261
262* Thu May 07 1998 Prospector System <bugs@redhat.com>
263- translations modified for de, fr, tr
264
265* Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
266- updated to 3.24
267- buildrooted
268
269* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
270- built against glibc
271
272* Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
273- Fixed problems caused by 64 bit time_t.
274
275* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
276- Improved recognition of Linux kernel images.
Note: See TracBrowser for help on using the repository browser.