source: projects/specs/trunk/f/file/file-vl.spec @ 12278

Revision 12278, 12.7 KB checked in by tomop, 5 years ago (diff)

updated 8 packages

apr-1.7.0-1

busybox-1.30.1-1

file-5.37-1

libgsf-1.14.46-1

libsndfile-1.0.28-2

subversion-1.12.2-1

uClibc-ng-1.0.32-1

wireshark-3.0.5-1

Line 
1%define __libtoolize :
2
3Summary:        A utility for determining file types.
4Summary(ja):    ファイルの種類を判別するユーティリティー
5Name:           file
6Version:        5.37
7Release:        1%{?_dist_release}
8Group:          Applications/System
9License:        BSD
10
11URL:            http://www.darwinsys.com/file/
12# master site is toooooooooooooooooo slow
13# Source0:        ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
14%define         altver %(echo %{version} | sed -e 's/\\./_/')
15Source0:        https://github.com/file/file/archive/FILE%{altver}.tar.gz#/file-FILE%{altver}.tar.gz
16
17# Addtional magic file for Vine
18Source10: magic.printer-j
19
20# Upstream says it's up to distributions to add a way to support local-magic.
21Patch0: file-localmagic.patch
22
23# not yet upstream
24Patch3: file-4.17-rpm-name.patch
25Patch4: file-5.04-volume_key.patch
26
27# fix double free on read error (#1685217)
28Patch14: file-5.37-double-free.patch
29
30# Vine
31Patch1000: file-5.14-magicbuild-fix.patch
32
33# Security
34#  none
35
36Buildroot: %{_tmppath}/%{name}-%{version}-root
37#BuildRequires: automake
38#BuildRequires: autoconf
39BuildRequires: zlib-devel
40Obsoletes: file-static
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: daisuke
45
46%description
47The file command is used to identify a particular file according to the
48type of data contained by the file.  File can identify many different
49file types, including ELF binaries, system libraries, RPM packages, and
50different graphics formats.
51
52You should install the file package, since the file command is such a
53useful utility.
54
55%description -l ja
56file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
57どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
58ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
59を含む、多くの異なるファイルの種類を見分けることができます。
60
61
62%package devel
63Summary:  Libraries and header files for file development
64Summary(ja): libmagic の開発用ファイル
65Group:    Development/Libraries
66Requires: %{name} = %{version}-%{release}
67
68%description devel
69The file-devel package contains the header files and libmagic library
70necessary for developing programs using libmagic.
71
72%package -n python-magic
73Summary: Python bindings for the libmagic API
74Group:   Development/Libraries
75BuildRequires: python-devel
76BuildRequires: python-setuptools
77BuildRequires: python-rpm-macros
78
79Requires: %{name} = %{version}-%{release}
80
81%description -n python-magic
82This package contains the Python bindings to allow access to the
83libmagic API. The libmagic library is also used by the familiar
84file(1) command.
85
86%package -n python3-magic
87Summary: Python bindings for the libmagic API
88Group:   Development/Libraries
89BuildRequires: python3-devel
90BuildRequires: python3-setuptools
91BuildRequires: python3-rpm-macros
92
93Requires: %{name} = %{version}-%{release}
94
95%description -n python3-magic
96This package contains the Python bindings to allow access to the
97libmagic API. The libmagic library is also used by the familiar
98file(1) command.
99
100
101%prep
102%setup -q -n file-FILE%{altver}
103autoreconf -ivf
104# Don't use -b -- it will lead to problems when compiling magic file!
105%patch0 -p1
106%patch3 -p1
107%patch4 -p1
108%patch14 -p1
109
110# Vine
111%patch1000 -p1
112
113# Security
114#  none
115
116cat %{SOURCE10} >> ./magic/Localstuff
117
118iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
119touch -r doc/libmagic.man doc/libmagic.man_
120mv doc/libmagic.man_ doc/libmagic.man
121
122%build
123autoreconf
124CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
125%configure --enable-fsect-man5 --disable-rpath
126# remove hardcoded library paths from local libtool
127sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
128sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
129export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
130make
131
132cd python
133%py_build
134%py3_build
135
136%install
137rm -rf $RPM_BUILD_ROOT
138mkdir -p $RPM_BUILD_ROOT%{_bindir}
139mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
140mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
141mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
142mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
143mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
144
145make install DESTDIR=$RPM_BUILD_ROOT
146
147cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
148ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
149##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
150ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
151
152cd python
153%py_install
154%py3_install
155
156%{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
157
158
159# LIBTOOL=/usr/bin/libtool
160#ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
161#ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
162
163#ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
164
165#{ cd ${RPM_BUILD_ROOT}
166#  strip .%{_bindir}/file
167#  cp %SOURCE1 .%{_datadir}/magic.mime
168#}
169
170# remove unuse files
171rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
172
173%clean
174rm -rf $RPM_BUILD_ROOT
175
176%post -p /sbin/ldconfig
177
178%postun -p /sbin/ldconfig
179
180
181%files
182%defattr(-,root,root)
183%license COPYING
184%doc ChangeLog README
185%{_bindir}/*
186%{_libdir}/libmagic.so.*
187%{_datadir}/file/*
188%{_datadir}/magic*
189%{_datadir}/misc/*
190%{_mandir}/man[15]/*
191
192%files devel
193%defattr(-,root,root,-)
194%{_libdir}/*.so
195%{_includedir}/magic.h
196%{_mandir}/man3/*
197
198%files -n python-magic
199%defattr(-, root, root, -)
200%license python/LICENSE
201%doc python/README* python/example.py
202%{python_sitelib}/magic.py
203%{python_sitelib}/magic.pyc
204%{python_sitelib}/magic.pyo
205%{python_sitelib}/*egg-info
206
207%files -n python3-magic
208%defattr(-, root, root, -)
209%license python/LICENSE
210%doc python/README* python/example.py
211%{python3_sitelib}/*
212
213
214%changelog
215* Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-1
216- new upstream release.
217- added python3 support.
218- updated Patch0.
219- dropped Patch1, 5-17 and 100: fixed in upstream.
220- imported Patch14 from rawhide.
221
222* Thu Jul 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.28-1
223- new upstream release.
224- dropped Patch200: fixed in upstream.
225- updated patches.
226- imported Patch15,17 and 100.
227
228* Sat Nov 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.20-1
229- new upstream release
230- update/drop patches based on fc22
231
232* Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.14-7
233- reflected 6.0 updates and bumped release
234  * Thu Sep 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-6
235  - drop patch230 (moved to patch320)
236  - add Patch240 for fix CVE-2014-0207
237  - add Patch250 for fix CVE-2014-0237
238  - add Patch260 for fix CVE-2014-0238
239  - add Patch270 for fix CVE-2014-3478
240  - add Patch280 for fix CVE-2014-3479
241  - add Patch290 for fix CVE-2014-3480
242  - add Patch300 for fix CVE-2014-3487
243  - add Patch310 for fix CVE-2014-3538
244  - add Patch320 for fix CVE-2014-3587
245    These patches are from debian/ubuntu, thanks.
246  * Thu Aug 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-5
247  - add patch230 for fix CVE-2014-3587 (cdf_read_property_info)
248  * Thu Mar 27 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-4
249  - add patch110,220 for fix regression of CVE-2014-2270
250  * Wed Mar 12 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-3
251  - add patch210 for fix CVE-2014-2270
252  * Thu Feb 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-2
253  - add patch200 for fix CVE-2014-1943
254
255* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.14-2
256- rebuild with VineSeed environment
257
258* Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
259- new upstream reelase
260- add patch100 to fix build error
261- remove -static subpackage and add Obs: file-static
262- fix old changelog date...
263
264* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
265- new upstream reelase
266- drop all local patches
267- import fedora patches
268
269* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
270- rebuild with python-2.7.2
271
272* Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
273- rebuild package
274- fix Patch100
275
276* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
277- new upstream release
278- updated Vine patches (but Patch100 has not been ported yet...)
279- split to devel and static subpackcages
280
281* Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
282- rebuilt with rpm-4.8.1
283- add environment variable LIBTOOL for make command
284
285* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
286- spec in utf-8
287- removed *.la
288
289* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
290- applied new versioning policy
291
292* Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
293- new upstream release
294- import debian/fedora patches
295- drop obsolete vine magic.
296
297* Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
298- rebuild for VineSeed with new tool chain
299
300* Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
301- add patch110 for fix CVE-2007-2799
302- add zlib-devel to BuildPreReq tag
303
304* Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
305- add patch100 for fix CVE-2007-1536
306
307* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
308- changed Group to Applications/System
309
310* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
311- new upstream release
312- update vine patches
313
314* Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
315- update Patch10, use 'size_t' in src/jcode.[ch]
316
317* Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
318- update to 4.03
319- update Patch0, 1, 10 for 4.03
320- s/Copyright/License/
321
322* Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
323- update to 4.02
324- update Vine patches for 4.02
325
326* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
327- new upstream release
328  - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
329- remove unneeded patches.
330- update Vine patches for 3.41
331
332* Mon Apr  1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
333- added NPDL2 data [Vine:02348]
334
335* Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
336- update to 3.37
337
338* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
339- 3.35-0vl3
340- disable some entries in elf for problems on big-endian archs
341
342* Wed Jun  6 2001 Jun Nishii <jun@vinelinux.org>
343- file-3.35-0vl1
344- ver.up
345- added %doc
346
347* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
348- file-3.33-1vl4
349- more fix and clean up jtext patch (file-3.33-vinejtext.patch)
350
351* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
352- file-3.33-1vl3
353- fix again jtext patch (file-3.33-vinejtext.patch)
354- added file-3.33-vinenames.patch to avoid miss-judgement
355
356* Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
357- file-3.33-1vl2
358- update jtext patch (file-3.33-vinejtext.patch)
359
360* Mon Jan  8 2001 Jun Nishii <jun@vinelinux.org>
361- file-3.33-1vl1
362- modify description-ja and spec
363
364* Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
365- file-3.28-2vl2
366- fixed %files section to handle compressed man pages
367
368* Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
369- marged RH 3.28-2 and Vine 3.27-3vl3
370
371* Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
372- add ia64 patch from rth
373
374* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
375- handle compressed manpages
376- update to 3.28
377
378* Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
379- Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
380
381* Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
382- patch  dues not apply bug.
383
384* Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
385- not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
386- ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
387
388* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
389- identify ELF stripped files correctly (#4665).
390- use SPARC (not sparc) consistently throughout (#4665).
391- add entries for MS Office files (#4665).
392
393* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
394- diddle magic so that *.tfm files are identified correctly.
395
396* Tue Jul  6 1999 Jeff Johnson <jbj@redhat.com>
397- update to 3.27.
398
399* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
400- experimental support for realmedia files added
401
402* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
403- auto rebuild in the new build environment (release 5)
404
405* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
406- strip binary.
407
408* Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
409- add SPARC V9 magic.
410
411* Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
412- update to 3.26.
413
414* Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
415- update to 3.25.
416- detect gimp XCF versions.
417
418* Thu May 07 1998 Prospector System <bugs@redhat.com>
419- translations modified for de, fr, tr
420
421* Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
422- updated to 3.24
423- buildrooted
424
425* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
426- built against glibc
427
428* Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
429- Fixed problems caused by 64 bit time_t.
430
431* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
432- Improved recognition of Linux kernel images.
Note: See TracBrowser for help on using the repository browser.