source: projects/specs/trunk/f/file/file-vl.spec @ 12531

Revision 12531, 12.8 KB checked in by tomop, 3 years ago (diff)

updated 10 packages

file-5.39-1

jansson-2.13.1-1

lz4-1.9.3-1

libarchive-3.5.1-1

libcap-ng-0.8.2-1

libevent-2.1.12-1

libnet-1.2-1

nss-3.61-1

openssl-1.1.1j-1

zstd-1.4.8-1

RevLine 
[521]1%define __libtoolize :
[2679]2
[12278]3Summary:        A utility for determining file types.
4Summary(ja):    ファイルの種類を判別するユーティリティー
5Name:           file
[12531]6Version:        5.39
7Release:        1%{?_dist_release}
8Group:          system
9Vendor:         Project Vine
10Distribution:   Vine Linux
11Packager:       daisuke
12
[12278]13License:        BSD
14URL:            http://www.darwinsys.com/file/
15# master site is toooooooooooooooooo slow
16# Source0:        ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
17%define         altver %(echo %{version} | sed -e 's/\\./_/')
18Source0:        https://github.com/file/file/archive/FILE%{altver}.tar.gz#/file-FILE%{altver}.tar.gz
[521]19
[2679]20# Addtional magic file for Vine
21Source10: magic.printer-j
[521]22
[7177]23# Upstream says it's up to distributions to add a way to support local-magic.
24Patch0: file-localmagic.patch
[12278]25
26# not yet upstream
[8236]27Patch3: file-4.17-rpm-name.patch
28Patch4: file-5.04-volume_key.patch
[2679]29
[10739]30# Vine
31Patch1000: file-5.14-magicbuild-fix.patch
[9019]32
[521]33Buildroot: %{_tmppath}/%{name}-%{version}-root
[2679]34#BuildRequires: automake
35#BuildRequires: autoconf
36BuildRequires: zlib-devel
[12278]37Obsoletes: file-static
[521]38
39%description
40The file command is used to identify a particular file according to the
41type of data contained by the file.  File can identify many different
42file types, including ELF binaries, system libraries, RPM packages, and
43different graphics formats.
44
45You should install the file package, since the file command is such a
46useful utility.
47
48%description -l ja
[2679]49file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
[521]50どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
51ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
52を含む、多くの異なるファイルの種類を見分けることができます。
53
54
[2679]55%package devel
56Summary:  Libraries and header files for file development
57Summary(ja): libmagic の開発用ファイル
[12531]58Group:    programming
[2679]59Requires: %{name} = %{version}-%{release}
60
61%description devel
62The file-devel package contains the header files and libmagic library
63necessary for developing programs using libmagic.
64
[12531]65
[2679]66%package -n python-magic
67Summary: Python bindings for the libmagic API
[12531]68Group:   programming
[12278]69BuildRequires: python-devel
70BuildRequires: python-setuptools
71BuildRequires: python-rpm-macros
72
[2679]73Requires: %{name} = %{version}-%{release}
74
75%description -n python-magic
76This package contains the Python bindings to allow access to the
77libmagic API. The libmagic library is also used by the familiar
78file(1) command.
79
[12278]80%package -n python3-magic
81Summary: Python bindings for the libmagic API
[12531]82Group:   programming
[12278]83BuildRequires: python3-devel
84BuildRequires: python3-setuptools
85BuildRequires: python3-rpm-macros
[2679]86
[12278]87Requires: %{name} = %{version}-%{release}
88
89%description -n python3-magic
90This package contains the Python bindings to allow access to the
91libmagic API. The libmagic library is also used by the familiar
92file(1) command.
93
94
[12531]95%debug_package
96
97
[521]98%prep
[12278]99%setup -q -n file-FILE%{altver}
100autoreconf -ivf
[9099]101# Don't use -b -- it will lead to problems when compiling magic file!
[7177]102%patch0 -p1
103%patch3 -p1
104%patch4 -p1
[521]105
[10739]106# Vine
107%patch1000 -p1
[9019]108
[2679]109cat %{SOURCE10} >> ./magic/Localstuff
[521]110
[2679]111iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
112touch -r doc/libmagic.man doc/libmagic.man_
113mv doc/libmagic.man_ doc/libmagic.man
114
[12531]115
[521]116%build
[8236]117autoreconf
[521]118CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
[2679]119%configure --enable-fsect-man5 --disable-rpath
120# remove hardcoded library paths from local libtool
121sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
122sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
123export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
124make
[521]125
[2679]126cd python
[12278]127%py_build
128%py3_build
[2679]129
[12531]130
[521]131%install
[2679]132rm -rf $RPM_BUILD_ROOT
133mkdir -p $RPM_BUILD_ROOT%{_bindir}
134mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
135mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
136mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
137mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
138mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
[521]139
[2679]140make install DESTDIR=$RPM_BUILD_ROOT
[521]141
[2679]142cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
143ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
144##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
145ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
[521]146
[2679]147cd python
[12278]148%py_install
149%py3_install
150
[2679]151%{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
152
153# LIBTOOL=/usr/bin/libtool
154#ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
155#ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
156
157#ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
158
159#{ cd ${RPM_BUILD_ROOT}
160#  strip .%{_bindir}/file
161#  cp %SOURCE1 .%{_datadir}/magic.mime
162#}
163
164# remove unuse files
[521]165rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
166
[12531]167
[521]168%clean
[2679]169rm -rf $RPM_BUILD_ROOT
[521]170
[12531]171
[2679]172%post -p /sbin/ldconfig
173%postun -p /sbin/ldconfig
174
175
[521]176%files
177%defattr(-,root,root)
[12278]178%license COPYING
179%doc ChangeLog README
[521]180%{_bindir}/*
181%{_libdir}/libmagic.so.*
182%{_datadir}/file/*
183%{_datadir}/magic*
184%{_datadir}/misc/*
185%{_mandir}/man[15]/*
186
[2679]187%files devel
188%defattr(-,root,root,-)
189%{_libdir}/*.so
[12531]190%{_libdir}/pkgconfig/*
[521]191%{_includedir}/magic.h
192%{_mandir}/man3/*
193
[2679]194%files -n python-magic
195%defattr(-, root, root, -)
[12278]196%license python/LICENSE
197%doc python/README* python/example.py
[2679]198%{python_sitelib}/magic.py
199%{python_sitelib}/magic.pyc
200%{python_sitelib}/magic.pyo
201%{python_sitelib}/*egg-info
202
[12278]203%files -n python3-magic
204%defattr(-, root, root, -)
205%license python/LICENSE
206%doc python/README* python/example.py
207%{python3_sitelib}/*
[2679]208
[12278]209
[521]210%changelog
[12531]211* Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.39-1
212- new upstream release.
213- dropped Patch14 and 9000: fixed in upstream.
214
[12299]215* Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-2
216- added Patch9000.
217
[12278]218* Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-1
219- new upstream release.
220- added python3 support.
221- updated Patch0.
222- dropped Patch1, 5-17 and 100: fixed in upstream.
223- imported Patch14 from rawhide.
224
[10739]225* Thu Jul 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.28-1
226- new upstream release.
227- dropped Patch200: fixed in upstream.
228- updated patches.
229- imported Patch15,17 and 100.
230
[9099]231* Sat Nov 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.20-1
232- new upstream release
233- update/drop patches based on fc22
234
[9019]235* Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.14-7
236- reflected 6.0 updates and bumped release
237  * Thu Sep 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-6
238  - drop patch230 (moved to patch320)
239  - add Patch240 for fix CVE-2014-0207
240  - add Patch250 for fix CVE-2014-0237
241  - add Patch260 for fix CVE-2014-0238
242  - add Patch270 for fix CVE-2014-3478
243  - add Patch280 for fix CVE-2014-3479
244  - add Patch290 for fix CVE-2014-3480
245  - add Patch300 for fix CVE-2014-3487
246  - add Patch310 for fix CVE-2014-3538
247  - add Patch320 for fix CVE-2014-3587
248    These patches are from debian/ubuntu, thanks.
249  * Thu Aug 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-5
250  - add patch230 for fix CVE-2014-3587 (cdf_read_property_info)
251  * Thu Mar 27 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-4
252  - add patch110,220 for fix regression of CVE-2014-2270
253  * Wed Mar 12 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-3
254  - add patch210 for fix CVE-2014-2270
255  * Thu Feb 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-2
256  - add patch200 for fix CVE-2014-1943
257
[8851]258* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.14-2
259- rebuild with VineSeed environment
260
[8236]261* Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
262- new upstream reelase
263- add patch100 to fix build error
264- remove -static subpackage and add Obs: file-static
265- fix old changelog date...
266
[7177]267* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
268- new upstream reelase
269- drop all local patches
270- import fedora patches
271
[5701]272* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
273- rebuild with python-2.7.2
274
[2730]275* Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
276- rebuild package
277- fix Patch100
278
[2679]279* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
280- new upstream release
281- updated Vine patches (but Patch100 has not been ported yet...)
282- split to devel and static subpackcages
283
[1926]284* Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
[2679]285- rebuilt with rpm-4.8.1
[1926]286- add environment variable LIBTOOL for make command
287
[521]288* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
289- spec in utf-8
290- removed *.la
291
292* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
293- applied new versioning policy
294
295* Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
296- new upstream release
297- import debian/fedora patches
298- drop obsolete vine magic.
299
300* Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
301- rebuild for VineSeed with new tool chain
302
303* Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
304- add patch110 for fix CVE-2007-2799
305- add zlib-devel to BuildPreReq tag
306
307* Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
308- add patch100 for fix CVE-2007-1536
309
310* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
311- changed Group to Applications/System
312
313* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
314- new upstream release
315- update vine patches
316
317* Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
318- update Patch10, use 'size_t' in src/jcode.[ch]
319
320* Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
321- update to 4.03
322- update Patch0, 1, 10 for 4.03
323- s/Copyright/License/
324
325* Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
326- update to 4.02
327- update Vine patches for 4.02
328
329* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
330- new upstream release
331  - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
332- remove unneeded patches.
333- update Vine patches for 3.41
334
335* Mon Apr  1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
336- added NPDL2 data [Vine:02348]
337
338* Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
339- update to 3.37
340
341* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
342- 3.35-0vl3
343- disable some entries in elf for problems on big-endian archs
344
345* Wed Jun  6 2001 Jun Nishii <jun@vinelinux.org>
346- file-3.35-0vl1
347- ver.up
348- added %doc
349
350* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
351- file-3.33-1vl4
352- more fix and clean up jtext patch (file-3.33-vinejtext.patch)
353
354* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
355- file-3.33-1vl3
356- fix again jtext patch (file-3.33-vinejtext.patch)
357- added file-3.33-vinenames.patch to avoid miss-judgement
358
359* Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
360- file-3.33-1vl2
361- update jtext patch (file-3.33-vinejtext.patch)
362
363* Mon Jan  8 2001 Jun Nishii <jun@vinelinux.org>
364- file-3.33-1vl1
365- modify description-ja and spec
366
367* Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
368- file-3.28-2vl2
369- fixed %files section to handle compressed man pages
370
371* Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
372- marged RH 3.28-2 and Vine 3.27-3vl3
373
374* Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
375- add ia64 patch from rth
376
377* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
378- handle compressed manpages
379- update to 3.28
380
381* Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
382- Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
383
384* Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
385- patch  dues not apply bug.
386
[8236]387* Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
[521]388- not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
389- ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
390
391* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
392- identify ELF stripped files correctly (#4665).
393- use SPARC (not sparc) consistently throughout (#4665).
394- add entries for MS Office files (#4665).
395
396* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
397- diddle magic so that *.tfm files are identified correctly.
398
399* Tue Jul  6 1999 Jeff Johnson <jbj@redhat.com>
400- update to 3.27.
401
402* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
403- experimental support for realmedia files added
404
405* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
406- auto rebuild in the new build environment (release 5)
407
408* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
409- strip binary.
410
411* Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
412- add SPARC V9 magic.
413
414* Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
415- update to 3.26.
416
417* Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
418- update to 3.25.
419- detect gimp XCF versions.
420
421* Thu May 07 1998 Prospector System <bugs@redhat.com>
422- translations modified for de, fr, tr
423
424* Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
425- updated to 3.24
426- buildrooted
427
428* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
429- built against glibc
430
431* Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
432- Fixed problems caused by 64 bit time_t.
433
434* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
435- Improved recognition of Linux kernel images.
Note: See TracBrowser for help on using the repository browser.