source: projects/specs/trunk/f/file-roller/file-roller-vl.spec @ 3801

Revision 3801, 9.0 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME packages: new upstream release, bogofilter: fix perl requirements, perl-modules: new package

Line 
1%define glib2_version 2.28.6
2%define gtk2_version 2.24.4
3%define gconf2_version 2.32.1
4%define nautilus_version 2.32.1
5%define desktop_file_utils_version 0.16
6%define gnome_doc_utils_version 0.3.2
7
8Summary:        File Roller is a tool for viewing and creating archives.
9Summary(ja):    File Roller - アーカイブの表示・作成ツール
10Name:           file-roller
11Version:        2.32.2
12Release:        1%{?_dist_release}
13
14License:        GPL
15Group:          Applications/Archiving
16Source0:        http://ftp.gnome.org/pub/GNOME/sources/file-roller/2.32/%{name}-%{version}.tar.bz2
17Source1:        file-roller.help.Makefile.am
18Source2:        file-roller.help.gnome-2-30.ja.po
19Source3:        file-roller-ja-figures.tar.bz2
20Source4:        file-roller.gnome-2-30.ja.po
21URL:            http://ftp.gnome.org/pub/gnome/sources/file-roller/
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
24Requires(post,postun): scrollkeeper >= 0.3.11
25Requires(post,postun): desktop-file-utils >= %{desktop_file_utils_version}
26Requires(post,pre,preun): GConf2
27
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: gtk2-devel >= %{gtk2_version}
30BuildRequires: GConf2-devel >= %{gconf2_version}
31BuildRequires: nautilus >= %{nautilus_version}
32BuildRequires: nautilus-devel >= %{nautilus_version}
33BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
34BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
35BuildRequires: libSM-devel
36BuildRequires: docbook-dtds
37
38%description
39File Roller is an application for creating and viewing archives files,
40such as tar files.
41
42%description -l ja
43File Roller は tar ファイルのようなアーカイブの表示や作成をするための
44アプリケーションです。
45
46%prep
47%setup -q
48
49## # add Japanese help
50## cp -f %{SOURCE1} help/Makefile.am
51## mkdir help/ja
52## cp -f %{SOURCE2} help/ja/ja.po
53## (cd help/ja && tar jxf %{SOURCE3})
54
55# update Japanese interface
56cp -f %{SOURCE4} po/ja.po
57
58# regenerate to fix path
59rm -f src/fr-enum-types.c
60
61%build
62%configure --disable-scrollkeeper
63export tagname=CC
64make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
70export tagname=CC
71make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
72unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
73
74# temporary hack to add missing semicolon, fix sent upstream
75#perl -pi -e 's/Categories=Application;Utility$/Categories=Application;Utility;/' $RPM_BUILD_ROOT%{_datadir}/applications/*
76
77desktop-file-install --vendor gnome --delete-original       \
78  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
79  --add-only-show-in GNOME                                  \
80  $RPM_BUILD_ROOT%{_datadir}/applications/*
81
82rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
83rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0/lib*.*a
84
85rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
86
87%find_lang %{name} --all-name --with-gnome
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post
93update-desktop-database %{_datadir}/applications >& /dev/null ||:
94scrollkeeper-update > /dev/null 2>&1 || :
95export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96gconftool-2 --makefile-install-rule   \
97    %{_sysconfdir}/gconf/schemas/file-roller.schemas > /dev/null
98
99touch --no-create %{_datadir}/icons/hicolor
100if [ -x /usr/bin/gtk-update-icon-cache ]; then
101  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
102fi
103
104%pre
105if [ "$1" -gt 1 ]; then
106  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
107  gconftool-2 --makefile-uninstall-rule   \
108      %{_sysconfdir}/gconf/schemas/file-roller.schemas > /dev/null
109fi
110
111%preun
112if [ "$1" -eq 0 ]; then
113  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
114  gconftool-2 --makefile-uninstall-rule   \
115      %{_sysconfdir}/gconf/schemas/file-roller.schemas > /dev/null
116fi
117
118%postun
119update-desktop-database %{_datadir}/applications >& /dev/null ||:
120scrollkeeper-update > /dev/null 2>&1 || :
121touch --no-create %{_datadir}/icons/hicolor
122if [ -x /usr/bin/gtk-update-icon-cache ]; then
123  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
124fi
125
126%files -f %{name}.lang
127%defattr(-, root, root)
128%doc README COPYING ChangeLog NEWS AUTHORS
129%{_sysconfdir}/gconf/schemas/*.schemas
130%{_bindir}/*
131%{_datadir}/applications/*
132%{_datadir}/file-roller
133%{_datadir}/icons/hicolor/*
134%{_libexecdir}/file-roller
135%{_libdir}/nautilus/extensions-2.0/libnautilus-fileroller.so
136
137%changelog
138* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
139- new upstream release
140
141* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
142- new upstream release
143
144* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
145- new upstream release
146- remove Patch
147- drop Source1, Source2, Source3
148
149* Mon Aug 23 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.2-3
150- add Source1-4
151
152* Sat Aug 21 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.2-2
153- add patch from https://bugzilla.gnome.org/show_bug.cgi?id=627387
154
155* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
156- new upstream release
157- add BuildRequires: docbook-dtds
158
159* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
160- new upstream release
161
162* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
163- new upstream release
164
165* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
166- new upstream release
167- add BuildRequires: nautilus-devel, gnome-doc-utils, libSM-devel
168
169* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
170- new upstream release
171
172* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
173- new upstream release
174
175* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
176- new upstream release
177
178* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
179- new upstream release
180
181* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
182- new upstream release
183- remove BR: libgnomeprint-devel, libgnomeprintui-devel
184
185* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
186- new upstream release
187
188* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
189- new upstream release
190
191* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
192- new upstream release
193
194* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
195- new upstream release
196
197* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
198- new upstream release
199
200* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
201- new upstream release
202
203* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-0vl1
204- new upstream release
205
206* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
207- new upstream release
208
209* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
210- new upstream release
211
212* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
213- new upstream release
214
215* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
216- new upstream release
217
218* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
219- new upstream release
220
221* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
222- new upstream release
223
224* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
225- new upstream release
226
227* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
228- new upstream version
229
230* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.4-0vl1
231- new upsteram release
232
233* Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
234- new upsteram release
235
236* Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.4-0vl3
237- fix typo
238
239* Sun Feb 15 2004 Tomoya TAKA <taka@vinelinux.org> 2.4.4-0vl2
240- add Patch0 to fix segfaults on 64-bit architectures.
241
242* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
243- new upstream release
244
245* Wed Dec 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
246- rebuild with new toolchain
247
248* Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
249- new upstream release
250
251* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
252- new upstream release
253
254* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
255- new upstream release
256
257* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
258- revert version to 2.2.4
259
260* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
261- rebuilt
262
263* Wed Jun 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
264- new upstream release
265
266* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
267- new upstream release
268
269* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
270- new upstream release
271
272* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
273- new upstream release
274
275* Thu Jan  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
276- new upstream release
277
278* Mon Dec  9 2002 Alexander Larsson <alexl@redhat.com> 2.1.3-3
279- fix server file path
280
281* Mon Dec  9 2002 Alexander Larsson <alexl@redhat.com> 2.1.3-2
282- Remove unpackaged files
283
284* Mon Dec  9 2002 Alexander Larsson <alexl@redhat.com> 2.1.3-1
285- Update to 2.1.3
286
287* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
288- 2.1.2
289- fix unpackaged files
290
291* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
292- fix URL field
293- put icon in file list
294- 2.0.0 stable release
295
296* Fri Jun 21 2002 Havoc Pennington <hp@redhat.com>
297- initial build
298
Note: See TracBrowser for help on using the repository browser.