source: projects/specs/trunk/f/fftw3/fftw3-vl.spec @ 5809

Revision 5809, 8.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define name fftw3
2%define version 3.3.1
3%define release 1%{?_dist_release}
4
5Name: %{name}
6Summary:   C subroutines for computing the Discrete Fourier Transform.
7Version:   %{version}
8Release:   %{release}
9
10Group:     System Environment/Libraries
11License:   GPLv2
12URL:       http://www.fftw.org/
13
14Source:    fftw-%{version}.tar.gz
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: gcc-gfortran
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22FFTW is a collection of fast C routines for computing the Discrete Fourier Transform in one or more dimensions.  It includes complex, real, and parallel transforms, and can handle arbitrary array sizes efficiently. This RPM package includes both the double- and single-precision FFTW uniprocessor and threads libraries.  (The single-precision files have an "f" postfix.)
23
24%description -l ja
25FFTW は1次元または多次元の離散フーリエ変換(DFT)を計算する高速なCルーチンのコレクションです.FFTW は複素数、実数、並列変換ができ、任意のサイズの配列を効果的に扱うことができます.このパッケージには、倍精度と単精度の単一CPUとスレッドに対応した FFTW のライブラリが収められています。(単精度用のファイル名にはfが最後に付けられています。)
26
27%package devel
28Summary:   Headers, libraries and docs for the FFTW library
29Group:     Development/Libraries
30Requires:  %{name} = %{version}-%{release}
31Requires(post): install-info
32Requires(preun): install-info
33
34%description devel
35This package contains header files and development libraries needed to
36develop programs using the FFTW fast Fourier transform library.
37
38%description devel -l ja
39このパッケージには、高速フーリエ変換のライブラリである FFTW を使ってプログラムを開発する際に必要となるヘッダーファイルやドキュメント、ライブラリが収められています.
40
41%package        static
42Summary:        Static version of the FFTW library
43Group:          Development/Libraries
44Requires:       %{name}-devel = %{version}-%{release}
45
46%description    static
47This package contains the statically linkable version of
48the FFTW fast Fourier transform library.
49
50
51%prep
52# We will be compiling three copies of FFTW, one for double precision, another
53# one for single precision and the other for long double precision. During the
54# build process, these copies will be stored in fftw-%{version}/double, single
55# and long
56
57# Unpack the tar archive, first (-c) creating a fftw-%{version}
58# directory and then unpacking in there.
59
60%setup -q -c -n fftw-%{version}
61
62for dir in single double long; do
63  cp -a fftw-%{version} $dir
64done
65rm -rf fftw-%{version}
66
67%build
68# Configure and build the double, single and long double precision versions.
69# Notes:
70#  (1) We install into ${RPM_BUILD_ROOT}, which is set either
71#      by the BuildRoot option above or by --buildroot at build-time.
72#      This allows you to build the RPM without blowing away your existing
73#      FFTW installation, and even without being root.
74#  (2) The double-precision version is installed with the normal library
75#      names, while the single-precision version is installed with an "f"
76#      postfix.
77
78# Configure uses g77 by default, if present on system
79export F77=gfortran
80
81%ifarch x86_64
82#CONFIG_FLAGS="--enable-sse --enable-sse2 --enable-shared --disable-dependency-tracking --enable-threads"
83CONFIG_FLAGS="--enable-shared --disable-dependency-tracking --enable-threads"
84%else
85CONFIG_FLAGS="--enable-shared --disable-dependency-tracking --enable-threads"
86%endif
87
88pushd double
89        %configure $CONFIG_FLAGS
90        sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
91        sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
92        make %{?_smp_mflags}
93popd
94pushd single
95        %configure $CONFIG_FLAGS --enable-single
96        sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
97        sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
98        make %{?_smp_mflags}
99popd
100pushd long
101        %configure $CONFIG_FLAGS --enable-long-double
102        sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
103        sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
104        make %{?_smp_mflags}
105popd
106
107%install
108rm -rf $RPM_BUILD_ROOT doc
109pushd double
110        make install DESTDIR=${RPM_BUILD_ROOT}
111        cp -a AUTHORS COPYING COPYRIGHT ChangeLog NEWS README* TODO ../
112        cp -a doc/ ../
113popd
114pushd single
115        make install DESTDIR=${RPM_BUILD_ROOT}
116popd
117pushd long
118        make install DESTDIR=${RPM_BUILD_ROOT}
119popd
120
121## remove unuse files
122rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
123rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
124
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%post devel
134/sbin/install-info --section="Math" %{_infodir}/%{name}.info.gz %{_infodir}/dir  2>/dev/null || :
135
136%preun devel
137if [ "$1" = 0 ]; then
138  /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
139fi
140
141
142%files
143%defattr (-,root,root)
144%doc AUTHORS COPYING COPYRIGHT ChangeLog NEWS README* TODO
145%{_bindir}/fftw*
146%{_libdir}/libfftw3*.so.*
147%{_mandir}/man1/fftw*
148
149%files devel
150%defattr (-,root,root)
151%doc doc/html/ doc/FAQ/fftw-faq.html/ doc/*.pdf
152%{_includedir}/fftw3*
153%{_libdir}/libfftw3*.so
154%{_libdir}/pkgconfig/fftw3*.pc
155%{_infodir}/fftw3*
156
157%files static
158%defattr (-,root,root)
159%{_libdir}/libfftw3*.a
160
161%changelog
162* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-1
163- new upstream release
164
165* Mon Oct 04 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.2-2
166- dropt "--enable-sse --enable-sse2" in configure (on x86_64)
167
168* Sun Oct 03 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.2-1
169- updated to 3.2.2
170- added long double precision support
171- split static libraries
172
173* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1vl5
174- applied new versioning policy, spec in utf-8
175- removed *.la
176- moved *.pc file to devel
177
178* Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 3.1.2-0vl1
179- new upstream release
180
181* Tue Nov 27 2007 Shu KONNO <owa@bg.wakwak.com> 3.1.1-0vl2
182- s/gcc-g77/gcc-gfortran/
183- x86_64 support
184
185* Tue May 30 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.1.1-0vl1
186- source version up
187
188* Thu Jan 29 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.0.1-0vl1
189- source version up to 3
190- package name to fftw3
191- enable sse2 for double and sse for single
192
193* Thu Jul 18 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.3-0vl1
194- modified for Vine.
195
196* Mon Feb 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 2.1.3-12bw
197- rebuild for RH72.
198
199* Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-11bw
200- corrected some wrong descriptions in this spec for RH71
201
202* Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-10bw
203- corrected some wrong descriptions in this spec
204
205* Mon Oct 08 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-9bw
206- rebuilt for Vine Linux 2.1.5
207
208* Thu Jun 14 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-8mdk
209- fixed by Mika Korhonen <mikak@ee.oulu.fi> :
210- removed broken ld.so.conf test (/usr/lib is not listed there anyways)
211- made install-info work with RPM macros shipping with newer Mandrakes
212  and actually add an entry to the top dir file
213
214* Tue Jan 09 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-7mdk
215- rebuild
216
217* Tue Aug 31 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-6mdk
218- add installinfo
219
220* Wed Aug 30 2000 Alexander Skwar <ASkwar@DigitalProjects.com> 2.1.3-5mdk
221- Actually used macros
222- Added %doc files
223- Shortened %files section of the SPEC file a lot
224- Provide libfftw as eXtace requires it
225- Obsolote libfftw package
226- Optimized for Pentium builds per README.hacks
227
228* Wed Aug 30 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-4mdk
229- BM
230- macros
231
232* Wed Apr 26 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-3mdk
233- fix group
234- spec helper fixes
235
236* Tue Jan 25 2000 Lenny Cartier <lenny@mandrakesoft.com>
237- updated, installs in /usr instead of /usr/local by Dara Hazeghi
238  <dara@pacbell.net>
239
240* Thu Dec 16 1999 Lenny Cartier <lenny@mandrakesoft.com>
241- new in contribs
242- bz2 archive
243- add defattr
Note: See TracBrowser for help on using the repository browser.