source: projects/specs/trunk/f/fftw3/fftw3-vl.spec @ 521

Revision 521, 6.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name fftw3
2%define version 3.1.2
3%define release 1%{?_dist_release}
4
5Name: %{name}
6Summary:   C subroutines for computing the Discrete Fourier Transform.
7Version:   %{version}
8Release:   %{release}
9License:   GPL
10Group:     Development/Libraries
11Source:    fftw-%{version}.tar.gz
12URL:       http://www.fftw.org/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: gcc, gcc-gfortran
15Requires:  glibc
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20FFTW is a collection of fast C routines for computing the Discrete Fourier Transform in one or more dimensions.  It includes complex, real, and parallel transforms, and can handle arbitrary array sizes efficiently. This RPM package includes both the double- and single-precision FFTW uniprocessor and threads libraries.  (The single-precision files have an "f" postfix.)
21
22%description -l ja
23FFTWは、1次元または多次元の離散的フーリエ変換(DFT)を計算する高速なCルーチンのコレクションです。FFTWは複素数、実数、並列変換ができ、任意のサイズの配列を効果的に扱うことができます。このパッケージには、倍精度と単精度の単一CPUとスレッドに対応したFFTWのライブラリが収められています。(単精度用のファイル名にはfが最後に付けられています。)
24
25%package devel
26Summary:   Headers, libraries, & docs for FFTW fast fourier transform library
27Group:     Development/Libraries
28Prefix:    %{_prefix}
29Requires:  %{name} = %{version}-%{release}
30
31%description devel
32This package contains the additional header files, documentation, and
33libraries you need to develop programs using the FFTW fast fourier
34transform library.
35
36%description devel -l ja
37このパッケージには、高速フーリエ変換のライブラリであるFFTWを使ってプログラムを開発する際に必要となるヘッダーファイルやドキュメント、ライブラリが収められています。
38
39%prep
40rm -rf $RPM_BUILD_ROOT
41
42# We will be compiling two copies of FFTW, one for double precision and
43# one for single precision.  During the build process, these copies
44# will be stored in fftw-%{version}/double and fftw-%{version}/single
45
46# Unpack the tar archive, first (-c) creating a fftw-%{version}
47# directory and then unpacking in there.
48
49%setup -q -c -n fftw-%{version}
50# Now, rename the unpacked FFTW directory to "double":
51mv fftw-%{version} fftw-%{version}-double
52
53# Last, make a copy of this directory in "single":
54cp -r fftw-%{version}-double fftw-%{version}-single
55
56%build
57# Configure and build the double and single precision versions.
58# Notes:
59#  (1) We install into ${RPM_BUILD_ROOT}, which is set either
60#      by the BuildRoot option above or by --buildroot at build-time.
61#      This allows you to build the RPM without blowing away your existing
62#      FFTW installation, and even without being root.
63#  (2) The double-precision version is installed with the normal library
64#      names, while the single-precision version is installed with an "f"
65#      postfix.
66
67cd fftw-%{version}-double
68%ifarch i386 | x86_64
69    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-sse2
70%else
71    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir}
72%endif
73make %{?_smp_mflags}
74
75cd ../fftw-%{version}-single
76%ifarch i386 | x86_64
77    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-sse --enable-float
78%else
79    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-float
80%endif
81make %{?_smp_mflags}
82
83%install
84cd fftw-%{version}-double
85%makeinstall
86cd ../fftw-%{version}-single
87%makeinstall
88
89# copy doc files where RPM will find them
90# put the HTML stuff in a sperate dir, so it appears nicely in the docdir
91cp -a doc ../
92
93# do the same to the other %doc files
94cp AUTHORS CONVENTIONS COPYING COPYRIGHT ChangeLog NEWS README TODO ..
95
96## remove unuse files
97rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post
103/sbin/ldconfig
104
105%postun
106/sbin/ldconfig
107
108%files
109%defattr (-,root,root)
110%doc doc/html doc/FAQ doc/*ps doc/*tex*
111%doc AUTHORS CONVENTIONS COPYING COPYRIGHT ChangeLog NEWS README TODO
112%{_bindir}/fftw*
113%{_libdir}/libfftw3*.so*
114%{_infodir}/fftw3*
115%{_mandir}/man1/fftw*
116
117
118%files devel
119%defattr (-,root,root)
120%{_includedir}/fftw3.*
121%{_libdir}/libfftw3*.a
122%{_libdir}/pkgconfig/fftw3*.pc
123
124%changelog
125* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1vl5
126- applied new versioning policy, spec in utf-8
127- removed *.la
128- moved *.pc file to devel
129
130* Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 3.1.2-0vl1
131- new upstream release
132
133* Tue Nov 27 2007 Shu KONNO <owa@bg.wakwak.com> 3.1.1-0vl2
134- s/gcc-g77/gcc-gfortran/
135- x86_64 support
136
137* Tue May 30 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.1.1-0vl1
138- source version up
139
140* Thu Jan 29 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.0.1-0vl1
141- source version up to 3
142- package name to fftw3
143- enable sse2 for double and sse for single
144
145* Thu Jul 18 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.3-0vl1
146- modified for Vine.
147
148* Mon Feb 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 2.1.3-12bw
149- rebuild for RH72.
150
151* Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-11bw
152- corrected some wrong descriptions in this spec for RH71
153
154* Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-10bw
155- corrected some wrong descriptions in this spec
156
157* Mon Oct 08 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-9bw
158- rebuilt for Vine Linux 2.1.5
159
160* Thu Jun 14 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-8mdk
161- fixed by Mika Korhonen <mikak@ee.oulu.fi> :
162- removed broken ld.so.conf test (/usr/lib is not listed there anyways)
163- made install-info work with RPM macros shipping with newer Mandrakes
164  and actually add an entry to the top dir file
165
166* Tue Jan 09 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-7mdk
167- rebuild
168
169* Tue Aug 31 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-6mdk
170- add installinfo
171
172* Wed Aug 30 2000 Alexander Skwar <ASkwar@DigitalProjects.com> 2.1.3-5mdk
173- Actually used macros
174- Added %doc files
175- Shortened %files section of the SPEC file a lot
176- Provide libfftw as eXtace requires it
177- Obsolote libfftw package
178- Optimized for Pentium builds per README.hacks
179
180* Wed Aug 30 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-4mdk
181- BM
182- macros
183
184* Wed Apr 26 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-3mdk
185- fix group
186- spec helper fixes
187
188* Tue Jan 25 2000 Lenny Cartier <lenny@mandrakesoft.com>
189- updated, installs in /usr instead of /usr/local by Dara Hazeghi
190  <dara@pacbell.net>
191
192* Thu Dec 16 1999 Lenny Cartier <lenny@mandrakesoft.com>
193- new in contribs
194- bz2 archive
195- add defattr
Note: See TracBrowser for help on using the repository browser.