source: projects/specs/trunk/f/fftw3/fftw3-vl.spec @ 9249

Revision 9249, 15.1 KB checked in by Takemikaduchi, 9 years ago (diff)

python3-{pyatspi,pycairo,pygobject},gedit,accerciser,eog-plugins: rebuild with python3
others: new upstream release

Line 
1%global quad 1
2
3Name:           fftw3
4Version:        3.3.4
5Release:        1%{?_dist_release}
6Summary:        C subroutines for computing the Discrete Fourier Transform.
7Group:          System Environment/Libraries
8License:        GPLv2+
9URL:            http://www.fftw.org
10Source0:        http://www.fftw.org/fftw-%{version}.tar.gz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14BuildRequires:  gcc-gfortran
15BuildRequires:  time
16BuildRequires:  perl
17
18Requires(post): info
19Requires(preun): info
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25FFTW is a collection of fast C routines for computing the Discrete Fourier Transform
26in one or more dimensions.  It includes complex, real, and parallel transforms, and
27can handle arbitrary array sizes efficiently. This RPM package includes both the
28double- and single-precision FFTW uniprocessor and threads libraries.
29(The single-precision files have an "s" prefix.)
30
31%description -l ja
32FFTW は1次元または多次元の離散フーリエ変換(DFT)を計算する高速なCルーチンのコレ
33クションです.FFTW は複素数、実数、並列変換ができ、任意のサイズの配列を効果的に
34扱うことができます.このパッケージには、倍精度と単精度の単一CPUとスレッドに対応
35した FFTW のライブラリが収められています。(単精度用のファイル名にはfが最後に付
36けられています。)
37
38
39%package libs
40Summary:        FFTW run-time library
41Group:          System Environment/Libraries
42Provides:       fftw3 = %{version}-%{release}
43# Pull in the actual libraries
44Requires:        %{name}-libs-single = %{version}-%{release}
45Requires:        %{name}-libs-double = %{version}-%{release}
46Requires:        %{name}-libs-long = %{version}-%{release}
47%if %{quad}
48Requires:        %{name}-libs-quad = %{version}-%{release}
49%endif
50
51%description libs
52This is a dummy package package, pulling in the individual FFTW
53run-time libraries.
54
55
56%package devel
57Summary:        Headers, libraries and docs for the FFTW library
58Group:          Development/Libraries
59Requires:       pkgconfig
60Requires:       %{name} = %{version}-%{release}
61Requires:       %{name}-libs = %{version}-%{release}
62Provides:       fftw3-devel = %{version}-%{release}
63
64%description devel
65FFTW is a C subroutine library for computing the Discrete Fourier
66Transform (DFT) in one or more dimensions, of both real and complex
67data, and of arbitrary input size.
68
69This package contains header files and development libraries needed to
70develop programs using the FFTW fast Fourier transform library.
71
72%package libs-double
73Summary:        FFTW library, double precision
74Group:          Development/Libraries
75
76%description libs-double
77This package contains the FFTW library compiled in double precision.
78
79%package libs-single
80Summary:        FFTW library, single precision
81Group:          Development/Libraries
82
83%description libs-single
84This package contains the FFTW library compiled in single precision.
85
86%package libs-long
87Summary:        FFTW library, long double precision
88Group:          Development/Libraries
89
90%description libs-long
91This package contains the FFTW library compiled in long double
92precision.
93
94%if %{quad}
95%package libs-quad
96Summary:        FFTW library, quadruple
97Group:          Development/Libraries
98
99%description libs-quad
100This package contains the FFTW library compiled in quadruple
101precision.
102%endif
103
104%package        static
105Summary:        Static versions of the FFTW libraries
106Group:          Development/Libraries
107Requires:       %{name}-devel = %{version}-%{release}
108Provides:       fftw3-static = %{version}-%{release}
109
110%description static
111The fftw-static package contains the statically linkable version of
112the FFTW fast Fourier transform library.
113
114%package docs
115Summary:        FFTW library manual
116Group:          Documentation
117BuildArch:      noarch
118
119%description docs
120This package contains the manual for the FFTW fast Fourier transform
121library.
122
123%prep
124%setup -q -n fftw-%{version}
125
126%build
127# Configure uses g77 by default, if present on system
128export F77=gfortran
129
130BASEFLAGS="--enable-shared --disable-dependency-tracking --enable-threads"
131BASEFLAGS+=" --enable-openmp"
132
133# Precisions to build
134prec_name[0]=single
135prec_name[1]=double
136prec_name[2]=long
137prec_name[3]=quad
138
139# Corresponding flags
140prec_flags[0]=--enable-single
141prec_flags[1]=--enable-double
142prec_flags[2]=--enable-long-double
143prec_flags[3]=--enable-quad-precision
144
145%ifarch x86_64
146# Enable SSE2 and AVX support for x86_64
147for((i=0;i<2;i++)); do
148 prec_flags[i]+=" --enable-sse2 --enable-avx"
149done
150%endif
151
152# No NEON run time detection, not all ARM SoCs have NEON
153#%ifarch %{arm}
154## Compile support for NEON instructions
155#for((i=0;i<2;i++)); do
156# prec_flags[i]+=" --enable-neon"
157#done
158#%endif
159
160#%ifarch ppc ppc64
161## Compile support for Altivec instructions
162#for((i=0;i<2;i++)); do
163 #prec_flags[i]+=" --enable-altivec"
164#done
165#%endif
166
167# Loop over precisions
168%if %{quad}
169for((iprec=0;iprec<4;iprec++))
170%else
171for((iprec=0;iprec<3;iprec++))
172%endif
173do
174 mkdir ${prec_name[iprec]}${ver_name[iver]}
175 cd ${prec_name[iprec]}${ver_name[iver]}
176 ln -s ../configure .
177 %{configure} ${BASEFLAGS} ${prec_flags[iprec]}
178 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
179 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
180 make %{?_smp_mflags}
181 cd ..
182done
183
184%install
185rm -rf ${RPM_BUILD_ROOT}
186%if %{quad}
187for ver in single double long quad
188%else
189for ver in single double long
190%endif
191do
192 make -C $ver install DESTDIR=${RPM_BUILD_ROOT}
193done
194rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
195rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
196
197%check
198bdir=`pwd`
199%if %{quad}
200for ver in single double long quad
201%else
202for ver in single double long
203%endif
204do
205 export LD_LIBRARY_PATH=$bdir/$ver/.libs:$bdir/$ver/threads/.libs
206 make -C $ver check
207done
208
209%clean
210rm -rf %{RPM_BUILD_ROOT}
211
212%post libs-single -p /sbin/ldconfig
213%postun libs-single -p /sbin/ldconfig
214
215%post libs-double -p /sbin/ldconfig
216%postun libs-double -p /sbin/ldconfig
217
218%post libs-long -p /sbin/ldconfig
219%postun libs-long -p /sbin/ldconfig
220
221%if %{quad}
222%post libs-quad -p /sbin/ldconfig
223%postun libs-quad -p /sbin/ldconfig
224%endif
225
226%post docs
227/sbin/install-info --section="Math" %{_infodir}/%{name}.info.gz %{_infodir}/dir  2>/dev/null || :
228
229%preun docs
230if [ "$1" = 0 ]; then
231  /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
232fi
233
234%files
235%defattr(-,root,root,-)
236%doc %{_mandir}/man1/fftw*.1.*
237%{_bindir}/fftw*-wisdom*
238
239%files libs
240%defattr(-,root,root,-)
241
242%files libs-single
243%defattr(-,root,root,-)
244%doc AUTHORS COPYING COPYRIGHT ChangeLog NEWS README* TODO
245%{_libdir}/libfftw3f.so.*
246%{_libdir}/libfftw3f_threads.so.*
247%{_libdir}/libfftw3f_omp.so.*
248
249%files libs-double
250%defattr(-,root,root,-)
251%doc AUTHORS COPYING COPYRIGHT ChangeLog NEWS README* TODO
252%{_libdir}/libfftw3.so.*
253%{_libdir}/libfftw3_threads.so.*
254%{_libdir}/libfftw3_omp.so.*
255
256%files libs-long
257%defattr(-,root,root,-)
258%doc AUTHORS COPYING COPYRIGHT ChangeLog NEWS README* TODO
259%{_libdir}/libfftw3l.so.*
260%{_libdir}/libfftw3l_threads.so.*
261%{_libdir}/libfftw3l_omp.so.*
262
263%if %{quad}
264%files libs-quad
265%defattr(-,root,root,-)
266%doc AUTHORS COPYING COPYRIGHT ChangeLog NEWS README* TODO
267%{_libdir}/libfftw3q.so.*
268%{_libdir}/libfftw3q_threads.so.*
269%{_libdir}/libfftw3q_omp.so.*
270%endif
271
272%files devel
273%defattr(-,root,root,-)
274%{_includedir}/fftw3*
275%{_libdir}/pkgconfig/fftw3*.pc
276%{_libdir}/libfftw3*.so
277
278%files docs
279%defattr(-,root,root,-)
280%doc doc/*.pdf doc/html/
281%doc doc/FAQ/fftw-faq.html/
282%doc %{_infodir}/fftw3.info*
283
284%files static
285%defattr(-,root,root,-)
286%{_libdir}/libfftw3*.a
287
288%changelog
289* Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.4-1
290- new upstream release
291- fix spec file based on fedora package
292
293  * Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-1
294  - new upstream release
295
296  * Mon Oct 04 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.2-2
297  - dropt "--enable-sse --enable-sse2" in configure (on x86_64)
298
299  * Sun Oct 03 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.2-1
300  - updated to 3.2.2
301  - added long double precision support
302  - split static libraries
303
304  * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1vl5
305  - applied new versioning policy, spec in utf-8
306  - removed *.la
307  - moved *.pc file to devel
308
309  * Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 3.1.2-0vl1
310  - new upstream release
311
312  * Tue Nov 27 2007 Shu KONNO <owa@bg.wakwak.com> 3.1.1-0vl2
313  - s/gcc-g77/gcc-gfortran/
314  - x86_64 support
315
316  * Tue May 30 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.1.1-0vl1
317  - source version up
318
319  * Thu Jan 29 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 3.0.1-0vl1
320  - source version up to 3
321  - package name to fftw3
322  - enable sse2 for double and sse for single
323
324  * Thu Jul 18 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.3-0vl1
325  - modified for Vine.
326
327  * Mon Feb 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 2.1.3-12bw
328  - rebuild for RH72.
329
330  * Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-11bw
331  - corrected some wrong descriptions in this spec for RH71
332
333  * Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-10bw
334  - corrected some wrong descriptions in this spec
335
336  * Mon Oct 08 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-9bw
337  - rebuilt for Vine Linux 2.1.5
338
339* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.4-5
340- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
341
342* Fri Jul  4 2014 Peter Robinson <pbrobinson@fedoraproject.org> 3.3.4-4
343- Disable SSE2/AVX on x86(32) as we support Pentium Pro as base
344- SSE2 only arrived with P-4
345- https://fedoraproject.org/wiki/Features/F12X86Support
346- Fix ARM macro
347- Disable NEON on ARM (we don't enable by default, needs runtime detection)
348
349* Thu Jul 03 2014 Conrad Meyer <cemeyer@uw.edu> - 3.3.4-3
350- Build with --enable-avx (rhbz# 1114964)
351
352* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.4-2
353- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
354
355* Tue Mar 18 2014 Susi Lehtola <jussilehtola@fedoraproject.org> - 3.3.4-1
356- Update to 3.3.4.
357
358* Sat Dec 14 2013 Conrad Meyer <cemeyer@uw.edu> - 3.3.3-8
359- Remove non-OpenMP / g77 build for obsolete RHEL (< 5)
360- Remove ancient Obsoletes (fftw < 3.3, Fedora < 16)
361- Remove ancient non-Quad build (Fedora < 15) on supported arch(s)
362- Remove obsolete conditional on BuildArch: noarch (RHEL < 6, Fedora < 13)
363
364* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.3-7
365- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
366
367* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.3-6
368- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
369
370* Sat Jan 19 2013 PPC Secondary Arch Admin <karsten@redhat.com> 3.3.3-5
371- disable altivec flag again, that works with single precision only
372
373* Mon Dec 24 2012 Susi Lehtola <jussilehtola@fedoraproject.org> - 3.3.3-4
374- Fix typo: should be %%ix86 instead of %%x86. Now should have SSE2 support
375  on x86 as well.
376
377* Tue Dec 18 2012 Susi Lehtola <jussilehtola@fedoraproject.org> - 3.3.3-3
378- After consultation with upstream, enable SSE2 also on x86, altivec on ppc
379  and ppc64 and NEON on arm.
380
381* Tue Dec 18 2012 Susi Lehtola <jussilehtola@fedoraproject.org> - 3.3.3-2
382- Enable SSE2 on x86_64.
383
384* Mon Nov 26 2012 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.3.3-1
385- Update to 3.3.3.
386
387* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.2-2
388- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
389
390* Fri Jun 15 2012 Orion Poplawski <orion@cora.nwra.com> - 3.3.2-1
391- Update to 3.3.2
392- Drop alignment patch
393
394* Fri Apr 27 2012 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.3.1-3
395- Fix FTBFS with gcc 4.7.
396
397* Thu Apr 26 2012 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.3.1-2
398- Reorganized libraries (BZ #812981).
399
400* Mon Feb 27 2012 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.3.1-1
401- Update to 3.3.1.
402
403* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3-5
404- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
405
406* Tue Oct 11 2011 Dan Horák <dan[at]danny.cz> - 3.3-4
407- libquadmath exists only on x86/x86_64 and ia64
408
409* Mon Oct 10 2011 Rex Dieter <rdieter@fedoraproject.org> 3.3-3
410- -devel: Provides: fftw3-devel (#744758)
411- -static: Provides: fftw3-static
412- drop %%_isa from Obsoletes
413
414* Sat Jul 30 2011 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.3-2
415- Conditionalize OpenMP and quadruple precision support based on capabilities
416  of system compiler.
417
418* Thu Jul 28 2011 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.3-1
419- Update to 3.3.
420
421* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-5
422- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
423
424* Sat Jan 9 2010 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.2.2-4
425- Get rid of rpath.
426
427* Sat Jan 9 2010 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.2.2-3
428- Branch out developers' manual to -doc.
429
430* Sat Jan 2 2010 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.2.2-2
431- Add check phase.
432- Cosmetic changes to spec file (unified changelog format, removed unnecessary
433  space).
434- Use rm instead of find -delete, as latter is not present on EPEL-4.
435- Generalize obsoletes of fftw3 packages. Add Obsoletes: fftw3-static.
436
437* Fri Jan 1 2010 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.2.2-1
438- Update to 3.2.2.
439- Make file listings more explicit.
440- Don't use file dependencies for info.
441
442* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-3
443- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
444
445* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-2
446- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
447
448* Sat Feb 14 2009 Conrad Meyer <konrad@tylerc.org> - 3.2.1-1
449- Bump to 3.2.1.
450
451* Thu Dec 4 2008 Conrad Meyer <konrad@tylerc.org> - 3.2-1
452- Bump to 3.2.
453
454* Fri Jul 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.2-7
455- fix license tag
456
457* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.1.2-6
458- Autorebuild for GCC 4.3
459
460* Fri Aug 24 2007 Quentin Spencer <qspencer@users.sf.net> 3.1.2-5
461- Rebuild for F8.
462
463* Fri Jul 27 2007 Quentin Spencer <qspencer@users.sf.net> 3.1.2-4
464- Split static libs into separate package (bug 249686).
465
466* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 3.1.2-3
467- rebuilt for unwind info generation, broken in gcc-4.1.1-21
468
469* Tue Sep 26 2006 Quentin Spencer <qspencer@users.sf.net> 3.1.2-2
470- BuildRequires: pkgconfig for -devel (bug 206444).
471
472* Fri Sep  8 2006 Quentin Spencer <qspencer@users.sf.net> 3.1.2-1
473- New release.
474
475* Fri Jun  2 2006 Quentin Spencer <qspencer@users.sf.net> 3.1.1-1
476- New upstream release.
477
478* Fri Feb 24 2006 Quentin Spencer <qspencer@users.sf.net> 3.1-4
479- Re-enable static libs (bug 181897).
480- Build long-double version of libraries (bug 182587).
481
482* Mon Feb 13 2006 Quentin Spencer <qspencer@users.sf.net> 3.1-3
483- Add Obsoletes and Provides.
484
485* Mon Feb 13 2006 Quentin Spencer <qspencer@users.sf.net> 3.1-2
486- Rebuild for Fedora Extras 5.
487- Disable static libs.
488- Remove obsolete configure options.
489
490* Wed Feb  1 2006 Quentin Spencer <qspencer@users.sf.net> 3.1-1
491- Upgrade to the 3.x branch, incorporating changes from the fftw3 spec file.
492- Add dist tag.
Note: See TracBrowser for help on using the repository browser.