source: projects/specs/trunk/f/fetchmail/fetchmail-vl.spec @ 521

Revision 521, 12.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1
2%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3
4Summary: A remote mail retrieval and forwarding utility.
5Summary(ja): 遠隔メール取得/フォワード用ユーティリティ
6Name: fetchmail
7Version: 6.3.14
8Release: 1%{_dist_release}
9Requires: smtpdaemon
10License: GPL
11Group: Applications/Internet
12URL: http://fetchmail.berlios.de/
13Source0: http://download.berlios.de/fetchmail/fetchmail-%{version}.tar.bz2
14Source1: fetchmailconf.1
15
16Patch1: fetchmail-6.3.5-stripnul.patch
17Patch2: fetchmail-6.3.5-nonewline.patch
18# Patch3: fetchmail-6.3.5-malformed_spam_crash.patch
19
20# security
21# Patch100: fetchmail-6.3.8_CVE-2007-4565.patch
22# Patch110: fetchmail-6.3.8_CVE-2008-2711.patch
23
24Buildroot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: openssl-devel
26BuildRequires: krb5-devel
27Requires: krb5-libs
28
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager: iwamoto, inagaki
32
33%package -n fetchmailconf
34Summary: A GUI utility for configuring your fetchmail preferences.
35Summary(ja): fetchmail を設定する為の GUI ユーティリティ
36Group: Applications/Internet
37Requires: python, tk, tkinter, fetchmail = %{version}-%{release}
38
39%description
40Fetchmail is a remote mail retrieval and forwarding utility intended
41for use over on-demand TCP/IP links, like SLIP or PPP connections.
42Fetchmail supports every remote-mail protocol currently in use on the
43Internet (POP2, POP3, RPOP, APOP, KPOP, all IMAPs, ESMTP ETRN) for
44retrieval.  Then Fetchmail forwards the mail through SMTP, so you can
45read it through your favorite mail client.
46
47Install fetchmail if you need to retrieve mail over SLIP or PPP
48connections.
49
50%description -l ja
51fetchmail は SLIP や PPP といったオンデマンド TCP/IP 接続環境で
52使われることを念頭に置いた遠隔メール取得/フォワードユーティリティです.
53fetchmail は,現在インターネット上で使われている様々なプロトコル
54(POP2, POP3, RPOP, APOP, KPOP, IMAP, ESMTP, ETRN) に対応しています.
55fetchmail はメールのフォワードには SMTP を用います.
56ですので,あなたのお好きなメールクライアントでメールを読むことが出来ます.
57
58SLIP や PPP 接続でメールを取得したい場合は fetchmail を
59インストールして下さい.
60
61%description -n fetchmailconf
62Fetchmailconf is a Tcl/Tk GUI application which edits your
63.fetchmailrc file, in order to configure the fetchmail mail retrieval
64program. Fetchmail's numerous options may be confusing to new users,
65but fetchmailconf may help to clear up the confusion.
66
67Install fetchmailconf if you need help configuring fetchmail. You'll
68need to have python and tk installed in order to use fetchmailconf.
69
70%description -n fetchmailconf -l ja
71fetchmailconf は fetchmail プログラムを制御する .fetchmailrc ファイルを
72編集する為の Tcl/Tk GUI アプリケーションです.
73fetchmail の様々なオプションは慣れないユーザにとっては混乱するばかりですが,
74fetchmailconf を使うと混乱すること無く設定が行えます.
75
76fetchmail の設定を簡単に行いたい場合は fetchmailconf をインストール
77して下さい.fetchmail を使うには python と tk もインストールされている
78必要があります.
79
80%prep
81%setup -q
82
83%patch1 -p1 -b .stripnul
84%patch2 -p1 -b .nonewline
85# %patch3 -p0 -b .malformed_spam
86
87# %patch100 -p0 -b .CVE-2007-4565
88# %patch110 -p1 -b .CVE-2008-2711
89
90%build
91%configure \
92           --enable-NTLM \
93           --with-ssl=/usr \
94           --with-kerberos5=/usr/kerberos \
95           --with-gssapi=/usr/kerberos
96
97%__make %{?_smp_mflags}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101%makeinstall
102rm -f $RPM_BUILD_ROOT%{_mandir}/man1/fetchmailconf.1*
103install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
104
105%find_lang %name
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files -f %{name}.lang
111%defattr(-,root,root)
112%doc FEATURES README NEWS NOTES *.html FAQ COPYING INSTALL
113%{_bindir}/fetchmail
114%{_mandir}/man1/fetchmail.1*
115
116%files -n fetchmailconf
117%defattr(-,root,root)
118%{_bindir}/fetchmailconf
119%{python_sitelib}/fetchmailconf.py*
120%{_mandir}/man1/fetchmailconf.1*
121
122%changelog
123* Thu Feb 11 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.14-1
124- new upstream release with security fix (CVE-2010-0562)
125
126* Sat Nov 28 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.13-1
127- new upstream release (including security fix CVE-2009-0266)
128
129* Thu Aug  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.11-1
130- new upstream release
131- enable krb5 for Vine 5 and later
132- fix configure option (drop old configure options)
133- fix changelog typo
134
135* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.10-1
136- new upstream release
137- fix changelog typo
138
139* Sat Nov 29 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9-1
140- new upstream release with CVE-2007-4565,CVE-2008-2711 fix
141- drop old pacthes which are included in new release
142
143* Fri Jun 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.8-3
144- add patch110 for fix CVE-2008-2711
145  (if 6.3.9 will be released, patch110 is no needed)
146- new versioning policy
147
148* Fri Aug 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.8-0vl2
149- add patch100 for fix CVE-2007-4565
150  (if 6.3.9 will be released, patch100 is no needed)
151
152* Mon Apr 16 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.8-0vl1
153- new upstream release with fixing CVE-2007-1558
154
155* Tue Mar 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.7-0vl1
156- new upstream release with fixing up fallout from the CVE-2006-5867
157
158* Wed Dec 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.6-0vl1
159- new upstream release with security fix (CVE-2006-5867,CVE-2006-5974)
160  - CVE-2006-5974 is already fixed by patch3
161- drop patch3 (is included in new release)
162- add Vendor/Distribution Tag
163
164* Wed Dec 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5-0vl1.1
165- test package
166- add patch1,2 from mandrave
167- add patch3 from upstream CVS
168
169* Fri Oct 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5-0vl1
170- new upstream release
171
172* Mon Jun 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.4-0vl1
173- new upstream release
174
175* Thu Dec 22 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
176- 6.2.5-0vl1.1
177- new upstream release
178- drop patch1
179- change source tarball gz -> bz2
180
181* Sun Aug 07 2005 Shu KONNO <owa@bg.wakwak.com> 6.2.5-0vl1.1
182- add fetchmail-patch-6.2.5.2.gz
183
184* Mon Nov 10 2003 IWAI, Masaharu <iwai@alib.jp> 6.2.5-0vl1
185- new upstream release
186
187* Tue Aug 26 2003 IWAI, Masaharu <iwai@alib.jp> 6.2.4-0vl1
188- new upstream release
189
190* Thu Jul 31 2003 IWAI Masaharu <iwai@alib.jp> 6.2.3-0vl1
191- new upstream release
192
193* Wed May 21 2003 IWAI Masaharu <iwai@alib.jp> 6.2.2-0vl2
194- revise URL and Source0 URL
195
196* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.2-0vl1
197- new upstream release
198  - this version include security fix patch.
199
200* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.1-0vl1
201- new upstream release
202  (hopefully fixed several security bugs)
203
204* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9.11-0vl1
205- new upstream release
206
207* Sun Feb 17 2002 Toru Sagami <sagami@vinelinux.org> 5.9.8-0vl1
208- updated to 5.9.8
209
210* Mon Jan 07 2002 Toru Sagami <sagami@vinelinux.org>
211- 5.9.6-0vl1
212
213* Mon Dec 10 2001 Toru Sagami <sagami@vinelinux.org>
214- 5.9.5-0vl1
215
216* Thu Oct 04 2001 Toru Sagami <sagami@vinelinux.org>
217- 5.9.4-0vl1
218
219* Tue Aug 14 2001 <sagami@vinelinux.org>
220- 5.9.0-0vl1
221
222* Thu Aug 02 2001 <sagami@vinelinux.org>
223- 5.8.15-0vl1
224- add tkinter for Requires
225
226* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
227- 5.8.11-0vl2
228- rebuilt with openssl-0.9.6b
229
230* Mon Jul 09 2001 <sagami@vinelinux.org>
231- 5.8.11-0vl1
232- built with openssl-0.9.6
233
234* Tue Jun 26 2001 <sagami@vinelinux.org>
235- 5.8.10-0vl1
236
237* Mon Jun 25 2001 <sagami@vinelinux.org>
238- 5.8.9-0vl1
239
240* Thu Jun 21 2001 <sagami@vinelinux.org>
241- 5.8.8-0vl1: updated to 5.8.8
242- use %%{find_lang}
243
244* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
245- 5.6.0-2vl1
246- based on 5.6.0-2 from Rawhide
247- added Japanese summary and description
248
249* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
250- enable NLS (#21419)
251
252* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
253- update to 5.6.0
254- revert "untagged" patch, which went upstream
255
256* Wed Nov  8 2000 Nalin Dahyabhai <nalin@redhat.com>
257- patch to handle untagged responses during IMAP-GSS authentication
258- update to 5.5.5
259
260* Thu Aug 17 2000 Nalin Dahyabhai <nalin@redhat.com>
261- enable SSL support
262
263* Sat Aug 12 2000 Nalin Dahyabhai <nalin@redhat.com>
264- update to 5.5.0
265- change Copyright: to License: GPL
266
267* Tue Aug  8 2000 Nalin Dahyabhai <nalin@redhat.com>
268- back out MDA patch; sendmail started listening by default again
269
270* Thu Aug  3 2000 Nalin Dahyabhai <nalin@redhat.com>
271- patch to use procmail as an MDA by default
272- patch to not run makedepend
273
274* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
275- automatic rebuild
276
277* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
278- update to 5.4.3
279
280* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
281- fix a typo in 5.4.2
282
283* Wed Jun 28 2000 Matt Wilson <msw@redhat.com>
284- fixed configure arguments to not have a continuation at the end of the last
285  one
286
287* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
288- update to 5.4.2
289
290* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
291- update to 5.4.1
292- FHS fixes, with mandir override
293- change fetchmailconf.1 symlink to an include
294
295* Thu May 25 2000 Nalin Dahyabhai <nalin@redhat.com>
296- fix Kerberos configure patch to work correctly for krb5 1.0, too
297
298* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
299- update to 5.4.0
300- rework Kerberos dependencies
301
302* Fri Apr 21 2000 Nalin Dahyabhai <nalin@redhat.com>
303- update to 5.3.8
304
305* Tue Apr  4 2000 Bill Nottingham <notting@redhat.com>
306- eliminate explicit krb5-configs dependency
307
308* Mon Mar  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
309- 5.3.1 - This fixes Bugs #9982 and #9987
310
311* Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
312- make kerberos support conditional at build-time
313
314* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
315- integrate kerberos support into main tree
316
317* Fri Feb 25 2000 Nalin Dahyabhai <nalin@redhat.com>
318- Add Kerberos and GSS authenticator support
319
320* Fri Feb 25 2000 Cristian Gafton <gafton@redhat.com>
321- version 5.3.0 has a correct version of the rfc822 patch
322
323* Fri Feb 25 2000 Jeff Johnson <jbj@redhat.com>
324- fix length of rfc822 headers in strcncasecmp().
325
326* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
327- 5.2.8 (fixes the POP3-UIDL bug)
328- Fix up the fetchmailconf man page symlink
329
330* Fri Feb 11 2000 Cristian Gafton <gafton@redhat.com>
331- version 5.2.7
332- add patch so that fetchmailconf will not output ssl configure statements
333  is no ssl is configured
334
335* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
336- rebuild to fix deps
337- man pages are compressed
338- enable %clean
339
340* Tue Jan 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
341- 5.2.3
342- fetchmailconf requires fetchmail = %{version}
343- fix compilation
344
345* Mon Dec 27 1999 Bernhard Rosenkraenzer <bero@redhat.com>
346- 5.2.2
347
348* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
349- got 5.1.0, fixes potential buffer overflow...
350
351* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
352- update to 5.0.4.
353
354* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
355- 5.0.0
356
357* Tue Mar 30 1999 Preston Brown <pbrown@redhat.com>
358- subpackage for fetchmailconf
359
360* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
361- auto rebuild in the new build environment (release 2)
362
363* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
364- version 4.7.0
365- build against glibc 2.1
366
367* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
368- correct typo in dangling symlink fix.
369
370* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
371- update to 4.5.8
372
373* Wed Jul 22 1998 Jeff Johnson <jbj@redhat.com>
374- update to 4.5.3.
375
376* Fri May 08 1998 Cristian Gafton <gafton@redhat.com>
377- fixed spelung eror in the decsriptoin
378
379* Thu May 07 1998 Cristian Gafton <gafton@redhat.com>
380- new version 4.4.4 fixes a lot of bugs
381
382* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
383- translations modified for de, fr, tr
384
385* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
386- upgraded to 4.4.1
387- buildroot
388
389* Thu Oct 23 1997 Michael Fulbright <msf@redhat.com>
390- Updated to 4.3.2 using SRPM from Eric Raymond
391
392* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
393- built against glibc
Note: See TracBrowser for help on using the repository browser.