source: projects/specs/trunk/f/fdupes/fdupes-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Finds duplicate files in a given set of directories
2Summary(ja):    指定されたディレクトリ群から重複ファイルを見つけるツール
3Name:           fdupes
4Version:        1.50
5Release:        0.1.PR2%{?_dist_release}
6License:        MIT
7Group:          Applications/System
8URL:            http://netdial.caribe.net/~adrian2/fdupes.html
9Source0:        http://netdial.caribe.net/~adrian2/programs/fdupes/beta/%{name}-%{version}-PR2.tar.gz
10
11Patch0:         %{name}-%{version}-destdir.patch
12# http://bugs.debian.org/213385
13Patch1:         %{name}-%{version}-compare-file.patch
14# http://bugs.debian.org/447601
15Patch2:         %{name}-%{version}-lfs.patch
16# http://bugs.debian.org/353789
17Patch3:         %{name}-%{version}-typo.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21%description
22FDUPES is a program for identifying duplicate files residing within specified
23directories.
24
25%prep
26%setup -q -n %{name}-%{version}-PR2
27%patch0 -p1
28%patch1 -p1
29%patch2 -p1
30%patch3 -p1
31
32%build
33make %{?_smp_mflags} COMPILER_OPTIONS="$RPM_OPT_FLAGS"
34
35%check
36./%{name} testdir
37./%{name} --omitfirst testdir
38./%{name} --recurse testdir
39./%{name} --size testdir
40# ... etc..
41
42%install
43rm -rf $RPM_BUILD_ROOT
44
45make install INSTALL="%{__install} -p" BIN_DIR=%{_bindir} \
46  MAN_BASE_DIR=%{_mandir} DESTDIR=$RPM_BUILD_ROOT
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(-,root,root,-)
53%doc CHANGES
54%doc CONTRIBUTORS
55%doc README
56%doc TODO
57%doc %{_mandir}/man1/%{name}.1*
58%{_bindir}/%{name}
59
60%changelog
61* Wed Sep 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp>  1.50-0.1.PR2
62- initial build for Vine Linux
63
64* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.50-0.2.PR2
65- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
66
67* Sun Feb 01 2009 Debarshi Ray <rishi@fedoraproject.org> - 1.50-0.1.PR2
68- Version bump to 1.50 PR2.
69  * Added --noprompt, --recurse and --summarize options
70  * Now sorts duplicates (old to new) for consistent order when listing or
71    deleting duplicate files.
72  * Now tests for early matching of files, which should help speed up the
73    matching process when large files are involved.
74  * Added warning whenever a file cannot be deleted.
75  * Fixed bug where some files would not be closed after failure.
76  * Fixed bug where confirmmatch() function wouldn't always deal properly with
77    zero-length files.
78  * Fixed bug where progress indicator would not be cleared when no files were
79    found.
80- Inclusion of string.h now added by upstream.
81- Added patch to fix file comparisons from Debian. (Debian BTS #213385)
82- Added patch to enable large file support on 32-bit systems from Debian.
83  (Debian BTS #447601)
84- Added patch to fix typo in the online manual page from Debian. (Debian BTS
85  #353789)
86
87* Tue Feb 19 2008 Release Engineering <rel-eng@fedoraproject.org> - 1.40-12
88- Autorebuild for gcc-4.3.
89
90* Thu Dec 27 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.40-11
91- Fixed Makefile to preserve timestamps using 'cp -p'.
92
93* Thu Nov 29 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.40-10
94- Release bumped to overcome spurious build.
95
96* Sun Nov 25 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.40-9
97- Initial build. Imported SPEC from Rawhide.
98- Fixed Makefile to use DESTDIR correctly.
99- Fixed sources to include string.h.
Note: See TracBrowser for help on using the repository browser.