source: projects/specs/trunk/f/fcitx-qt5/fcitx-qt5.spec @ 11710

Revision 11710, 6.0 KB checked in by ara_t, 6 years ago (diff)

fcitx-qt5: initial release

Line 
1%global project_name FcitxQt5
2
3%define pkg_name    fcitx-qt5
4%define pkg_version 1.2.3
5%define pkg_release 1%{?_dist_release}
6
7Summary: Fcitx IM module for Qt5
8Name:    %{pkg_name}
9Version: %{pkg_version}
10Release: %{pkg_release}
11
12# The entire source code is GPLv2+ except
13# platforminputcontext/ which is BSD
14License: GPLv2+ and BSD
15Group:   System Environment/Libraries
16
17URL:     https://github.com/fcitx/fcitx-qt5
18Source0: http://download.fcitx-im.org/%{name}/%{name}-%{version}.tar.xz
19
20BuildRequires: cmake
21BuildRequires: fcitx-devel
22BuildRequires: qt5-qtbase-devel
23BuildRequires: libxkbcommon-devel
24BuildRequires: extra-cmake-modules
25BuildRequires: gettext-devel
26# The author requests that fcitx-qt5 should be rebuilt for each minor version
27# of qt5. qt5-qtbase-private-devel is not actually required for build, but
28# left for Qt maintainer to tract this case.
29BuildRequires: qt5-qtbase-private-devel
30
31Vendor:       Project Vine
32Distribution: Vine Linux
33
34
35%description
36This package provides Fcitx Qt5 input context.
37
38%package devel
39Summary:        Development files for fcitx-qt5
40Group:          Development/Libraries
41Requires:       %{name} = %{version}-%{release}
42Requires:       cmake
43
44%description devel
45The %{name}-devel package contains libraries and header files necessary for
46developing programs using fcitx-qt5 libraries.
47
48
49%prep
50%{__rm} -rf ${RPM_BUILD_ROOT}
51%setup -q
52
53%build
54%{cmake} .
55%{__make} %{?_smp_mflags}
56
57%install
58%{__make} install/fast DESTDIR=${RPM_BUILD_ROOT} INSTALL="install -p"
59%find_lang %{name}
60
61%clean
62%{__rm} -rf ${RPM_BUILD_ROOT}
63
64%post -p %{_syssbindir}/ldconfig
65
66%postun -p %{_syssbindir}/ldconfig
67
68
69%files -f %{name}.lang
70%doc README COPYING COPYING.BSD
71%{_libdir}/fcitx/libexec/%{name}-gui-wrapper
72%{_libdir}/lib%{project_name}*.so.*
73%{_libdir}/fcitx/qt/
74%{_qt5_plugindir}/platforminputcontexts/libfcitxplatforminputcontextplugin.so
75
76%files devel
77%{_includedir}/%{project_name}
78%{_libdir}/lib%{project_name}*.so
79%{_libdir}/cmake/*
80
81
82%changelog
83* Fri Jun 08 2018 Toshiaki Ara <ara_t@384.jp> 1.2.3-1
84- initial release for Vine Linux
85
86* Wed Jun  6 2018 Robin Lee <cheeselee@fedoraproject.org> - 1.2.3-1
87- Update to 1.2.3 (#1584926)
88
89* Sun May 27 2018 Rex Dieter <rdieter@fedoraproject.org> - 1.2.2-5
90- rebuild (qt5)
91
92* Mon Feb 19 2018 Robin Lee <cheeselee@fedoraproject.org> - 1.2.2-4
93- rebuild (qt5)
94
95* Wed Feb 14 2018 Robin Lee <cheeselee@fedoraproject.org> - 1.2.2-3
96- BR: qt5-qtbase-private-devel
97
98* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.2-2
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
100
101* Sat Jan 27 2018 Fedora Release Monitoring  <release-monitoring@fedoraproject.org> - 1.2.2-1
102- Update to 1.2.2 (#1539217)
103
104* Wed Dec 20 2017 Jan Grulich <jgrulich@redhat.com> - 1.2.1-2
105- rebuild (qt5)
106
107* Wed Dec 13 2017 Robin Lee <cheeselee@fedoraproject.org> - 1.2.1-1
108- Update to 1.2.1 (BZ#1511238)
109- License changed to GPLv2+ and BSD
110
111* Sun Nov 26 2017 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-3
112- rebuild (qt5)
113
114* Mon Oct 09 2017 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-2
115- rebuild (qt5)
116
117* Sun Sep 24 2017 Robin Lee <cheeselee@fedoraproject> - 1.1.1-1
118- Update to 1.1.1 (BZ#1492079)
119
120* Mon Aug 07 2017 Björn Esser <besser82@fedoraproject.org> - 1.1.0-6
121- Rebuilt for AutoReq cmake-filesystem
122
123* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-5
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
125
126* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-4
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
128
129* Wed Jul 19 2017 Rex Dieter <rdieter@fedoraproject.org> - 1.1.0-3
130-  rebuild (qt5)
131
132* Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 1.1.0-2
133- Rebuild due to bug in RPM (RHBZ #1468476)
134
135* Fri May 12 2017 Robin Lee <cheeselee@fedoraproject.org> - 1.1.0-1
136- Update to 1.1.0
137
138* Wed May 10 2017 Rex Dieter <rdieter@fedoraproject.org> - 1.0.6-5
139- rebuild (qt5)
140
141* Thu Mar 30 2017 Rex Dieter <rdieter@fedoraproject.org> - 1.0.6-4
142- rebuild (qt5)
143
144* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-3
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
146
147* Thu Nov 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 1.0.6-2
148- bump Release
149
150* Thu Nov 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 1.0.6-1.2
151- f24 branch rebuild (qt5)
152
153* Fri Oct 21 2016 Robin Lee <cheeselee@fedoraproject.org> - 1.0.6-1
154- Upate to 1.0.6 (BZ#1384262)
155
156* Tue Jul 19 2016 Rex Dieter <rdieter@fedoraproject.org> - 1.0.5-7
157- use macro version of qt5 dep
158
159* Sun Jul 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 1.0.5-6
160- rebuild (qtbase)
161
162* Thu Jun 09 2016 Rex Dieter <rdieter@fedoraproject.org> - 1.0.5-5
163- rebuild (qtbase)
164
165* Sun Apr 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 1.0.5-4
166- BR: qt5-qtbase-private-devel
167
168* Mon Mar 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 1.0.5-3
169- rebuild (Qt5)
170
171* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.5-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
173
174* Mon Jan 25 2016 Robin Lee <cheeselee@fedoraproject.org> - 1.0.5-1
175- Update to 1.0.5
176
177* Mon Dec 07 2015 Rex Dieter <rdieter@fedoraproject.org> 1.0.4-4
178- rebuild (qt5)
179
180* Fri Oct 09 2015 Rex Dieter <rdieter@fedoraproject.org> 1.0.4-3
181- rebuild(qt5), tighten qt5 dep, .spec cosmetics
182
183* Wed Sep 23 2015 Robin Lee <cheeselee@fedoraproject.org> - 1.0.4-2
184- Requires a versioned qt5-qtbase
185
186* Tue Sep 22 2015 Robin Lee <cheeselee@fedoraproject.org> - 1.0.4-1
187- Update to 1.0.4
188
189* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
190- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
191
192* Mon Jun  1 2015 Robin Lee <cheeselee@fedoraproject.org> - 1.0.2-2
193- Don't explicitly require fcitx
194
195* Thu Apr 30 2015 Robin Lee <cheeselee@fedoraproject.org> - 1.0.2-1
196- Update to 1.0.2
197- License tag revised
198- BR: libxkbcommon-devel
199
200* Thu Apr 16 2015 Robin Lee <cheeselee@fedoraproject.org> - 1.0.1-1
201- Update to 1.0.1
202
203* Fri Dec 12 2014 Robin Lee <cheeselee@fedoraproject.org> - 0.1.3-1
204- Initial package
Note: See TracBrowser for help on using the repository browser.