source: projects/specs/trunk/f/fcitx-kkc/fcitx-kkc-vl.spec @ 9540

Revision 9540, 2.3 KB checked in by iwaim, 9 years ago (diff)

fcitx-kkc 0.1.1-2

Line 
1%define ver 0.1.1
2%define rel 2
3
4Summary: Japanese Kana Kanji Engine for Fcitx
5Name: fcitx-kkc
6Version: %{ver}
7Release: %{rel}%{_dist_release}
8License: GPLv3
9Group: System Environment/Libraries
10URL: https://fcitx-im.org
11Source0: http://download.fcitx-im.org/fcitx-kkc/%{name}-%{version}.tar.xz
12Source1: https://raw.githubusercontent.com/fcitx/fcitx-kkc/5a98b507abdd6888e3124bca1448ad4e4d25b0ef/po/ja.po
13Patch0: https://github.com/m-shibata/fcitx-kkc/commit/49c0045cd5d0262d73d6006db9f6074707247717.patch
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
15BuildRequires: cmake
16BuildRequires: fcitx-devel >= 4.2.8
17BuildRequires: libkkc-devel >= 0.2.3
18Requires: fcitx
19
20Distribution: Vine Linux
21Vendor:       Project Vine
22Packager:     iwaim
23
24%description
25Japanese Kana Kanji Engine for Fcitx.
26
27%prep
28%setup -q
29%patch0 -p1
30%__cp %{SOURCE1} po/ja.po
31
32%build
33%__mkdir build
34pushd build
35%cmake ENABLE_QT=On ..
36make %{?_smp_mflags}
37popd
38
39%install
40rm -rf $RPM_BUILD_ROOT
41pushd build
42make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
43popd
44
45%find_lang %{name}
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%post
51/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
52
53%postun
54if [ $1 -eq 0 ] ; then
55  /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
56  /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
57fi
58
59%posttrans
60/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
61
62%files -f %{name}.lang
63%defattr(-,root,root,-)
64%doc COPYING
65%{_libdir}/fcitx/fcitx-kkc.so
66%{_libdir}/fcitx/qt/libfcitx-kkc-config.so
67%{_datadir}/fcitx/addon/fcitx-kkc.conf
68%{_datadir}/fcitx/configdesc/fcitx-kkc.desc
69%{_datadir}/fcitx/imicon/kkc.png
70%{_datadir}/fcitx/inputmethod/kkc.conf
71%dir %{_datadir}/fcitx/kkc
72%{_datadir}/fcitx/kkc/dictionary_list
73%{_datadir}/fcitx/kkc/rule
74%{_datadir}/icons/hicolor/64x64/apps/fcitx-kkc.png
75%dir %{_includedir}/fcitx/module/kkc
76%{_includedir}/fcitx/module/kkc/fcitx-kkc.h
77
78%changelog
79* Sat May  2 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.1.1-2
80- update ja.po from upstream
81- add 'fix the check for the keymap conflict was inverted' patch (Patch0)
82- clean up spec file
83
84* Sun Jun 15 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.1.1-1
85- update to 0.1.1
86
87* Sun Dec 22 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.1.0-1.git51112956
88- initial relase
89
Note: See TracBrowser for help on using the repository browser.