source: projects/specs/trunk/f/fcgi/fcgi-vl.spec @ 10760

Revision 10760, 4.3 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define snap -SNAP-0910052249
2
3Summary:        FastCGI development kit
4Summary(ja):    FastCGI 開発キット
5Name:           fcgi
6Version:        2.4.1
7Release:        3%{?_dist_release}
8
9Group:          Development/Languages
10License:        BSD
11URL:            http://www.fastcgi.com/#TheDevKit
12Source0:        http://fastcgi.com/dist/fcgi-%{version}%{?snap}.tar.gz
13Source1:        fcgi-autogen.sh
14Patch0:         fcgi-2.4.0-autotools.patch
15# Patch0 created with Source1 after patching Patch1 and Patch2
16#Patch1:         fcgi-2.4.0-configure.in.patch
17#Patch2:         fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
18Patch3:         fcgi-2.4.0-gcc44_fixes.patch
19Patch4:         fcgi-2.4.1-poll.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23# for -perl
24BuildRequires:  perl(ExtUtils::MakeMaker)
25
26# don't "provide" private Perl libs
27%global __provides_exclude_from %{perl_vendorarch}.*\\.so$
28
29%description
30FastCGI is a language independent, scalable, open extension to CGI that
31provides high performance without the limitations of server specific APIs.
32
33
34%package        devel
35Summary:        Development files for %{name}
36Summary(ja):    Development files for %{name}
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39
40
41%description    devel
42The %{name}-devel package contains libraries and header files for
43developing applications that use %{name}.
44
45
46%package perl
47Summary:        Perl bindings for %{name}
48Summary(ja):    Perl bindings for %{name}
49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
52
53
54%description    perl
55The %{name}-perl package contains the perl bindings for fcgi.
56
57
58%prep
59%setup -q -n "%{name}-%{version}%{snap}"
60#%patch0 -p1
61%patch3 -p1
62%patch4 -p1
63
64# remove DOS End Of Line Encoding
65sed -i 's/\r//' doc/fastcgi-prog-guide/ch2c.htm
66# fix file permissions
67chmod a-x include/fcgios.h libfcgi/os_unix.c
68
69
70%build
71%configure
72# does not build with parallel make flags
73make
74
75%install
76%{__rm} -rf %{buildroot}
77%{__mkdir_p} %{buildroot}
78
79make install DESTDIR=%{buildroot}
80%{__rm} -fv %{buildroot}/%{_libdir}/libfcgi{++,}.{l,}a
81install -p -m 0644 -D doc/cgi-fcgi.1 %{buildroot}/%{_mandir}/man1/cgi-fcgi.1
82for manpage in doc/*.3
83do
84install -p -m 0644 -D $manpage %{buildroot}%{_mandir}/man3/$(basename $manpage)
85done
86%{__rm} -f -- doc/*.1
87%{__rm} -f -- doc/*.3
88
89
90%post
91/sbin/ldconfig
92
93%postun
94/sbin/ldconfig
95
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100
101%files
102%defattr(-,root,root,-)
103%{_bindir}/cgi-fcgi
104%{_libdir}/libfcgi.so.*
105%{_libdir}/libfcgi++.so.*
106%{_mandir}/man1/*
107%defattr(0644,root,root,0755)
108%doc LICENSE.TERMS README
109
110
111%files devel
112%defattr(-,root,root,-)
113%{_includedir}/*
114%{_libdir}/libfcgi.so
115%{_libdir}/libfcgi++.so
116%{_mandir}/man3/*
117%defattr(0644,root,root,0755)
118%doc doc/
119
120
121%changelog
122* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> 2.4.1-3
123- rebuild with gcc-5.4.0
124
125* Mon Dec 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-2
126- made to use internal dependency generator.
127
128* Tue Jul  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
129- new upstream release.
130- removed perl binding (not used).
131
132* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.4.0-2vl6
133- build with perl 5.12.3
134
135* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
136- initial build for Vine Linux
137
138* Sun Mar 01 2009 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-9
139- Stripping bad provides of private Perl extension libs
140
141* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-8
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
143
144* Sun Feb 15 2009 Till Maas <opensource@till.name> - 2.4.0-7
145- Add missing #include <cstdio> to make it compile with gcc 4.4
146
147* Tue Oct 14 2008 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-6
148- package up the perl bindings in their own subpackage
149
150* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.4.0-5
151- Autorebuild for GCC 4.3
152
153* Thu Aug 23 2007 Till Maas <opensource till name> - 2.4.0-4
154- bump release for rebuild
155
156* Wed Jul 11 2007 Till Maas <opensource till name> - 2.4.0-3
157- remove parallel make flags
158
159* Tue Apr 17 2007 Till Maas <opensource till name> - 2.4.0-2
160- add some documentation
161- add mkdir ${RPM_BUILD_ROOT} to %%install
162- install man-pages
163
164* Mon Mar 5 2007 Till Maas <opensource till name> - 2.4.0-1
165- Initial spec for fedora
Note: See TracBrowser for help on using the repository browser.