source: projects/specs/trunk/f/fbreader/fbreader-vl.spec @ 5530

Revision 5530, 10.3 KB checked in by munepi, 12 years ago (diff)

updated fbreader-vl.spec

Line 
1## set Qt4 for make
2%define my_make    %__make QTPATH=${QTDIR} QTINCLUDE="-I ${QTDIR}/../include" MOC=%{_libdir}/qt4/bin/moc LDFLAGS="-L $QTDIR"
3
4
5Name:           fbreader
6Version:        0.12.10
7Release:        2%{?_dist_release}
8Summary:        E-book reader
9
10Group:          Applications/Publishing
11License:        GPLv2+
12URL:            http://www.fbreader.org/
13Source0:        http://www.fbreader.org/fbreader-sources-%{version}.tgz
14Source1:        README.Fedora
15Patch0:         fbreader-0.12.9-desktop-file.patch
16Patch1:         fbreader-optflags.patch
17# Use to expose the compiler flags used during build
18# Patch2:         fbreader-debug.patch
19Patch3:         fbreader-defaults.patch
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  expat-devel bzip2-devel liblinebreak-devel
23BuildRequires:  gtk2-devel fribidi-devel
24BuildRequires:  curl-devel >= 7.17
25BuildRequires:  libjpeg-devel desktop-file-utils
26BuildRequires:  qt4-devel sqlite3-devel
27
28# needed because sometimes the API change without soname bump
29Requires:       zlibrary = %{version}-%{release}
30
31
32%description
33FBReader is an e-book reader, with the following main features:
34
35* Supports several formats: fb2, HTML, CHM, plucker, Palmdoc, zTxt
36  (Weasel), TCR (psion), RTF, OEB, OpenReader, mobipocket, plain text.
37* Direct reading from tar, zip, gzip and bzip2 archives. (Multiple
38  books in one archive are supported.)
39* Automatic library building.
40* Automatic encoding detection is supported.
41* Automatically generated contents table.
42* Embedded images support.
43* Footnotes/hyperlinks support.
44* Position indicator.
45* Keeps the last open book and the last read positions for all opened
46  books between runs.
47* List of last opened books.
48* Automatic hyphenations. Liang's algorithm is used. The same
49  algorithm is used in TeX, and TeX hyphenation patterns are used in
50  FBReader. Patterns for Czech, English, Esperanto, French, German and
51  Russian are included in the current version.
52* Text search.
53* Full-screen mode.
54* Screen rotation by 90, 180 and 270 degrees.
55#'
56
57%package        gtk
58Summary:        E-book reader (GTK+ interface)
59Group:          Applications/Publishing
60Requires:       %{name} = %{version}-%{release}
61Requires:       zlibrary-ui-gtk = %{version}-%{release}
62
63%description    gtk
64A virtual package that bundles both the FBreader e-book reader and its
65GTK+ user interface.
66
67
68%package        qt
69Summary:        E-book reader (Qt interface)
70Group:          Applications/Publishing
71Requires:       %{name} = %{version}-%{release}
72Requires:       zlibrary-ui-qt = %{version}-%{release}
73
74%description    qt
75A virtual package that bundles both the FBreader e-book reader and its
76Qt4 user interface.
77
78
79%package -n     zlibrary
80Summary:        Cross-platform GUI library
81Group:          System Environment/Libraries
82Requires:       zlibrary-ui = %{version}-%{release}
83
84%description -n zlibrary
85ZLibrary is a cross-platform library to build applications running on
86desktop Linux, Windows, and different Linux-based PDAs.
87
88
89%package -n     zlibrary-devel
90Summary:        Development files for zlibrary
91Group:          Development/Libraries
92Requires:       zlibrary = %{version}-%{release}
93
94%description -n zlibrary-devel
95This package contains the libraries amd header files that are needed
96for writing applications with Zlibrary.
97
98
99%package -n     zlibrary-ui-gtk
100Summary:        GTK+ interface module for ZLibrary
101Group:          System Environment/Libraries
102Provides:       zlibrary-ui = %{version}-%{release}
103
104Requires(posttrans): /sbin/update-alternatives
105Requires(postun):    /sbin/update-alternatives
106
107%description -n zlibrary-ui-gtk
108ZLibrary is a cross-platform library to build applications running on
109desktop Linux, Windows, and different Linux-based PDAs.
110
111This package provides a GTK+-based UI for ZLibrary.
112
113
114%package -n     zlibrary-ui-qt
115Summary:        Qt4 interface module for ZLibrary
116Group:          System Environment/Libraries
117Provides:       zlibrary-ui = %{version}-%{release}
118Provides:       zlibrary-ui-qt4 = %{version}-%{release}
119Obsoletes:      zlibrary-ui-qt4 < %{version}-%{release}
120
121Requires(posttrans): /sbin/update-alternatives
122Requires(postun):    /sbin/update-alternatives
123
124%description -n zlibrary-ui-qt
125ZLibrary is a cross-platform library to build applications running on
126desktop Linux, Windows, and different Linux-based PDAs.
127
128This package provides a Qt4-based UI for ZLibrary.
129
130%prep
131%setup -q
132%patch0 -p1 -b .desktop-file
133%patch1 -p0 -b .optflags
134#%patch2 -p0 -b .debug
135%patch3 -p0 -b .defaults
136cp -p %{SOURCE1} .
137
138
139%build
140## export $QTDIR
141unset QTDIR || : ; . /etc/profile.d/qt4.sh
142
143%my_make %{?_smp_mflags} -C zlibrary/core TARGET_ARCH=desktop \
144     LIBDIR=%{_libdir} UI_TYPE=dummy
145%my_make %{?_smp_mflags} -C zlibrary/text TARGET_ARCH=desktop \
146     LIBDIR=%{_libdir} UI_TYPE=dummy
147%my_make %{?_smp_mflags} -C zlibrary/ui TARGET_ARCH=desktop \
148     LIBDIR=%{_libdir} UI_TYPE=gtk
149%my_make %{?_smp_mflags} -C zlibrary/ui TARGET_ARCH=desktop \
150     LIBDIR=%{_libdir} UI_TYPE=qt4
151%my_make %{?_smp_mflags} -C fbreader TARGET_ARCH=desktop \
152     LIBDIR=%{_libdir} UI_TYPE=dummy
153
154
155%install
156%__rm -rf $RPM_BUILD_ROOT
157%__make -C zlibrary/core do_install do_install_dev \
158     DESTDIR=$RPM_BUILD_ROOT TARGET_ARCH=desktop \
159     LIBDIR=%{_libdir} UI_TYPE=dummy
160%__make -C zlibrary/text do_install do_install_dev \
161     DESTDIR=$RPM_BUILD_ROOT TARGET_ARCH=desktop \
162     LIBDIR=%{_libdir} UI_TYPE=dummy
163%__make -C zlibrary/ui do_install DESTDIR=$RPM_BUILD_ROOT TARGET_ARCH=desktop \
164     LIBDIR=%{_libdir} UI_TYPE=gtk
165%__make -C zlibrary/ui do_install DESTDIR=$RPM_BUILD_ROOT TARGET_ARCH=desktop \
166     LIBDIR=%{_libdir} UI_TYPE=qt4
167%__make -C fbreader do_install DESTDIR=$RPM_BUILD_ROOT TARGET_ARCH=desktop \
168     UI_TYPE=dummy
169
170desktop-file-install --vendor="vine" \
171    --remove-category="Application" \
172    --delete-original \
173    --dir=%{buildroot}%{_datadir}/applications \
174    %{buildroot}%{_datadir}/applications/FBReader.desktop
175
176
177%clean
178%__rm -rf $RPM_BUILD_ROOT
179
180
181%post -n zlibrary -p /sbin/ldconfig
182
183%postun -n zlibrary -p /sbin/ldconfig
184
185%posttrans -n zlibrary-ui-gtk
186/sbin/update-alternatives \
187  --install \
188  %{_libdir}/zlibrary/ui/zlui-active.so \
189  zlibrary-ui \
190  %{_libdir}/zlibrary/ui/zlui-gtk.so \
191  2
192
193%posttrans -n zlibrary-ui-qt
194/sbin/update-alternatives \
195  --install \
196  %{_libdir}/zlibrary/ui/zlui-active.so \
197  zlibrary-ui \
198  %{_libdir}/zlibrary/ui/zlui-qt4.so \
199  1
200
201%postun -n zlibrary-ui-gtk
202if [ $1 -eq 0 ]; then
203    /sbin/update-alternatives --remove zlibrary-ui \
204        %{_libdir}/zlibrary/ui/zlui-gtk.so
205fi
206exit 0
207
208%postun -n zlibrary-ui-qt
209if [ $1 -eq 0 ]; then
210    /sbin/update-alternatives --remove unison \
211        %{_libdir}/zlibrary/ui/zlui-qt4.so
212fi
213exit 0
214
215%files
216%defattr(-,root,root,-)
217%doc fbreader/LICENSE README.Fedora
218%{_bindir}/FBReader
219%{_datadir}/FBReader
220%{_datadir}/applications/*-FBReader.desktop
221%{_datadir}/pixmaps/FBReader.png
222%{_datadir}/pixmaps/FBReader
223
224%files gtk
225%files qt
226
227%files -n zlibrary
228%defattr(-,root,root,-)
229%doc fbreader/LICENSE
230%{_libdir}/lib*.so.*
231%dir %{_libdir}/zlibrary
232%dir %{_libdir}/zlibrary/ui
233%exclude %{_datadir}/zlibrary/keynames-*.xml
234%{_datadir}/zlibrary
235
236%files -n zlibrary-devel
237%defattr(-,root,root,-)
238%{_includedir}/*
239%{_libdir}/lib*.so
240
241%files -n zlibrary-ui-gtk
242%defattr(-,root,root,-)
243%{_libdir}/zlibrary/ui/zlui-gtk.so
244%{_datadir}/zlibrary/keynames-gtk.xml
245
246%files -n zlibrary-ui-qt
247%defattr(-,root,root,-)
248%{_libdir}/zlibrary/ui/zlui-qt4.so
249%{_datadir}/zlibrary/keynames-qt4.xml
250
251
252
253%changelog
254* Sat Jan 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.10-2
255- rebuild
256
257* Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.12.10-1
258- initial build based on Fedora development
259
260* Mon Jun  7 2010 Michel Salim <salimma@fedoraproject.org> - 0.12.10-1
261- Update to 0.12.10
262
263* Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 0.12.9-1
264- Update to 0.12.9
265
266* Sat Feb 13 2010 Michel Salim <salimma@fedoraproject.org> - 0.12.2-1
267- Update to 0.12.2
268- Fix overlap between fbreader and zlibrary
269
270* Tue Jan 26 2010 Michel Salim <salimma@fedoraproject.org> - 0.12.1-1
271- Update to 0.12.1
272
273* Sat Oct 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.7-4
274- Provide virtual packages for each available interface
275- Use alternatives to select the user interface (see README.Fedora)
276
277* Thu Sep 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.7-3
278- Split out zlibrary and zlibrary-ui subpackages (fixes bz# 523946)
279
280* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.7-2
281- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
282
283* Tue Mar 31 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.7-1
284- Update to 0.10.7
285
286* Tue Feb 24 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.3-3
287- Fix for GCC 4.4
288
289* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.3-2
290- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
291
292* Thu Feb  5 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.3-1
293- Update to 0.10.3
294
295* Wed Jan 28 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.2-1
296- Update to 0.10.2
297
298* Wed Jan 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.0-1
299- Update to 0.10.0
300
301* Thu Jul 31 2008 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.8.17-1
302- Update to 0.8.17
303
304* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.8.12-2
305- Autorebuild for GCC 4.3
306
307* Sun Jan 20 2008 Michel Alexandre Salim <michel.sylvan@gmail.com> - 0.8.12-1
308- Update to 0.8.12
309
310* Mon Jan  7 2008 Michel Alexandre Salim <michel.sylvan@gmail.com> - 0.8.10-1
311- Update to 0.8.10
312- Remove workaround for PDB issues on x86_64; fixed upstream
313
314* Thu Dec 20 2007 Michel Alexandre Salim <michel.sylvan@gmail.com> - 0.8.8a-1
315- Update to 0.8.8a
316- Workaround for PDB format handler when reading certain files
317
318* Wed Dec 19 2007 Michel Alexandre Salim <michel.sylvan@gmail.com> - 0.8.8-2
319- Fix inclusion of debug files where libdir=/usr/lib (bz #411891)
320
321* Sun Dec  2 2007 Michel Alexandre Salim <michel.sylvan@gmail.com> - 0.8.8-1
322- Update to 0.8.8
323
324* Thu Oct 18 2007 Michel Alexandre Salim <michel.sylvan@gmail.com> - 0.8.6d-3
325- Generate proper -debuginfo subpackage (bz #329841, Ville Skytta)
326- Add README.Fedora detailing zTXT bug on x86_64
327
328* Sat Sep 22 2007 Michel Alexandre Salim <michel.sylvan@gmail.com> - 0.8.6d-2
329- Fix vendor tag
330- Use compiler flags provided by the system
331
332* Sun Sep 16 2007 Michel Alexandre Salim <michel.sylvan@gmail.com> - 0.8.6d-1
333- Initial package
Note: See TracBrowser for help on using the repository browser.