source: projects/specs/trunk/f/farsight2/farsight2-vl.spec @ 5341

Revision 5341, 6.0 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define gst_ver 0.10.35
4%define gst_plugins_base_ver 0.10.35
5%define gst_plugins_good 0.10.30
6%define gst_python 0.10.10
7
8Name:           farsight2
9Version:        0.0.31
10Release:        1%{?_dist_release}
11Summary:        Libraries for videoconferencing
12Summary(ja):    ビデオ会議のためのライブラリ
13
14Group:          System Environment/Libraries
15License:        LGPLv2+
16URL:            http://farsight.freedesktop.org/wiki/
17Source0:        http://farsight.freedesktop.org/releases/%{name}/%{name}-%{version}.tar.gz
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  glib2-devel >= 2.14
21BuildRequires:  gstreamer-devel >= %{gst_ver}
22BuildRequires:  gstreamer-plugins-base-devel >= %{gst_plugins_base_ver}
23BuildRequires:  gstreamer-python-devel >= %{gst_python}
24BuildRequires:  libnice-devel >= 0.0.9
25BuildRequires:  gupnp-devel
26BuildRequires:  gupnp-igd-devel
27BuildRequires:  python-devel
28BuildRequires:  pygobject-devel
29
30Requires:       gstreamer-plugins-good >= %{gst_plugins_good}
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36%{name} is a collection of GStreamer modules and libraries for
37videoconferencing.
38
39
40%package        python
41Summary:        Python binding for %{name}
42Group:          Development/Libraries
43Requires:       %{name} = %{version}-%{release}
44
45%description    python
46Python bindings for %{name}.
47
48
49%package        devel
50Summary:        Development files for %{name}
51Group:          Development/Libraries
52Requires:       %{name} = %{version}-%{release}
53Requires:       %{name}-python = %{version}-%{release}
54Requires:       gstreamer-devel  >= %{gst_ver}
55Requires:       gstreamer-plugins-base-devel >= %{gst_plugins_base_ver}
56Requires:       pkgconfig
57
58
59%description    devel
60The %{name}-devel package contains libraries and header files for
61developing applications that use %{name}.
62
63%prep
64%setup -q
65
66%build
67%configure                                                              \
68  --with-package-name='Vine Linux farsight2 package'                    \
69  --disable-static
70
71sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
72sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
73make %{?_smp_mflags}
74
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
79find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88
89%files
90%defattr(-,root,root,-)
91%doc COPYING
92%{_libdir}/*.so.*
93%dir %{_libdir}/%{name}-0.0
94%{_libdir}/%{name}-0.0/libmulticast-transmitter.so
95%{_libdir}/%{name}-0.0/libnice-transmitter.so
96%{_libdir}/%{name}-0.0/librawudp-transmitter.so
97%{_libdir}/%{name}-0.0/libshm-transmitter.so
98%{_libdir}/gstreamer-0.10/libfsfunnel.so
99%{_libdir}/gstreamer-0.10/libfsrtpconference.so
100%{_libdir}/gstreamer-0.10/libfsvideoanyrate.so
101%{_libdir}/gstreamer-0.10/libfsrtcpfilter.so
102%{_libdir}/gstreamer-0.10/libfsmsnconference.so
103%{_libdir}/gstreamer-0.10/libfsrawconference.so
104%{_datadir}/farsight2/0.0/fsrtpconference
105
106%files python
107%defattr(-,root,root,-)
108%{python_sitearch}/farsight.so
109
110%files devel
111%defattr(-,root,root,-)
112%{_libdir}/libgstfarsight-0.10.so
113%{_libdir}/pkgconfig/%{name}-0.10.pc
114%{_includedir}/gstreamer-0.10/gst/farsight/
115%{_datadir}/gtk-doc/html/%{name}-libs-0.10
116%{_datadir}/gtk-doc/html/%{name}-plugins-0.10
117
118
119%changelog
120* Sat Dec 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.31-1
121- new upstream release
122
123* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.30-1
124- new upstream release
125
126* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.29-1
127- new upstream release
128- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
129
130* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.0.17-2
131- rebuilt with rpm-4.8.1 for pkg-config
132- added BR: gupnp-devel
133
134* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.17-1
135- new upstream release
136
137* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.0.16-3
138- rebuild with python-2.6
139
140* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.16-2
141- initial build for Vine Linux
142
143* Tue Oct  6 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.16-1
144- Update to 0.0.16.
145
146* Thu Sep 17 2009 Bastien Nocera <bnocera@redhat.com> 0.0.15-2
147- Rebuild for new gupnp
148
149* Thu Sep  3 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.15-1
150- Update to 0.0.15.
151
152* Thu Aug 06 2009 Warren Togami <wtogami@redhat.com> - 0.0.14-1
153- 0.0.14
154
155* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.12-4
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
157
158* Wed Jul 22 2009 Warren Togami <wtogami@redhat.com> - 0.0.12-3
159- rebuild
160
161* Mon Jun 22 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.12-2
162- Remove unnecessary requires on gst-plugins-farsight.
163
164* Sat May 30 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.12-1
165- Update to 0.0.12.
166
167* Tue May 26 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.11-1
168- Update to 0.0.11.
169
170* Wed May 20 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.10-1
171- Update to 0.0.10.
172
173* Tue Apr  7 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.9-1
174- Update to 0.0.9.
175
176* Tue Mar 17 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.8-1
177- Update to 0.0.8.
178- Bump min version of gstreamer needed.
179
180* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-3
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
182
183* Mon Jan 19 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.7-2
184- Add BR on gupnp-igd-devel, pygobject2-devel, and pygtk2-devel.
185
186* Fri Jan  9 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.7-1
187- Update to 0.0.7.
188
189* Mon Jan  5 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-4
190- Add BR on libnice-devel and build libnice transmitter.
191- Set gstreamer package name & origin.
192
193* Fri Jan 02 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-3
194- Rebuild.
195
196* Wed Dec 31 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-2
197- Preserve time stamps.
198
199* Tue Dec 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-1
200- Initial Fedora spec.
Note: See TracBrowser for help on using the repository browser.