source: projects/specs/trunk/f/facile/facile-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Functional Constraint Library implemented in Objective Caml
2Name: facile
3Version: 1.1
4Release: 10%{?_dist_release}
5License: LGPL
6Group: System Environment/Libraries
7Source: http://www.recherche.enac.fr/opti/facile/distrib/%{name}-%{version}.tar.gz
8URL: http://www.recherche.enac.fr/opti/facile/
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: ocaml >= 3.02
11Requires: ocaml >= 3.02
12
13%description
14FaCiLe is a constraint programming library on integer and integer set
15finite domains written in OCaml. It offers all usual facilities to create and
16manipulate finite domain variables, arithmetic expressions and constraints
17(possibly non-linear), built-in global constraints (difference, cardinality,
18sorting etc.) and search and optimization goals. FaCiLe allows as well to
19build easily user-defined constraints and goals (including recursive ones),
20making pervasive use of OCaml higher-order functionals to provide a simple
21and flexible interface for the user. As FaCiLe is an OCaml library and not
22"yet another language", the user benefits from type inference and strong
23typing discipline, high level of abstraction, modules and objects system,
24as well as native code compilation efficiency, garbage collection and replay
25debugger, all features of OCaml (among many others) that allow to prototype
26and experiment quickly: modeling, data processing and interface are
27implemented with the same powerful and efficient language. For a more
28complete description, you may consult the preface and foreword of the online
29documentation
30
31%prep
32%setup -q
33
34%build
35./configure
36make
37
38%install
39rm -rf $RPM_BUILD_ROOT
40mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/facile
41cp src/facile.cmi src/facile.cma src/facile.cmxa src/facile.a $RPM_BUILD_ROOT%{_libdir}/ocaml/facile
42chmod a+r $RPM_BUILD_ROOT%{_libdir}/ocaml/facile/facile.cmi
43chmod a+r $RPM_BUILD_ROOT%{_libdir}/ocaml/facile/facile.cma
44chmod a+r $RPM_BUILD_ROOT%{_libdir}/ocaml/facile/facile.cmxa
45chmod a+r $RPM_BUILD_ROOT%{_libdir}/ocaml/facile/facile.a
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%check
51make check
52
53%files
54%defattr(-,root,root)
55%doc LICENSE README
56%{_libdir}/ocaml/facile/*
57
58%changelog
59* Sun Sep 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1-10
60- rebuilt with ocaml-3.11.0 (x86_64 has not built with ocaml-3.11.0)
61
62* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-9
63- rebuilt with ocaml-3.11.0
64
65* Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-8
66- rebuild with ocaml-3.10.2
67
68* Thu Feb  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl5.2
69- rebuild with ocaml-3.10.1 on Vine4.2
70
71* Thu Feb  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl7
72- rebuild with ocaml-3.10.1
73
74* Tue Oct 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl5.1
75- rebuild with ocaml-3.10.0 on Vine4.1
76
77* Sun Sep 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-0vl6
78- rebuild with ocaml-3.10.0
79
80* Thu Jun 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1-0vl5
81- rebuild with ocaml-3.09.2 on VineSeed
82
83* Thu Mar 23 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl4
84- rebuild with ocaml-3.09.1 on VineSeed
85
86* Thu Mar 23 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
87- rebuild with ocaml-3.09.1 on Vine3.2
88
89* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
90- rebuild for VineSeed
91
92* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
93- initial release
Note: See TracBrowser for help on using the repository browser.