source: projects/specs/trunk/e/extace/extace-vl.spec @ 521

Revision 521, 3.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define fftw_version 2.1.3
2Summary: A GNOME sound displayer.
3Summary(ja): GNOME ¥µ¥¦¥ó¥É¥Ç¥£¥¹¥×¥ì¥¤¥×¥í¥°¥é¥à
4Name: extace
5Version: 1.4.4
6Release: 2vl1
7Copyright: GPL
8Group: Applications/Multimedia
9Source: http://download.sourceforge.net/eXtace/extace-%{version}.tar.gz
10Source1: http://www.fftw.org/fftw-%{fftw_version}.tar.gz
11Patch0: extace-1.2.25-libfftw.patch
12Patch1: extace-1.4.4-configure.in.patch
13patch2: extace-1.4.4-cflags.patch
14BuildRoot: %{_tmppath}/%{name}-root
15URL: http://extace.sourceforge.net/
16
17# Someone needs
18%description
19eXtace is a audio visualization plugin for the GNOME GUI desktop
20environment. It connects to EsounD (the Enlightened Sound Daemon) and
21displays the audio data as either a 3D textured landscape, a 3D
22pointed landscape, a 16-128 channel graphic EQ, or a colored
23Oscilloscope.
24
25%description -l ja
26extace ¤Ï GNOME GUI ¥Ç¥¹¥¯¥È¥Ã¥×´Ä¶­¸þ¤±¤Î¥ª¡¼¥Ç¥£¥ª²Ä»ë²½¥×¥é¥°¥¤¥ó¤Ç¤¹¡¥
27extace ¤Ï esound (the Enlightened Sound Daemon) ¤ÈÀܳ¤·¡¤¥ª¡¼¥Ç¥£¥ª¥Ç¡¼¥¿¤ò
283D ¥Æ¥¯¥¹¥Á¥ã¥é¥ó¥É¥¹¥±¡¼¥×¡¤3D ¥Ý¥¤¥ó¥È¥é¥ó¥É¥¹¥±¡¼¥×¡¤16-128 ¥Á¥ã¥ó¥Í¥ë¤Î
29¥°¥é¥Õ¥£¥Ã¥¯¥¤¥³¥é¥¤¥¶¡¤°¿¤¤¤Ï¥«¥é¡¼ÈÇ¥ª¥·¥í¥¹¥³¡¼¥×¤È¤·¤Æɽ¼¨¤·¤Þ¤¹¡¥
30
31
32%prep
33%setup -q -a 1
34%patch0 -p1 -b .libfftw
35%patch1 -p1 -b .configure.in
36autoheader
37autoconf
38
39
40%build
41rm -rf $RPM_BUILD_ROOT
42
43# Build FFTW first.
44%ifarch %{ix86}
45HACKFLAGS="--enable-i386-hacks"
46%endif
47
48CFLAGS="$RPM_OPT_FLAGS"
49%ifarch alpha
50CFLAGS="$CFLAGS -mieee"
51%endif
52export CFLAGS
53CPPFLAGS="-I$RPM_BUILD_ROOT%{_includedir}"; export CPPFLAGS
54LDFLAGS="-L$RPM_BUILD_ROOT%{_libdir}"; export LDFLAGS
55
56pushd fftw-%{fftw_version}
57%configure ${HACKFLAGS} \
58        --enable-shared=no --enable-static=yes \
59        --enable-debug=no --enable-debug-alignment=n
60%{makeinstall}
61popd
62
63# Build Extace itself
64%configure --disable-alsa
65make
66
67
68%install
69# Now wipe out fftw, because we don't want to install it.
70rm -rf $RPM_BUILD_ROOT
71%{makeinstall}
72
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77
78%files
79%defattr(-,root,root)
80%{_bindir}/extace
81%{_datadir}/gnome/apps/Multimedia/extace.desktop
82
83
84%changelog
85* Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
86- 1.4.4-2vl1
87- based on 1.4.4-2 from Rawhide
88- added Japanese summary and description
89
90* Tue Jan 30 2001 Elliot Lee <sopwith@redhat.com> 1.4.4-2
91- Fix bug #14273 (issues on the Alpha) by making sure -mieee is in $CFLAGS and that
92  $CFLAGS actually gets used by extace.
93
94* Tue Jan 16 2001 Philipp Knirsch <pknirsch@redhat.de>
95- Updated to 1.4.4
96- Fixed the ALSA requirement (--disable-alsa) as most sounddrivers are now
97  OSS (and it won't even compile with ALSA anymore ;).
98
99* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
100- automatic rebuild
101
102* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
103- Update to 1.2.25
104
105* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
106- Update to 1.2.23
107- Update fftw library to 2.1.3
108- Remove specific config.guess
109- Use %%makeinstall
110- Don't strip binaries
111
112* Tue Jan 04 2000 Elliot Lee <sopwith@redhat.com>
113- Update to 1.2.15
114
115* Fri Sep 03 1999 Elliot Lee <sopwith@redhat.com>
116- Create extace package
117- Include FFTW in here instead of using gsl (FFTW is faster).
Note: See TracBrowser for help on using the repository browser.