source: projects/specs/trunk/e/expect/expect-vl.spec @ 521

Revision 521, 8.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define tcl_major 8.4
2%define thread_major 2.5
3%define majorver 5.43
4
5Summary: A Tcl/Tk development environment: expect
6Summary(ja): Tcl/Tk 開発環境: expect
7Name: expect
8Version: %{majorver}.0
9Release: 1%{?_dist_release}
10Group: Development/Languages
11URL: http://expect.nist.gov/
12License: BSD
13Source0: http://expect.nist.gov/src/%{name}-%{version}.tar.gz
14Patch0: expect-5.32.2-random.patch
15Patch6: expect-5.38.0-spawn-43310.patch
16Patch8: expect-5.32.2-setpgrp.patch
17Patch10: expect-5.38.0-lib-spec.patch
18Patch11: expect-5.39.0-libdir.patch
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: tcl >= %{tcl_major}
22BuildRequires: thread >= %{thread_major}
23BuildRequires: autoconf213
24
25%description -n expect
26Expect is a tcl extension for automating interactive applications such
27as telnet, ftp, passwd, fsck, rlogin, tip, etc.  Expect is also useful
28for testing the named applications.  Expect makes it easy for a script
29to control another program and interact with it.
30
31Install the expect package if you'd like to develop scripts which interact
32with interactive applications.  You'll also need to install the tcl
33package.
34
35%package devel
36Summary: Development files for expect library.
37Group: Development/Languages
38Requires: expect = %{version}-%{release}
39Obsoletes: expect <= 5.43-0vl4
40
41%description devel
42This package contains development files for the expect library.
43
44%package -n expectk
45Summary: expectk and some scripts
46Group: Development/Languages
47Requires: expect = %{version}-%{release}
48Obsoletes: expect <= 5.43-0vl4
49
50%description -n expectk
51This package contains expectk and some scripts that use it.
52
53%prep
54%setup -q -n %{name}-%{majorver}
55%patch0 -p1 -b .random
56%patch6 -p2 -b .spawn
57%patch8 -p2 -b .pgrp
58%patch10 -p1 -b .libspec
59%patch11 -p1 -b .libdir
60
61# patch10 touch configure.in
62autoconf-2.13
63
64%build
65%configure --enable-64bit \
66        --with-tcl=%{_libdir} --with-tk=%{_libdir} \
67        --with-tclinclude=%{_includedir}/tcl-private/generic \
68        --with-tkinclude=%{_includedir}/tk-private/generic \
69        --enable-shared --enable-threads --with-x=yes --enable-gcc
70make
71
72%install
73rm -rf ${RPM_BUILD_ROOT}
74mkdir -p ${RPM_BUILD_ROOT}
75make INSTALL_ROOT=%{buildroot} install
76
77# for linking with -lexpect
78ln -s libexpect%{majorver}.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
79
80# remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
81rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
82rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
83rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
84
85%post -p /sbin/ldconfig -n expect
86
87%postun -p /sbin/ldconfig -n expect
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%%defattr(-,root,root)
94%doc FAQ HISTORY NEWS README
95%{_bindir}/expect
96%{_bindir}/autoexpect
97%{_bindir}/dislocate
98%{_bindir}/ftp-rfc
99%{_bindir}/kibitz
100%{_bindir}/lpunlock
101%{_bindir}/mkpasswd
102%{_bindir}/passmass
103%{_bindir}/rftp
104%{_bindir}/rlogin-cwd
105%{_bindir}/timed-read
106%{_bindir}/timed-run
107%{_bindir}/unbuffer
108%{_bindir}/weather
109%{_bindir}/xkibitz
110%dir %{_libdir}/expect%{majorver}
111%{_libdir}/expect%{majorver}/pkgIndex.tcl
112%{_libdir}/libexpect%{majorver}.so
113%{_mandir}/man1/autoexpect.1.gz
114%{_mandir}/man1/dislocate.1.gz
115%{_mandir}/man1/expect.1.gz
116%{_mandir}/man1/kibitz.1.gz
117%{_mandir}/man1/mkpasswd.1.gz
118%{_mandir}/man1/passmass.1.gz
119%{_mandir}/man1/tknewsbiff.1.gz
120%{_mandir}/man1/unbuffer.1.gz
121%{_mandir}/man1/xkibitz.1.gz
122
123%files devel
124%defattr(-,root,root,-)
125%exclude %{_libdir}/expect%{majorver}/libexpect%{majorver}.a
126%exclude %{_libdir}/libexpect%{majorver}.a
127%{_libdir}/libexpect.so
128%{_mandir}/man3/libexpect.3*
129%{_includedir}/*
130
131%files -n expectk
132%defattr(-,root,root,-)
133%{_bindir}/expectk
134%{_bindir}/multixterm
135%{_bindir}/tknewsbiff
136%{_bindir}/tkpasswd
137%{_bindir}/xpstat
138%{_mandir}/man1/expectk.1*
139%{_mandir}/man1/multixterm.1*
140%{_mandir}/man1/tknewsbiff.1*
141
142
143%changelog
144* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
145- applied new versioning policy and spec in utf-8
146
147* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
148- rebuilt with tcl/tk-8.4.18
149
150* Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
151- split to expect-devel and expectk sub package.
152- add libexpect.so to expect-devel (<BTS:wishes:0136>)
153
154* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
155- rebuilt with tcl/tk-8.4.16
156
157* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
158- rebuilt with new toolchain
159
160* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
161- rebuild for tcl/tk-8.4.12
162- added --enable-64bit to configure's option
163
164* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
165- updated expect to 5.43.0
166- dropped expect-5.39.0-64bit-82547.patch (for fixed)
167- dropped expect-5.32.2-kibitz.patch (for fixed)
168- dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
169- rebuilt with tcl/tk 8.4.11
170
171* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
172- rebuild for tcl/tk-8.4.6
173
174* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
175- update based on fedora
176
177* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
178- update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
179
180* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
181- splite source package
182- add include files
183
184* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
185- expand some macros.. (FIXME)
186
187* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
188- use %configure macros
189- add Patch 47,50
190
191* Thu May 31 2001 <sagami@vinelinux.org>
192- 8.0.5_jp-10
193- unexpand old %%{configure}, new one causes build failure
194- fixed missing libtkx.so libtclx.so symlink in /usr/lib
195- install manpages into %%{_mandir} and mode 644
196
197* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
198- 8.0.5_jp-9
199- modified %install section to handle compressed man pages
200- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
201
202* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
203- changed default fonts
204
205* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
206- added defattr
207
208* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
209- added some symlinks, such as libtcl8.0.so.
210- obsoletes version number using _jp, now 8.0.5-31vl1
211
212* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
213- Apply Tcl/Tk 8.0 Japanese Patch 1.7
214
215* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
216- fix tclX symlinks.
217- compile on systems where SIGPWR == SIGLOST.
218
219* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
220- update tcl/tk to 8.0.5.
221- avoid "containing" in Tix (#2332).
222
223* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
224- use /usr/bin/write in kibitz (#1320).
225- use cirrus.sprl.umich.edu in weather (#1926).
226
227* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
228- auto rebuild in the new build environment (release 28)
229
230* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
231- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
232
233* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
234- expect does unaligned access on alpha (#989)
235- upgrade tcl/tk/tclX to 8.0.4
236- upgrade expect to 5.28.
237- add itcl 3.0.1
238
239* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
240- call libtoolize to allow building on the arm
241- build for glibc 2.1
242- strip binaries
243
244* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
245- update tcl/tk/tclX to 8.0.3, expect is updated also.
246
247* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
248- expect: mkpasswd needs delay before sending password (problem #576)
249
250* Thu May 07 1998 Prospector System <bugs@redhat.com>
251- translations modified for de, fr, tr
252
253* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
254- fixed expect binaries exec permissions
255
256* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
257- updated to Tix 4.1.0.006
258- updated version numbers of tcl/tk to relflect includsion of p2
259
260* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
261- updated tcl/tk to patch level 2
262- updated tclX to 8.0.2
263
264* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
265- fixed filelist for tix... replacing path to the expect binary in scripts
266  was leaving junk files around.
267
268* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
269- added patch to remove libieee test in configure.in for tcl and tk.
270  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
271  solution for all systems
272- fixed src urls
273
274* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
275- removed version numbers from descriptions
276
277* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
278- updated to tcl/tk 8.0 and related versions of packages
279
280* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
281- built against glibc
282- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.