source: projects/specs/trunk/e/expect/expect-vl.spec @ 1262

Revision 1262, 8.5 KB checked in by owa, 14 years ago (diff)

updated tcl/tk

Line 
1%define tcl_major 8.4
2%define thread_major 2.5
3%define majorver 5.43
4
5Summary: A Tcl/Tk development environment: expect
6Summary(ja): Tcl/Tk 開発環境: expect
7Name: expect
8Version: %{majorver}.0
9Release: 3%{?_dist_release}
10Group: Development/Languages
11URL: http://expect.nist.gov/
12License: BSD
13Source0: http://expect.nist.gov/src/%{name}-%{version}.tar.gz
14Patch0: expect-5.32.2-random.patch
15Patch6: expect-5.38.0-spawn-43310.patch
16Patch8: expect-5.32.2-setpgrp.patch
17Patch10: expect-5.38.0-lib-spec.patch
18Patch11: expect-5.39.0-libdir.patch
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: tcl >= %{tcl_major}
22BuildRequires: thread >= %{thread_major}
23BuildRequires: autoconf213
24
25%description -n expect
26Expect is a tcl extension for automating interactive applications such
27as telnet, ftp, passwd, fsck, rlogin, tip, etc.  Expect is also useful
28for testing the named applications.  Expect makes it easy for a script
29to control another program and interact with it.
30
31Install the expect package if you'd like to develop scripts which interact
32with interactive applications.  You'll also need to install the tcl
33package.
34
35%package devel
36Summary: Development files for expect library.
37Group: Development/Libraries
38Requires: expect = %{version}-%{release}
39Obsoletes: expect <= 5.43-0vl4
40
41%description devel
42This package contains development files for the expect library.
43
44%package -n expectk
45Summary: expectk and some scripts
46Group: Development/Languages
47Requires: expect = %{version}-%{release}
48Obsoletes: expect <= 5.43-0vl4
49
50%description -n expectk
51This package contains expectk and some scripts that use it.
52
53%prep
54%setup -q -n %{name}-%{majorver}
55%patch0 -p1 -b .random
56%patch6 -p2 -b .spawn
57%patch8 -p2 -b .pgrp
58%patch10 -p1 -b .libspec
59%patch11 -p1 -b .libdir
60
61# patch10 touch configure.in
62autoconf-2.13
63
64%build
65%configure --enable-64bit \
66        --with-tcl=%{_libdir} --with-tk=%{_libdir} \
67        --with-tclinclude=%{_includedir}/tcl-private/generic \
68        --with-tkinclude=%{_includedir}/tk-private/generic \
69        --enable-shared --enable-threads --with-x=yes --enable-gcc
70make
71
72%install
73rm -rf ${RPM_BUILD_ROOT}
74mkdir -p ${RPM_BUILD_ROOT}
75make INSTALL_ROOT=%{buildroot} install
76
77# for linking with -lexpect
78ln -s libexpect%{majorver}.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
79
80# remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
81rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
82rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
83rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
84
85%post -p /sbin/ldconfig -n expect
86
87%postun -p /sbin/ldconfig -n expect
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%%defattr(-,root,root)
94%doc FAQ HISTORY NEWS README
95%{_bindir}/expect
96%{_bindir}/autoexpect
97%{_bindir}/dislocate
98%{_bindir}/ftp-rfc
99%{_bindir}/kibitz
100%{_bindir}/lpunlock
101%{_bindir}/mkpasswd
102%{_bindir}/passmass
103%{_bindir}/rftp
104%{_bindir}/rlogin-cwd
105%{_bindir}/timed-read
106%{_bindir}/timed-run
107%{_bindir}/unbuffer
108%{_bindir}/weather
109%{_bindir}/xkibitz
110%dir %{_libdir}/expect%{majorver}
111%{_libdir}/expect%{majorver}/pkgIndex.tcl
112%{_libdir}/libexpect%{majorver}.so
113%{_mandir}/man1/autoexpect.1.gz
114%{_mandir}/man1/dislocate.1.gz
115%{_mandir}/man1/expect.1.gz
116%{_mandir}/man1/kibitz.1.gz
117%{_mandir}/man1/mkpasswd.1.gz
118%{_mandir}/man1/passmass.1.gz
119%{_mandir}/man1/tknewsbiff.1.gz
120%{_mandir}/man1/unbuffer.1.gz
121%{_mandir}/man1/xkibitz.1.gz
122
123%files devel
124%defattr(-,root,root,-)
125%exclude %{_libdir}/expect%{majorver}/libexpect%{majorver}.a
126%exclude %{_libdir}/libexpect%{majorver}.a
127%{_libdir}/libexpect.so
128%{_mandir}/man3/libexpect.3*
129%{_includedir}/*
130
131%files -n expectk
132%defattr(-,root,root,-)
133%{_bindir}/expectk
134%{_bindir}/multixterm
135%{_bindir}/tknewsbiff
136%{_bindir}/tkpasswd
137%{_bindir}/xpstat
138%{_mandir}/man1/expectk.1*
139%{_mandir}/man1/multixterm.1*
140%{_mandir}/man1/tknewsbiff.1*
141
142
143%changelog
144* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
145- rebuilt with tcl/tk-8.4.19-2
146
147* Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
148- rebuilt with new toolchain
149- changed devel Group to Development/Libraries
150
151* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
152- applied new versioning policy and spec in utf-8
153
154* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
155- rebuilt with tcl/tk-8.4.18
156
157* Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
158- split to expect-devel and expectk sub package.
159- add libexpect.so to expect-devel (<BTS:wishes:0136>)
160
161* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
162- rebuilt with tcl/tk-8.4.16
163
164* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
165- rebuilt with new toolchain
166
167* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
168- rebuild for tcl/tk-8.4.12
169- added --enable-64bit to configure's option
170
171* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
172- updated expect to 5.43.0
173- dropped expect-5.39.0-64bit-82547.patch (for fixed)
174- dropped expect-5.32.2-kibitz.patch (for fixed)
175- dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
176- rebuilt with tcl/tk 8.4.11
177
178* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
179- rebuild for tcl/tk-8.4.6
180
181* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
182- update based on fedora
183
184* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
185- update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
186
187* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
188- splite source package
189- add include files
190
191* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
192- expand some macros.. (FIXME)
193
194* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
195- use %configure macros
196- add Patch 47,50
197
198* Thu May 31 2001 <sagami@vinelinux.org>
199- 8.0.5_jp-10
200- unexpand old %%{configure}, new one causes build failure
201- fixed missing libtkx.so libtclx.so symlink in /usr/lib
202- install manpages into %%{_mandir} and mode 644
203
204* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
205- 8.0.5_jp-9
206- modified %install section to handle compressed man pages
207- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
208
209* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
210- changed default fonts
211
212* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
213- added defattr
214
215* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
216- added some symlinks, such as libtcl8.0.so.
217- obsoletes version number using _jp, now 8.0.5-31vl1
218
219* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
220- Apply Tcl/Tk 8.0 Japanese Patch 1.7
221
222* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
223- fix tclX symlinks.
224- compile on systems where SIGPWR == SIGLOST.
225
226* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
227- update tcl/tk to 8.0.5.
228- avoid "containing" in Tix (#2332).
229
230* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
231- use /usr/bin/write in kibitz (#1320).
232- use cirrus.sprl.umich.edu in weather (#1926).
233
234* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
235- auto rebuild in the new build environment (release 28)
236
237* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
238- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
239
240* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
241- expect does unaligned access on alpha (#989)
242- upgrade tcl/tk/tclX to 8.0.4
243- upgrade expect to 5.28.
244- add itcl 3.0.1
245
246* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
247- call libtoolize to allow building on the arm
248- build for glibc 2.1
249- strip binaries
250
251* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
252- update tcl/tk/tclX to 8.0.3, expect is updated also.
253
254* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
255- expect: mkpasswd needs delay before sending password (problem #576)
256
257* Thu May 07 1998 Prospector System <bugs@redhat.com>
258- translations modified for de, fr, tr
259
260* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
261- fixed expect binaries exec permissions
262
263* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
264- updated to Tix 4.1.0.006
265- updated version numbers of tcl/tk to relflect includsion of p2
266
267* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
268- updated tcl/tk to patch level 2
269- updated tclX to 8.0.2
270
271* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
272- fixed filelist for tix... replacing path to the expect binary in scripts
273  was leaving junk files around.
274
275* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
276- added patch to remove libieee test in configure.in for tcl and tk.
277  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
278  solution for all systems
279- fixed src urls
280
281* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
282- removed version numbers from descriptions
283
284* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
285- updated to tcl/tk 8.0 and related versions of packages
286
287* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
288- built against glibc
289- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.