source: projects/specs/trunk/e/expect/expect-vl.spec @ 12236

Revision 12236, 12.4 KB checked in by tomop, 5 years ago (diff)

updated 8 packages

expect-5.45.4-1

postgresql-12.0-1

python-2.7.16-4

python3-3.5.7-3

rp-pppoe-3.13-3

tcl-8.6.9-1

tix-8.4.3-4

tk-8.6.9-1

Line 
1%{!?tcl_version: %define tcl_version %(echo 'puts $tcl_version' | tclsh)}
2%{!?tcl_sitearch: %define tcl_sitearch %{_libdir}/tcl%{tcl_version}}
3
4%define tcl_major 8.6
5%define majorver 5.45
6
7Summary: A Tcl/Tk development environment: expect
8Summary(ja): Tcl/Tk 開発環境: expect
9Name: expect
10Version: %{majorver}.4
11Release: 1%{?_dist_release}
12License: Public Domain
13Group: Development/Languages
14# URL: probably more useful is http://sourceforge.net/projects/expect/
15URL: https://core.tcl-lang.org/expect/index
16
17Source: https://downloads.sourceforge.net/%{name}/%{name}%{version}.tar.gz
18# Patch0: fixes change log file permissions
19Patch0: expect-5.43.0-log_file.patch
20# Patch1: fixes install location, change pkgIndex
21Patch1: expect-5.43.0-pkgpath.patch
22# Patch2: fixes minor man page formatting issue
23Patch2: expect-5.45-man-page.patch
24# Patch3: fixes segmentation fault during matching characters
25Patch3: expect-5.45-match-gt-numchars-segfault.patch
26# Patch4: fixes memory leak when using -re, http://sourceforge.net/p/expect/patches/13/
27Patch4: expect-5.45-re-memleak.patch
28# Patch5: use vsnprintf instead of vsprintf to avoid buffer overflow
29Patch5: expect-5.45-exp-log-buf-overflow.patch
30# Patch6: fixes segfaults if Tcl is built with stubs and Expect is used directly
31#   from C program rhbz#1091060
32Patch6: expect-5.45-segfault-with-stubs.patch
33# Patch7: fixes leaked fd, patch by Matej Mužila, rhbz#1001220
34Patch7: expect-5.45-fd-leak.patch
35# Patch8: unificates usage message of expect binary and man page, adds -h flag
36Patch8: expect-5.45.4-unification-of-usage-and-man-page.patch
37# Patch9: fixes issues detected by static analysis
38Patch9: expect-5.45.4-covscan-fixes.patch
39# examples patches
40# Patch100: changes random function
41Patch100: expect-5.32.2-random.patch
42# Patch101: fixes bz674184 - mkpasswd fails randomly
43Patch101: expect-5.45-mkpasswd-dash.patch
44# Patch102: fixes bz703702 - let user know that telnet is needed for
45# running some examples
46Patch102: expect-5.45-check-telnet.patch
47# Patch103: use full path to 'su', it's safer
48Patch103: expect-5.45-passmass-su-full-path.patch
49# Patch104: rhbz 963889, fixes inaccuracy in mkpasswd man page
50Patch104: expect-5.45-mkpasswd-man.patch
51# Patch105: Fix error with -Werror=format-security
52Patch105: expect-5.45-format-security.patch
53
54Buildroot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: tk-devel >= %{tcl_major}
56BuildRequires: autoconf
57BuildRequires: chrpath
58BuildRequires: libX11-devel
59BuildRequires: libXft-devel
60
61Vendor: Project Vine
62Distribution: Vine Linux
63
64%description -n expect
65Expect is a tcl extension for automating interactive applications such
66as telnet, ftp, passwd, fsck, rlogin, tip, etc.  Expect is also useful
67for testing the named applications.  Expect makes it easy for a script
68to control another program and interact with it.
69
70Install the expect package if you'd like to develop scripts which interact
71with interactive applications.  You'll also need to install the tcl
72package.
73
74%package devel
75Summary: Development files for expect library.
76Summary(ja): expect ライブラリの開発用ファイル
77Group: Development/Libraries
78Requires: expect = %{version}-%{release}
79Obsoletes: expect <= 5.43-0vl4
80
81%description devel
82This package contains development files for the expect library.
83
84%package -n expectk
85Summary: A program-script interaction and testing utility
86Group: Development/Tools
87Requires: expect = %{version}-%{release}
88Obsoletes: expect <= 5.43-0vl4
89
90%description -n expectk
91This package originally contained expectk and some scripts
92that used it. As expectk was removed from upstream tarball
93in expect-5.45, now the package contains just these scripts.
94Please use tclsh with package require Tk and Expect instead
95of expectk.
96
97%prep
98%setup -q -n expect%{version}
99%patch0 -p1 -b .log_file
100%patch1 -p1 -b .pkgpath
101%patch2 -p1 -b .man-page
102%patch3 -p1 -b .match-gt-numchars-segfault
103%patch4 -p1 -b .re-memleak
104%patch5 -p1 -b .exp-log-buf-overflow
105%patch6 -p1 -b .segfault-with-stubs
106%patch7 -p1 -b .fd-leak
107%patch8 -p1 -b .unification-of-usage-and-man-page
108%patch9 -p1 -b .covscan-fixes
109# examples fixes
110%patch100 -p1 -b .random
111%patch101 -p1 -b .mkpasswd-dash
112%patch102 -p1 -b .check-telnet
113%patch103 -p1 -b .passmass-su-full-path
114%patch104 -p1 -b .mkpasswd-man
115%patch105 -p0 -b .format-security
116# -pkgpath.patch touch configure.in
117aclocal
118autoconf
119( cd testsuite
120  autoconf -I.. )
121
122%build
123%configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
124        --with-tclinclude=%{_includedir}/tcl-private/generic
125make %{?_smp_mflags}
126
127%check
128make test
129
130%install
131rm -rf ${RPM_BUILD_ROOT}
132make install DESTDIR="$RPM_BUILD_ROOT"
133
134# move
135mv "$RPM_BUILD_ROOT"%{tcl_sitearch}/expect%{version}/libexpect%{version}.so "$RPM_BUILD_ROOT"%{_libdir}
136
137# for linking with -lexpect
138ln -s libexpect%{majorver}.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
139
140# remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
141rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
142rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
143rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
144
145# remove rpath
146chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libexpect%{version}.so
147
148
149%post -p /sbin/ldconfig -n expect
150
151%postun -p /sbin/ldconfig -n expect
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%files
157%%defattr(-,root,root)
158%doc FAQ HISTORY NEWS README
159%{_bindir}/expect
160%{_bindir}/autoexpect
161%{_bindir}/dislocate
162%{_bindir}/ftp-rfc
163%{_bindir}/kibitz
164%{_bindir}/lpunlock
165%{_bindir}/mkpasswd
166%{_bindir}/passmass
167%{_bindir}/rftp
168%{_bindir}/rlogin-cwd
169%{_bindir}/timed-read
170%{_bindir}/timed-run
171%{_bindir}/unbuffer
172%{_bindir}/weather
173%{_bindir}/xkibitz
174%dir %{tcl_sitearch}/expect%{version}
175%{tcl_sitearch}/expect%{version}/pkgIndex.tcl
176%{_libdir}/libexpect%{version}.so
177%{_mandir}/man1/autoexpect.1.gz
178%{_mandir}/man1/dislocate.1.gz
179%{_mandir}/man1/expect.1.gz
180%{_mandir}/man1/kibitz.1.gz
181%{_mandir}/man1/mkpasswd.1.gz
182%{_mandir}/man1/passmass.1.gz
183%{_mandir}/man1/tknewsbiff.1.gz
184%{_mandir}/man1/unbuffer.1.gz
185%{_mandir}/man1/xkibitz.1.gz
186
187%files devel
188%defattr(-,root,root,-)
189%{_libdir}/libexpect.so
190%{_mandir}/man3/libexpect.3*
191%{_includedir}/*
192
193%files -n expectk
194%defattr(-,root,root,-)
195%{_bindir}/multixterm
196%{_bindir}/tknewsbiff
197%{_bindir}/tkpasswd
198%{_bindir}/xpstat
199%{_mandir}/man1/multixterm.1*
200%{_mandir}/man1/tknewsbiff.1*
201
202
203%changelog
204* Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.45.4-1
205- new upstream release.
206- built with tcl/tk-8.6.9.
207- updated patches.
208- imported Patch8, 9 and 105 from rawhide.
209
210* Sat Dec 5 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.45-2
211- fixed a symlink.
212- fixed BR:.
213
214* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.45-1
215- updated to 5.45
216- rebuilt with tcl/tk 8.5.15
217
218* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 5.44.1.15-1
219- update to 5.44.1.15:sync ed Hat Enterprise Linux 6 expect-5.44.1.15-4.el6
220- add BuildRequires: tk, chrpath
221- update License: Public Domain
222- drop obsolete patches
223 - random patch (Patch0)
224 - spawn-43310 patch (Patch6)
225 - setpgrp patch (Patch8)
226 - lib spec patch (Patch10)
227 - libdir patch (Patch11)
228- add some patches from RHEL expect-5.44.1.15-4.el6
229 - fixes log file permissions patch (Patch500)
230 - fixes install location patch (Patch501)
231 - tk init patch (Patch502)
232 - match gt numchars segfault patch (Patch503)
233 - man page patch (Patch504)
234 - random patch (Patch600)
235 - unbuffer exit code patch (Patch601)
236 - passmass su full path Patch (Patch602)
237- update build and install section: sync RHEL expect-5.44.1.15-4.el6
238- add Vendor and Distribution tags
239
240* Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.43-5
241- add missing BuildRequires: libX11-devel
242
243* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 5.43-4
244- rebuilt with rpm-4.8.1-3
245
246* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
247- rebuilt with tcl/tk-8.4.19-2
248
249* Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
250- rebuilt with new toolchain
251- changed devel Group to Development/Libraries
252
253* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
254- applied new versioning policy and spec in utf-8
255
256* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
257- rebuilt with tcl/tk-8.4.18
258
259* Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
260- split to expect-devel and expectk sub package.
261- add libexpect.so to expect-devel (<BTS:wishes:0136>)
262
263* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
264- rebuilt with tcl/tk-8.4.16
265
266* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
267- rebuilt with new toolchain
268
269* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
270- rebuild for tcl/tk-8.4.12
271- added --enable-64bit to configure's option
272
273* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
274- updated expect to 5.43.0
275- dropped expect-5.39.0-64bit-82547.patch (for fixed)
276- dropped expect-5.32.2-kibitz.patch (for fixed)
277- dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
278- rebuilt with tcl/tk 8.4.11
279
280* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
281- rebuild for tcl/tk-8.4.6
282
283* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
284- update based on fedora
285
286* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
287- update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
288
289* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
290- splite source package
291- add include files
292
293* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
294- expand some macros.. (FIXME)
295
296* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
297- use %configure macros
298- add Patch 47,50
299
300* Thu May 31 2001 <sagami@vinelinux.org>
301- 8.0.5_jp-10
302- unexpand old %%{configure}, new one causes build failure
303- fixed missing libtkx.so libtclx.so symlink in /usr/lib
304- install manpages into %%{_mandir} and mode 644
305
306* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
307- 8.0.5_jp-9
308- modified %install section to handle compressed man pages
309- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
310
311* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
312- changed default fonts
313
314* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
315- added defattr
316
317* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
318- added some symlinks, such as libtcl8.0.so.
319- obsoletes version number using _jp, now 8.0.5-31vl1
320
321* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
322- Apply Tcl/Tk 8.0 Japanese Patch 1.7
323
324* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
325- fix tclX symlinks.
326- compile on systems where SIGPWR == SIGLOST.
327
328* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
329- update tcl/tk to 8.0.5.
330- avoid "containing" in Tix (#2332).
331
332* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
333- use /usr/bin/write in kibitz (#1320).
334- use cirrus.sprl.umich.edu in weather (#1926).
335
336* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
337- auto rebuild in the new build environment (release 28)
338
339* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
340- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
341
342* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
343- expect does unaligned access on alpha (#989)
344- upgrade tcl/tk/tclX to 8.0.4
345- upgrade expect to 5.28.
346- add itcl 3.0.1
347
348* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
349- call libtoolize to allow building on the arm
350- build for glibc 2.1
351- strip binaries
352
353* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
354- update tcl/tk/tclX to 8.0.3, expect is updated also.
355
356* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
357- expect: mkpasswd needs delay before sending password (problem #576)
358
359* Thu May 07 1998 Prospector System <bugs@redhat.com>
360- translations modified for de, fr, tr
361
362* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
363- fixed expect binaries exec permissions
364
365* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
366- updated to Tix 4.1.0.006
367- updated version numbers of tcl/tk to relflect includsion of p2
368
369* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
370- updated tcl/tk to patch level 2
371- updated tclX to 8.0.2
372
373* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
374- fixed filelist for tix... replacing path to the expect binary in scripts
375  was leaving junk files around.
376
377* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
378- added patch to remove libieee test in configure.in for tcl and tk.
379  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
380  solution for all systems
381- fixed src urls
382
383* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
384- removed version numbers from descriptions
385
386* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
387- updated to tcl/tk 8.0 and related versions of packages
388
389* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
390- built against glibc
391- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.